]> git.pld-linux.org Git - packages/psi-plus.git/blob - psi-plus.spec
- drop unused patches
[packages/psi-plus.git] / psi-plus.spec
1 #
2 # TODO: - check BRs
3 #
4 # NOTE:
5 #
6 # To generate source package use generate-tarball.sh script included to this spec as SourceX.
7 # Requires: git-core, subversion and sed >= 4.0
8 #
9 %define         ver     0.15
10 %define         rev     3784
11 %define         rel     0.%{rev}.1
12 #
13 Summary:        PSI - Jabber client
14 Summary(de.UTF-8):      PSI - ein Instant Messaging Client-Programm für Jabber
15 Summary(pl.UTF-8):      PSI - klient Jabbera
16 Name:           psi-plus
17 Version:        %{ver}.%{rev}
18 Release:        %{rel}
19 License:        GPL v2+ / LGPL v2.1+
20 Group:          Applications/Communications
21 Source0:        psi-%{version}.tar.xz
22 # Source0-md5:  576c2b20cc0748dbf9cae02f7bb69391
23 Source1:        psi-lang.tar.bz2
24 # Source1-md5:  cf6d82f53f1f1600a49bb61ba81151bf
25 Source2:        generate-tarball.sh
26 Patch0:         %{name}-fix_configure_for_ksh.patch
27 Patch1:         %{name}-customos.patch
28 Patch2:         %{name}-icon_buttons_big_return-mod.patch
29 Patch3:         %{name}-empty_group-fix.patch
30 URL:            http://psi-plus.com/
31 BuildRequires:  Qt3Support-devel
32 BuildRequires:  QtCore-devel
33 BuildRequires:  QtDBus-devel
34 BuildRequires:  QtNetwork-devel
35 BuildRequires:  QtXml-devel
36 BuildRequires:  aspell-devel
37 BuildRequires:  libstdc++-devel
38 BuildRequires:  openssl-devel >= 0.9.7c
39 BuildRequires:  qca-devel >= 2.0.0
40 BuildRequires:  qt4-build >= 4.4.0
41 BuildRequires:  qt4-linguist >= 4.4.0
42 BuildRequires:  qt4-qmake >= 4.4.0
43 BuildRequires:  tar >= 1:1.22
44 BuildRequires:  which
45 BuildRequires:  xorg-lib-libX11-devel
46 BuildRequires:  xorg-lib-libXScrnSaver-devel
47 BuildRequires:  xorg-proto-scrnsaverproto-devel
48 BuildRequires:  xz >= 1:4.999.7
49 BuildRequires:  zlib-devel
50 Requires:       gstreamer-v4l2
51 Requires:       gstreamer-video4linux
52 Requires:       qt4-plugin-qca-ossl
53 Suggests:       gpgme >= 1.0.0
54 Obsoletes:      qt-designer-psiwidgets
55 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57 %description
58 PSI is a communicator for the Jabber open messaging system. It is
59 based on the Qt library. It supports SSL encrypted connections. The
60 default behaviour for SSL was changed so that it looks for SSL
61 certificates in $DATADIR/certs or in ~/.psi/certs.
62
63 Psi+ is a development branch of Psi IM Jabber client.
64
65 %description -l de.UTF-8
66 Psi ist ein Instant Messaging (IM) Client-Programm für das
67 Jabber-Protokoll (XMPP), welches das Qt Toolkit nutzt.
68
69 %description -l pl.UTF-8
70 PSI jest komunikatorem dla otwartego systemu wiadomości Jabber. Został
71 stworzony w oparciu o bibliotekę Qt. PSI wspiera połączenia szyfrowane
72 SSL. W stosunku do domyślnego zachowania komunikatora została
73 wprowadzona zmiana, która powoduje, że certyfikaty SSL są poszukiwane
74 w katalogu $DATADIR/certs lub ~/.psi/certs.
75
76 Psi+ jest rozwojową gałęzią komunikatora Psi IM Jabber.
77
78 %prep
79 %setup -q -n psi-%{version} -a 1
80 %patch0 -p0
81 %patch1 -p1
82 %patch2 -p1
83 %patch3 -p1
84
85 %{__rm} -r third-party
86
87 %build
88 ./configure \
89         --prefix=%{_prefix} \
90         --datadir=%{_datadir} \
91         --libdir=%{_libdir} \
92         --no-separate-debug-info
93
94 %{__make}
95
96 cd lang
97 lrelease-qt4 *.ts
98
99 %install
100 rm -rf $RPM_BUILD_ROOT
101
102 export QTDIR=%{_libdir}/qt4
103
104 install -d $RPM_BUILD_ROOT%{_libdir}/psi/plugins
105
106 %{__make} install \
107         INSTALL_ROOT=$RPM_BUILD_ROOT
108
109 cp -a lang/*.qm $RPM_BUILD_ROOT%{_datadir}/psi/
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %files
115 %defattr(644,root,root,755)
116 %doc README
117 %attr(755,root,root) %{_bindir}/psi-plus
118 %dir %{_datadir}/psi
119 %lang(ar) %{_datadir}/psi/*_ar.qm
120 %lang(ca) %{_datadir}/psi/*_ca.qm
121 %lang(cs) %{_datadir}/psi/*_cs.qm
122 %lang(da) %{_datadir}/psi/*_da.qm
123 %lang(de) %{_datadir}/psi/*_de.qm
124 %lang(el) %{_datadir}/psi/*_el.qm
125 %lang(eo) %{_datadir}/psi/*_eo.qm
126 %lang(es) %{_datadir}/psi/*_es.qm
127 %lang(fi) %{_datadir}/psi/*_fi.qm
128 %lang(fr) %{_datadir}/psi/*_fr.qm
129 %lang(it) %{_datadir}/psi/*_it.qm
130 %lang(jp) %{_datadir}/psi/*_jp.qm
131 %lang(mk) %{_datadir}/psi/*_mk.qm
132 %lang(nl) %{_datadir}/psi/*_nl.qm
133 %lang(pl) %{_datadir}/psi/*_pl.qm
134 %lang(pt_BR) %{_datadir}/psi/*_ptbr.qm
135 %lang(pt) %{_datadir}/psi/*_pt.qm
136 %lang(ru) %{_datadir}/psi/*_ru.qm
137 %lang(se) %{_datadir}/psi/*_se.qm
138 %lang(sk) %{_datadir}/psi/*_sk.qm
139 %lang(sr) %{_datadir}/psi/*_sr.qm
140 %lang(uk) %{_datadir}/psi/*_uk.qm
141 %lang(zh) %{_datadir}/psi/*_zh.qm
142 %dir %{_libdir}/psi
143 %dir %{_libdir}/psi/plugins
144 %{_datadir}/psi/certs
145 %{_datadir}/psi/iconsets
146 %{_datadir}/psi/sound
147 %{_desktopdir}/*.desktop
148 %{_iconsdir}/hicolor/*/*/*.png
This page took 0.731106 seconds and 4 git commands to generate.