]> git.pld-linux.org Git - packages/protobuf.git/blob - protobuf.spec
38503a7ac4ff425e39298d8392361b641a9d5232
[packages/protobuf.git] / protobuf.spec
1 # TODO:
2 # - add bindings for java (maven build)
3 # - add bindings for javascript
4 # - add bindings for csharp
5 #
6 # Conditional build:
7 %bcond_without  python2 # Python 2.x bindings
8 %bcond_without  python3 # Python 3.x bindings
9 %bcond_without  ruby    # Ruby bindings
10 %bcond_without  tests   # perform "make check"
11
12 Summary:        Protocol Buffers - Google's data interchange format
13 Summary(pl.UTF-8):      Protocol Buffers - format wymiany danych Google
14 Name:           protobuf
15 Version:        3.9.0
16 Release:        1
17 License:        BSD
18 Group:          Libraries
19 #Source0Download: https://github.com/google/protobuf/releases
20 Source0:        https://github.com/google/protobuf/releases/download/v%{version}/%{name}-all-%{version}.tar.gz
21 # Source0-md5:  a44c3bbee380181c86f573b835294782
22 Source1:        ftdetect-proto.vim
23 Patch0:         system-gtest.patch
24 Patch1:         no-wrap-memcpy.patch
25 URL:            https://github.com/google/protobuf/
26 BuildRequires:  autoconf >= 2.59
27 BuildRequires:  automake >= 1:1.9
28 #%{?with_tests:BuildRequires:   gmock-devel >= 1.9.0}
29 #%{?with_tests:BuildRequires:   gtest-devel >= 1.9.0}
30 BuildRequires:  libstdc++-devel >= 6:4.7
31 BuildRequires:  libtool
32 BuildRequires:  pkgconfig
33 %if %{with python2}
34 BuildRequires:  python-modules >= 1:2.6
35 BuildRequires:  python-setuptools
36 %endif
37 %if %{with python3}
38 BuildRequires:  python3-modules >= 1:3.3
39 BuildRequires:  python3-setuptools
40 %endif
41 %if %{with python2} || %{with python3}
42 BuildRequires:  rpm-pythonprov
43 %endif
44 BuildRequires:  rpmbuild(macros) >= 1.714
45 %if %{with ruby}
46 BuildRequires:  ruby-devel
47 BuildRequires:  ruby-rake
48 BuildRequires:  ruby-rake-compiler
49 %endif
50 BuildRequires:  zlib-devel >= 1.2.0.4
51 Requires:       %{name}-libs = %{version}-%{release}
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 %define         _vimdatadir     %{_datadir}/vim
55
56 # triggers bogus "overflow in constant expression" errors with gcc 4.9 .. 5.4
57 %define         filterout       -fwrapv
58
59 %description
60 Protocol Buffers are a way of encoding structured data in an efficient
61 yet extensible format. Google uses Protocol Buffers for almost all of
62 its internal RPC protocols and file formats.
63
64 Protocol buffers are a flexible, efficient, automated mechanism for
65 serializing structured data - think XML, but smaller, faster, and
66 simpler. You define how you want your data to be structured once, then
67 you can use special generated source code to easily write and read
68 your structured data to and from a variety of data streams and using a
69 variety of languages. You can even update your data structure without
70 breaking deployed programs that are compiled against the "old" format.
71
72 This package contains Protocol Buffers compiler for all programming
73 languages.
74
75 %description -l pl.UTF-8
76 Bufory protokołowe (Protocol Buffers) to sposób kodowania danych
77 strukturalnych w wydajny i rozszerzalny sposób. Google używa buforów
78 protokołowych do prawie wszystkich wewnętrznych protokołów RPC i
79 formatów plików.
80
81 Bufory protokołowe to elastyczny, wydajny i zautomatyzowany sposób
82 serializacji danych strukturalnych - podobny do XML-a, ale mniejszy,
83 szybszy i prostszy. Definiuje się raz, jaką strukturę mają mieć dane,
84 a następnie używa specjalnie wygenerowanego kodu źródłowego do łatwego
85 zapisu i odczytu danych strukturalnych do i z różnych strumieni
86 danych, z poziomu różnych języków. Można nawet uaktualniać strukturę
87 danych bez psucia programów skompilowanych w oparciu o "stary" format.
88
89 Ten pakiet zawiera kompilator buforów protokołowych dla wszystkich
90 języków programowania. 
91
92 %package libs
93 Summary:        Protocol Buffers library
94 Summary(pl.UTF-8):      Biblioteka buforów protokołowych (Protocol Buffers)
95 Group:          Libraries
96 Requires:       zlib >= 1.2.0.4
97
98 %description libs
99 Protocol Buffers library.
100
101 %description libs -l pl.UTF-8
102 Biblioteka buforów protokołowych (Protocol Buffers).
103
104 %package lite
105 Summary:        Protocol Buffers LITE_RUNTIME library
106 Summary(pl.UTF-8):      Biblioteka LITE_RUNTIME buforów protokołowych (Protocol Buffers)
107 Group:          Libraries
108
109 %description lite
110 Protocol Buffers library for programs built with optimize_for =
111 LITE_RUNTIME.
112
113 The "optimize_for = LITE_RUNTIME" option causes the compiler to
114 generate code which only depends libprotobuf-lite, which is much
115 smaller than libprotobuf but lacks descriptors, reflection, and some
116 other features.
117
118 %description lite -l pl.UTF-8
119 Biblioteka buforów protokołowych (Protocol Buffers) zbudowana dla
120 programów z opcją optimize_for = LITE_RUNTIME.
121
122 Opcja ta powoduje, że kompilator generuje kod, który wymaga tylko
123 biblioteki libprotobuf-lite, która jest mniejsza niż libprotobuf, ale
124 nie ma niektórych elementów, takich jak deskryptory czy refleksje.
125
126 %package devel
127 Summary:        Header files for Protocol Buffers libraries
128 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek buforów protokołowych (Protocol Buffers)
129 Group:          Development/Libraries
130 Requires:       %{name} = %{version}-%{release}
131 Requires:       %{name}-libs = %{version}-%{release}
132 Requires:       %{name}-lite = %{version}-%{release}
133 Requires:       libstdc++-devel >= 6:4.7
134
135 %description devel
136 Header files for Protocol Buffers libraries.
137
138 %description devel -l pl.UTF-8
139 Pliki nagłówkowe bibliotek buforów protokołowych (Protocol Buffers).
140
141 %package static
142 Summary:        Static Protocol Buffers libraries
143 Summary(pl.UTF-8):      Statyczne biblioteki buforów protokołowych (Protocol Buffers)
144 Group:          Development/Libraries
145 Requires:       %{name}-devel = %{version}-%{release}
146
147 %description static
148 Static Protocol Buffers libraries.
149
150 %description static -l pl.UTF-8
151 Statyczne biblioteki buforów protokołowych (Protocol Buffers).
152
153 %package -n python-protobuf
154 Summary:        Python 2 bindings for Protocol Buffers
155 Summary(pl.UTF-8):      Wiązania Pythona 2 do buforów protokołowych (Protocol Buffers)
156 Group:          Development/Languages/Python
157 Requires:       python-modules >= 1:2.6
158 # does not use C++ library at this time
159
160 %description -n python-protobuf
161 Python 2 bindings for Protocol Buffers.
162
163 %description -n python-protobuf -l pl.UTF-8
164 Wiązania Pythona 2 do buforów protokołowych (Protocol Buffers).
165
166 %package -n python3-protobuf
167 Summary:        Python 3 bindings for Protocol Buffers
168 Summary(pl.UTF-8):      Wiązania Pythona 3 do buforów protokołowych (Protocol Buffers)
169 Group:          Development/Languages/Python
170 Requires:       python3-modules >= 1:3.3
171 # does not use C++ library at this time
172
173 %description -n python3-protobuf
174 Python 3 bindings for Protocol Buffers.
175
176 %description -n python3-protobuf -l pl.UTF-8
177 Wiązania Pythona 3 do buforów protokołowych (Protocol Buffers).
178
179 %package -n ruby-google-protobuf
180 Summary:        Ruby bindings for Google Protocol Buffers
181 Summary(pl.UTF-8):      Wiązania języka Ruby do biblioteki Google Protocol Buffers
182 Group:          Development/Languages
183 Requires:       ruby
184
185 %description -n ruby-google-protobuf
186 Ruby bindings for Google Protocol Buffers.
187
188 %description -n ruby-google-protobuf -l pl.UTF-8
189 Wiązania języka Ruby do biblioteki Google Protocol Buffers.
190
191 %package -n vim-syntax-protobuf
192 Summary:        Vim syntax highlighting for Protocol Buffers descriptions
193 Summary(pl.UTF-8):      Podświetlanie składni Vima dla opisów buforów protokołowych (Protocol Buffers)
194 Group:          Development/Libraries
195 Requires:       vim-rt >= 4:7.2.170
196
197 %description -n vim-syntax-protobuf
198 This package contains syntax highlighting for Protocol Buffers
199 descriptions in Vim editor.
200
201 %description -n vim-syntax-protobuf -l pl.UTF-8
202 Ten pakiet zawiera pliki podświetlania składni edytora Vim dla
203 opisów buforów protokołowych (Protocol Buffers).
204
205 %prep
206 %setup -q
207 # protobuf needs gtest 1.9.0 (not released yet), use bundled version
208 #patch0 -p1
209 %patch1 -p1
210
211 #ln -s /usr/src/gmock/src/gmock*.cc src
212
213 # remove for gtest >= 1.9
214 #%{__sed} -i -e 's/INSTANTIATE_TEST_SUITE_P/INSTANTIATE_TEST_CASE_P/' src/google/protobuf/{compiler/command_line_interface_unittest.cc,descriptor_unittest.cc,dynamic_message_unittest.cc,map_field_test.cc,util/internal/default_value_objectwriter_test.cc,util/internal/protostream_objectsource_test.cc,util/internal/protostream_objectwriter_test.cc}
215
216 %build
217 %{__libtoolize}
218 %{__aclocal} -I m4
219 %{__autoconf}
220 %{__autoheader}
221 %{__automake}
222 # Additional variables defined according to https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=192821
223 %configure \
224         CFLAGS='%{rpmcflags} -DGOOGLE_PROTOBUF_NO_RTTI' \
225         CPPFLAGS='%{rpmcppflags} -DGOOGLE_PROTOBUF_NO_RTTI' \
226         --disable-silent-rules \
227         --disable-external-gtest
228 %{__make}
229
230 cd python
231 %if %{with python2}
232 %py_build
233 %endif
234 %if %{with python3}
235 %py3_build
236 %endif
237 cd ..
238
239 %if %{with ruby}
240 cd ruby
241 rake
242 #rake clobber_package gem
243 cd ..
244 %endif
245
246 %if %{with tests}
247 %{__make} check
248 %endif
249
250 %install
251 rm -rf $RPM_BUILD_ROOT
252 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
253
254 %{__make} install \
255         STRIPBINARIES=no \
256         INSTALL="install -p"  \
257         CPPROG="cp -p" \
258         DESTDIR=$RPM_BUILD_ROOT
259
260 install -d $RPM_BUILD_ROOT%{_vimdatadir}/{syntax,ftdetect}
261 cp -p editors/proto.vim $RPM_BUILD_ROOT%{_vimdatadir}/syntax/proto.vim
262 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_vimdatadir}/ftdetect/proto.vim
263
264 cd python
265 %if %{with python2}
266 %py_install
267 %py_postclean
268 %endif
269 %if %{with python3}
270 %py3_install
271 %endif
272 cd ..
273
274 %if %{with ruby}
275 install -d $RPM_BUILD_ROOT{%{ruby_vendorarchdir}/google,%{ruby_vendorlibdir}/google,%{ruby_specdir}}
276 install ruby/lib/google/protobuf_c.so $RPM_BUILD_ROOT%{ruby_vendorarchdir}/google
277 cp -pr ruby/lib/google/{protobuf,protobuf.rb} $RPM_BUILD_ROOT%{ruby_vendorlibdir}/google
278 cp -p ruby/google-protobuf.gemspec $RPM_BUILD_ROOT%{ruby_specdir}/google-protobuf-%{version}.gemspec
279 %endif
280 cp -pr examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
281
282 %clean
283 rm -rf $RPM_BUILD_ROOT
284
285 %post   -p /sbin/ldconfig
286 %postun -p /sbin/ldconfig
287
288 %post   libs -p /sbin/ldconfig
289 %postun libs -p /sbin/ldconfig
290
291 %post   lite -p /sbin/ldconfig
292 %postun lite -p /sbin/ldconfig
293
294 %files
295 %defattr(644,root,root,755)
296 %doc CHANGES.txt CONTRIBUTORS.txt LICENSE README.md
297 %attr(755,root,root) %{_bindir}/protoc
298 %attr(755,root,root) %{_libdir}/libprotoc.so.*.*.*
299 %attr(755,root,root) %ghost %{_libdir}/libprotoc.so.20
300
301 %files libs
302 %defattr(644,root,root,755)
303 %attr(755,root,root) %{_libdir}/libprotobuf.so.*.*.*
304 %attr(755,root,root) %ghost %{_libdir}/libprotobuf.so.20
305
306 %files lite
307 %defattr(644,root,root,755)
308 %attr(755,root,root) %{_libdir}/libprotobuf-lite.so.*.*.*
309 %attr(755,root,root) %ghost %{_libdir}/libprotobuf-lite.so.20
310
311 %files devel
312 %defattr(644,root,root,755)
313 %attr(755,root,root) %{_libdir}/libprotobuf-lite.so
314 %attr(755,root,root) %{_libdir}/libprotobuf.so
315 %attr(755,root,root) %{_libdir}/libprotoc.so
316 %{_libdir}/libprotobuf-lite.la
317 %{_libdir}/libprotobuf.la
318 %{_libdir}/libprotoc.la
319 # XXX: dir shared with libtcmalloc
320 %dir %{_includedir}/google
321 %{_includedir}/google/protobuf
322 %{_pkgconfigdir}/protobuf-lite.pc
323 %{_pkgconfigdir}/protobuf.pc
324 %{_examplesdir}/%{name}-%{version}
325
326 %files static
327 %defattr(644,root,root,755)
328 %{_libdir}/libprotobuf-lite.a
329 %{_libdir}/libprotobuf.a
330 %{_libdir}/libprotoc.a
331
332 %if %{with python2}
333 %files -n python-protobuf
334 %defattr(644,root,root,755)
335 %doc python/README.md
336 %dir %{py_sitescriptdir}/google
337 %{py_sitescriptdir}/google/protobuf
338 %{py_sitescriptdir}/protobuf-%{version}-py*.egg-info
339 %{py_sitescriptdir}/protobuf-%{version}-py*-nspkg.pth
340 %endif
341
342 %if %{with python3}
343 %files -n python3-protobuf
344 %defattr(644,root,root,755)
345 %doc python/README.md
346 %dir %{py3_sitescriptdir}/google
347 %{py3_sitescriptdir}/google/protobuf
348 %{py3_sitescriptdir}/protobuf-%{version}-py*.egg-info
349 %{py3_sitescriptdir}/protobuf-%{version}-py*-nspkg.pth
350 %endif
351
352 %if %{with ruby}
353 %files -n ruby-google-protobuf
354 %defattr(644,root,root,755)
355 %doc ruby/README.md
356 %dir %{ruby_vendorarchdir}/google
357 %attr(755,root,root) %{ruby_vendorarchdir}/google/protobuf_c.so
358 %dir %{ruby_vendorlibdir}/google
359 %{ruby_vendorlibdir}/google/protobuf.rb
360 %{ruby_vendorlibdir}/google/protobuf
361 %{ruby_specdir}/google-protobuf-%{version}.gemspec
362 %endif
363
364 %files -n vim-syntax-protobuf
365 %defattr(644,root,root,755)
366 %{_datadir}/vim/ftdetect/proto.vim
367 %{_datadir}/vim/syntax/proto.vim
This page took 0.110117 seconds and 2 git commands to generate.