]> git.pld-linux.org Git - packages/ppp.git/commitdiff
rediff patches; rel 3
authorJan Palus <atler@pld-linux.org>
Mon, 4 Oct 2021 12:00:09 +0000 (14:00 +0200)
committerJan Palus <atler@pld-linux.org>
Mon, 4 Oct 2021 12:00:09 +0000 (14:00 +0200)
- ppp-rp-pppoe-macaddr already applied upstream

ppp-2.4.3-mppe-mppc-1.1.patch
ppp-ifpppstatsreq.patch
ppp-pidfile-owner.patch
ppp-rp-pppoe-macaddr.patch [deleted file]
ppp-static.patch
ppp.spec
pppd-2.4.2-chapms-strip-domain.patch

index b4d15870f94907f68453f1191bbd0d9a6019af21..0c0ab7f6664e9434d00f2a3249ba21b3c3a82607 100644 (file)
@@ -29,8 +29,8 @@ diff -ruN ppp-2.4.3.orig/include/linux/ppp-comp.h ppp-2.4.3/include/linux/ppp-co
        /* Update state for an incompressible packet received */
        void    (*incomp) (void *state, unsigned char *ibuf, int icnt);
 @@ -288,6 +288,33 @@
-           opts |= MPPE_OPT_UNKNOWN;           \
-     } while (/* CONSTCOND */ 0)
+ #define CI_MPPE                       18      /* config option for MPPE */
+ #define CILEN_MPPE            6       /* length of config option */
  
 +/* MPPE/MPPC definitions by J.D.*/
 +#define MPPE_STATELESS          MPPE_H_BIT    /* configuration bit H */
@@ -66,8 +66,8 @@ diff -ruN ppp-2.4.3.orig/include/net/ppp-comp.h ppp-2.4.3/include/net/ppp-comp.h
 --- ppp-2.4.3.orig/include/net/ppp-comp.h      2002-12-06 10:49:15.000000000 +0100
 +++ ppp-2.4.3/include/net/ppp-comp.h   2004-11-21 13:54:09.000000000 +0100
 @@ -255,6 +255,33 @@
-           opts |= MPPE_OPT_UNKNOWN;           \
-     } while (/* CONSTCOND */ 0)
+ #define CI_MPPE                       18      /* config option for MPPE */
+ #define CILEN_MPPE            6       /* length of config option */
  
 +/* MPPE/MPPC definitions by J.D.*/
 +#define MPPE_STATELESS          MPPE_H_BIT    /* configuration bit H */
index d5a628151613b69bda3713154d34021577c1416e..63b79cfe7452d29f500cf08598fa7385fb4027a4 100644 (file)
@@ -1,8 +1,8 @@
 --- ppp-2.4.5/pppd/sys-linux.c~        2013-02-16 23:11:59.688775791 +0100
 +++ ppp-2.4.5/pppd/sys-linux.c 2013-02-16 23:14:00.675182263 +0100
 @@ -1364,20 +1364,22 @@
-     int u;
-     struct pppd_stats *stats;
+ int
+ get_ppp_stats(int u, struct pppd_stats *stats)
  {
 -    struct ifpppstatsreq req;
 +    struct ifreq req;
@@ -33,8 +33,8 @@
 --- ppp-2.4.5/pppstats/pppstats.c~     2013-02-16 23:15:47.231215213 +0100
 +++ ppp-2.4.5/pppstats/pppstats.c      2013-02-16 23:17:58.624537526 +0100
 @@ -143,12 +143,14 @@
- get_ppp_stats(curp)
-     struct ppp_stats *curp;
+ static void
+ get_ppp_stats(struct ppp_stats *curp)
  {
 -    struct ifpppstatsreq req;
 +    struct ifreq req;
 -#define ifr_name ifr__name
 -#endif
  
-     strncpy(req.ifr_name, interface, sizeof(req.ifr_name));
-     if (ioctl(s, SIOCGPPPSTATS, &req) < 0) {
+     strncpy(req.ifr_name, interface, IFNAMSIZ);
+     req.ifr_name[IFNAMSIZ - 1] = 0;
 --- ppp-2.4.5/pppstats/pppstats.c~     2013-02-16 23:20:49.762187752 +0100
 +++ ppp-2.4.5/pppstats/pppstats.c      2013-02-16 23:23:53.923478616 +0100
 @@ -167,15 +167,13 @@
- get_ppp_cstats(csp)
-     struct ppp_comp_stats *csp;
+ static void
+ get_ppp_cstats(struct ppp_comp_stats *csp)
  {
 -    struct ifpppcstatsreq creq;
 +    struct ifreq creq;
@@ -92,8 +92,8 @@
 -#endif
 +    creq.ifr_data = (caddr_t) &rstats;
  
-     strncpy(creq.ifr_name, interface, sizeof(creq.ifr_name));
-     if (ioctl(s, SIOCGPPPCSTATS, &creq) < 0) {
+     strncpy(creq.ifr_name, interface, IFNAMSIZ);
+     creq.ifr_name[IFNAMSIZ - 1] = 0;
 @@ -192,28 +190,28 @@
      }
  
index 14b446df42e997bac4a8e7fc0f3bd19e61b961ab..86d3042cf42ca6baa545664f1a9dd3435b4a6ce9 100644 (file)
@@ -3,7 +3,7 @@ diff -Naur ppp-2.4.1/pppd/main.c ppp-2.4.1-p/pppd/main.c
 +++ ppp-2.4.1-p/pppd/main.c    Thu May 16 11:36:43 2002
 @@ -795,6 +795,11 @@
      if ((pidfile = fopen(pidfilename, "w")) != NULL) {
-       fprintf(pidfile, "%d\n", getpid());
+       fprintf(pidfile, "%d\n", pid);
        (void) fclose(pidfile);
 +      if (getuid() != geteuid()) {
 +              if ((chown(pidfilename, getuid(), -1)) < 0) {
diff --git a/ppp-rp-pppoe-macaddr.patch b/ppp-rp-pppoe-macaddr.patch
deleted file mode 100644 (file)
index 84ceade..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- ppp-2.4.2-20020901.org/pppd/plugins/pppoe/plugin.c Tue Sep  3 22:16:35 2002
-+++ ppp-2.4.2-20020901/pppd/plugins/pppoe/plugin.c     Tue Sep  3 22:17:41 2002
-@@ -174,6 +174,8 @@
-           (unsigned) conn->peerEth[4],
-           (unsigned) conn->peerEth[5]);
-+    script_setenv("MACREMOTE", remote_number, 0);
-+    
-     if (connect(conn->sessionSocket, (struct sockaddr *) &sp,
-               sizeof(struct sockaddr_pppox)) < 0) {
-       fatal("Failed to connect PPPoE socket: %d %m", errno);
index 04f9fa93cbd641255bdf45e3f70edb844fdf0444..dd69cfe71059c782e2e32fd7ca589ac53b38e596 100644 (file)
@@ -50,7 +50,7 @@
 +++ ppp-2.3.7.new/pppd/ipcp.h  Wed Apr 28 20:27:15 1999
 @@ -70,4 +70,10 @@
  
- char *ip_ntoa __P((u_int32_t));
+ char *ip_ntoa(u_int32_t);
  
 +/* Added to allow static and dynamic ip(s).
 + * Holds the static ip from pap-secrets
index 0afe11e116c2dfa61b6a2901aca5f7f817725536..b19cd791f793409b981a0d690a8c7bbdd4336680 100644 (file)
--- a/ppp.spec
+++ b/ppp.spec
@@ -18,7 +18,7 @@ Summary(tr.UTF-8):    PPP sunucu süreci
 Summary(zh_CN.UTF-8):  PPP 配置和管理软件包
 Name:          ppp
 Version:       2.4.9
-Release:       2
+Release:       3
 Epoch:         3
 License:       distributable
 Group:         Networking/Daemons
@@ -34,7 +34,6 @@ Patch0:               %{name}-make.patch
 Patch2:                %{name}-debian_scripts.patch
 Patch3:                %{name}-static.patch
 Patch4:                %{name}-pidfile-owner.patch
-Patch6:                %{name}-rp-pppoe-macaddr.patch
 #Patch7:               http://public.planetmirror.com/pub/mppe/pppd-2.4.2-chapms-strip-domain.patch.gz
 Patch7:                pppd-2.4.2-chapms-strip-domain.patch
 Patch8:                %{name}-openssl.patch
@@ -121,7 +120,6 @@ Wtyczka PPPoATM dla pppd.
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
-%patch6 -p1
 %patch7 -p1
 %patch8 -p1
 %if "%{_lib}" == "lib64"
index d376de92e3ecef67cbeff6974a3ed6424afa5055..ebabbbdd3c788aac6a40e4f12c45109c3a3da8e2 100644 (file)
@@ -23,7 +23,7 @@ diff -uNra ppp-2.4.2/pppd/chap-new.c ppp-2.4.2-new/pppd/chap-new.c
 +++ ppp-2.4.2-new/pppd/chap-new.c      Sat Dec 20 19:17:42 2003
 @@ -396,6 +396,14 @@
        int ok;
-       char secret[MAXSECRETLEN];
+       unsigned char secret[MAXSECRETLEN];
        int secret_len;
 +#ifdef CHAPMS
 +      char nametmp[MAXNAMELEN];
@@ -35,18 +35,18 @@ diff -uNra ppp-2.4.2/pppd/chap-new.c ppp-2.4.2-new/pppd/chap-new.c
 +#endif
  
        /* Get the secret that the peer is supposed to know */
-       if (!get_secret(0, name, ourname, secret, &secret_len, 1)) {
+       if (!get_secret(0, name, ourname, (char *)secret, &secret_len, 1)) {
 diff -uNra ppp-2.4.2/pppd/pppd.h ppp-2.4.2-new/pppd/pppd.h
 --- ppp-2.4.2/pppd/pppd.h      Mon Apr  7 01:01:46 2003
 +++ ppp-2.4.2-new/pppd/pppd.h  Sat Dec 20 18:58:23 2003
 @@ -310,6 +310,10 @@
- extern bool   dump_options;   /* print out option values */
  extern bool   dryrun;         /* check everything, print options, exit */
+ extern int    child_wait;     /* # seconds to wait for children at end */
  
 +#ifdef CHAPMS
 +extern bool   ms_ignore_domain; /* Ignore any MS domain prefix */
 +#endif
 +
- #ifdef MAXOCTETS
- extern unsigned int maxoctets;             /* Maximum octetes per session (in bytes) */
- extern int       maxoctets_dir;      /* Direction :
+ #ifdef USE_EAPTLS
+ extern char   *crl_dir;
+ extern char   *crl_file;
This page took 0.326593 seconds and 4 git commands to generate.