]> git.pld-linux.org Git - packages/ppp.git/blob - ppp.spec
- updated make patch, use %%configure in radiusclient to use proper optflags
[packages/ppp.git] / ppp.spec
1 #
2 # Conditional build:
3 # _with_pppoatm - with PPPoATM support (which requires kernel 2.4 and atm-devel)
4 #
5 # TODO:
6 # - fix ppp over atm
7 %define snap    20030613
8 Summary:        ppp daemon package for Linux
9 Summary(de):    ppp-Dämonpaket für Linux
10 Summary(es):    Servidor ppp para Linux
11 Summary(fr):    Paquetage du démon ppp pour Linux
12 Summary(pl):    Demon PPP dla Linuksa
13 Summary(pt_BR): Servidor ppp para Linux
14 Summary(ru):    äÅÍÏΠppp
15 Summary(tr):    PPP sunucu süreci
16 Summary(zh_CN): PPP ÅäÖú͹ÜÀíÈí¼þ°ü.
17 Name:           ppp
18 Version:        2.4.2
19 Release:        0.%{snap}.1
20 Epoch:          2
21 License:        distributable
22 Group:          Networking/Daemons
23 Source0:        cvs://pserver.samba.org/ppp/%{name}-%{version}-%{snap}.tar.bz2
24 # Source0-md5:  cd1aeae556f6c2d61cb99d219eb32eac
25 Source1:        %{name}.pamd
26 Source2:        %{name}.pon
27 Source3:        %{name}.poff
28 Source4:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
29 # Source4-md5:  3801b59005bef8f52856300fe3167a64
30 Source5:        %{name}.logrotate
31 Patch0:         %{name}-make.patch
32 Patch1:         %{name}-expect.patch
33 Patch2:         %{name}-debian_scripts.patch
34 Patch3:         %{name}-static.patch
35 #http://www.sfgoth.com/~mitch/linux/atm/pppoatm/pppoatm-pppd-vs-2.4.0b2+240600.diff.gz
36 Patch4:         %{name}-pppoatm.patch
37 Patch5:         %{name}-pidfile-owner.patch
38 Patch6:         %{name}-rp-pppoe-update.patch
39 Patch7:         %{name}-rp-pppoe-macaddr.patch
40 URL:            http://www.samba.org/ppp/
41 BuildRequires:  automake
42 %{?_with_pppoatm:BuildRequires: linux-atm-devel}
43 BuildRequires:  pam-devel
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %description
47 This is the daemon and documentation for PPP support. It requires a
48 kernel greater than 2.2.11 which is built with PPP support. The
49 default kernels include PPP support as a module. This version supports
50 IPv6, too.
51
52 %description -l de
53 Dies ist der Dämon und die Dokumentation für PPP-Support. Erfordert
54 einen Kernel höher als 2.2.11, der mit PPP-Support gebaut ist. Die
55 Standard- Red-Hat-Kernel schließen PPP-Support als Modul ein. (IPv6)
56
57 %description -l es
58 Este es el servidor y la documentación para soporte PPP. Requiere un
59 kernel superior al 2.0. Los kernels padrón de la Conectiva incluyen
60 soporte PPP como módulo.
61
62 %description -l fr
63 Ceci est le démon et la documentation pour le support PPP. Cela
64 réclame un noyau supérieur au 2.2.11 et construit avec le support PPP.
65 Le noyau par défaut de Red Hat contient le support PPP sous forme de
66 module. (IPv6)
67
68 %description -l pl
69 Pakiet zawiera demona i dokumentacjê umo¿liwiaj±c± korzystanie z
70 protoko³u PPP. Wymaga j±dra 2.2.11 - lub pó¼niejszego - z wkompilowan±
71 obs³ug± protoko³u PPP. Standardowe j±dro z dystrybucji zawiera
72 wsparcie dla PPP skompilowane jako modu³. (IPv6)
73
74 %description -l pt_BR
75 Este é o servidor e a documentação para suporte PPP. Ele requer um
76 kernel superior ao 2.0. Os kernels-padrão da Conectiva incluem suporte
77 PPP como módulo.
78
79 %description -l ru
80 äÅÍÏÎ, ËÏÎÆÉÇÕÒÁÃÉÏÎÎÙÅ ÆÁÊÌÙ É ÄÏËÕÍÅÎÔÁÃÉÑ ÄÌÑ ÐÏÄÄÅÒÖËÉ PPP.
81
82 %description -l tr
83 Bu paket PPP desteði için belgeler ve sunucu sürecini içerir. Çekirdek
84 sürümünun 2.2.11'dan daha yüksek olmasýný gerektirir. Öntanýmlý Red
85 Hat çekirdeði PPP desteðini bir modül olarak içerir. (IPv6)
86
87 %package plugin-devel
88 Summary:        Stuff needed to build plugins for pppd
89 Summary(pl):    Rzeczy potrzebne do budowania wtyczek dla pppd
90 Group:          Development/Libraries
91 Requires:       %{name} = %{version}
92
93 %description plugin-devel
94 Development files needed to build plugins for pppd.
95
96 %description plugin-devel -l pl
97 Pliki nag³ówkowe potrzebne do budowania wtyczek dla pppd.
98
99 %prep
100 %setup -q -n %{name}-%{version}-%{snap}
101 %patch0 -p1
102 %patch1 -p1
103 %patch2 -p1
104 %patch3 -p1
105 %{?_with_pppoatm:%patch4 -p1}
106 %patch5 -p1
107 %patch6 -p1
108 %patch7 -p1
109
110 %build
111 cd pppd/plugins/radius/radiusclient
112 # touch seems no longer needed?
113 #find . -exec touch "{}" ";"
114 cp -f /usr/share/automake/config.* .
115 %configure2_13 \
116         --enable-shared \
117         --enable-static
118 cd ../../../..
119 # note: not autoconf configure
120 %configure
121 %{__make} \
122         OPT_FLAGS="%{rpmcflags}" \
123         CC=%{__cc}
124
125 %install
126 rm -rf $RPM_BUILD_ROOT
127 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_bindir},%{_mandir}/man{1,8}} \
128         $RPM_BUILD_ROOT{%{_sysconfdir}/{pam.d,ppp/peers},/var/log} \
129         $RPM_BUILD_ROOT/etc/logrotate.d
130
131 %{__make} install \
132         DESTDIR=$RPM_BUILD_ROOT
133
134 install %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/pon
135 install %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}/poff
136 install debian/plog $RPM_BUILD_ROOT%{_bindir}
137
138 install etc.ppp/chap-secrets $RPM_BUILD_ROOT%{_sysconfdir}/ppp
139 install debian/pap-secrets $RPM_BUILD_ROOT%{_sysconfdir}/ppp
140 install debian/options $RPM_BUILD_ROOT%{_sysconfdir}/ppp
141 install debian/options.ttyXX $RPM_BUILD_ROOT%{_sysconfdir}/ppp
142
143 bzip2 -dc %{SOURCE4} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
144
145 install %{SOURCE5} $RPM_BUILD_ROOT/etc/logrotate.d/ppp
146 > $RPM_BUILD_ROOT/var/log/ppp.log
147
148 rm -f scripts/README
149
150 install %{SOURCE1} $RPM_BUILD_ROOT/etc/pam.d/ppp
151
152 %clean
153 rm -rf $RPM_BUILD_ROOT
154
155 %post   -p /sbin/ldconfig
156 %postun -p /sbin/ldconfig
157
158 %files
159 %defattr(644,root,root,755)
160 %doc README.linux debian/README.debian scripts
161 %doc debian/win95.ppp README.MSCHAP8* FAQ debian/ppp-2.3.0.STATIC.README
162 %doc README.MPPE README.pppoe README.cbcp README.pwfd TODO
163 %attr(755,root,root) %{_bindir}/*
164 %attr(755,root,root) %{_sbindir}/chat
165 %attr(755,root,root) %{_sbindir}/ppp*
166 %dir %{_libdir}/pppd
167 %dir %{_libdir}/pppd/*.*
168 %attr(755,root,root) %{_libdir}/pppd/*.*/minconn.so
169 %attr(755,root,root) %{_libdir}/pppd/*.*/pass*.so
170 %attr(755,root,root) %{_libdir}/pppd/*.*/rp-pppoe.so
171 %attr(755,root,root) %{_libdir}/pppd/*.*/rad*.so
172 %{?_with_pppoatm:%attr(755,root,root) %{_libdir}/pppd/*.*/pppoatm.so}
173
174 %{_mandir}/man8/*
175 %lang(fr) %{_mandir}/fr/man8/*
176 %lang(ja) %{_mandir}/ja/man8/*
177 %lang(ko) %{_mandir}/ko/man8/*
178 %lang(pl) %{_mandir}/pl/man8/*
179
180 %attr(600,root,root) %config(missingok,noreplace) %verify(not md5 size mtime) %{_sysconfdir}/ppp/*-secrets
181 %attr(644,root,root) %config(missingok,noreplace) %verify(not md5 size mtime) %{_sysconfdir}/ppp/options*
182 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/ppp
183 %attr(640,root,root) /etc/logrotate.d/ppp
184 %attr(640,root,root) %ghost /var/log/ppp.log
185
186 %dir %{_sysconfdir}/ppp/peers
187
188 %files plugin-devel
189 %defattr(644,root,root,755)
190 %dir %{_includedir}/pppd
191 %{_includedir}/pppd/pppd.h
192 %{_includedir}/pppd/patchlevel.h
This page took 0.070209 seconds and 3 git commands to generate.