]> git.pld-linux.org Git - packages/povray.git/commitdiff
- am/as-needed fix from boost patch is still needed
authorJan Rękorajski <baggins@pld-linux.org>
Tue, 2 Apr 2013 19:28:40 +0000 (21:28 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Tue, 2 Apr 2013 19:28:40 +0000 (21:28 +0200)
boost-1.50.patch
povray.spec

index a3a1e59e1ef2a75c47b22d5ac31dffbe64233afe..5117496c3bfe14619ee71fca37a4876a6fb3b535 100644 (file)
                    done
  
              fi
-diff -ur povray-3.7.0.RC6.orig/source/backend/scene/view.cpp povray-3.7.0.RC6/source/backend/scene/view.cpp
---- povray-3.7.0.RC6.orig/source/backend/scene/view.cpp        2012-07-11 12:26:19.627968703 +0200
-+++ povray-3.7.0.RC6/source/backend/scene/view.cpp     2012-07-11 12:31:21.111291400 +0200
-@@ -1550,7 +1550,7 @@
-       }
-       boost::xtime t;
--      boost::xtime_get (&t, boost::TIME_UTC);
-+      boost::xtime_get (&t, boost::TIME_UTC_);
-       t.sec += 3;
-       // this will cause us to wait until the other threads are done.
-diff -ur povray-3.7.0.RC6.orig/source/base/timer.cpp povray-3.7.0.RC6/source/base/timer.cpp
---- povray-3.7.0.RC6.orig/source/base/timer.cpp        2012-02-05 21:54:15.000000000 +0100
-+++ povray-3.7.0.RC6/source/base/timer.cpp     2012-07-11 12:31:21.107958067 +0200
-@@ -117,7 +117,7 @@
- POV_LONG TimerDefault::ElapsedRealTime() const
- {
-       boost::xtime t;
--      boost::xtime_get(&t, boost::TIME_UTC);
-+      boost::xtime_get(&t, boost::TIME_UTC_);
-       POV_LONG tt = (POV_LONG)(t.sec) * (POV_LONG)(1000000000) + (POV_LONG)(t.nsec);
-       POV_LONG st = (POV_LONG)(realTimeStart.sec) * (POV_LONG)(1000000000) + (POV_LONG)(realTimeStart.nsec);
-       return ((tt - st) / (POV_LONG)(1000000));
-@@ -126,7 +126,7 @@
- POV_LONG TimerDefault::ElapsedCPUTime() const
- {
-       boost::xtime t;
--      boost::xtime_get(&t, boost::TIME_UTC);
-+      boost::xtime_get(&t, boost::TIME_UTC_);
-       POV_LONG tt = (POV_LONG)(t.sec) * (POV_LONG)(1000000000) + (POV_LONG)(t.nsec);
-       POV_LONG st = (POV_LONG)(cpuTimeStart.sec) * (POV_LONG)(1000000000) + (POV_LONG)(cpuTimeStart.nsec);
-       return ((tt - st) / (POV_LONG)(1000000));
-@@ -139,8 +139,8 @@
- void TimerDefault::Reset()
- {
--      boost::xtime_get(&realTimeStart, boost::TIME_UTC);
--      boost::xtime_get(&cpuTimeStart, boost::TIME_UTC);
-+      boost::xtime_get(&realTimeStart, boost::TIME_UTC_);
-+      boost::xtime_get(&cpuTimeStart, boost::TIME_UTC_);
- }
- }
-@@ -155,7 +155,7 @@
- void Delay(unsigned int msec)
- {
-       boost::xtime t;
--      boost::xtime_get(&t, boost::TIME_UTC);
-+      boost::xtime_get(&t, boost::TIME_UTC_);
-       POV_ULONG ns = (POV_ULONG)(t.sec) * (POV_ULONG)(1000000000) + (POV_ULONG)(t.nsec) + (POV_ULONG)(msec) * (POV_ULONG)(1000000);
-       t.sec = (boost::xtime::xtime_sec_t)(ns / (POV_ULONG)(1000000000));
-       t.nsec = (boost::xtime::xtime_nsec_t)(ns % (POV_ULONG)(1000000000));
-diff -ur povray-3.7.0.RC6.orig/vfe/unix/platformbase.cpp povray-3.7.0.RC6/vfe/unix/platformbase.cpp
---- povray-3.7.0.RC6.orig/vfe/unix/platformbase.cpp    2012-06-19 18:29:38.000000000 +0200
-+++ povray-3.7.0.RC6/vfe/unix/platformbase.cpp 2012-07-11 12:31:21.114624733 +0200
-@@ -126,7 +126,7 @@
- #else
-               // taken from source/base/timer.cpp
-               boost::xtime t;
--              boost::xtime_get(&t, boost::TIME_UTC);
-+              boost::xtime_get(&t, boost::TIME_UTC_);
-               POV_ULONG ns = (POV_ULONG)(t.sec) * (POV_ULONG)(1000000000) + (POV_ULONG)(t.nsec) + (POV_ULONG)(msec) * (POV_ULONG)(1000000);
-               t.sec = (boost::xtime::xtime_sec_t)(ns / (POV_ULONG)(1000000000));
-               t.nsec = (boost::xtime::xtime_nsec_t)(ns % (POV_ULONG)(1000000000));
-diff -ur povray-3.7.0.RC6.orig/vfe/vfepovms.cpp povray-3.7.0.RC6/vfe/vfepovms.cpp
---- povray-3.7.0.RC6.orig/vfe/vfepovms.cpp     2012-06-19 18:29:40.000000000 +0200
-+++ povray-3.7.0.RC6/vfe/vfepovms.cpp  2012-07-11 12:31:21.114624733 +0200
-@@ -247,7 +247,7 @@
-     // TODO: have a shorter wait but loop, and check for system shutdown
-     boost::xtime t;
--    boost::xtime_get (&t, boost::TIME_UTC);
-+    boost::xtime_get (&t, boost::TIME_UTC_);
-     t.nsec += 50000000 ;
-     m_Event.timed_wait (lock, t);
-diff -ur povray-3.7.0.RC6.orig/vfe/vfesession.cpp povray-3.7.0.RC6/vfe/vfesession.cpp
---- povray-3.7.0.RC6.orig/vfe/vfesession.cpp   2012-06-19 18:29:40.000000000 +0200
-+++ povray-3.7.0.RC6/vfe/vfesession.cpp        2012-07-11 12:31:21.114624733 +0200
-@@ -967,7 +967,7 @@
-   if (WaitTime > 0)
-   {
-     boost::xtime t;
--    boost::xtime_get (&t, boost::TIME_UTC);
-+    boost::xtime_get (&t, boost::TIME_UTC_);
-     t.sec += WaitTime / 1000 ;
-     t.nsec += (WaitTime % 1000) * 1000000 ;
-     m_SessionEvent.timed_wait (lock, t);
-@@ -1034,7 +1034,7 @@
-   // we can't call pause directly since it will result in a thread context
-   // error. pause must be called from the context of the worker thread.
-   boost::xtime t;
--  boost::xtime_get (&t, boost::TIME_UTC);
-+  boost::xtime_get (&t, boost::TIME_UTC_);
-   t.sec += 3 ;
-   m_RequestFlag = rqPauseRequest;
-   if (m_RequestEvent.timed_wait(lock, t) == false)
-@@ -1057,7 +1057,7 @@
-   // we can't call resume directly since it will result in a thread context
-   // error. it must be called from the context of the worker thread.
-   boost::xtime t;
--  boost::xtime_get (&t, boost::TIME_UTC);
-+  boost::xtime_get (&t, boost::TIME_UTC_);
-   t.sec += 3 ;
-   m_RequestFlag = rqResumeRequest;
-   if (m_RequestEvent.timed_wait(lock, t) == false)
-@@ -1123,7 +1123,7 @@
-   m_LastError = vfeNoError;
-   boost::xtime t;
--  boost::xtime_get (&t, boost::TIME_UTC);
-+  boost::xtime_get (&t, boost::TIME_UTC_);
-   t.sec += 3 ;
- #ifdef _DEBUG
-   t.sec += 120;
index cb02582af1d9866f884cc7397ad2c305b2d6f8ff..08b7843c36bfff3774452b9bf4b5d9a8fc9f4133 100644 (file)
@@ -22,6 +22,7 @@ Source0:      http://www.povray.org/redirect/www.povray.org/beta/source/%{name}-%{_sr
 # Source0:     %{name}-%{version}-%{snap}.tar.gz
 Source1:       %{name}-ax_boost_base.m4
 Patch0:                %{name}-nouserfiles.patch
+Patch1:                boost-1.50.patch
 URL:           http://www.povray.org/
 BuildRequires: autoconf
 BuildRequires: automake
@@ -103,6 +104,7 @@ PVM/xwin.
 %setup -q -n %{name}-%{_src_pov_ver}
 cp %{SOURCE1} unix/config/ax_boost_base.m4
 %patch0 -p1
+%patch1 -p1
 
 %build
 %{__aclocal}
@@ -112,7 +114,6 @@ COMPILED_BY="PLD/Linux Team";export COMPILED_BY;
 %if %{with x} && %{with pvm}
 %configure \
        --libdir=%{_datadir} \
-       --with-boost-thread=boost_thread-mt \
        --enable-pvm \
        --with-pvm-arch=%{_pvmarch} \
        --with-pvm-libs=%{_libdir}
@@ -125,7 +126,6 @@ install unix/povray x-pvmpov
 
 %configure \
        --libdir=%{_datadir} \
-       --with-boost-thread=boost_thread-mt \
        --enable-pvm \
        --with-pvm-arch=%{_pvmarch} \
        --with-pvm-libs=%{_libdir} \
@@ -137,7 +137,6 @@ install unix/povray pvmpov
 %if %{with x}
 %configure \
        --libdir=%{_datadir} \
-       --with-boost-thread=boost_thread-mt
 %{__make}
 install unix/povray x-povray
 %{__make} clean
@@ -145,7 +144,6 @@ install unix/povray x-povray
 
 %configure \
        --libdir=%{_datadir} \
-       --with-boost-thread=boost_thread-mt \
        --without-x
 %{__make}
 
This page took 0.054089 seconds and 4 git commands to generate.