]> git.pld-linux.org Git - packages/povray.git/blob - povray.spec
- BR: ac,am
[packages/povray.git] / povray.spec
1
2 #
3 # todo:
4 #      patch for s#/usr/local#/usr# in povray.ini
5 #      (no)svga version
6 #
7
8 # Conditional build:
9 # _without_x    - without X11 subpackage
10 # _without_pvm  - without PVM support
11 #
12 %define         snap 20030110
13 Summary:        Persistence of Vision Ray Tracer
14 Summary(pl):    Persistence of Vision Ray Tracer
15 Name:           povray
16 Version:        3.50c
17 Release:        1
18 License:        distributable
19 Group:          Applications/Graphics
20 #Source0:       ftp://ftp.povray.org/pub/povray/Official/Unix/povuni_s.tgz
21 # based on sources from CVS at http://pvmpov.sourceforge.net/
22 Source0:        %{name}-%{version}-%{snap}.tar.gz
23 # Source0-md5: 4dc3a74c6182e9f9cb2fc46187fe7e6b
24 Patch0:         %{name}-legal.patch
25 URL:            http://www.povray.org/
26 %{!?_without_x:BuildRequires:XFree86-devel}
27 BuildRequires:  autoconf
28 BuildRequires:  automake
29 BuildRequires:  libjpeg-devel
30 BuildRequires:  libpng-devel >= 1.0.8
31 BuildRequires:  libstdc++-devel
32 BuildRequires:  libtiff-devel
33 %{!?_without_pvm:BuildRequires:pvm-devel >= 3.4.3-24 }
34 BuildRequires:  zlib-devel
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %define         _libdir         %{_datadir}
38 %define         _pvmarch        %(/usr/bin/pvmgetarch)
39 %define         _pvmroot        /usr/lib/pvm3
40
41 %description
42 The Persistence of Vision(tm) Ray-Tracer creates three-dimensional,
43 photo-realistic images using a rendering technique called ray-tracing.
44 It reads in a text file containing information describing the objects
45 and lighting in a scene and generates an image of that scene from the
46 view point of a camera also described in the text file. Ray-tracing is
47 not a fast process by any means, but it produces very high quality
48 images with realistic reflections, shading, perspective and other
49 effects.
50
51 %description -l pl
52 Persistence of Vision(tm) Ray-Tracer tworzy trójwymiarowe,
53 fotorealistyczne obrazy za pomoc± techniki renderingu zwanej
54 ray-tracing. Program pobiera z pliku tekstowego informacje opisuj±ce
55 obiekty oraz ¶wiat³o przedstawianego ¶wiata, a nastêpnie generuje
56 rysunek z punktu widzenia kamery, która tak¿e jest definiowana w w/w
57 pliku tekstowym. Ray-tracing nie pozwala na szybkie tworzenie obrazów,
58 ale za to twórca otrzymuje wyskokiej jako¶ci bitmapy z realistycznymi
59 efektami, tj. odbicia ¶wiat³a, cienie, perspektywa i inne.
60
61 %package X11
62 Summary:        X Window povray executable
63 Summary(pl):    povray pod X Window
64 Group:          Applications/Graphics
65 Requires:       %{name} = %{version}
66
67 %description X11
68 The Persistence of Vision(tm) Ray-Tracer X Window executable.
69
70 %description X11 -l pl
71 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla X
72 Window.
73
74 %package pvm
75 Summary:        PVM/unix povray executable
76 Summary(pl):    Plik wykonywalny povray dla PVM/unix
77 Group:          Applications/Graphics
78 Requires:       %{name} = %{version}
79
80 %description pvm
81 The Persistence of Vision(tm) Ray-Tracer PVM/unix executable.
82
83 %description pvm -l pl
84 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla
85 PVM/unix.
86
87 %package pvm-X11
88 Summary:        PVM/xwin povray executable
89 Summary(pl):    Plik wykonywalny povray dla PVM/xwin
90 Group:          Applications/Graphics
91 Requires:       %{name} = %{version}
92
93 %description pvm-X11
94 The Persistence of Vision(tm) Ray-Tracer PVM/xwin executable.
95
96 %description pvm-X11 -l pl
97 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla
98 PVM/xwin.
99
100 %prep
101 %setup -q
102
103 %build
104 %{__aclocal}
105 %{__autoconf}
106 %{__automake}
107 %if %{!?_without_pvm:%{!?_without_x:1}%{?_without_x:0}}%{?_without_pvm:0}
108 %configure \
109         --enable-pvm \
110         --with-pvm-arch=%{_pvmarch} \
111         --x-includes=/usr/X11R6/include \
112         --x-libraries=/usr/X11R6/lib
113 %{__make}
114 install src/povray x-pvmpov
115 %endif
116
117 %if %{!?_without_pvm:1}%{?_without_pvm:0}
118 %{__make} clean
119
120 %configure \
121         --enable-pvm \
122         --with-pvm-arch=%{_pvmarch} \
123         --without-x
124 %{__make}
125 install src/povray pvmpov
126 %endif
127
128 %if %{!?_without_x:1}%{?_without_x:0}
129 %configure \
130         --x-includes=/usr/X11R6/include \
131         --x-libraries=/usr/X11R6/lib
132 %{__make}
133 install src/povray x-povray
134 %{__make} clean
135 %endif
136
137 %configure \
138         --without-x
139 %{__make}
140
141
142 %install
143 rm -rf $RPM_BUILD_ROOT
144 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/usr/X11R6/bin} \
145         $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}
146
147 %{__make} install \
148         DESTDIR=$RPM_BUILD_ROOT
149
150 %if %{!?_without_x:1}%{?_without_x:0}
151 install x-povray $RPM_BUILD_ROOT%{_bindir}
152 %endif
153
154 %if %{!?_without_pvm:%{!?_without_x:1}%{?_without_x:0}}%{?_without_pvm:0}
155 install x-pvmpov $RPM_BUILD_ROOT%{_bindir}/x-pvmpov
156 ln -s %{_binir}/x-pvmpov $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}/x-pvmpov
157 %endif
158
159 %if %{!?_without_pvm:1}%{?_without_pvm:0}
160 install pvmpov $RPM_BUILD_ROOT%{_bindir}/pvmpov
161 ln -s %{_binir}/pvmpov $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}/pvmpov
162 %endif
163
164 install povray.ini $RPM_BUILD_ROOT%{_sysconfdir}
165 install povray.conf $RPM_BUILD_ROOT%{_sysconfdir}
166 ln -sf %{_sysconfdir}/povray.ini $RPM_BUILD_ROOT%{_datadir}/povray-3.5/povray.ini
167
168 %clean
169 rm -rf $RPM_BUILD_ROOT
170
171 %files
172 %defattr(644,root,root,755)
173 %doc AUTHORS ChangeLog NEWS README* povlegal.doc *.txt doc/html
174 %attr(755,root,root) %{_bindir}/povray
175 %{_libdir}/povray*
176 %{_mandir}/man?/*
177 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/povray.*
178
179 %if %{!?_without_x:1}%{?_without_x:0}
180 %files X11
181 %defattr(644,root,root,755)
182 %attr(755,root,root) %{_bindir}/x-povray
183 %endif
184
185 %if %{!?_without_pvm:1}%{?_without_pvm:0}
186 %files pvm
187 %defattr(644,root,root,755)
188 %attr(755,root,root) %{_pvmroot}/bin/%{_pvmarch}/pvmpov
189 %attr(755,root,root) %{_bindir}/pvmpov
190 %endif
191
192 %if %{!?_without_pvm:%{!?_without_x:1}%{?_without_x:0}}%{?_without_pvm:0}
193 %files pvm-X11
194 %defattr(644,root,root,755)
195 %attr(755,root,root) %{_pvmroot}/bin/%{_pvmarch}/x-pvmpov
196 %attr(755,root,root) %{_bindir}/x-pvmpov
197 %endif
This page took 0.149165 seconds and 4 git commands to generate.