]> git.pld-linux.org Git - packages/povray.git/blob - povray.spec
- rel .3
[packages/povray.git] / povray.spec
1 #
2 # Conditional build:
3 %bcond_without  x       # - without X11 subpackage
4 %bcond_with     pvm     # - with PVM support
5 %bcond_with     svga    # - with svgalib support (doesn't work on many platforms)
6 #
7 %define         _src_pov_ver    3.7.0.RC5
8
9 Summary:        Persistence of Vision Ray Tracer
10 Summary(pl.UTF-8):      Persistence of Vision Ray Tracer
11 Name:           povray
12 Version:        3.7.0
13 Release:        0.RC5.3
14 Epoch:          1
15 License:        distributable
16 Group:          Applications/Graphics
17 #Source0:       http://www.povray.org/ftp/pub/povray/Official/Unix/%{name}-%{_src_pov_ver}.tar.bz2
18 Source0:        http://www.povray.org/redirect/www.povray.org/beta/source/%{name}-%{_src_pov_ver}.tar.gz
19 # Source0-md5:  d272acba3c4116796b061703c0cfa97d
20 # based on sources from CVS at http://pvmpov.sourceforge.net/
21 # Source0:      %{name}-%{version}-%{snap}.tar.gz
22 Source1:        %{name}-ax_boost_base.m4
23 Patch0:         %{name}-nouserfiles.patch
24 URL:            http://www.povray.org/
25 BuildRequires:  autoconf
26 BuildRequires:  automake
27 BuildRequires:  libjpeg-devel
28 BuildRequires:  libpng-devel >= 1.4.0
29 BuildRequires:  libstdc++-devel
30 BuildRequires:  libtiff-devel
31 %{?with_pvm:BuildRequires:      pvm-devel >= 3.4.3-24}
32 %{?with_svga:BuildRequires:     svgalib-devel}
33 %{?with_x:BuildRequires:        xorg-lib-libX11-devel}
34 BuildRequires:  zlib-devel
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %if %{with pvm}
38 %define         _pvmarch        %(/usr/bin/pvmgetarch)
39 %define         _pvmroot        /usr/%{_lib}/pvm3
40 %endif
41
42 %description
43 The Persistence of Vision(tm) Ray-Tracer creates three-dimensional,
44 photo-realistic images using a rendering technique called ray-tracing.
45 It reads in a text file containing information describing the objects
46 and lighting in a scene and generates an image of that scene from the
47 view point of a camera also described in the text file. Ray-tracing is
48 not a fast process by any means, but it produces very high quality
49 images with realistic reflections, shading, perspective and other
50 effects.
51
52 %description -l pl.UTF-8
53 Persistence of Vision(tm) Ray-Tracer tworzy trójwymiarowe,
54 fotorealistyczne obrazy za pomocą techniki renderingu zwanej
55 ray-tracing. Program pobiera z pliku tekstowego informacje opisujące
56 obiekty oraz światło przedstawianego świata, a następnie generuje
57 rysunek z punktu widzenia kamery, która także jest definiowana w w/w
58 pliku tekstowym. Ray-tracing nie pozwala na szybkie tworzenie obrazów,
59 ale za to twórca otrzymuje wyskokiej jakości bitmapy z realistycznymi
60 efektami, tj. odbicia światła, cienie, perspektywa i inne.
61
62 %package X11
63 Summary:        X Window povray executable
64 Summary(pl.UTF-8):      povray pod X Window
65 Group:          Applications/Graphics
66 Requires:       %{name} = %{epoch}:%{version}-%{release}
67
68 %description X11
69 The Persistence of Vision(tm) Ray-Tracer X Window executable.
70
71 %description X11 -l pl.UTF-8
72 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla X
73 Window.
74
75 %package pvm
76 Summary:        PVM/Unix povray executable
77 Summary(pl.UTF-8):      Plik wykonywalny povray dla PVM/Unix
78 Group:          Applications/Graphics
79 Requires:       %{name} = %{epoch}:%{version}-%{release}
80
81 %description pvm
82 The Persistence of Vision(tm) Ray-Tracer PVM/Unix executable.
83
84 %description pvm -l pl.UTF-8
85 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla
86 PVM/Unix.
87
88 %package pvm-X11
89 Summary:        PVM/xwin povray executable
90 Summary(pl.UTF-8):      Plik wykonywalny povray dla PVM/xwin
91 Group:          Applications/Graphics
92 Requires:       %{name} = %{epoch}:%{version}-%{release}
93
94 %description pvm-X11
95 The Persistence of Vision(tm) Ray-Tracer PVM/xwin executable.
96
97 %description pvm-X11 -l pl.UTF-8
98 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla
99 PVM/xwin.
100
101 %prep
102 %setup -q -n %{name}-%{_src_pov_ver}
103 cp %{SOURCE1} unix/config/ax_boost_base.m4
104 %patch0 -p1
105
106 %build
107 %{__aclocal}
108 %{__autoconf}
109 %{__automake}
110 COMPILED_BY="PLD/Linux Team";export COMPILED_BY;
111 %if %{with x} && %{with pvm}
112 %configure \
113         --libdir=%{_datadir} \
114         --enable-pvm \
115         --with-pvm-arch=%{_pvmarch} \
116         --with-pvm-libs=%{_libdir}
117 %{__make}
118 install unix/povray x-pvmpov
119 %endif
120
121 %if %{with pvm}
122 %{__make} clean
123
124 %configure \
125         --libdir=%{_datadir} \
126         --enable-pvm \
127         --with-pvm-arch=%{_pvmarch} \
128         --with-pvm-libs=%{_libdir} \
129         --without-x
130 %{__make}
131 install unix/povray pvmpov
132 %endif
133
134 %if %{with x}
135 %configure \
136         --libdir=%{_datadir}
137 %{__make}
138 install unix/povray x-povray
139 %{__make} clean
140 %endif
141
142 %configure \
143         --libdir=%{_datadir} \
144         --without-x
145 %{__make}
146
147 %install
148 rm -rf $RPM_BUILD_ROOT
149 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_bindir},%{_datadir}}
150 %if %{with pvm}
151 install -d $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}
152 %endif
153
154 %{__make} install \
155         INSTALL="install -c -D" \
156         mkdir_p="mkdir -p" \
157         DESTDIR=$RPM_BUILD_ROOT
158
159 %if %{with x}
160 install x-povray $RPM_BUILD_ROOT%{_bindir}
161 %endif
162
163 %if %{with x} && %{with pvm}
164 install x-pvmpov $RPM_BUILD_ROOT%{_bindir}/x-pvmpov
165 ln -s %{_bindir}/x-pvmpov $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}/x-pvmpov
166 %endif
167
168 %if %{with pvm}
169 install pvmpov $RPM_BUILD_ROOT%{_bindir}/pvmpov
170 ln -s %{_bindir}/pvmpov $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}/pvmpov
171 %endif
172
173 ##install povray.ini $RPM_BUILD_ROOT%{_sysconfdir}
174 ##install povray.conf $RPM_BUILD_ROOT%{_sysconfdir}
175
176 %clean
177 rm -rf $RPM_BUILD_ROOT
178
179 %files
180 %defattr(644,root,root,755)
181 %doc AUTHORS ChangeLog NEWS README* changes.txt
182 %attr(755,root,root) %{_bindir}/povray
183 %{_datadir}/povray*
184 %{_docdir}/povray*
185 %{_mandir}/man?/*
186 %dir %{_sysconfdir}/povray
187 %dir %{_sysconfdir}/povray/3.7
188 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/3.7/povray.*
189 ## %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/povray.*
190
191 %if %{with x}
192 %files X11
193 %defattr(644,root,root,755)
194 %attr(755,root,root) %{_bindir}/x-povray
195 %endif
196
197 %if %{with pvm}
198 %files pvm
199 %defattr(644,root,root,755)
200 %attr(755,root,root) %{_pvmroot}/bin/%{_pvmarch}/pvmpov
201 %attr(755,root,root) %{_bindir}/pvmpov
202 %endif
203
204 %if %{with pvm} && %{with x}
205 %files pvm-X11
206 %defattr(644,root,root,755)
207 %attr(755,root,root) %{_pvmroot}/bin/%{_pvmarch}/x-pvmpov
208 %attr(755,root,root) %{_bindir}/x-pvmpov
209 %endif
This page took 0.043542 seconds and 4 git commands to generate.