]> git.pld-linux.org Git - packages/povray.git/blob - povray.spec
- added missing povray.conf configuration file
[packages/povray.git] / povray.spec
1 #
2 # Conditional build:
3 # _without_x    - without X11 subpackage
4 # _without_pvm  - [temporarily disabled by default] without PVM support
5 #
6 Summary:        Persistence of Vision Ray Tracer
7 Summary(pl):    Persistence of Vision Ray Tracer
8 Name:           povray
9 Version:        3.50c
10 Release:        1
11 License:        distributable
12 Group:          Applications/Graphics
13 Source0:        ftp://ftp.povray.org/pub/povray/Official/Unix/povuni_s.tgz
14 Source1:        %{name}-%{version}.md5sum
15 Patch0:         %{name}-legal.patch
16 Patch1:         %{name}-types.patch
17 # pvm support not yet available - http://pvmpov.sourceforge.net/
18 URL:            http://www.povray.org/
19 BuildRequires:  libjpeg-devel
20 BuildRequires:  libpng-devel >= 1.0.8
21 BuildRequires:  libstdc++-devel
22 BuildRequires:  libtiff-devel
23 BuildRequires:  zlib-devel
24 %{!?_without_x:BuildRequires:XFree86-devel}
25 #%{!?_without_pvm:BuildRequires:pvm-devel >= 3.4.3-24 }
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         _libdir         %{_datadir}
29
30 %description
31 The Persistence of Vision(tm) Ray-Tracer creates three-dimensional,
32 photo-realistic images using a rendering technique called ray-tracing.
33 It reads in a text file containing information describing the objects
34 and lighting in a scene and generates an image of that scene from the
35 view point of a camera also described in the text file. Ray-tracing is
36 not a fast process by any means, but it produces very high quality
37 images with realistic reflections, shading, perspective and other
38 effects.
39
40 %description -l pl
41 Persistence of Vision(tm) Ray-Tracer tworzy trójwymiarowe,
42 fotorealistyczne obrazy za pomoc± techniki renderingu zwanej
43 ray-tracing. Program pobiera z pliku tekstowego informacje opisuj±ce
44 obiekty oraz ¶wiat³o przedstawianego ¶wiata, a nastêpnie generuje
45 rysunek z punktu widzenia kamery, która tak¿e jest definiowana w w/w
46 pliku tekstowym. Ray-tracing nie pozwala na szybkie tworzenie obrazów,
47 ale za to twórca otrzymuje wyskokiej jako¶ci bitmapy z realistycznymi
48 efektami, tj. odbicia ¶wiat³a, cienie, perspektywa i inne.
49
50 %package X11
51 Summary:        X Window povray executable
52 Summary(pl):    povray pod X Window
53 Group:          Applications/Graphics
54 Requires:       %{name} = %{version}
55
56 %description X11
57 The Persistence of Vision(tm) Ray-Tracer X Window executable.
58
59 %description X11 -l pl
60 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla X
61 Window.
62
63 %package pvm
64 Summary:        PVM/unix povray executable
65 Group:          Applications/Graphics
66 Requires:       %{name} = %{version}
67
68 %description pvm
69 The Persistence of Vision(tm) Ray-Tracer PVM/unix executable.
70
71 %description X11 -l pl
72 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla
73 PVM/unix.
74
75 %package pvm-X11
76 Summary:        PVM/xwin povray executable
77 Group:          Applications/Graphics
78 Requires:       %{name} = %{version}
79
80 %description pvm-X11
81 The Persistence of Vision(tm) Ray-Tracer PVM/xwin executable.
82
83 %description X11 -l pl
84 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla
85 PVM/xwin.
86
87 %prep
88 cd %{_sourcedir}
89 md5sum -c %{name}-%{version}.md5sum
90 cd -
91 %setup -q
92 %patch0 -p1
93 %ifarch alpha
94 %patch1 -p1
95 %endif
96
97 %build
98 %{__aclocal}
99 %{__autoconf}
100 %{__automake}
101 %if %{!?_without_x:1}%{?_without_x:0}
102 %configure \
103         --x-includes=%{_prefix}/X11R6/include \
104         --x-libraries=%{_prefix}/X11R6/lib
105 %{__make}
106 install src/povray x-povray
107 %{__make} clean
108 %endif
109
110 %configure \
111         --without-x
112 %{__make}
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_prefix}/X11R6/bin}
117
118 %{__make} install \
119         DESTDIR=$RPM_BUILD_ROOT
120
121 %if %{!?_without_x:1}%{?_without_x:0}
122 install x-povray $RPM_BUILD_ROOT%{_prefix}/X11R6/bin
123 %endif
124
125 install povray.ini $RPM_BUILD_ROOT%{_sysconfdir}
126 install povray.conf $RPM_BUILD_ROOT%{_sysconfdir}
127 ln -sf %{_sysconfdir}/povray.ini $RPM_BUILD_ROOT%{_datadir}/povray-3.5/povray.ini
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %files
133 %defattr(644,root,root,755)
134 %doc AUTHORS ChangeLog NEWS README* povlegal.doc *.txt doc/html
135 %attr(755,root,root) %{_bindir}/povray
136 %{_libdir}/povray*
137 %{_mandir}/man?/*
138 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/povray.*
139
140 %if %{!?_without_x:1}%{?_without_x:0}
141 %files X11
142 %defattr(644,root,root,755)
143 %attr(755,root,root) %{_prefix}/X11R6/bin/x-povray
144 %endif
145
146 #%if %{!?_without_pvm:1}%{?_without_pvm:0}
147 #%files pvm
148 #%defattr(644,root,root,755)
149 #%attr(755,root,root) %{_pvm_root}/bin/%{_pvm_arch}/pvmpov
150 #
151 #%if %{!?_without_x:1}%{?_without_x:0}
152 #%files pvm-X11
153 #%defattr(644,root,root,755)
154 #%attr(755,root,root) %{_pvm_root}/bin/%{_pvm_arch}/x-pvmpov
155 #%endif
156 #%endif
This page took 0.048246 seconds and 4 git commands to generate.