]> git.pld-linux.org Git - packages/povray.git/blob - povray.spec
- updated to 3.6.1,
[packages/povray.git] / povray.spec
1
2 #
3 # todo:
4 #      patch for s#/usr/local#/usr# in povray.ini
5 #
6 #
7 # Conditional build:
8 %bcond_without  x       # - without X11 subpackage
9 %bcond_with     pvm             # - with PVM support
10 %bcond_with     svga    # - with svgalib support (doesn't work on many platforms)
11 #
12 %define         _src_pov_ver    3.6.1
13
14 Summary:        Persistence of Vision Ray Tracer
15 Summary(pl):    Persistence of Vision Ray Tracer
16 Name:           povray
17 Version:        3.6.1
18 Release:        0.1
19 Epoch:          1
20 License:        distributable
21 Group:          Applications/Graphics
22 Source0:        http://www.povray.org/ftp/pub/povray/Official/Unix/%{name}-%{_src_pov_ver}.tar.bz2
23 # Source0-md5:  b5789bb7eeaed0809c5c82d0efda571d
24 # based on sources from CVS at http://pvmpov.sourceforge.net/
25 # Source0:      %{name}-%{version}-%{snap}.tar.gz
26 Patch0:         %{name}-legal.patch
27 Patch1:         %{name}-64bit.patch
28 Patch2:         %{name}-X-libs.patch
29 Patch3:         %{name}-lib64.patch
30 Patch4:         %{name}-no_svgalib.patch
31 URL:            http://www.povray.org/
32 %{?with_x:BuildRequires:        xorg-lib-libX11-devel}
33 BuildRequires:  autoconf
34 BuildRequires:  automake
35 BuildRequires:  libjpeg-devel
36 BuildRequires:  libpng-devel >= 1.0.8
37 BuildRequires:  libstdc++-devel
38 BuildRequires:  libtiff-devel
39 %{?with_pvm:BuildRequires:      pvm-devel >= 3.4.3-24}
40 %{?with_svga:BuildRequires:     svgalib-devel}
41 BuildRequires:  zlib-devel
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %if %{with pvm}
45 %define         _pvmarch        %(/usr/bin/pvmgetarch)
46 %define         _pvmroot        /usr/%{_lib}/pvm3
47 %endif
48
49 %description
50 The Persistence of Vision(tm) Ray-Tracer creates three-dimensional,
51 photo-realistic images using a rendering technique called ray-tracing.
52 It reads in a text file containing information describing the objects
53 and lighting in a scene and generates an image of that scene from the
54 view point of a camera also described in the text file. Ray-tracing is
55 not a fast process by any means, but it produces very high quality
56 images with realistic reflections, shading, perspective and other
57 effects.
58
59 %description -l pl
60 Persistence of Vision(tm) Ray-Tracer tworzy trójwymiarowe,
61 fotorealistyczne obrazy za pomoc± techniki renderingu zwanej
62 ray-tracing. Program pobiera z pliku tekstowego informacje opisuj±ce
63 obiekty oraz ¶wiat³o przedstawianego ¶wiata, a nastêpnie generuje
64 rysunek z punktu widzenia kamery, która tak¿e jest definiowana w w/w
65 pliku tekstowym. Ray-tracing nie pozwala na szybkie tworzenie obrazów,
66 ale za to twórca otrzymuje wyskokiej jako¶ci bitmapy z realistycznymi
67 efektami, tj. odbicia ¶wiat³a, cienie, perspektywa i inne.
68
69 %package X11
70 Summary:        X Window povray executable
71 Summary(pl):    povray pod X Window
72 Group:          Applications/Graphics
73 Requires:       %{name} = %{version}
74
75 %description X11
76 The Persistence of Vision(tm) Ray-Tracer X Window executable.
77
78 %description X11 -l pl
79 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla X
80 Window.
81
82 %if %{with pvm}
83 %package pvm
84 Summary:        PVM/unix povray executable
85 Summary(pl):    Plik wykonywalny povray dla PVM/unix
86 Group:          Applications/Graphics
87 Requires:       %{name} = %{version}
88
89 %description pvm
90 The Persistence of Vision(tm) Ray-Tracer PVM/unix executable.
91
92 %description pvm -l pl
93 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla
94 PVM/unix.
95
96 %package pvm-X11
97 Summary:        PVM/xwin povray executable
98 Summary(pl):    Plik wykonywalny povray dla PVM/xwin
99 Group:          Applications/Graphics
100 Requires:       %{name} = %{version}
101
102 %description pvm-X11
103 The Persistence of Vision(tm) Ray-Tracer PVM/xwin executable.
104
105 %description pvm-X11 -l pl
106 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla
107 PVM/xwin.
108 %endif
109
110 %prep
111 %setup -q
112 ##%patch1 -p1
113 ##%patch2 -p1
114 %if "%{_lib}" == "lib64"
115 ##%patch3 -p1
116 %endif
117 %if %{without svga}
118 ##%patch4 -p1
119 %endif
120
121 %build
122 %{__aclocal}
123 %{__autoconf}
124 %{__automake}
125 COMPILED_BY="xx";export COMPILED_BY;
126 %if %{with x} && %{with pvm}
127 %configure \
128         --libdir=%{_datadir} \
129         --enable-pvm \
130         --with-pvm-arch=%{_pvmarch} \
131         --with-pvm-libs=%{_libdir} \
132         --x-includes=/usr/X11R6/include \
133         --x-libraries=/usr/X11R6/%{_lib}
134 %{__make}
135 install unix/povray x-pvmpov
136 %endif
137
138 %if %{with pvm}
139 %{__make} clean
140
141 %configure \
142         --libdir=%{_datadir} \
143         --enable-pvm \
144         --with-pvm-arch=%{_pvmarch} \
145         --with-pvm-libs=%{_libdir} \
146         --without-x
147 %{__make}
148 install unix/povray pvmpov
149 %endif
150
151 %if %{with x}
152 %configure \
153         --libdir=%{_datadir} \
154         --x-includes=/usr/X11R6/include \
155         --x-libraries=/usr/X11R6/%{_lib} 
156 %{__make}
157 install unix/povray x-povray
158 %{__make} clean
159 %endif
160
161 %configure \
162         --libdir=%{_datadir} \
163         --without-x
164 %{__make}
165
166
167 %install
168 rm -rf $RPM_BUILD_ROOT
169 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/usr/X11R6/bin} \
170         $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}
171
172 %{__make} install \
173         DESTDIR=$RPM_BUILD_ROOT
174
175 %if %{with x}
176 install x-povray $RPM_BUILD_ROOT%{_bindir}
177 %endif
178
179 %if %{with x} && %{with pvm}
180 install x-pvmpov $RPM_BUILD_ROOT%{_bindir}/x-pvmpov
181 ln -s %{_bindir}/x-pvmpov $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}/x-pvmpov
182 %endif
183
184 %if %{with pvm}
185 install pvmpov $RPM_BUILD_ROOT%{_bindir}/pvmpov
186 ln -s %{_bindir}/pvmpov $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}/pvmpov
187 %endif
188
189 ##install povray.ini $RPM_BUILD_ROOT%{_sysconfdir}
190 ##install povray.conf $RPM_BUILD_ROOT%{_sysconfdir}
191
192 %clean
193 rm -rf $RPM_BUILD_ROOT
194
195 %files
196 %defattr(644,root,root,755)
197 %doc AUTHORS ChangeLog NEWS README* doc/povlegal.doc doc/*.txt doc/html
198 %attr(755,root,root) %{_bindir}/povray
199 %{_datadir}/povray*
200 %{_docdir}/povray*
201 %{_mandir}/man?/*
202 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/%{_src_pov_ver}/povray.*
203 ## %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/povray.*
204
205 %if %{with x}
206 %files X11
207 %defattr(644,root,root,755)
208 %attr(755,root,root) %{_bindir}/x-povray
209 %endif
210
211 %if %{with pvm}
212 %files pvm
213 %defattr(644,root,root,755)
214 %attr(755,root,root) %{_pvmroot}/bin/%{_pvmarch}/pvmpov
215 %attr(755,root,root) %{_bindir}/pvmpov
216 %endif
217
218 %if %{with pvm} && %{with x}
219 %files pvm-X11
220 %defattr(644,root,root,755)
221 %attr(755,root,root) %{_pvmroot}/bin/%{_pvmarch}/x-pvmpov
222 %attr(755,root,root) %{_bindir}/x-pvmpov
223 %endif
This page took 0.112029 seconds and 4 git commands to generate.