]> git.pld-linux.org Git - packages/povray.git/blob - povray.spec
- removed all Group fields translations (oure rpm now can handle translating
[packages/povray.git] / povray.spec
1 Summary:        Persistence of Vision Ray Tracer
2 Summary(pl):    Persistence of Vision Ray Tracer
3 Name:           povray
4 Version:        3.1g
5 Release:        5
6 License:        distrituable
7 Group:          Applications/Graphics
8 Source0:        ftp://ftp.povray.org/pub/povray/Official/Unix/povuni_s.tgz
9 Source1:        ftp://ftp.povray.org/pub/povray/Official/Unix/povuni_d.tgz
10 # pvm.patch is instead of that source, and its based on it
11 #Source2:       pvmpov-3.1e2.tgz
12 Patch0:         %{name}-makefile_and_config.patch
13 Patch1:         %{name}-pvm.patch
14 Patch2:         %{name}-png_with_pvm.patch
15 URL:            http://www.povray.org/
16 BuildRequires:  zlib-devel
17 BuildRequires:  libpng-devel >= 1.0.8
18 %{!?_without_x:BuildRequires:XFree86-devel}
19 %{!?_without_pvm:BuildRequires:pvm-devel >= 3.4.3-24 }
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 #ugly but now _pvm_root/_pvm_arch isnt defined in macros
23
24 %define         _pvm_root       %{_libdir}/pvm3
25 %define         _pvm_arch       %(ls %{_pvm_root}/conf/|sed -e 's/\.def//')
26
27 %description
28 The Persistence of Vision(tm) Ray-Tracer creates three-dimensional,
29 photo-realistic images using a rendering technique called ray-tracing.
30 It reads in a text file containing information describing the objects
31 and lighting in a scene and generates an image of that scene from the
32 view point of a camera also described in the text file. Ray-tracing is
33 not a fast process by any means, but it produces very high quality
34 images with realistic reflections, shading, perspective and other
35 effects.
36
37 %description -l pl
38 Persistence of Vision(tm) Ray-Tracer tworzy trójwymiarowe,
39 fotorealistyczne obrazy za pomoc± techniki renderingu zwanej
40 ray-tracing. Program pobiera z pliku tekstowego informacje opisuj±ce
41 obiekty oraz ¶wiat³o przedstawianego ¶wiata, a nastêpnie generuje
42 rysunek z punktu widzenia kamery, która tak¿e jest definiowana w w/w
43 pliku tekstowym. Ray-tracing nie pozwala na szybkie tworzenie obrazów,
44 ale za to twórca otrzymuje wyskokiej jako¶ci bitmapy z realistycznymi
45 efektami, tj. odbicia ¶wiat³a, cienie, perspektywa i inne.
46
47 %if %{!?_without_x:1}%{?_without_x}
48 %package X11
49 Summary:        X Window povray executable
50 Summary(pl):    povray pod X Window
51 Group:          Applications/Graphics
52 Requires:       %{name} = %{version}
53
54 %description X11
55 The Persistence of Vision(tm) Ray-Tracer X Window executable.
56
57 %description X11 -l pl
58 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla X Window.
59 %endif
60
61 %if %{!?_without_pvm:1}%{?_without_pvm:0}
62 %package pvm
63 Summary:        PVM/unix povray executable
64 Group:          Applications/Graphics
65 Requires:       %{name} = %{version}
66
67 %description pvm
68 The Persistence of Vision(tm) Ray-Tracer PVM/unix executable.
69
70 %description X11 -l pl
71 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla PVM/unix.
72
73 %if %{!?_without_x:1}%{?_without_x:0}
74 %package pvm-X11
75 Summary:        PVM/xwin povray executable
76 Group:          Applications/Graphics
77 Requires:       %{name} = %{version}
78
79 %description pvm-X11
80 The Persistence of Vision(tm) Ray-Tracer PVM/xwin executable.
81
82 %description X11 -l pl
83 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla PVM/xwin.
84 %endif
85 %endif
86
87 %prep
88 %setup -q -n povray31 -b 1
89 %patch0 -p1
90 %patch1 -p0
91 %patch2 -p1
92
93 %build
94 cd source/unix
95 %{__make} newunix %{!?_without_x:newxwin} %{!?_without_pvm:newunix_pvm %{!?_without_x:newxwin_pvm}} OPT_FLAGS="%{rpmcflags}"
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99 install -d $RPM_BUILD_ROOT{%{_bindir},/etc/skel,%{_mandir}/man1,%{_datadir}/povray31,%{_pvm_root}/bin/%{_pvm_arch}}
100
101
102 install source/unix/povray $RPM_BUILD_ROOT%{_bindir}
103 %{!?_without_x:install source/unix/x-povray $RPM_BUILD_ROOT%{_bindir}}
104 %{!?_without_pvm:install source/unix/pvmpov $RPM_BUILD_ROOT%{_pvm_root}/bin/%{_pvm_arch}}
105 %{!?_without_pvm:%{!?_without_x:install source/unix/x-pvmpov $RPM_BUILD_ROOT%{_pvm_root}/bin/%{_pvm_arch}}}
106 install source/unix/povrayrc $RPM_BUILD_ROOT/etc/skel/.povrayrc
107
108 install povray.1 $RPM_BUILD_ROOT%{_mandir}/man1
109
110 cp -r allscene include scenes $RPM_BUILD_ROOT%{_datadir}/povray31
111 install *.ini *.pov $RPM_BUILD_ROOT%{_datadir}/povray31
112
113 gzip -9nf gamma.gif.txt povlegal.doc povuser.txt
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %files
119 %defattr(644,root,root,755)
120 %doc gamma.gif.txt.gz povuser.txt.gz gamma.gif povlegal.doc.gz
121 %attr(755,root,root) %{_bindir}/povray
122 %{_datadir}/povray31
123 /etc/skel/.povrayrc
124 %{_mandir}/man1/*
125
126 %if %{!?_without_x:1}%{?_without_x:0}
127 %files X11
128 %defattr(644,root,root,755)
129 %attr(755,root,root) %{_bindir}/x-povray
130 %endif
131
132 %if %{!?_without_pvm:1}%{?_without_pvm:0}
133 %files pvm
134 %defattr(644,root,root,755)
135 %attr(755,root,root) %{_pvm_root}/bin/%{_pvm_arch}/pvmpov
136
137 %if %{!?_without_x:1}%{?_without_x:0}
138 %files pvm-X11
139 %defattr(644,root,root,755)
140 %attr(755,root,root) %{_pvm_root}/bin/%{_pvm_arch}/x-pvmpov
141 %endif
142 %endif
This page took 0.060241 seconds and 4 git commands to generate.