]> git.pld-linux.org Git - packages/povray.git/blob - povray.spec
- rel .2
[packages/povray.git] / povray.spec
1 #
2 # Conditional build:
3 %bcond_without  x       # - without X11 subpackage
4 %bcond_with     pvm     # - with PVM support
5 %bcond_with     svga    # - with svgalib support (doesn't work on many platforms)
6 #
7 %define         _src_pov_ver    3.7.0.RC5
8
9 Summary:        Persistence of Vision Ray Tracer
10 Summary(pl.UTF-8):      Persistence of Vision Ray Tracer
11 Name:           povray
12 Version:        3.7.0
13 Release:        0.RC5.2
14 Epoch:          1
15 License:        distributable
16 Group:          Applications/Graphics
17 #Source0:       http://www.povray.org/ftp/pub/povray/Official/Unix/%{name}-%{_src_pov_ver}.tar.bz2
18 Source0:        http://www.povray.org/redirect/www.povray.org/beta/source/%{name}-%{_src_pov_ver}.tar.gz
19 # Source0-md5:  d272acba3c4116796b061703c0cfa97d
20 # based on sources from CVS at http://pvmpov.sourceforge.net/
21 # Source0:      %{name}-%{version}-%{snap}.tar.gz
22 Source1:        %{name}-ax_boost_base.m4
23 Patch0:         %{name}-nouserfiles.patch
24 URL:            http://www.povray.org/
25 BuildRequires:  autoconf
26 BuildRequires:  automake
27 BuildRequires:  libjpeg-devel
28 BuildRequires:  libpng-devel >= 1.4.0
29 BuildRequires:  libstdc++-devel
30 BuildRequires:  libtiff-devel
31 %{?with_pvm:BuildRequires:      pvm-devel >= 3.4.3-24}
32 %{?with_svga:BuildRequires:     svgalib-devel}
33 %{?with_x:BuildRequires:        xorg-lib-libX11-devel}
34 BuildRequires:  zlib-devel
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %if %{with pvm}
38 %define         _pvmarch        %(/usr/bin/pvmgetarch)
39 %define         _pvmroot        /usr/%{_lib}/pvm3
40 %endif
41
42 %description
43 The Persistence of Vision(tm) Ray-Tracer creates three-dimensional,
44 photo-realistic images using a rendering technique called ray-tracing.
45 It reads in a text file containing information describing the objects
46 and lighting in a scene and generates an image of that scene from the
47 view point of a camera also described in the text file. Ray-tracing is
48 not a fast process by any means, but it produces very high quality
49 images with realistic reflections, shading, perspective and other
50 effects.
51
52 %description -l pl.UTF-8
53 Persistence of Vision(tm) Ray-Tracer tworzy trójwymiarowe,
54 fotorealistyczne obrazy za pomocą techniki renderingu zwanej
55 ray-tracing. Program pobiera z pliku tekstowego informacje opisujące
56 obiekty oraz światło przedstawianego świata, a następnie generuje
57 rysunek z punktu widzenia kamery, która także jest definiowana w w/w
58 pliku tekstowym. Ray-tracing nie pozwala na szybkie tworzenie obrazów,
59 ale za to twórca otrzymuje wyskokiej jakości bitmapy z realistycznymi
60 efektami, tj. odbicia światła, cienie, perspektywa i inne.
61
62 %package X11
63 Summary:        X Window povray executable
64 Summary(pl.UTF-8):      povray pod X Window
65 Group:          Applications/Graphics
66 Requires:       %{name} = %{epoch}:%{version}-%{release}
67
68 %description X11
69 The Persistence of Vision(tm) Ray-Tracer X Window executable.
70
71 %description X11 -l pl.UTF-8
72 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla X
73 Window.
74
75 %package pvm
76 Summary:        PVM/Unix povray executable
77 Summary(pl.UTF-8):      Plik wykonywalny povray dla PVM/Unix
78 Group:          Applications/Graphics
79 Requires:       %{name} = %{epoch}:%{version}-%{release}
80
81 %description pvm
82 The Persistence of Vision(tm) Ray-Tracer PVM/Unix executable.
83
84 %description pvm -l pl.UTF-8
85 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla
86 PVM/Unix.
87
88 %package pvm-X11
89 Summary:        PVM/xwin povray executable
90 Summary(pl.UTF-8):      Plik wykonywalny povray dla PVM/xwin
91 Group:          Applications/Graphics
92 Requires:       %{name} = %{epoch}:%{version}-%{release}
93
94 %description pvm-X11
95 The Persistence of Vision(tm) Ray-Tracer PVM/xwin executable.
96
97 %description pvm-X11 -l pl.UTF-8
98 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla
99 PVM/xwin.
100
101 %prep
102 %setup -q -n %{name}-%{_src_pov_ver}
103 cp %{SOURCE1} unix/config/ax_boost_base.m4
104 %patch0 -p1
105
106 %build
107 %{__aclocal}
108 %{__autoconf}
109 %{__automake}
110 COMPILED_BY="PLD/Linux Team";export COMPILED_BY;
111 %if %{with x} && %{with pvm}
112 %configure \
113         --libdir=%{_datadir} \
114         --enable-pvm \
115         --with-pvm-arch=%{_pvmarch} \
116         --with-pvm-libs=%{_libdir} \
117         --x-includes=%{_includedir}/X11 \
118         --x-libraries=%{_libdir}
119 %{__make}
120 install unix/povray x-pvmpov
121 %endif
122
123 %if %{with pvm}
124 %{__make} clean
125
126 %configure \
127         --libdir=%{_datadir} \
128         --enable-pvm \
129         --with-pvm-arch=%{_pvmarch} \
130         --with-pvm-libs=%{_libdir} \
131         --without-x
132 %{__make}
133 install unix/povray pvmpov
134 %endif
135
136 %if %{with x}
137 %configure \
138         --libdir=%{_datadir} \
139         --x-includes=%{_includedir}/X11 \
140         --x-libraries=%{_libdir}
141 %{__make}
142 install unix/povray x-povray
143 %{__make} clean
144 %endif
145
146 %configure \
147         --libdir=%{_datadir} \
148         --without-x
149 %{__make}
150
151
152 %install
153 rm -rf $RPM_BUILD_ROOT
154 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_bindir}}
155 %if %{with pvm}
156 install -d $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}
157 %endif
158
159 %{__make} -j1 install \
160         DESTDIR=$RPM_BUILD_ROOT
161
162 %if %{with x}
163 install x-povray $RPM_BUILD_ROOT%{_bindir}
164 %endif
165
166 %if %{with x} && %{with pvm}
167 install x-pvmpov $RPM_BUILD_ROOT%{_bindir}/x-pvmpov
168 ln -s %{_bindir}/x-pvmpov $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}/x-pvmpov
169 %endif
170
171 %if %{with pvm}
172 install pvmpov $RPM_BUILD_ROOT%{_bindir}/pvmpov
173 ln -s %{_bindir}/pvmpov $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}/pvmpov
174 %endif
175
176 ##install povray.ini $RPM_BUILD_ROOT%{_sysconfdir}
177 ##install povray.conf $RPM_BUILD_ROOT%{_sysconfdir}
178
179 %clean
180 rm -rf $RPM_BUILD_ROOT
181
182 %files
183 %defattr(644,root,root,755)
184 %doc AUTHORS ChangeLog NEWS README* changes.txt
185 %attr(755,root,root) %{_bindir}/povray
186 %{_datadir}/povray*
187 %{_docdir}/povray*
188 %{_mandir}/man?/*
189 %dir %{_sysconfdir}/povray
190 %dir %{_sysconfdir}/povray/3.7
191 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/3.7/povray.*
192 ## %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/povray.*
193
194 %if %{with x}
195 %files X11
196 %defattr(644,root,root,755)
197 %attr(755,root,root) %{_bindir}/x-povray
198 %endif
199
200 %if %{with pvm}
201 %files pvm
202 %defattr(644,root,root,755)
203 %attr(755,root,root) %{_pvmroot}/bin/%{_pvmarch}/pvmpov
204 %attr(755,root,root) %{_bindir}/pvmpov
205 %endif
206
207 %if %{with pvm} && %{with x}
208 %files pvm-X11
209 %defattr(644,root,root,755)
210 %attr(755,root,root) %{_pvmroot}/bin/%{_pvmarch}/x-pvmpov
211 %attr(755,root,root) %{_bindir}/x-pvmpov
212 %endif
This page took 0.047169 seconds and 4 git commands to generate.