]> git.pld-linux.org Git - packages/povray.git/blob - povray.spec
- add boost-thread configure option as suggested by upstream
[packages/povray.git] / povray.spec
1 #
2 # Conditional build:
3 %bcond_without  x       # - without X11 subpackage
4 %bcond_with     pvm     # - with PVM support
5 %bcond_with     svga    # - with svgalib support (doesn't work on many platforms)
6 #
7 %define         _rc             RC7
8 %define         _src_pov_ver    3.7.0.%{_rc}
9
10 Summary:        Persistence of Vision Ray Tracer
11 Summary(pl.UTF-8):      Persistence of Vision Ray Tracer
12 Name:           povray
13 Version:        3.7.0
14 Release:        0.%{_rc}.1
15 Epoch:          1
16 License:        distributable
17 Group:          Applications/Graphics
18 #Source0:       http://www.povray.org/ftp/pub/povray/Official/Unix/%{name}-%{_src_pov_ver}.tar.bz2
19 Source0:        http://www.povray.org/redirect/www.povray.org/beta/source/%{name}-%{_src_pov_ver}.tar.bz2
20 # Source0-md5:  7d24ec051af67bcf040a898a267d920a
21 # based on sources from CVS at http://pvmpov.sourceforge.net/
22 # Source0:      %{name}-%{version}-%{snap}.tar.gz
23 Source1:        %{name}-ax_boost_base.m4
24 Patch0:         %{name}-nouserfiles.patch
25 URL:            http://www.povray.org/
26 BuildRequires:  autoconf
27 BuildRequires:  automake
28 BuildRequires:  libjpeg-devel
29 BuildRequires:  libpng-devel >= 1.4.0
30 BuildRequires:  libstdc++-devel
31 BuildRequires:  libtiff-devel
32 %{?with_pvm:BuildRequires:      pvm-devel >= 3.4.3-24}
33 %{?with_svga:BuildRequires:     svgalib-devel}
34 %{?with_x:BuildRequires:        xorg-lib-libX11-devel}
35 BuildRequires:  zlib-devel
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %if %{with pvm}
39 %define         _pvmarch        %(/usr/bin/pvmgetarch)
40 %define         _pvmroot        /usr/%{_lib}/pvm3
41 %endif
42
43 %description
44 The Persistence of Vision(tm) Ray-Tracer creates three-dimensional,
45 photo-realistic images using a rendering technique called ray-tracing.
46 It reads in a text file containing information describing the objects
47 and lighting in a scene and generates an image of that scene from the
48 view point of a camera also described in the text file. Ray-tracing is
49 not a fast process by any means, but it produces very high quality
50 images with realistic reflections, shading, perspective and other
51 effects.
52
53 %description -l pl.UTF-8
54 Persistence of Vision(tm) Ray-Tracer tworzy trójwymiarowe,
55 fotorealistyczne obrazy za pomocą techniki renderingu zwanej
56 ray-tracing. Program pobiera z pliku tekstowego informacje opisujące
57 obiekty oraz światło przedstawianego świata, a następnie generuje
58 rysunek z punktu widzenia kamery, która także jest definiowana w w/w
59 pliku tekstowym. Ray-tracing nie pozwala na szybkie tworzenie obrazów,
60 ale za to twórca otrzymuje wyskokiej jakości bitmapy z realistycznymi
61 efektami, tj. odbicia światła, cienie, perspektywa i inne.
62
63 %package X11
64 Summary:        X Window povray executable
65 Summary(pl.UTF-8):      povray pod X Window
66 Group:          Applications/Graphics
67 Requires:       %{name} = %{epoch}:%{version}-%{release}
68
69 %description X11
70 The Persistence of Vision(tm) Ray-Tracer X Window executable.
71
72 %description X11 -l pl.UTF-8
73 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla X
74 Window.
75
76 %package pvm
77 Summary:        PVM/Unix povray executable
78 Summary(pl.UTF-8):      Plik wykonywalny povray dla PVM/Unix
79 Group:          Applications/Graphics
80 Requires:       %{name} = %{epoch}:%{version}-%{release}
81
82 %description pvm
83 The Persistence of Vision(tm) Ray-Tracer PVM/Unix executable.
84
85 %description pvm -l pl.UTF-8
86 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla
87 PVM/Unix.
88
89 %package pvm-X11
90 Summary:        PVM/xwin povray executable
91 Summary(pl.UTF-8):      Plik wykonywalny povray dla PVM/xwin
92 Group:          Applications/Graphics
93 Requires:       %{name} = %{epoch}:%{version}-%{release}
94
95 %description pvm-X11
96 The Persistence of Vision(tm) Ray-Tracer PVM/xwin executable.
97
98 %description pvm-X11 -l pl.UTF-8
99 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla
100 PVM/xwin.
101
102 %prep
103 %setup -q -n %{name}-%{_src_pov_ver}
104 cp %{SOURCE1} unix/config/ax_boost_base.m4
105 %patch0 -p1
106
107 %build
108 %{__aclocal}
109 %{__autoconf}
110 %{__automake}
111 COMPILED_BY="PLD/Linux Team";export COMPILED_BY;
112 %if %{with x} && %{with pvm}
113 %configure \
114         --libdir=%{_datadir} \
115         --with-boost-thread=boost_thread-mt \
116         --enable-pvm \
117         --with-pvm-arch=%{_pvmarch} \
118         --with-pvm-libs=%{_libdir}
119 %{__make}
120 install unix/povray x-pvmpov
121 %endif
122
123 %if %{with pvm}
124 %{__make} clean
125
126 %configure \
127         --libdir=%{_datadir} \
128         --with-boost-thread=boost_thread-mt \
129         --enable-pvm \
130         --with-pvm-arch=%{_pvmarch} \
131         --with-pvm-libs=%{_libdir} \
132         --without-x
133 %{__make}
134 install unix/povray pvmpov
135 %endif
136
137 %if %{with x}
138 %configure \
139         --libdir=%{_datadir} \
140         --with-boost-thread=boost_thread-mt
141 %{__make}
142 install unix/povray x-povray
143 %{__make} clean
144 %endif
145
146 %configure \
147         --libdir=%{_datadir} \
148         --with-boost-thread=boost_thread-mt \
149         --without-x
150 %{__make}
151
152 %install
153 rm -rf $RPM_BUILD_ROOT
154 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_bindir},%{_datadir}}
155 %if %{with pvm}
156 install -d $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}
157 %endif
158
159 %{__make} install \
160         INSTALL="install -c -D" \
161         mkdir_p="mkdir -p" \
162         DESTDIR=$RPM_BUILD_ROOT
163
164 %if %{with x}
165 install x-povray $RPM_BUILD_ROOT%{_bindir}
166 %endif
167
168 %if %{with x} && %{with pvm}
169 install x-pvmpov $RPM_BUILD_ROOT%{_bindir}/x-pvmpov
170 ln -s %{_bindir}/x-pvmpov $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}/x-pvmpov
171 %endif
172
173 %if %{with pvm}
174 install pvmpov $RPM_BUILD_ROOT%{_bindir}/pvmpov
175 ln -s %{_bindir}/pvmpov $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}/pvmpov
176 %endif
177
178 ##install povray.ini $RPM_BUILD_ROOT%{_sysconfdir}
179 ##install povray.conf $RPM_BUILD_ROOT%{_sysconfdir}
180
181 %clean
182 rm -rf $RPM_BUILD_ROOT
183
184 %files
185 %defattr(644,root,root,755)
186 %doc AUTHORS ChangeLog NEWS README* changes.txt
187 %attr(755,root,root) %{_bindir}/povray
188 %{_datadir}/povray*
189 %{_docdir}/povray*
190 %{_mandir}/man?/*
191 %dir %{_sysconfdir}/povray
192 %dir %{_sysconfdir}/povray/3.7
193 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/3.7/povray.*
194 ## %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/povray.*
195
196 %if %{with x}
197 %files X11
198 %defattr(644,root,root,755)
199 %attr(755,root,root) %{_bindir}/x-povray
200 %endif
201
202 %if %{with pvm}
203 %files pvm
204 %defattr(644,root,root,755)
205 %attr(755,root,root) %{_pvmroot}/bin/%{_pvmarch}/pvmpov
206 %attr(755,root,root) %{_bindir}/pvmpov
207 %endif
208
209 %if %{with pvm} && %{with x}
210 %files pvm-X11
211 %defattr(644,root,root,755)
212 %attr(755,root,root) %{_pvmroot}/bin/%{_pvmarch}/x-pvmpov
213 %attr(755,root,root) %{_bindir}/x-pvmpov
214 %endif
This page took 0.051943 seconds and 4 git commands to generate.