]> git.pld-linux.org Git - packages/povray.git/blob - povray.spec
- rel 3
[packages/povray.git] / povray.spec
1 #
2 # Conditional build:
3 %bcond_without  x       # - without X11 subpackage
4 %bcond_with     pvm     # - with PVM support
5 %bcond_with     svga    # - with svgalib support (doesn't work on many platforms)
6 #
7 %define         _rc             RC6
8 %define         _src_pov_ver    3.7.0.%{_rc}
9
10 Summary:        Persistence of Vision Ray Tracer
11 Summary(pl.UTF-8):      Persistence of Vision Ray Tracer
12 Name:           povray
13 Version:        3.7.0
14 Release:        0.%{_rc}.3
15 Epoch:          1
16 License:        distributable
17 Group:          Applications/Graphics
18 #Source0:       http://www.povray.org/ftp/pub/povray/Official/Unix/%{name}-%{_src_pov_ver}.tar.bz2
19 Source0:        http://www.povray.org/redirect/www.povray.org/beta/source/%{name}-%{_src_pov_ver}.tar.gz
20 # Source0-md5:  e441015262acfa60949082dbc7995493
21 # based on sources from CVS at http://pvmpov.sourceforge.net/
22 # Source0:      %{name}-%{version}-%{snap}.tar.gz
23 Source1:        %{name}-ax_boost_base.m4
24 Patch0:         %{name}-nouserfiles.patch
25 Patch1:         boost-1.50.patch
26 URL:            http://www.povray.org/
27 BuildRequires:  autoconf
28 BuildRequires:  automake
29 BuildRequires:  libjpeg-devel
30 BuildRequires:  libpng-devel >= 1.4.0
31 BuildRequires:  libstdc++-devel
32 BuildRequires:  libtiff-devel
33 %{?with_pvm:BuildRequires:      pvm-devel >= 3.4.3-24}
34 %{?with_svga:BuildRequires:     svgalib-devel}
35 %{?with_x:BuildRequires:        xorg-lib-libX11-devel}
36 BuildRequires:  zlib-devel
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %if %{with pvm}
40 %define         _pvmarch        %(/usr/bin/pvmgetarch)
41 %define         _pvmroot        /usr/%{_lib}/pvm3
42 %endif
43
44 %description
45 The Persistence of Vision(tm) Ray-Tracer creates three-dimensional,
46 photo-realistic images using a rendering technique called ray-tracing.
47 It reads in a text file containing information describing the objects
48 and lighting in a scene and generates an image of that scene from the
49 view point of a camera also described in the text file. Ray-tracing is
50 not a fast process by any means, but it produces very high quality
51 images with realistic reflections, shading, perspective and other
52 effects.
53
54 %description -l pl.UTF-8
55 Persistence of Vision(tm) Ray-Tracer tworzy trójwymiarowe,
56 fotorealistyczne obrazy za pomocą techniki renderingu zwanej
57 ray-tracing. Program pobiera z pliku tekstowego informacje opisujące
58 obiekty oraz światło przedstawianego świata, a następnie generuje
59 rysunek z punktu widzenia kamery, która także jest definiowana w w/w
60 pliku tekstowym. Ray-tracing nie pozwala na szybkie tworzenie obrazów,
61 ale za to twórca otrzymuje wyskokiej jakości bitmapy z realistycznymi
62 efektami, tj. odbicia światła, cienie, perspektywa i inne.
63
64 %package X11
65 Summary:        X Window povray executable
66 Summary(pl.UTF-8):      povray pod X Window
67 Group:          Applications/Graphics
68 Requires:       %{name} = %{epoch}:%{version}-%{release}
69
70 %description X11
71 The Persistence of Vision(tm) Ray-Tracer X Window executable.
72
73 %description X11 -l pl.UTF-8
74 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla X
75 Window.
76
77 %package pvm
78 Summary:        PVM/Unix povray executable
79 Summary(pl.UTF-8):      Plik wykonywalny povray dla PVM/Unix
80 Group:          Applications/Graphics
81 Requires:       %{name} = %{epoch}:%{version}-%{release}
82
83 %description pvm
84 The Persistence of Vision(tm) Ray-Tracer PVM/Unix executable.
85
86 %description pvm -l pl.UTF-8
87 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla
88 PVM/Unix.
89
90 %package pvm-X11
91 Summary:        PVM/xwin povray executable
92 Summary(pl.UTF-8):      Plik wykonywalny povray dla PVM/xwin
93 Group:          Applications/Graphics
94 Requires:       %{name} = %{epoch}:%{version}-%{release}
95
96 %description pvm-X11
97 The Persistence of Vision(tm) Ray-Tracer PVM/xwin executable.
98
99 %description pvm-X11 -l pl.UTF-8
100 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla
101 PVM/xwin.
102
103 %prep
104 %setup -q -n %{name}-%{_src_pov_ver}
105 cp %{SOURCE1} unix/config/ax_boost_base.m4
106 %patch0 -p1
107 %patch1 -p1
108
109 %build
110 %{__aclocal}
111 %{__autoconf}
112 %{__automake}
113 COMPILED_BY="PLD/Linux Team";export COMPILED_BY;
114 %if %{with x} && %{with pvm}
115 %configure \
116         --libdir=%{_datadir} \
117         --enable-pvm \
118         --with-pvm-arch=%{_pvmarch} \
119         --with-pvm-libs=%{_libdir}
120 %{__make}
121 install unix/povray x-pvmpov
122 %endif
123
124 %if %{with pvm}
125 %{__make} clean
126
127 %configure \
128         --libdir=%{_datadir} \
129         --enable-pvm \
130         --with-pvm-arch=%{_pvmarch} \
131         --with-pvm-libs=%{_libdir} \
132         --without-x
133 %{__make}
134 install unix/povray pvmpov
135 %endif
136
137 %if %{with x}
138 %configure \
139         --libdir=%{_datadir}
140 %{__make}
141 install unix/povray x-povray
142 %{__make} clean
143 %endif
144
145 %configure \
146         --libdir=%{_datadir} \
147         --without-x
148 %{__make}
149
150 %install
151 rm -rf $RPM_BUILD_ROOT
152 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_bindir},%{_datadir}}
153 %if %{with pvm}
154 install -d $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}
155 %endif
156
157 %{__make} install \
158         INSTALL="install -c -D" \
159         mkdir_p="mkdir -p" \
160         DESTDIR=$RPM_BUILD_ROOT
161
162 %if %{with x}
163 install x-povray $RPM_BUILD_ROOT%{_bindir}
164 %endif
165
166 %if %{with x} && %{with pvm}
167 install x-pvmpov $RPM_BUILD_ROOT%{_bindir}/x-pvmpov
168 ln -s %{_bindir}/x-pvmpov $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}/x-pvmpov
169 %endif
170
171 %if %{with pvm}
172 install pvmpov $RPM_BUILD_ROOT%{_bindir}/pvmpov
173 ln -s %{_bindir}/pvmpov $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}/pvmpov
174 %endif
175
176 ##install povray.ini $RPM_BUILD_ROOT%{_sysconfdir}
177 ##install povray.conf $RPM_BUILD_ROOT%{_sysconfdir}
178
179 %clean
180 rm -rf $RPM_BUILD_ROOT
181
182 %files
183 %defattr(644,root,root,755)
184 %doc AUTHORS ChangeLog NEWS README* changes.txt
185 %attr(755,root,root) %{_bindir}/povray
186 %{_datadir}/povray*
187 %{_docdir}/povray*
188 %{_mandir}/man?/*
189 %dir %{_sysconfdir}/povray
190 %dir %{_sysconfdir}/povray/3.7
191 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/3.7/povray.*
192 ## %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/povray.*
193
194 %if %{with x}
195 %files X11
196 %defattr(644,root,root,755)
197 %attr(755,root,root) %{_bindir}/x-povray
198 %endif
199
200 %if %{with pvm}
201 %files pvm
202 %defattr(644,root,root,755)
203 %attr(755,root,root) %{_pvmroot}/bin/%{_pvmarch}/pvmpov
204 %attr(755,root,root) %{_bindir}/pvmpov
205 %endif
206
207 %if %{with pvm} && %{with x}
208 %files pvm-X11
209 %defattr(644,root,root,755)
210 %attr(755,root,root) %{_pvmroot}/bin/%{_pvmarch}/x-pvmpov
211 %attr(755,root,root) %{_bindir}/x-pvmpov
212 %endif
This page took 0.075453 seconds and 4 git commands to generate.