]> git.pld-linux.org Git - packages/povray.git/blob - povray.spec
s/distrituable/distributable in License
[packages/povray.git] / povray.spec
1 Summary:        Persistence of Vision Ray Tracer
2 Summary(pl):    Persistence of Vision Ray Tracer
3 Name:           povray
4 Version:        3.1g
5 Release:        5
6 License:        distributable
7 Group:          Applications/Graphics
8 Source0:        ftp://ftp.povray.org/pub/povray/Official/Unix/povuni_s.tgz
9 Source1:        ftp://ftp.povray.org/pub/povray/Official/Unix/povuni_d.tgz
10 # pvm.patch is instead of that source, and its based on it
11 #Source2:       pvmpov-3.1e2.tgz
12 Patch0:         %{name}-makefile_and_config.patch
13 Patch1:         %{name}-pvm.patch
14 Patch2:         %{name}-png_with_pvm.patch
15 URL:            http://www.povray.org/
16 BuildRequires:  zlib-devel
17 BuildRequires:  libpng-devel >= 1.0.8
18 %{!?_without_x:BuildRequires:XFree86-devel}
19 %{!?_without_pvm:BuildRequires:pvm-devel >= 3.4.3-24 }
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 #ugly but now _pvm_root/_pvm_arch isnt defined in macros
23
24 %define         _pvm_root       %{_libdir}/pvm3
25 %define         _pvm_arch       %(ls %{_pvm_root}/conf/|sed -e 's/\.def//')
26
27 %description
28 The Persistence of Vision(tm) Ray-Tracer creates three-dimensional,
29 photo-realistic images using a rendering technique called ray-tracing.
30 It reads in a text file containing information describing the objects
31 and lighting in a scene and generates an image of that scene from the
32 view point of a camera also described in the text file. Ray-tracing is
33 not a fast process by any means, but it produces very high quality
34 images with realistic reflections, shading, perspective and other
35 effects.
36
37 %description -l pl
38 Persistence of Vision(tm) Ray-Tracer tworzy trójwymiarowe,
39 fotorealistyczne obrazy za pomoc± techniki renderingu zwanej
40 ray-tracing. Program pobiera z pliku tekstowego informacje opisuj±ce
41 obiekty oraz ¶wiat³o przedstawianego ¶wiata, a nastêpnie generuje
42 rysunek z punktu widzenia kamery, która tak¿e jest definiowana w w/w
43 pliku tekstowym. Ray-tracing nie pozwala na szybkie tworzenie obrazów,
44 ale za to twórca otrzymuje wyskokiej jako¶ci bitmapy z realistycznymi
45 efektami, tj. odbicia ¶wiat³a, cienie, perspektywa i inne.
46
47 %if %{!?_without_x:1}%{?_without_x}
48 %package X11
49 Summary:        X Window povray executable
50 Summary(pl):    povray pod X Window
51 Group:          Applications/Graphics
52 Requires:       %{name} = %{version}
53
54 %description X11
55 The Persistence of Vision(tm) Ray-Tracer X Window executable.
56
57 %description X11 -l pl
58 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla X
59 Window.
60 %endif
61
62 %if %{!?_without_pvm:1}%{?_without_pvm:0}
63 %package pvm
64 Summary:        PVM/unix povray executable
65 Group:          Applications/Graphics
66 Requires:       %{name} = %{version}
67
68 %description pvm
69 The Persistence of Vision(tm) Ray-Tracer PVM/unix executable.
70
71 %description X11 -l pl
72 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla
73 PVM/unix.
74
75 %if %{!?_without_x:1}%{?_without_x:0}
76 %package pvm-X11
77 Summary:        PVM/xwin povray executable
78 Group:          Applications/Graphics
79 Requires:       %{name} = %{version}
80
81 %description pvm-X11
82 The Persistence of Vision(tm) Ray-Tracer PVM/xwin executable.
83
84 %description X11 -l pl
85 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla
86 PVM/xwin.
87 %endif
88 %endif
89
90 %prep
91 %setup -q -n povray31 -b 1
92 %patch0 -p1
93 %patch1 -p0
94 %patch2 -p1
95
96 %build
97 cd source/unix
98 %{__make} newunix %{!?_without_x:newxwin} %{!?_without_pvm:newunix_pvm %{!?_without_x:newxwin_pvm}} OPT_FLAGS="%{rpmcflags}"
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102 install -d $RPM_BUILD_ROOT{%{_bindir},/etc/skel,%{_mandir}/man1,%{_datadir}/povray31,%{_pvm_root}/bin/%{_pvm_arch}}
103
104
105 install source/unix/povray $RPM_BUILD_ROOT%{_bindir}
106 %{!?_without_x:install source/unix/x-povray $RPM_BUILD_ROOT%{_bindir}}
107 %{!?_without_pvm:install source/unix/pvmpov $RPM_BUILD_ROOT%{_pvm_root}/bin/%{_pvm_arch}}
108 %{!?_without_pvm:%{!?_without_x:install source/unix/x-pvmpov $RPM_BUILD_ROOT%{_pvm_root}/bin/%{_pvm_arch}}}
109 install source/unix/povrayrc $RPM_BUILD_ROOT/etc/skel/.povrayrc
110
111 install povray.1 $RPM_BUILD_ROOT%{_mandir}/man1
112
113 cp -r allscene include scenes $RPM_BUILD_ROOT%{_datadir}/povray31
114 install *.ini *.pov $RPM_BUILD_ROOT%{_datadir}/povray31
115
116 gzip -9nf gamma.gif.txt povlegal.doc povuser.txt
117
118 %clean
119 rm -rf $RPM_BUILD_ROOT
120
121 %files
122 %defattr(644,root,root,755)
123 %doc gamma.gif.txt.gz povuser.txt.gz gamma.gif povlegal.doc.gz
124 %attr(755,root,root) %{_bindir}/povray
125 %{_datadir}/povray31
126 /etc/skel/.povrayrc
127 %{_mandir}/man1/*
128
129 %if %{!?_without_x:1}%{?_without_x:0}
130 %files X11
131 %defattr(644,root,root,755)
132 %attr(755,root,root) %{_bindir}/x-povray
133 %endif
134
135 %if %{!?_without_pvm:1}%{?_without_pvm:0}
136 %files pvm
137 %defattr(644,root,root,755)
138 %attr(755,root,root) %{_pvm_root}/bin/%{_pvm_arch}/pvmpov
139
140 %if %{!?_without_x:1}%{?_without_x:0}
141 %files pvm-X11
142 %defattr(644,root,root,755)
143 %attr(755,root,root) %{_pvm_root}/bin/%{_pvm_arch}/x-pvmpov
144 %endif
145 %endif
This page took 0.043112 seconds and 4 git commands to generate.