]> git.pld-linux.org Git - packages/povray.git/blob - povray.spec
- pvm related fixes
[packages/povray.git] / povray.spec
1
2 #
3 # todo:
4 #      patch for s#/usr/local#/usr# in povray.ini
5 #      (no)svga version
6 #
7
8 # Conditional build:
9 # _without_x    - without X11 subpackage
10 # _without_pvm  - without PVM support
11 #
12 %define         snap 20030110
13 Summary:        Persistence of Vision Ray Tracer
14 Summary(pl):    Persistence of Vision Ray Tracer
15 Name:           povray
16 Version:        3.50c
17 Release:        1
18 License:        distributable
19 Group:          Applications/Graphics
20 #Source0:       ftp://ftp.povray.org/pub/povray/Official/Unix/povuni_s.tgz
21 # based on sources from CVS at http://pvmpov.sourceforge.net/
22 Source0:        %{name}-%{version}-%{snap}.tar.gz
23 Patch0:         %{name}-legal.patch
24 URL:            http://www.povray.org/
25 BuildRequires:  libjpeg-devel
26 BuildRequires:  libpng-devel >= 1.0.8
27 BuildRequires:  libstdc++-devel
28 BuildRequires:  libtiff-devel
29 BuildRequires:  zlib-devel
30 %{!?_without_x:BuildRequires:XFree86-devel}
31 %{!?_without_pvm:BuildRequires:pvm-devel >= 3.4.3-24 }
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define         _libdir         %{_datadir}
35 %define         _pvmarch        %(/usr/bin/pvmgetarch)
36 %define         _pvmroot        /usr/lib/pvm3/
37
38 %description
39 The Persistence of Vision(tm) Ray-Tracer creates three-dimensional,
40 photo-realistic images using a rendering technique called ray-tracing.
41 It reads in a text file containing information describing the objects
42 and lighting in a scene and generates an image of that scene from the
43 view point of a camera also described in the text file. Ray-tracing is
44 not a fast process by any means, but it produces very high quality
45 images with realistic reflections, shading, perspective and other
46 effects.
47
48 %description -l pl
49 Persistence of Vision(tm) Ray-Tracer tworzy trójwymiarowe,
50 fotorealistyczne obrazy za pomoc± techniki renderingu zwanej
51 ray-tracing. Program pobiera z pliku tekstowego informacje opisuj±ce
52 obiekty oraz ¶wiat³o przedstawianego ¶wiata, a nastêpnie generuje
53 rysunek z punktu widzenia kamery, która tak¿e jest definiowana w w/w
54 pliku tekstowym. Ray-tracing nie pozwala na szybkie tworzenie obrazów,
55 ale za to twórca otrzymuje wyskokiej jako¶ci bitmapy z realistycznymi
56 efektami, tj. odbicia ¶wiat³a, cienie, perspektywa i inne.
57
58 %package X11
59 Summary:        X Window povray executable
60 Summary(pl):    povray pod X Window
61 Group:          Applications/Graphics
62 Requires:       %{name} = %{version}
63
64 %description X11
65 The Persistence of Vision(tm) Ray-Tracer X Window executable.
66
67 %description X11 -l pl
68 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla X
69 Window.
70
71 %package pvm
72 Summary:        PVM/unix povray executable
73 Summary(pl):    Plik wykonywalny povray dla PVM/unix
74 Group:          Applications/Graphics
75 Requires:       %{name} = %{version}
76
77 %description pvm
78 The Persistence of Vision(tm) Ray-Tracer PVM/unix executable.
79
80 %description X11 -l pl
81 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla
82 PVM/unix.
83
84 %package pvm-X11
85 Summary:        PVM/xwin povray executable
86 Summary(pl):    Plik wykonywalny povray dla PVM/xwin
87 Group:          Applications/Graphics
88 Requires:       %{name} = %{version}
89
90 %description pvm-X11
91 The Persistence of Vision(tm) Ray-Tracer PVM/xwin executable.
92
93 %description X11 -l pl
94 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla
95 PVM/xwin.
96
97 %prep
98 %setup -q
99
100 %build
101 %{__aclocal}
102 %{__autoconf}
103 %{__automake}
104 %if %{!?_without_pvm:%{!?_without_x:1}%{?_without_x:0}}%{?_without_pvm:0}
105 %configure \
106         --enable-pvm \
107         --with-pvm-arch=%{_pvmarch} \
108         --x-includes=%{_prefix}/X11R6/include \
109         --x-libraries=%{_prefix}/X11R6/lib
110 %{__make}
111 install src/povray x-pvmpov
112 %endif
113
114 %if %{!?_without_pvm:1}%{?_without_pvm:0}
115 %{__make} clean
116
117 %configure \
118         --enable-pvm \
119         --with-pvm-arch=%{_pvmarch} \
120         --without-x
121 %{__make}
122 install src/povray pvmpov
123 %endif
124
125 %if %{!?_without_x:1}%{?_without_x:0}
126 %configure \
127         --x-includes=%{_prefix}/X11R6/include \
128         --x-libraries=%{_prefix}/X11R6/lib
129 %{__make}
130 install src/povray x-povray
131 %{__make} clean
132 %endif
133
134 %configure \
135         --without-x
136 %{__make}
137
138
139 %install
140 rm -rf $RPM_BUILD_ROOT
141 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_prefix}/X11R6/bin} \
142         $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}
143
144 %{__make} install \
145         DESTDIR=$RPM_BUILD_ROOT
146
147 %if %{!?_without_x:1}%{?_without_x:0}
148 install x-povray $RPM_BUILD_ROOT%{_bindir}
149 %endif
150
151 %if %{!?_without_pvm:%{!?_without_x:1}%{?_without_x:0}}%{?_without_pvm:0}
152 install x-pvmpov $RPM_BUILD_ROOT%{_bindir}/x-pvmpov
153 ln -s %{_binir}/x-pvmpov $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}/x-pvmpov
154 %endif
155
156 %if %{!?_without_pvm:1}%{?_without_pvm:0}
157 install pvmpov $RPM_BUILD_ROOT%{_bindir}/pvmpov
158 ln -s %{_binir}/pvmpov $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}/pvmpov
159 %endif
160
161 install povray.ini $RPM_BUILD_ROOT%{_sysconfdir}
162 install povray.conf $RPM_BUILD_ROOT%{_sysconfdir}
163 ln -sf %{_sysconfdir}/povray.ini $RPM_BUILD_ROOT%{_datadir}/povray-3.5/povray.ini
164
165 %clean
166 rm -rf $RPM_BUILD_ROOT
167
168 %files
169 %defattr(644,root,root,755)
170 %doc AUTHORS ChangeLog NEWS README* povlegal.doc *.txt doc/html
171 %attr(755,root,root) %{_bindir}/povray
172 %{_libdir}/povray*
173 %{_mandir}/man?/*
174 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/povray.*
175
176 %if %{!?_without_x:1}%{?_without_x:0}
177 %files X11
178 %defattr(644,root,root,755)
179 %attr(755,root,root) %{_bindir}/x-povray
180 %endif
181
182 %if %{!?_without_pvm:1}%{?_without_pvm:0}
183 %files pvm
184 %defattr(644,root,root,755)
185 %attr(755,root,root) %{_pvmroot}/bin/%{_pvmarch}/pvmpov
186 %attr(755,root,root) %{_bindir}/pvmpov
187 %endif
188
189 %if %{!?_without_pvm:%{!?_without_x:1}%{?_without_x:0}}%{?_without_pvm:0}
190 %files pvm-X11
191 %defattr(644,root,root,755)
192 %attr(755,root,root) %{_pvmroot}/bin/%{_pvmarch}/x-pvmpov
193 %attr(755,root,root) %{_bindir}/x-pvmpov
194 %endif
This page took 0.047535 seconds and 4 git commands to generate.