]> git.pld-linux.org Git - packages/povray.git/blob - povray.spec
- pl Summary/description fixes
[packages/povray.git] / povray.spec
1
2 #
3 # todo:
4 #      patch for s#/usr/local#/usr# in povray.ini
5 #
6
7 # Conditional build:
8 # _without_x    - without X11 subpackage
9 # _without_pvm  - [temporarily disabled by default] without PVM support
10 #
11 Summary:        Persistence of Vision Ray Tracer
12 Summary(pl):    Persistence of Vision Ray Tracer
13 Name:           povray
14 Version:        3.50c
15 Release:        1
16 License:        distributable
17 Group:          Applications/Graphics
18 Source0:        ftp://ftp.povray.org/pub/povray/Official/Unix/povuni_s.tgz
19 Source1:        %{name}-%{version}.md5sum
20 Patch0:         %{name}-legal.patch
21 Patch1:         %{name}-types.patch
22 # pvm support not yet available - http://pvmpov.sourceforge.net/
23 URL:            http://www.povray.org/
24 BuildRequires:  libjpeg-devel
25 BuildRequires:  libpng-devel >= 1.0.8
26 BuildRequires:  libstdc++-devel
27 BuildRequires:  libtiff-devel
28 BuildRequires:  zlib-devel
29 %{!?_without_x:BuildRequires:XFree86-devel}
30 #%{!?_without_pvm:BuildRequires:pvm-devel >= 3.4.3-24 }
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         _libdir         %{_datadir}
34
35 %description
36 The Persistence of Vision(tm) Ray-Tracer creates three-dimensional,
37 photo-realistic images using a rendering technique called ray-tracing.
38 It reads in a text file containing information describing the objects
39 and lighting in a scene and generates an image of that scene from the
40 view point of a camera also described in the text file. Ray-tracing is
41 not a fast process by any means, but it produces very high quality
42 images with realistic reflections, shading, perspective and other
43 effects.
44
45 %description -l pl
46 Persistence of Vision(tm) Ray-Tracer tworzy trójwymiarowe,
47 fotorealistyczne obrazy za pomoc± techniki renderingu zwanej
48 ray-tracing. Program pobiera z pliku tekstowego informacje opisuj±ce
49 obiekty oraz ¶wiat³o przedstawianego ¶wiata, a nastêpnie generuje
50 rysunek z punktu widzenia kamery, która tak¿e jest definiowana w w/w
51 pliku tekstowym. Ray-tracing nie pozwala na szybkie tworzenie obrazów,
52 ale za to twórca otrzymuje wyskokiej jako¶ci bitmapy z realistycznymi
53 efektami, tj. odbicia ¶wiat³a, cienie, perspektywa i inne.
54
55 %package X11
56 Summary:        X Window povray executable
57 Summary(pl):    povray pod X Window
58 Group:          Applications/Graphics
59 Requires:       %{name} = %{version}
60
61 %description X11
62 The Persistence of Vision(tm) Ray-Tracer X Window executable.
63
64 %description X11 -l pl
65 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla X
66 Window.
67
68 %package pvm
69 Summary:        PVM/unix povray executable
70 Summary(pl):    Plik wykonywalny povray dla PVM/unix
71 Group:          Applications/Graphics
72 Requires:       %{name} = %{version}
73
74 %description pvm
75 The Persistence of Vision(tm) Ray-Tracer PVM/unix executable.
76
77 %description X11 -l pl
78 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla
79 PVM/unix.
80
81 %package pvm-X11
82 Summary:        PVM/xwin povray executable
83 Summary(pl):    Plik wykonywalny povray dla PVM/xwin
84 Group:          Applications/Graphics
85 Requires:       %{name} = %{version}
86
87 %description pvm-X11
88 The Persistence of Vision(tm) Ray-Tracer PVM/xwin executable.
89
90 %description X11 -l pl
91 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla
92 PVM/xwin.
93
94 %prep
95 cd %{_sourcedir}
96 md5sum -c %{name}-%{version}.md5sum
97 cd -
98 %setup -q
99 %patch0 -p1
100 %ifarch alpha
101 %patch1 -p1
102 %endif
103
104 %build
105 %{__aclocal}
106 %{__autoconf}
107 %{__automake}
108 %if %{!?_without_x:1}%{?_without_x:0}
109 %configure \
110         --x-includes=%{_prefix}/X11R6/include \
111         --x-libraries=%{_prefix}/X11R6/lib
112 %{__make}
113 install src/povray x-povray
114 %{__make} clean
115 %endif
116
117 %configure \
118         --without-x
119 %{__make}
120
121 %install
122 rm -rf $RPM_BUILD_ROOT
123 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_prefix}/X11R6/bin}
124
125 %{__make} install \
126         DESTDIR=$RPM_BUILD_ROOT
127
128 %if %{!?_without_x:1}%{?_without_x:0}
129 install x-povray $RPM_BUILD_ROOT%{_prefix}/X11R6/bin
130 %endif
131
132 install povray.ini $RPM_BUILD_ROOT%{_sysconfdir}
133 install povray.conf $RPM_BUILD_ROOT%{_sysconfdir}
134 ln -sf %{_sysconfdir}/povray.ini $RPM_BUILD_ROOT%{_datadir}/povray-3.5/povray.ini
135
136 %clean
137 rm -rf $RPM_BUILD_ROOT
138
139 %files
140 %defattr(644,root,root,755)
141 %doc AUTHORS ChangeLog NEWS README* povlegal.doc *.txt doc/html
142 %attr(755,root,root) %{_bindir}/povray
143 %{_libdir}/povray*
144 %{_mandir}/man?/*
145 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/povray.*
146
147 %if %{!?_without_x:1}%{?_without_x:0}
148 %files X11
149 %defattr(644,root,root,755)
150 %attr(755,root,root) %{_prefix}/X11R6/bin/x-povray
151 %endif
152
153 #%if %{!?_without_pvm:1}%{?_without_pvm:0}
154 #%files pvm
155 #%defattr(644,root,root,755)
156 #%attr(755,root,root) %{_pvm_root}/bin/%{_pvm_arch}/pvmpov
157 #
158 #%if %{!?_without_x:1}%{?_without_x:0}
159 #%files pvm-X11
160 #%defattr(644,root,root,755)
161 #%attr(755,root,root) %{_pvm_root}/bin/%{_pvm_arch}/x-pvmpov
162 #%endif
163 #%endif
This page took 0.097234 seconds and 4 git commands to generate.