]> git.pld-linux.org Git - packages/povray.git/blob - povray.spec
- up to RC7 (last rc)
[packages/povray.git] / povray.spec
1 #
2 # Conditional build:
3 %bcond_without  x       # - without X11 subpackage
4 %bcond_with     pvm     # - with PVM support
5 %bcond_with     svga    # - with svgalib support (doesn't work on many platforms)
6 #
7 %define         _rc             RC7
8 %define         _src_pov_ver    3.7.0.%{_rc}
9
10 Summary:        Persistence of Vision Ray Tracer
11 Summary(pl.UTF-8):      Persistence of Vision Ray Tracer
12 Name:           povray
13 Version:        3.7.0
14 Release:        0.%{_rc}.1
15 Epoch:          1
16 License:        distributable
17 Group:          Applications/Graphics
18 #Source0:       http://www.povray.org/ftp/pub/povray/Official/Unix/%{name}-%{_src_pov_ver}.tar.bz2
19 Source0:        http://www.povray.org/redirect/www.povray.org/beta/source/%{name}-%{_src_pov_ver}.tar.bz2
20 # Source0-md5:  7d24ec051af67bcf040a898a267d920a
21 # based on sources from CVS at http://pvmpov.sourceforge.net/
22 # Source0:      %{name}-%{version}-%{snap}.tar.gz
23 Source1:        %{name}-ax_boost_base.m4
24 Patch0:         %{name}-nouserfiles.patch
25 URL:            http://www.povray.org/
26 BuildRequires:  autoconf
27 BuildRequires:  automake
28 BuildRequires:  libjpeg-devel
29 BuildRequires:  libpng-devel >= 1.4.0
30 BuildRequires:  libstdc++-devel
31 BuildRequires:  libtiff-devel
32 %{?with_pvm:BuildRequires:      pvm-devel >= 3.4.3-24}
33 %{?with_svga:BuildRequires:     svgalib-devel}
34 %{?with_x:BuildRequires:        xorg-lib-libX11-devel}
35 BuildRequires:  zlib-devel
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %if %{with pvm}
39 %define         _pvmarch        %(/usr/bin/pvmgetarch)
40 %define         _pvmroot        /usr/%{_lib}/pvm3
41 %endif
42
43 %description
44 The Persistence of Vision(tm) Ray-Tracer creates three-dimensional,
45 photo-realistic images using a rendering technique called ray-tracing.
46 It reads in a text file containing information describing the objects
47 and lighting in a scene and generates an image of that scene from the
48 view point of a camera also described in the text file. Ray-tracing is
49 not a fast process by any means, but it produces very high quality
50 images with realistic reflections, shading, perspective and other
51 effects.
52
53 %description -l pl.UTF-8
54 Persistence of Vision(tm) Ray-Tracer tworzy trójwymiarowe,
55 fotorealistyczne obrazy za pomocą techniki renderingu zwanej
56 ray-tracing. Program pobiera z pliku tekstowego informacje opisujące
57 obiekty oraz światło przedstawianego świata, a następnie generuje
58 rysunek z punktu widzenia kamery, która także jest definiowana w w/w
59 pliku tekstowym. Ray-tracing nie pozwala na szybkie tworzenie obrazów,
60 ale za to twórca otrzymuje wyskokiej jakości bitmapy z realistycznymi
61 efektami, tj. odbicia światła, cienie, perspektywa i inne.
62
63 %package X11
64 Summary:        X Window povray executable
65 Summary(pl.UTF-8):      povray pod X Window
66 Group:          Applications/Graphics
67 Requires:       %{name} = %{epoch}:%{version}-%{release}
68
69 %description X11
70 The Persistence of Vision(tm) Ray-Tracer X Window executable.
71
72 %description X11 -l pl.UTF-8
73 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla X
74 Window.
75
76 %package pvm
77 Summary:        PVM/Unix povray executable
78 Summary(pl.UTF-8):      Plik wykonywalny povray dla PVM/Unix
79 Group:          Applications/Graphics
80 Requires:       %{name} = %{epoch}:%{version}-%{release}
81
82 %description pvm
83 The Persistence of Vision(tm) Ray-Tracer PVM/Unix executable.
84
85 %description pvm -l pl.UTF-8
86 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla
87 PVM/Unix.
88
89 %package pvm-X11
90 Summary:        PVM/xwin povray executable
91 Summary(pl.UTF-8):      Plik wykonywalny povray dla PVM/xwin
92 Group:          Applications/Graphics
93 Requires:       %{name} = %{epoch}:%{version}-%{release}
94
95 %description pvm-X11
96 The Persistence of Vision(tm) Ray-Tracer PVM/xwin executable.
97
98 %description pvm-X11 -l pl.UTF-8
99 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla
100 PVM/xwin.
101
102 %prep
103 %setup -q -n %{name}-%{_src_pov_ver}
104 cp %{SOURCE1} unix/config/ax_boost_base.m4
105 %patch0 -p1
106
107 %build
108 %{__aclocal}
109 %{__autoconf}
110 %{__automake}
111 COMPILED_BY="PLD/Linux Team";export COMPILED_BY;
112 %if %{with x} && %{with pvm}
113 %configure \
114         --libdir=%{_datadir} \
115         --enable-pvm \
116         --with-pvm-arch=%{_pvmarch} \
117         --with-pvm-libs=%{_libdir}
118 %{__make}
119 install unix/povray x-pvmpov
120 %endif
121
122 %if %{with pvm}
123 %{__make} clean
124
125 %configure \
126         --libdir=%{_datadir} \
127         --enable-pvm \
128         --with-pvm-arch=%{_pvmarch} \
129         --with-pvm-libs=%{_libdir} \
130         --without-x
131 %{__make}
132 install unix/povray pvmpov
133 %endif
134
135 %if %{with x}
136 %configure \
137         --libdir=%{_datadir}
138 %{__make}
139 install unix/povray x-povray
140 %{__make} clean
141 %endif
142
143 %configure \
144         --libdir=%{_datadir} \
145         --without-x
146 %{__make}
147
148 %install
149 rm -rf $RPM_BUILD_ROOT
150 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_bindir},%{_datadir}}
151 %if %{with pvm}
152 install -d $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}
153 %endif
154
155 %{__make} install \
156         INSTALL="install -c -D" \
157         mkdir_p="mkdir -p" \
158         DESTDIR=$RPM_BUILD_ROOT
159
160 %if %{with x}
161 install x-povray $RPM_BUILD_ROOT%{_bindir}
162 %endif
163
164 %if %{with x} && %{with pvm}
165 install x-pvmpov $RPM_BUILD_ROOT%{_bindir}/x-pvmpov
166 ln -s %{_bindir}/x-pvmpov $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}/x-pvmpov
167 %endif
168
169 %if %{with pvm}
170 install pvmpov $RPM_BUILD_ROOT%{_bindir}/pvmpov
171 ln -s %{_bindir}/pvmpov $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}/pvmpov
172 %endif
173
174 ##install povray.ini $RPM_BUILD_ROOT%{_sysconfdir}
175 ##install povray.conf $RPM_BUILD_ROOT%{_sysconfdir}
176
177 %clean
178 rm -rf $RPM_BUILD_ROOT
179
180 %files
181 %defattr(644,root,root,755)
182 %doc AUTHORS ChangeLog NEWS README* changes.txt
183 %attr(755,root,root) %{_bindir}/povray
184 %{_datadir}/povray*
185 %{_docdir}/povray*
186 %{_mandir}/man?/*
187 %dir %{_sysconfdir}/povray
188 %dir %{_sysconfdir}/povray/3.7
189 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/3.7/povray.*
190 ## %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/povray.*
191
192 %if %{with x}
193 %files X11
194 %defattr(644,root,root,755)
195 %attr(755,root,root) %{_bindir}/x-povray
196 %endif
197
198 %if %{with pvm}
199 %files pvm
200 %defattr(644,root,root,755)
201 %attr(755,root,root) %{_pvmroot}/bin/%{_pvmarch}/pvmpov
202 %attr(755,root,root) %{_bindir}/pvmpov
203 %endif
204
205 %if %{with pvm} && %{with x}
206 %files pvm-X11
207 %defattr(644,root,root,755)
208 %attr(755,root,root) %{_pvmroot}/bin/%{_pvmarch}/x-pvmpov
209 %attr(755,root,root) %{_bindir}/x-pvmpov
210 %endif
This page took 0.055581 seconds and 4 git commands to generate.