]> git.pld-linux.org Git - packages/povray.git/blob - povray.spec
- todo added
[packages/povray.git] / povray.spec
1
2 #
3 # todo:
4 #      patch for s#/usr/local#/usr# in povray.ini
5 #
6
7 # Conditional build:
8 # _without_x    - without X11 subpackage
9 # _without_pvm  - [temporarily disabled by default] without PVM support
10 #
11 Summary:        Persistence of Vision Ray Tracer
12 Summary(pl):    Persistence of Vision Ray Tracer
13 Name:           povray
14 Version:        3.50c
15 Release:        1
16 License:        distributable
17 Group:          Applications/Graphics
18 Source0:        ftp://ftp.povray.org/pub/povray/Official/Unix/povuni_s.tgz
19 Source1:        %{name}-%{version}.md5sum
20 Patch0:         %{name}-legal.patch
21 Patch1:         %{name}-types.patch
22 # pvm support not yet available - http://pvmpov.sourceforge.net/
23 URL:            http://www.povray.org/
24 BuildRequires:  libjpeg-devel
25 BuildRequires:  libpng-devel >= 1.0.8
26 BuildRequires:  libstdc++-devel
27 BuildRequires:  libtiff-devel
28 BuildRequires:  zlib-devel
29 %{!?_without_x:BuildRequires:XFree86-devel}
30 #%{!?_without_pvm:BuildRequires:pvm-devel >= 3.4.3-24 }
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         _libdir         %{_datadir}
34
35 %description
36 The Persistence of Vision(tm) Ray-Tracer creates three-dimensional,
37 photo-realistic images using a rendering technique called ray-tracing.
38 It reads in a text file containing information describing the objects
39 and lighting in a scene and generates an image of that scene from the
40 view point of a camera also described in the text file. Ray-tracing is
41 not a fast process by any means, but it produces very high quality
42 images with realistic reflections, shading, perspective and other
43 effects.
44
45 %description -l pl
46 Persistence of Vision(tm) Ray-Tracer tworzy trójwymiarowe,
47 fotorealistyczne obrazy za pomoc± techniki renderingu zwanej
48 ray-tracing. Program pobiera z pliku tekstowego informacje opisuj±ce
49 obiekty oraz ¶wiat³o przedstawianego ¶wiata, a nastêpnie generuje
50 rysunek z punktu widzenia kamery, która tak¿e jest definiowana w w/w
51 pliku tekstowym. Ray-tracing nie pozwala na szybkie tworzenie obrazów,
52 ale za to twórca otrzymuje wyskokiej jako¶ci bitmapy z realistycznymi
53 efektami, tj. odbicia ¶wiat³a, cienie, perspektywa i inne.
54
55 %package X11
56 Summary:        X Window povray executable
57 Summary(pl):    povray pod X Window
58 Group:          Applications/Graphics
59 Requires:       %{name} = %{version}
60
61 %description X11
62 The Persistence of Vision(tm) Ray-Tracer X Window executable.
63
64 %description X11 -l pl
65 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla X
66 Window.
67
68 %package pvm
69 Summary:        PVM/unix povray executable
70 Group:          Applications/Graphics
71 Requires:       %{name} = %{version}
72
73 %description pvm
74 The Persistence of Vision(tm) Ray-Tracer PVM/unix executable.
75
76 %description X11 -l pl
77 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla
78 PVM/unix.
79
80 %package pvm-X11
81 Summary:        PVM/xwin povray executable
82 Group:          Applications/Graphics
83 Requires:       %{name} = %{version}
84
85 %description pvm-X11
86 The Persistence of Vision(tm) Ray-Tracer PVM/xwin executable.
87
88 %description X11 -l pl
89 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla
90 PVM/xwin.
91
92 %prep
93 cd %{_sourcedir}
94 md5sum -c %{name}-%{version}.md5sum
95 cd -
96 %setup -q
97 %patch0 -p1
98 %ifarch alpha
99 %patch1 -p1
100 %endif
101
102 %build
103 %{__aclocal}
104 %{__autoconf}
105 %{__automake}
106 %if %{!?_without_x:1}%{?_without_x:0}
107 %configure \
108         --x-includes=%{_prefix}/X11R6/include \
109         --x-libraries=%{_prefix}/X11R6/lib
110 %{__make}
111 install src/povray x-povray
112 %{__make} clean
113 %endif
114
115 %configure \
116         --without-x
117 %{__make}
118
119 %install
120 rm -rf $RPM_BUILD_ROOT
121 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_prefix}/X11R6/bin}
122
123 %{__make} install \
124         DESTDIR=$RPM_BUILD_ROOT
125
126 %if %{!?_without_x:1}%{?_without_x:0}
127 install x-povray $RPM_BUILD_ROOT%{_prefix}/X11R6/bin
128 %endif
129
130 install povray.ini $RPM_BUILD_ROOT%{_sysconfdir}
131 install povray.conf $RPM_BUILD_ROOT%{_sysconfdir}
132 ln -sf %{_sysconfdir}/povray.ini $RPM_BUILD_ROOT%{_datadir}/povray-3.5/povray.ini
133
134 %clean
135 rm -rf $RPM_BUILD_ROOT
136
137 %files
138 %defattr(644,root,root,755)
139 %doc AUTHORS ChangeLog NEWS README* povlegal.doc *.txt doc/html
140 %attr(755,root,root) %{_bindir}/povray
141 %{_libdir}/povray*
142 %{_mandir}/man?/*
143 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/povray.*
144
145 %if %{!?_without_x:1}%{?_without_x:0}
146 %files X11
147 %defattr(644,root,root,755)
148 %attr(755,root,root) %{_prefix}/X11R6/bin/x-povray
149 %endif
150
151 #%if %{!?_without_pvm:1}%{?_without_pvm:0}
152 #%files pvm
153 #%defattr(644,root,root,755)
154 #%attr(755,root,root) %{_pvm_root}/bin/%{_pvm_arch}/pvmpov
155 #
156 #%if %{!?_without_x:1}%{?_without_x:0}
157 #%files pvm-X11
158 #%defattr(644,root,root,755)
159 #%attr(755,root,root) %{_pvm_root}/bin/%{_pvm_arch}/x-pvmpov
160 #%endif
161 #%endif
This page took 0.045482 seconds and 4 git commands to generate.