]> git.pld-linux.org Git - packages/povray.git/blob - povray.spec
- Added missing br: pvm
[packages/povray.git] / povray.spec
1
2 #
3 # todo:
4 #      patch for s#/usr/local#/usr# in povray.ini
5 #
6 #
7 # Conditional build:
8 %bcond_without x        # - without X11 subpackage
9 %bcond_without pvm      # - without PVM support
10 %bcond_with svga        # - with svgalib support (doesn't work on many platforms)
11 #
12 %define         snap 20030110
13 Summary:        Persistence of Vision Ray Tracer
14 Summary(pl):    Persistence of Vision Ray Tracer
15 Name:           povray
16 Version:        3.50c
17 Release:        3
18 License:        distributable
19 Group:          Applications/Graphics
20 #Source0:       ftp://ftp.povray.org/pub/povray/Official/Unix/povuni_s.tgz
21 # based on sources from CVS at http://pvmpov.sourceforge.net/
22 Source0:        %{name}-%{version}-%{snap}.tar.gz
23 # Source0-md5: 4dc3a74c6182e9f9cb2fc46187fe7e6b
24 Patch0:         %{name}-legal.patch
25 Patch1:         %{name}-64bit.patch
26 Patch2:         %{name}-X-libs.patch
27 Patch3:         %{name}-lib64.patch
28 Patch4:         %{name}-no_svgalib.patch
29 URL:            http://www.povray.org/
30 %{?with_x:BuildRequires:        XFree86-devel}
31 BuildRequires:  autoconf
32 BuildRequires:  automake
33 BuildRequires:  libjpeg-devel
34 BuildRequires:  libpng-devel >= 1.0.8
35 BuildRequires:  pvm
36 BuildRequires:  libstdc++-devel
37 BuildRequires:  libtiff-devel
38 %{?with_pvm:BuildRequires:      pvm-devel >= 3.4.3-24}
39 %{?with_svga:BuildRequires:     svgalib-devel}
40 BuildRequires:  zlib-devel
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %define         _pvmarch        %(/usr/bin/pvmgetarch)
44 %define         _pvmroot        /usr/%{_lib}/pvm3
45
46 %description
47 The Persistence of Vision(tm) Ray-Tracer creates three-dimensional,
48 photo-realistic images using a rendering technique called ray-tracing.
49 It reads in a text file containing information describing the objects
50 and lighting in a scene and generates an image of that scene from the
51 view point of a camera also described in the text file. Ray-tracing is
52 not a fast process by any means, but it produces very high quality
53 images with realistic reflections, shading, perspective and other
54 effects.
55
56 %description -l pl
57 Persistence of Vision(tm) Ray-Tracer tworzy trójwymiarowe,
58 fotorealistyczne obrazy za pomoc± techniki renderingu zwanej
59 ray-tracing. Program pobiera z pliku tekstowego informacje opisuj±ce
60 obiekty oraz ¶wiat³o przedstawianego ¶wiata, a nastêpnie generuje
61 rysunek z punktu widzenia kamery, która tak¿e jest definiowana w w/w
62 pliku tekstowym. Ray-tracing nie pozwala na szybkie tworzenie obrazów,
63 ale za to twórca otrzymuje wyskokiej jako¶ci bitmapy z realistycznymi
64 efektami, tj. odbicia ¶wiat³a, cienie, perspektywa i inne.
65
66 %package X11
67 Summary:        X Window povray executable
68 Summary(pl):    povray pod X Window
69 Group:          Applications/Graphics
70 Requires:       %{name} = %{version}
71
72 %description X11
73 The Persistence of Vision(tm) Ray-Tracer X Window executable.
74
75 %description X11 -l pl
76 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla X
77 Window.
78
79 %package pvm
80 Summary:        PVM/unix povray executable
81 Summary(pl):    Plik wykonywalny povray dla PVM/unix
82 Group:          Applications/Graphics
83 Requires:       %{name} = %{version}
84
85 %description pvm
86 The Persistence of Vision(tm) Ray-Tracer PVM/unix executable.
87
88 %description pvm -l pl
89 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla
90 PVM/unix.
91
92 %package pvm-X11
93 Summary:        PVM/xwin povray executable
94 Summary(pl):    Plik wykonywalny povray dla PVM/xwin
95 Group:          Applications/Graphics
96 Requires:       %{name} = %{version}
97
98 %description pvm-X11
99 The Persistence of Vision(tm) Ray-Tracer PVM/xwin executable.
100
101 %description pvm-X11 -l pl
102 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla
103 PVM/xwin.
104
105 %prep
106 %setup -q
107 %patch1 -p1
108 %patch2 -p1
109 %if "%{_lib}" == "lib64"
110 %patch3 -p1
111 %endif
112 %if %{without svga}
113 %patch4 -p1
114 %endif
115
116 %build
117 %{__aclocal}
118 %{__autoconf}
119 %{__automake}
120 %if %{with x} && %{with pvm}
121 %configure \
122         --libdir=%{_datadir} \
123         --enable-pvm \
124         --with-pvm-arch=%{_pvmarch} \
125         --with-pvm-libs=%{_libdir} \
126         --x-includes=/usr/X11R6/include \
127         --x-libraries=/usr/X11R6/%{_lib}
128 %{__make}
129 install src/povray x-pvmpov
130 %endif
131
132 %if %{with pvm}
133 %{__make} clean
134
135 %configure \
136         --libdir=%{_datadir} \
137         --enable-pvm \
138         --with-pvm-arch=%{_pvmarch} \
139         --with-pvm-libs=%{_libdir} \
140         --without-x
141 %{__make}
142 install src/povray pvmpov
143 %endif
144
145 %if %{with x}
146 %configure \
147         --libdir=%{_datadir} \
148         --x-includes=/usr/X11R6/include \
149         --x-libraries=/usr/X11R6/%{_lib} 
150 %{__make}
151 install src/povray x-povray
152 %{__make} clean
153 %endif
154
155 %configure \
156         --libdir=%{_datadir} \
157         --without-x
158 %{__make}
159
160
161 %install
162 rm -rf $RPM_BUILD_ROOT
163 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/usr/X11R6/bin} \
164         $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}
165
166 %{__make} install \
167         DESTDIR=$RPM_BUILD_ROOT
168
169 %if %{with x}
170 install x-povray $RPM_BUILD_ROOT%{_bindir}
171 %endif
172
173 %if %{with x} && %{with pvm}
174 install x-pvmpov $RPM_BUILD_ROOT%{_bindir}/x-pvmpov
175 ln -s %{_bindir}/x-pvmpov $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}/x-pvmpov
176 %endif
177
178 %if %{with pvm}
179 install pvmpov $RPM_BUILD_ROOT%{_bindir}/pvmpov
180 ln -s %{_bindir}/pvmpov $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}/pvmpov
181 %endif
182
183 install povray.ini $RPM_BUILD_ROOT%{_sysconfdir}
184 install povray.conf $RPM_BUILD_ROOT%{_sysconfdir}
185 ln -sf %{_sysconfdir}/povray.ini $RPM_BUILD_ROOT%{_datadir}/povray-3.5/povray.ini
186
187 %clean
188 rm -rf $RPM_BUILD_ROOT
189
190 %files
191 %defattr(644,root,root,755)
192 %doc AUTHORS ChangeLog NEWS README* povlegal.doc *.txt doc/html
193 %attr(755,root,root) %{_bindir}/povray
194 %{_datadir}/povray*
195 %{_mandir}/man?/*
196 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/povray.*
197
198 %if %{with x}
199 %files X11
200 %defattr(644,root,root,755)
201 %attr(755,root,root) %{_bindir}/x-povray
202 %endif
203
204 %if %{with pvm}
205 %files pvm
206 %defattr(644,root,root,755)
207 %attr(755,root,root) %{_pvmroot}/bin/%{_pvmarch}/pvmpov
208 %attr(755,root,root) %{_bindir}/pvmpov
209 %endif
210
211 %if %{with pvm} && %{with x}
212 %files pvm-X11
213 %defattr(644,root,root,755)
214 %attr(755,root,root) %{_pvmroot}/bin/%{_pvmarch}/x-pvmpov
215 %attr(755,root,root) %{_bindir}/x-pvmpov
216 %endif
This page took 0.092155 seconds and 4 git commands to generate.