]> git.pld-linux.org Git - packages/povray.git/blob - povray.spec
- use sources from pvmpov.sf.net to build PVM enabled POV-Ray
[packages/povray.git] / povray.spec
1
2 #
3 # todo:
4 #      patch for s#/usr/local#/usr# in povray.ini
5 #      (no)svga version
6 #
7
8 # Conditional build:
9 # _without_x    - without X11 subpackage
10 # _without_pvm  - without PVM support
11 #
12 %define         snap 20030110
13 Summary:        Persistence of Vision Ray Tracer
14 Summary(pl):    Persistence of Vision Ray Tracer
15 Name:           povray
16 Version:        3.50c
17 Release:        1
18 License:        distributable
19 Group:          Applications/Graphics
20 #Source0:       ftp://ftp.povray.org/pub/povray/Official/Unix/povuni_s.tgz
21 # based on sources from CVS at http://pvmpov.sourceforge.net/
22 Source0:        %{name}-%{version}-%{snap}.tar.gz
23 Source1:        %{name}-%{version}.md5sum
24 Patch0:         %{name}-legal.patch
25 Patch1:         %{name}-types.patch
26 URL:            http://www.povray.org/
27 BuildRequires:  libjpeg-devel
28 BuildRequires:  libpng-devel >= 1.0.8
29 BuildRequires:  libstdc++-devel
30 BuildRequires:  libtiff-devel
31 BuildRequires:  zlib-devel
32 %{!?_without_x:BuildRequires:XFree86-devel}
33 #%{!?_without_pvm:BuildRequires:pvm-devel >= 3.4.3-24 }
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %define         _libdir         %{_datadir}
37 %define         _pvmarch        %(/usr/bin/pvmgetarch)
38 %define         _pvmroot        /usr/lib/pvm3/
39
40 %description
41 The Persistence of Vision(tm) Ray-Tracer creates three-dimensional,
42 photo-realistic images using a rendering technique called ray-tracing.
43 It reads in a text file containing information describing the objects
44 and lighting in a scene and generates an image of that scene from the
45 view point of a camera also described in the text file. Ray-tracing is
46 not a fast process by any means, but it produces very high quality
47 images with realistic reflections, shading, perspective and other
48 effects.
49
50 %description -l pl
51 Persistence of Vision(tm) Ray-Tracer tworzy trójwymiarowe,
52 fotorealistyczne obrazy za pomoc± techniki renderingu zwanej
53 ray-tracing. Program pobiera z pliku tekstowego informacje opisuj±ce
54 obiekty oraz ¶wiat³o przedstawianego ¶wiata, a nastêpnie generuje
55 rysunek z punktu widzenia kamery, która tak¿e jest definiowana w w/w
56 pliku tekstowym. Ray-tracing nie pozwala na szybkie tworzenie obrazów,
57 ale za to twórca otrzymuje wyskokiej jako¶ci bitmapy z realistycznymi
58 efektami, tj. odbicia ¶wiat³a, cienie, perspektywa i inne.
59
60 %package X11
61 Summary:        X Window povray executable
62 Summary(pl):    povray pod X Window
63 Group:          Applications/Graphics
64 Requires:       %{name} = %{version}
65
66 %description X11
67 The Persistence of Vision(tm) Ray-Tracer X Window executable.
68
69 %description X11 -l pl
70 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla X
71 Window.
72
73 %package pvm
74 Summary:        PVM/unix povray executable
75 Summary(pl):    Plik wykonywalny povray dla PVM/unix
76 Group:          Applications/Graphics
77 Requires:       %{name} = %{version}
78
79 %description pvm
80 The Persistence of Vision(tm) Ray-Tracer PVM/unix executable.
81
82 %description X11 -l pl
83 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla
84 PVM/unix.
85
86 %package pvm-X11
87 Summary:        PVM/xwin povray executable
88 Summary(pl):    Plik wykonywalny povray dla PVM/xwin
89 Group:          Applications/Graphics
90 Requires:       %{name} = %{version}
91
92 %description pvm-X11
93 The Persistence of Vision(tm) Ray-Tracer PVM/xwin executable.
94
95 %description X11 -l pl
96 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla
97 PVM/xwin.
98
99 %prep
100 #cd %{_sourcedir}
101 #md5sum -c %{name}-%{version}.md5sum
102 #cd -
103 %setup -q
104 #%patch0 -p1
105 %ifarch alpha
106 %patch1 -p1
107 %endif
108
109 %build
110 %{__aclocal}
111 %{__autoconf}
112 %{__automake}
113 %if %{!?_without_pvm:%{!?_without_x:1}%{?_without_x:0}}%{?_without_pvm:0}
114 %configure \
115         --enable-pvm \
116         --with-pvm-arch=%{_pvmarch} \
117         --x-includes=%{_prefix}/X11R6/include \
118         --x-libraries=%{_prefix}/X11R6/lib
119 %{__make}
120 install src/povray x-pvmpov
121 %endif
122
123 %if %{!?_without_pvm:1}%{?_without_pvm:0}
124 %{__make} clean
125
126 %configure \
127         --enable-pvm \
128         --with-pvm-arch=%{_pvmarch} \
129         --without-x
130 %{__make}
131 install src/povray pvmpov
132 %endif
133
134 %if %{!?_without_x:1}%{?_without_x:0}
135 %configure \
136         --x-includes=%{_prefix}/X11R6/include \
137         --x-libraries=%{_prefix}/X11R6/lib
138 %{__make}
139 install src/povray x-povray
140 %{__make} clean
141 %endif
142
143 %configure \
144         --without-x
145 %{__make}
146
147
148 %install
149 rm -rf $RPM_BUILD_ROOT
150 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_prefix}/X11R6/bin} \
151         $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}
152
153 %{__make} install \
154         DESTDIR=$RPM_BUILD_ROOT
155
156 %if %{!?_without_x:1}%{?_without_x:0}
157 install x-povray $RPM_BUILD_ROOT%{_prefix}/X11R6/bin
158 %endif
159
160 %if %{!?_without_pvm:%{!?_without_x:1}%{?_without_x:0}}%{?_without_pvm:0}
161 install x-pvmpov $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}/x-pvmpov
162 %endif
163
164 %if %{!?_without_pvm:1}%{?_without_pvm:0}
165 install pvmpov $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}/pvmpov
166 %endif
167
168 install povray.ini $RPM_BUILD_ROOT%{_sysconfdir}
169 install povray.conf $RPM_BUILD_ROOT%{_sysconfdir}
170 ln -sf %{_sysconfdir}/povray.ini $RPM_BUILD_ROOT%{_datadir}/povray-3.5/povray.ini
171
172 %clean
173 rm -rf $RPM_BUILD_ROOT
174
175 %files
176 %defattr(644,root,root,755)
177 %doc AUTHORS ChangeLog NEWS README* povlegal.doc *.txt doc/html
178 %attr(755,root,root) %{_bindir}/povray
179 %{_libdir}/povray*
180 %{_mandir}/man?/*
181 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/povray.*
182
183 %if %{!?_without_x:1}%{?_without_x:0}
184 %files X11
185 %defattr(644,root,root,755)
186 %attr(755,root,root) %{_prefix}/X11R6/bin/x-povray
187 %endif
188
189 %if %{!?_without_pvm:1}%{?_without_pvm:0}
190 %files pvm
191 %defattr(644,root,root,755)
192 %attr(755,root,root) %{_pvmroot}/bin/%{_pvmarch}/pvmpov
193 %endif
194
195 %if %{!?_without_pvm:%{!?_without_x:1}%{?_without_x:0}}%{?_without_pvm:0}
196 %files pvm-X11
197 %defattr(644,root,root,755)
198 %attr(755,root,root) %{_pvmroot}/bin/%{_pvmarch}/x-pvmpov
199 %endif
This page took 0.047748 seconds and 4 git commands to generate.