]> git.pld-linux.org Git - packages/povray.git/blob - povray.spec
- release 7
[packages/povray.git] / povray.spec
1 #
2 # Conditional build:
3 %bcond_without  x       # - without X11 subpackage
4 %bcond_with     pvm             # - with PVM support
5 %bcond_with     svga    # - with svgalib support (doesn't work on many platforms)
6 #
7 %define         _src_pov_ver    3.6.1
8
9 Summary:        Persistence of Vision Ray Tracer
10 Summary(pl.UTF-8):      Persistence of Vision Ray Tracer
11 Name:           povray
12 Version:        3.6.1
13 Release:        7
14 Epoch:          1
15 License:        distributable
16 Group:          Applications/Graphics
17 Source0:        http://www.povray.org/ftp/pub/povray/Official/Unix/%{name}-%{_src_pov_ver}.tar.bz2
18 # Source0-md5:  b5789bb7eeaed0809c5c82d0efda571d
19 # based on sources from CVS at http://pvmpov.sourceforge.net/
20 # Source0:      %{name}-%{version}-%{snap}.tar.gz
21 Patch0:         %{name}-legal.patch
22 Patch1:         %{name}-64bit.patch
23 Patch2:         %{name}-X-libs.patch
24 Patch3:         %{name}-lib64.patch
25 Patch4:         %{name}-no_svgalib.patch
26 Patch5:         %{name}-m4.patch
27 URL:            http://www.povray.org/
28 BuildRequires:  autoconf
29 BuildRequires:  automake
30 BuildRequires:  libjpeg-devel
31 BuildRequires:  libpng-devel >= 1.0.8
32 BuildRequires:  libstdc++-devel
33 BuildRequires:  libtiff-devel
34 %{?with_pvm:BuildRequires:      pvm-devel >= 3.4.3-24}
35 %{?with_svga:BuildRequires:     svgalib-devel}
36 %{?with_x:BuildRequires:        xorg-lib-libX11-devel}
37 BuildRequires:  zlib-devel
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %if %{with pvm}
41 %define         _pvmarch        %(/usr/bin/pvmgetarch)
42 %define         _pvmroot        /usr/%{_lib}/pvm3
43 %endif
44
45 %description
46 The Persistence of Vision(tm) Ray-Tracer creates three-dimensional,
47 photo-realistic images using a rendering technique called ray-tracing.
48 It reads in a text file containing information describing the objects
49 and lighting in a scene and generates an image of that scene from the
50 view point of a camera also described in the text file. Ray-tracing is
51 not a fast process by any means, but it produces very high quality
52 images with realistic reflections, shading, perspective and other
53 effects.
54
55 %description -l pl.UTF-8
56 Persistence of Vision(tm) Ray-Tracer tworzy trójwymiarowe,
57 fotorealistyczne obrazy za pomocą techniki renderingu zwanej
58 ray-tracing. Program pobiera z pliku tekstowego informacje opisujące
59 obiekty oraz światło przedstawianego świata, a następnie generuje
60 rysunek z punktu widzenia kamery, która także jest definiowana w w/w
61 pliku tekstowym. Ray-tracing nie pozwala na szybkie tworzenie obrazów,
62 ale za to twórca otrzymuje wyskokiej jakości bitmapy z realistycznymi
63 efektami, tj. odbicia światła, cienie, perspektywa i inne.
64
65 %package X11
66 Summary:        X Window povray executable
67 Summary(pl.UTF-8):      povray pod X Window
68 Group:          Applications/Graphics
69 Requires:       %{name} = %{epoch}:%{version}-%{release}
70
71 %description X11
72 The Persistence of Vision(tm) Ray-Tracer X Window executable.
73
74 %description X11 -l pl.UTF-8
75 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla X
76 Window.
77
78 %package pvm
79 Summary:        PVM/Unix povray executable
80 Summary(pl.UTF-8):      Plik wykonywalny povray dla PVM/Unix
81 Group:          Applications/Graphics
82 Requires:       %{name} = %{epoch}:%{version}-%{release}
83
84 %description pvm
85 The Persistence of Vision(tm) Ray-Tracer PVM/Unix executable.
86
87 %description pvm -l pl.UTF-8
88 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla
89 PVM/Unix.
90
91 %package pvm-X11
92 Summary:        PVM/xwin povray executable
93 Summary(pl.UTF-8):      Plik wykonywalny povray dla PVM/xwin
94 Group:          Applications/Graphics
95 Requires:       %{name} = %{epoch}:%{version}-%{release}
96
97 %description pvm-X11
98 The Persistence of Vision(tm) Ray-Tracer PVM/xwin executable.
99
100 %description pvm-X11 -l pl.UTF-8
101 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla
102 PVM/xwin.
103
104 %prep
105 %setup -q
106 ##%patch1 -p1
107 ##%patch2 -p1
108 %if "%{_lib}" == "lib64"
109 ##%patch3 -p1
110 %endif
111 %if !%{with svga}
112 ##%patch4 -p1
113 %endif
114 %patch5 -p1
115
116 %build
117 %{__aclocal}
118 %{__autoconf}
119 %{__automake}
120 COMPILED_BY="PLD/Linux Team";export COMPILED_BY;
121 %if %{with x} && %{with pvm}
122 %configure \
123         --libdir=%{_datadir} \
124         --enable-pvm \
125         --with-pvm-arch=%{_pvmarch} \
126         --with-pvm-libs=%{_libdir} \
127         --x-includes=/usr/X11R6/include \
128         --x-libraries=/usr/X11R6/%{_lib}
129 %{__make}
130 install unix/povray x-pvmpov
131 %endif
132
133 %if %{with pvm}
134 %{__make} clean
135
136 %configure \
137         --libdir=%{_datadir} \
138         --enable-pvm \
139         --with-pvm-arch=%{_pvmarch} \
140         --with-pvm-libs=%{_libdir} \
141         --without-x
142 %{__make}
143 install unix/povray pvmpov
144 %endif
145
146 %if %{with x}
147 %configure \
148         --libdir=%{_datadir} \
149         --x-includes=/usr/X11R6/include \
150         --x-libraries=/usr/X11R6/%{_lib}
151 %{__make}
152 install unix/povray x-povray
153 %{__make} clean
154 %endif
155
156 %configure \
157         --libdir=%{_datadir} \
158         --without-x
159 %{__make}
160
161
162 %install
163 rm -rf $RPM_BUILD_ROOT
164 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/usr/X11R6/bin}
165 %if %{with pvm}
166 install -d $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}
167 %endif
168
169 %{__make} install \
170         DESTDIR=$RPM_BUILD_ROOT
171
172 %if %{with x}
173 install x-povray $RPM_BUILD_ROOT%{_bindir}
174 %endif
175
176 %if %{with x} && %{with pvm}
177 install x-pvmpov $RPM_BUILD_ROOT%{_bindir}/x-pvmpov
178 ln -s %{_bindir}/x-pvmpov $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}/x-pvmpov
179 %endif
180
181 %if %{with pvm}
182 install pvmpov $RPM_BUILD_ROOT%{_bindir}/pvmpov
183 ln -s %{_bindir}/pvmpov $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}/pvmpov
184 %endif
185
186 ##install povray.ini $RPM_BUILD_ROOT%{_sysconfdir}
187 ##install povray.conf $RPM_BUILD_ROOT%{_sysconfdir}
188
189 %clean
190 rm -rf $RPM_BUILD_ROOT
191
192 %files
193 %defattr(644,root,root,755)
194 %doc AUTHORS ChangeLog NEWS README* doc/povlegal.doc doc/*.txt doc/html
195 %attr(755,root,root) %{_bindir}/povray
196 %{_datadir}/povray*
197 %{_docdir}/povray*
198 %{_mandir}/man?/*
199 %dir %{_sysconfdir}/povray
200 %dir %{_sysconfdir}/povray/3.6
201 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/3.6/povray.*
202 ## %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/povray.*
203
204 %if %{with x}
205 %files X11
206 %defattr(644,root,root,755)
207 %attr(755,root,root) %{_bindir}/x-povray
208 %endif
209
210 %if %{with pvm}
211 %files pvm
212 %defattr(644,root,root,755)
213 %attr(755,root,root) %{_pvmroot}/bin/%{_pvmarch}/pvmpov
214 %attr(755,root,root) %{_bindir}/pvmpov
215 %endif
216
217 %if %{with pvm} && %{with x}
218 %files pvm-X11
219 %defattr(644,root,root,755)
220 %attr(755,root,root) %{_pvmroot}/bin/%{_pvmarch}/x-pvmpov
221 %attr(755,root,root) %{_bindir}/x-pvmpov
222 %endif
This page took 0.041191 seconds and 4 git commands to generate.