]> git.pld-linux.org Git - packages/povray.git/blob - povray.spec
- massive attack, adding Source-md5
[packages/povray.git] / povray.spec
1
2 #
3 # todo:
4 #      patch for s#/usr/local#/usr# in povray.ini
5 #      (no)svga version
6 #
7
8 # Conditional build:
9 # _without_x    - without X11 subpackage
10 # _without_pvm  - without PVM support
11 #
12 %define         snap 20030110
13 Summary:        Persistence of Vision Ray Tracer
14 Summary(pl):    Persistence of Vision Ray Tracer
15 Name:           povray
16 Version:        3.50c
17 Release:        1
18 License:        distributable
19 Group:          Applications/Graphics
20 #Source0:       ftp://ftp.povray.org/pub/povray/Official/Unix/povuni_s.tgz
21 # based on sources from CVS at http://pvmpov.sourceforge.net/
22 Source0:        %{name}-%{version}-%{snap}.tar.gz
23 # Source0-md5: 4dc3a74c6182e9f9cb2fc46187fe7e6b
24 Patch0:         %{name}-legal.patch
25 URL:            http://www.povray.org/
26 BuildRequires:  libjpeg-devel
27 BuildRequires:  libpng-devel >= 1.0.8
28 BuildRequires:  libstdc++-devel
29 BuildRequires:  libtiff-devel
30 BuildRequires:  zlib-devel
31 %{!?_without_x:BuildRequires:XFree86-devel}
32 %{!?_without_pvm:BuildRequires:pvm-devel >= 3.4.3-24 }
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %define         _libdir         %{_datadir}
36 %define         _pvmarch        %(/usr/bin/pvmgetarch)
37 %define         _pvmroot        /usr/lib/pvm3/
38
39 %description
40 The Persistence of Vision(tm) Ray-Tracer creates three-dimensional,
41 photo-realistic images using a rendering technique called ray-tracing.
42 It reads in a text file containing information describing the objects
43 and lighting in a scene and generates an image of that scene from the
44 view point of a camera also described in the text file. Ray-tracing is
45 not a fast process by any means, but it produces very high quality
46 images with realistic reflections, shading, perspective and other
47 effects.
48
49 %description -l pl
50 Persistence of Vision(tm) Ray-Tracer tworzy trójwymiarowe,
51 fotorealistyczne obrazy za pomoc± techniki renderingu zwanej
52 ray-tracing. Program pobiera z pliku tekstowego informacje opisuj±ce
53 obiekty oraz ¶wiat³o przedstawianego ¶wiata, a nastêpnie generuje
54 rysunek z punktu widzenia kamery, która tak¿e jest definiowana w w/w
55 pliku tekstowym. Ray-tracing nie pozwala na szybkie tworzenie obrazów,
56 ale za to twórca otrzymuje wyskokiej jako¶ci bitmapy z realistycznymi
57 efektami, tj. odbicia ¶wiat³a, cienie, perspektywa i inne.
58
59 %package X11
60 Summary:        X Window povray executable
61 Summary(pl):    povray pod X Window
62 Group:          Applications/Graphics
63 Requires:       %{name} = %{version}
64
65 %description X11
66 The Persistence of Vision(tm) Ray-Tracer X Window executable.
67
68 %description X11 -l pl
69 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla X
70 Window.
71
72 %package pvm
73 Summary:        PVM/unix povray executable
74 Summary(pl):    Plik wykonywalny povray dla PVM/unix
75 Group:          Applications/Graphics
76 Requires:       %{name} = %{version}
77
78 %description pvm
79 The Persistence of Vision(tm) Ray-Tracer PVM/unix executable.
80
81 %description X11 -l pl
82 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla
83 PVM/unix.
84
85 %package pvm-X11
86 Summary:        PVM/xwin povray executable
87 Summary(pl):    Plik wykonywalny povray dla PVM/xwin
88 Group:          Applications/Graphics
89 Requires:       %{name} = %{version}
90
91 %description pvm-X11
92 The Persistence of Vision(tm) Ray-Tracer PVM/xwin executable.
93
94 %description X11 -l pl
95 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla
96 PVM/xwin.
97
98 %prep
99 %setup -q
100
101 %build
102 %{__aclocal}
103 %{__autoconf}
104 %{__automake}
105 %if %{!?_without_pvm:%{!?_without_x:1}%{?_without_x:0}}%{?_without_pvm:0}
106 %configure \
107         --enable-pvm \
108         --with-pvm-arch=%{_pvmarch} \
109         --x-includes=%{_prefix}/X11R6/include \
110         --x-libraries=%{_prefix}/X11R6/lib
111 %{__make}
112 install src/povray x-pvmpov
113 %endif
114
115 %if %{!?_without_pvm:1}%{?_without_pvm:0}
116 %{__make} clean
117
118 %configure \
119         --enable-pvm \
120         --with-pvm-arch=%{_pvmarch} \
121         --without-x
122 %{__make}
123 install src/povray pvmpov
124 %endif
125
126 %if %{!?_without_x:1}%{?_without_x:0}
127 %configure \
128         --x-includes=%{_prefix}/X11R6/include \
129         --x-libraries=%{_prefix}/X11R6/lib
130 %{__make}
131 install src/povray x-povray
132 %{__make} clean
133 %endif
134
135 %configure \
136         --without-x
137 %{__make}
138
139
140 %install
141 rm -rf $RPM_BUILD_ROOT
142 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_prefix}/X11R6/bin} \
143         $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}
144
145 %{__make} install \
146         DESTDIR=$RPM_BUILD_ROOT
147
148 %if %{!?_without_x:1}%{?_without_x:0}
149 install x-povray $RPM_BUILD_ROOT%{_bindir}
150 %endif
151
152 %if %{!?_without_pvm:%{!?_without_x:1}%{?_without_x:0}}%{?_without_pvm:0}
153 install x-pvmpov $RPM_BUILD_ROOT%{_bindir}/x-pvmpov
154 ln -s %{_binir}/x-pvmpov $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}/x-pvmpov
155 %endif
156
157 %if %{!?_without_pvm:1}%{?_without_pvm:0}
158 install pvmpov $RPM_BUILD_ROOT%{_bindir}/pvmpov
159 ln -s %{_binir}/pvmpov $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}/pvmpov
160 %endif
161
162 install povray.ini $RPM_BUILD_ROOT%{_sysconfdir}
163 install povray.conf $RPM_BUILD_ROOT%{_sysconfdir}
164 ln -sf %{_sysconfdir}/povray.ini $RPM_BUILD_ROOT%{_datadir}/povray-3.5/povray.ini
165
166 %clean
167 rm -rf $RPM_BUILD_ROOT
168
169 %files
170 %defattr(644,root,root,755)
171 %doc AUTHORS ChangeLog NEWS README* povlegal.doc *.txt doc/html
172 %attr(755,root,root) %{_bindir}/povray
173 %{_libdir}/povray*
174 %{_mandir}/man?/*
175 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/povray.*
176
177 %if %{!?_without_x:1}%{?_without_x:0}
178 %files X11
179 %defattr(644,root,root,755)
180 %attr(755,root,root) %{_bindir}/x-povray
181 %endif
182
183 %if %{!?_without_pvm:1}%{?_without_pvm:0}
184 %files pvm
185 %defattr(644,root,root,755)
186 %attr(755,root,root) %{_pvmroot}/bin/%{_pvmarch}/pvmpov
187 %attr(755,root,root) %{_bindir}/pvmpov
188 %endif
189
190 %if %{!?_without_pvm:%{!?_without_x:1}%{?_without_x:0}}%{?_without_pvm:0}
191 %files pvm-X11
192 %defattr(644,root,root,755)
193 %attr(755,root,root) %{_pvmroot}/bin/%{_pvmarch}/x-pvmpov
194 %attr(755,root,root) %{_bindir}/x-pvmpov
195 %endif
This page took 0.038411 seconds and 4 git commands to generate.