]> git.pld-linux.org Git - packages/povray.git/blob - povray.spec
- s/Copyright/License/
[packages/povray.git] / povray.spec
1 Summary:        Persistence of Vision Ray Tracer
2 Summary(pl):    Persistence of Vision Ray Tracer
3 Name:           povray
4 Version:        3.1g
5 Release:        5
6 License:        distrituable
7 Group:          Applications/Graphics
8 Group(de):      Applikationen/Grafik
9 Group(pl):      Aplikacje/Grafika
10 Source0:        ftp://ftp.povray.org/pub/povray/Official/Unix/povuni_s.tgz
11 Source1:        ftp://ftp.povray.org/pub/povray/Official/Unix/povuni_d.tgz
12 # pvm.patch is instead of that source, and its based on it
13 #Source2:       pvmpov-3.1e2.tgz
14 Patch0:         %{name}-makefile_and_config.patch
15 Patch1:         %{name}-pvm.patch
16 Patch2:         %{name}-png_with_pvm.patch
17 URL:            http://www.povray.org/
18 BuildRequires:  zlib-devel
19 BuildRequires:  libpng-devel >= 1.0.8
20 %{!?_without_x:BuildRequires:XFree86-devel}
21 %{!?_without_pvm:BuildRequires:pvm-devel >= 3.4.3-24 }
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 #ugly but now _pvm_root/_pvm_arch isnt defined in macros
25
26 %define         _pvm_root       %{_libdir}/pvm3
27 %define         _pvm_arch       %(ls %{_pvm_root}/conf/|sed -e 's/\.def//')
28
29 %description
30 The Persistence of Vision(tm) Ray-Tracer creates three-dimensional,
31 photo-realistic images using a rendering technique called ray-tracing.
32 It reads in a text file containing information describing the objects
33 and lighting in a scene and generates an image of that scene from the
34 view point of a camera also described in the text file. Ray-tracing is
35 not a fast process by any means, but it produces very high quality
36 images with realistic reflections, shading, perspective and other
37 effects.
38
39 %description -l pl
40 Persistence of Vision(tm) Ray-Tracer tworzy trójwymiarowe,
41 fotorealistyczne obrazy za pomoc± techniki renderingu zwanej
42 ray-tracing. Program pobiera z pliku tekstowego informacje opisuj±ce
43 obiekty oraz ¶wiat³o przedstawianego ¶wiata, a nastêpnie generuje
44 rysunek z punktu widzenia kamery, która tak¿e jest definiowana w w/w
45 pliku tekstowym. Ray-tracing nie pozwala na szybkie tworzenie obrazów,
46 ale za to twórca otrzymuje wyskokiej jako¶ci bitmapy z realistycznymi
47 efektami, tj. odbicia ¶wiat³a, cienie, perspektywa i inne.
48
49 %if %{!?_without_x:1}%{?_without_x}
50 %package X11
51 Summary:        X Window povray executable
52 Summary(pl):    povray pod X Window
53 Group:          Applications/Graphics
54 Group(de):      Applikationen/Grafik
55 Group(pl):      Aplikacje/Grafika
56 Requires:       %{name} = %{version}
57
58 %description X11
59 The Persistence of Vision(tm) Ray-Tracer X Window executable.
60 %endif
61
62 %if %{!?_without_pvm:1}%{?_without_pvm:0}
63 %package pvm
64 Summary:        PVM/unix povray executable
65 Group:          Applications/Graphics
66 Group(de):      Applikationen/Grafik
67 Group(pl):      Aplikacje/Grafika
68 Requires:       %{name} = %{version}
69
70 %description pvm
71 The Persistence of Vision(tm) Ray-Tracer PVM/unix executable.
72
73 %if %{!?_without_x:1}%{?_without_x:0}
74 %package pvm-X11
75 Summary:        PVM/xwin povray executable
76 Group:          Applications/Graphics
77 Group(de):      Applikationen/Grafik
78 Group(pl):      Aplikacje/Grafika
79 Requires:       %{name} = %{version}
80
81 %description pvm-X11
82 The Persistence of Vision(tm) Ray-Tracer PVM/xwin executable.
83 %endif
84 %endif
85
86 %prep
87 %setup -q -n povray31 -b 1 
88 %patch0 -p1
89 %patch1 -p0
90 %patch2 -p1
91
92 %build
93 cd source/unix
94 %{__make} newunix %{!?_without_x:newxwin} %{!?_without_pvm:newunix_pvm %{!?_without_x:newxwin_pvm}} OPT_FLAGS="%{rpmcflags}"
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98 install -d $RPM_BUILD_ROOT{%{_bindir},/etc/skel,%{_mandir}/man1,%{_datadir}/povray31,%{_pvm_root}/bin/%{_pvm_arch}}
99
100
101 install source/unix/povray $RPM_BUILD_ROOT%{_bindir}
102 %{!?_without_x:install source/unix/x-povray $RPM_BUILD_ROOT%{_bindir}}
103 %{!?_without_pvm:install source/unix/pvmpov $RPM_BUILD_ROOT%{_pvm_root}/bin/%{_pvm_arch}}
104 %{!?_without_pvm:%{!?_without_x:install source/unix/x-pvmpov $RPM_BUILD_ROOT%{_pvm_root}/bin/%{_pvm_arch}}}
105 install source/unix/povrayrc $RPM_BUILD_ROOT/etc/skel/.povrayrc
106
107 install povray.1 $RPM_BUILD_ROOT%{_mandir}/man1
108
109 cp -r allscene include scenes $RPM_BUILD_ROOT%{_datadir}/povray31
110 install *.ini *.pov $RPM_BUILD_ROOT%{_datadir}/povray31
111
112 gzip -9nf gamma.gif.txt povlegal.doc povuser.txt
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %files
118 %defattr(644,root,root,755)
119 %doc gamma.gif.txt.gz povuser.txt.gz gamma.gif povlegal.doc.gz
120 %attr(755,root,root) %{_bindir}/povray
121 %{_datadir}/povray31
122 /etc/skel/.povrayrc
123 %{_mandir}/man1/*
124
125 %if %{!?_without_x:1}%{?_without_x:0}
126 %files X11
127 %defattr(644,root,root,755)
128 %attr(755,root,root) %{_bindir}/x-povray
129 %endif
130
131 %if %{!?_without_pvm:1}%{?_without_pvm:0}
132 %files pvm
133 %defattr(644,root,root,755)
134 %attr(755,root,root) %{_pvm_root}/bin/%{_pvm_arch}/pvmpov
135
136 %if %{!?_without_x:1}%{?_without_x:0}
137 %files pvm-X11
138 %defattr(644,root,root,755)
139 %attr(755,root,root) %{_pvm_root}/bin/%{_pvm_arch}/x-pvmpov
140 %endif
141 %endif
This page took 0.042681 seconds and 4 git commands to generate.