]> git.pld-linux.org Git - packages/povray.git/blob - povray.spec
- updated to version 3.6.1,
[packages/povray.git] / povray.spec
1
2 #
3 # todo:
4 #      patch for s#/usr/local#/usr# in povray.ini
5 #
6 #
7 # Conditional build:
8 %bcond_without x        # - without X11 subpackage
9 %bcond_with pvm         # - with PVM support
10 %bcond_with svga        # - with svgalib support (doesn't work on many platforms)
11 #
12 %define         _src_pov_ver    3.6
13
14 Summary:        Persistence of Vision Ray Tracer
15 Summary(pl):    Persistence of Vision Ray Tracer
16 Name:           povray
17 Version:        3.6.1
18 Release:        0.5
19 License:        distributable
20 Group:          Applications/Graphics
21 Source0:        http://www.povray.org/ftp/pub/povray/Official/Unix/povray-%{_src_pov_ver}.tar.bz2
22 # Source0-md5:  b5789bb7eeaed0809c5c82d0efda571d
23 # based on sources from CVS at http://pvmpov.sourceforge.net/
24 # Source0:      %{name}-%{version}-%{snap}.tar.gz
25 Patch0:         %{name}-legal.patch
26 Patch1:         %{name}-64bit.patch
27 Patch2:         %{name}-X-libs.patch
28 Patch3:         %{name}-lib64.patch
29 Patch4:         %{name}-no_svgalib.patch
30 URL:            http://www.povray.org/
31 %{?with_x:BuildRequires:        XFree86-devel}
32 BuildRequires:  autoconf
33 BuildRequires:  automake
34 BuildRequires:  libjpeg-devel
35 BuildRequires:  libpng-devel >= 1.0.8
36 BuildRequires:  libstdc++-devel
37 BuildRequires:  libtiff-devel
38 %{?with_pvm:BuildRequires:      pvm-devel >= 3.4.3-24}
39 %{?with_svga:BuildRequires:     svgalib-devel}
40 BuildRequires:  zlib-devel
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %define         _pvmarch        %(/usr/bin/pvmgetarch)
44 %define         _pvmroot        /usr/%{_lib}/pvm3
45
46 %description
47 The Persistence of Vision(tm) Ray-Tracer creates three-dimensional,
48 photo-realistic images using a rendering technique called ray-tracing.
49 It reads in a text file containing information describing the objects
50 and lighting in a scene and generates an image of that scene from the
51 view point of a camera also described in the text file. Ray-tracing is
52 not a fast process by any means, but it produces very high quality
53 images with realistic reflections, shading, perspective and other
54 effects.
55
56 %description -l pl
57 Persistence of Vision(tm) Ray-Tracer tworzy trójwymiarowe,
58 fotorealistyczne obrazy za pomoc± techniki renderingu zwanej
59 ray-tracing. Program pobiera z pliku tekstowego informacje opisuj±ce
60 obiekty oraz ¶wiat³o przedstawianego ¶wiata, a nastêpnie generuje
61 rysunek z punktu widzenia kamery, która tak¿e jest definiowana w w/w
62 pliku tekstowym. Ray-tracing nie pozwala na szybkie tworzenie obrazów,
63 ale za to twórca otrzymuje wyskokiej jako¶ci bitmapy z realistycznymi
64 efektami, tj. odbicia ¶wiat³a, cienie, perspektywa i inne.
65
66 %package X11
67 Summary:        X Window povray executable
68 Summary(pl):    povray pod X Window
69 Group:          Applications/Graphics
70 Requires:       %{name} = %{version}
71
72 %description X11
73 The Persistence of Vision(tm) Ray-Tracer X Window executable.
74
75 %description X11 -l pl
76 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla X
77 Window.
78
79 %package pvm
80 Summary:        PVM/unix povray executable
81 Summary(pl):    Plik wykonywalny povray dla PVM/unix
82 Group:          Applications/Graphics
83 Requires:       %{name} = %{version}
84
85 %description pvm
86 The Persistence of Vision(tm) Ray-Tracer PVM/unix executable.
87
88 %description pvm -l pl
89 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla
90 PVM/unix.
91
92 %package pvm-X11
93 Summary:        PVM/xwin povray executable
94 Summary(pl):    Plik wykonywalny povray dla PVM/xwin
95 Group:          Applications/Graphics
96 Requires:       %{name} = %{version}
97
98 %description pvm-X11
99 The Persistence of Vision(tm) Ray-Tracer PVM/xwin executable.
100
101 %description pvm-X11 -l pl
102 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla
103 PVM/xwin.
104
105 %prep
106 %setup -q
107 ##%patch1 -p1
108 ##%patch2 -p1
109 %if "%{_lib}" == "lib64"
110 ##%patch3 -p1
111 %endif
112 %if %{without svga}
113 ##%patch4 -p1
114 %endif
115
116 %build
117 %{__aclocal}
118 %{__autoconf}
119 %{__automake}
120 COMPILED_BY="xx";export COMPILED_BY;
121 %if %{with x} && %{with pvm}
122 %configure \
123         --libdir=%{_datadir} \
124         --enable-pvm \
125         --with-pvm-arch=%{_pvmarch} \
126         --with-pvm-libs=%{_libdir} \
127         --x-includes=/usr/X11R6/include \
128         --x-libraries=/usr/X11R6/%{_lib}
129 %{__make}
130 install unix/povray x-pvmpov
131 %endif
132
133 %if %{with pvm}
134 %{__make} clean
135
136 %configure \
137         --libdir=%{_datadir} \
138         --enable-pvm \
139         --with-pvm-arch=%{_pvmarch} \
140         --with-pvm-libs=%{_libdir} \
141         --without-x
142 %{__make}
143 install unix/povray pvmpov
144 %endif
145
146 %if %{with x}
147 %configure \
148         --libdir=%{_datadir} \
149         --x-includes=/usr/X11R6/include \
150         --x-libraries=/usr/X11R6/%{_lib} 
151 %{__make}
152 install unix/povray x-povray
153 %{__make} clean
154 %endif
155
156 %configure \
157         --libdir=%{_datadir} \
158         --without-x
159 %{__make}
160
161
162 %install
163 rm -rf $RPM_BUILD_ROOT
164 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/usr/X11R6/bin} \
165         $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}
166
167 %{__make} install \
168         DESTDIR=$RPM_BUILD_ROOT
169
170 %if %{with x}
171 install x-povray $RPM_BUILD_ROOT%{_bindir}
172 %endif
173
174 %if %{with x} && %{with pvm}
175 install x-pvmpov $RPM_BUILD_ROOT%{_bindir}/x-pvmpov
176 ln -s %{_bindir}/x-pvmpov $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}/x-pvmpov
177 %endif
178
179 %if %{with pvm}
180 install pvmpov $RPM_BUILD_ROOT%{_bindir}/pvmpov
181 ln -s %{_bindir}/pvmpov $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}/pvmpov
182 %endif
183
184 ##install povray.ini $RPM_BUILD_ROOT%{_sysconfdir}
185 ##install povray.conf $RPM_BUILD_ROOT%{_sysconfdir}
186
187 %clean
188 rm -rf $RPM_BUILD_ROOT
189
190 %files
191 %defattr(644,root,root,755)
192 %doc AUTHORS ChangeLog NEWS README* doc/povlegal.doc doc/*.txt doc/html
193 %attr(755,root,root) %{_bindir}/povray
194 %{_datadir}/povray*
195 %{_docdir}/povray*
196 %{_mandir}/man?/*
197 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/%{name}/%{_src_pov_ver}/povray.*
198 ## %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/povray.*
199
200 %if %{with x}
201 %files X11
202 %defattr(644,root,root,755)
203 %attr(755,root,root) %{_bindir}/x-povray
204 %endif
205
206 %if %{with pvm}
207 %files pvm
208 %defattr(644,root,root,755)
209 %attr(755,root,root) %{_pvmroot}/bin/%{_pvmarch}/pvmpov
210 %attr(755,root,root) %{_bindir}/pvmpov
211 %endif
212
213 %if %{with pvm} && %{with x}
214 %files pvm-X11
215 %defattr(644,root,root,755)
216 %attr(755,root,root) %{_pvmroot}/bin/%{_pvmarch}/x-pvmpov
217 %attr(755,root,root) %{_bindir}/x-pvmpov
218 %endif
This page took 0.053272 seconds and 4 git commands to generate.