]> git.pld-linux.org Git - packages/povray.git/blob - povray.spec
- release 9
[packages/povray.git] / povray.spec
1 #
2 # Conditional build:
3 %bcond_without  x       # - without X11 subpackage
4 %bcond_with     pvm             # - with PVM support
5 %bcond_with     svga    # - with svgalib support (doesn't work on many platforms)
6 #
7 %define         _src_pov_ver    3.6.1
8
9 Summary:        Persistence of Vision Ray Tracer
10 Summary(pl.UTF-8):      Persistence of Vision Ray Tracer
11 Name:           povray
12 Version:        3.6.1
13 Release:        9
14 Epoch:          1
15 License:        distributable
16 Group:          Applications/Graphics
17 Source0:        http://www.povray.org/ftp/pub/povray/Official/Unix/%{name}-%{_src_pov_ver}.tar.bz2
18 # Source0-md5:  b5789bb7eeaed0809c5c82d0efda571d
19 # based on sources from CVS at http://pvmpov.sourceforge.net/
20 # Source0:      %{name}-%{version}-%{snap}.tar.gz
21 Patch0:         %{name}-legal.patch
22 Patch1:         %{name}-64bit.patch
23 Patch2:         %{name}-X-libs.patch
24 Patch3:         %{name}-lib64.patch
25 Patch4:         %{name}-no_svgalib.patch
26 Patch5:         %{name}-m4.patch
27 Patch6:         %{name}-png.patch
28 URL:            http://www.povray.org/
29 BuildRequires:  autoconf
30 BuildRequires:  automake
31 BuildRequires:  libjpeg-devel
32 BuildRequires:  libpng-devel >= 1.4.0
33 BuildRequires:  libstdc++-devel
34 BuildRequires:  libtiff-devel
35 %{?with_pvm:BuildRequires:      pvm-devel >= 3.4.3-24}
36 %{?with_svga:BuildRequires:     svgalib-devel}
37 %{?with_x:BuildRequires:        xorg-lib-libX11-devel}
38 BuildRequires:  zlib-devel
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %if %{with pvm}
42 %define         _pvmarch        %(/usr/bin/pvmgetarch)
43 %define         _pvmroot        /usr/%{_lib}/pvm3
44 %endif
45
46 %description
47 The Persistence of Vision(tm) Ray-Tracer creates three-dimensional,
48 photo-realistic images using a rendering technique called ray-tracing.
49 It reads in a text file containing information describing the objects
50 and lighting in a scene and generates an image of that scene from the
51 view point of a camera also described in the text file. Ray-tracing is
52 not a fast process by any means, but it produces very high quality
53 images with realistic reflections, shading, perspective and other
54 effects.
55
56 %description -l pl.UTF-8
57 Persistence of Vision(tm) Ray-Tracer tworzy trójwymiarowe,
58 fotorealistyczne obrazy za pomocą techniki renderingu zwanej
59 ray-tracing. Program pobiera z pliku tekstowego informacje opisujące
60 obiekty oraz światło przedstawianego świata, a następnie generuje
61 rysunek z punktu widzenia kamery, która także jest definiowana w w/w
62 pliku tekstowym. Ray-tracing nie pozwala na szybkie tworzenie obrazów,
63 ale za to twórca otrzymuje wyskokiej jakości bitmapy z realistycznymi
64 efektami, tj. odbicia światła, cienie, perspektywa i inne.
65
66 %package X11
67 Summary:        X Window povray executable
68 Summary(pl.UTF-8):      povray pod X Window
69 Group:          Applications/Graphics
70 Requires:       %{name} = %{epoch}:%{version}-%{release}
71
72 %description X11
73 The Persistence of Vision(tm) Ray-Tracer X Window executable.
74
75 %description X11 -l pl.UTF-8
76 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla X
77 Window.
78
79 %package pvm
80 Summary:        PVM/Unix povray executable
81 Summary(pl.UTF-8):      Plik wykonywalny povray dla PVM/Unix
82 Group:          Applications/Graphics
83 Requires:       %{name} = %{epoch}:%{version}-%{release}
84
85 %description pvm
86 The Persistence of Vision(tm) Ray-Tracer PVM/Unix executable.
87
88 %description pvm -l pl.UTF-8
89 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla
90 PVM/Unix.
91
92 %package pvm-X11
93 Summary:        PVM/xwin povray executable
94 Summary(pl.UTF-8):      Plik wykonywalny povray dla PVM/xwin
95 Group:          Applications/Graphics
96 Requires:       %{name} = %{epoch}:%{version}-%{release}
97
98 %description pvm-X11
99 The Persistence of Vision(tm) Ray-Tracer PVM/xwin executable.
100
101 %description pvm-X11 -l pl.UTF-8
102 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla
103 PVM/xwin.
104
105 %prep
106 %setup -q
107 ##%patch1 -p1
108 ##%patch2 -p1
109 %if "%{_lib}" == "lib64"
110 ##%patch3 -p1
111 %endif
112 %if !%{with svga}
113 ##%patch4 -p1
114 %endif
115 %patch5 -p1
116 %patch6 -p1
117
118 %build
119 %{__aclocal}
120 %{__autoconf}
121 %{__automake}
122 COMPILED_BY="PLD/Linux Team";export COMPILED_BY;
123 %if %{with x} && %{with pvm}
124 %configure \
125         --libdir=%{_datadir} \
126         --enable-pvm \
127         --with-pvm-arch=%{_pvmarch} \
128         --with-pvm-libs=%{_libdir} \
129         --x-includes=/usr/X11R6/include \
130         --x-libraries=/usr/X11R6/%{_lib}
131 %{__make}
132 install unix/povray x-pvmpov
133 %endif
134
135 %if %{with pvm}
136 %{__make} clean
137
138 %configure \
139         --libdir=%{_datadir} \
140         --enable-pvm \
141         --with-pvm-arch=%{_pvmarch} \
142         --with-pvm-libs=%{_libdir} \
143         --without-x
144 %{__make}
145 install unix/povray pvmpov
146 %endif
147
148 %if %{with x}
149 %configure \
150         --libdir=%{_datadir} \
151         --x-includes=/usr/X11R6/include \
152         --x-libraries=/usr/X11R6/%{_lib}
153 %{__make}
154 install unix/povray x-povray
155 %{__make} clean
156 %endif
157
158 %configure \
159         --libdir=%{_datadir} \
160         --without-x
161 %{__make}
162
163
164 %install
165 rm -rf $RPM_BUILD_ROOT
166 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/usr/X11R6/bin}
167 %if %{with pvm}
168 install -d $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}
169 %endif
170
171 %{__make} install \
172         DESTDIR=$RPM_BUILD_ROOT
173
174 %if %{with x}
175 install x-povray $RPM_BUILD_ROOT%{_bindir}
176 %endif
177
178 %if %{with x} && %{with pvm}
179 install x-pvmpov $RPM_BUILD_ROOT%{_bindir}/x-pvmpov
180 ln -s %{_bindir}/x-pvmpov $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}/x-pvmpov
181 %endif
182
183 %if %{with pvm}
184 install pvmpov $RPM_BUILD_ROOT%{_bindir}/pvmpov
185 ln -s %{_bindir}/pvmpov $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}/pvmpov
186 %endif
187
188 ##install povray.ini $RPM_BUILD_ROOT%{_sysconfdir}
189 ##install povray.conf $RPM_BUILD_ROOT%{_sysconfdir}
190
191 %clean
192 rm -rf $RPM_BUILD_ROOT
193
194 %files
195 %defattr(644,root,root,755)
196 %doc AUTHORS ChangeLog NEWS README* doc/povlegal.doc doc/*.txt doc/html
197 %attr(755,root,root) %{_bindir}/povray
198 %{_datadir}/povray*
199 %{_docdir}/povray*
200 %{_mandir}/man?/*
201 %dir %{_sysconfdir}/povray
202 %dir %{_sysconfdir}/povray/3.6
203 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/3.6/povray.*
204 ## %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/povray.*
205
206 %if %{with x}
207 %files X11
208 %defattr(644,root,root,755)
209 %attr(755,root,root) %{_bindir}/x-povray
210 %endif
211
212 %if %{with pvm}
213 %files pvm
214 %defattr(644,root,root,755)
215 %attr(755,root,root) %{_pvmroot}/bin/%{_pvmarch}/pvmpov
216 %attr(755,root,root) %{_bindir}/pvmpov
217 %endif
218
219 %if %{with pvm} && %{with x}
220 %files pvm-X11
221 %defattr(644,root,root,755)
222 %attr(755,root,root) %{_pvmroot}/bin/%{_pvmarch}/x-pvmpov
223 %attr(755,root,root) %{_bindir}/x-pvmpov
224 %endif
This page took 0.168739 seconds and 4 git commands to generate.