]> git.pld-linux.org Git - packages/povray.git/blob - povray.spec
- up to 3.7.1-beta.5
[packages/povray.git] / povray.spec
1 #
2 # Conditional build:
3 %bcond_without  x       # - without X11 subpackage
4 %bcond_with     pvm     # - with PVM support
5 %bcond_with     svga    # - with svgalib support (doesn't work on many platforms)
6 #
7 %define beta    beta.5
8 Summary:        Persistence of Vision Ray Tracer
9 Summary(pl.UTF-8):      Persistence of Vision Ray Tracer
10 Name:           povray
11 Version:        3.7.1
12 Release:        0.%{beta}.1
13 Epoch:          1
14 License:        AGPLv3+
15 Group:          Applications/Graphics
16 Source0:        https://github.com/POV-Ray/povray/archive/v%{version}-%{beta}/%{name}-%{version}-%{beta}.tar.gz
17 # Source0-md5:  eeff460742acdaa84ebbc7e7e5135981
18 URL:            http://www.povray.org/
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  libjpeg-devel
22 BuildRequires:  libpng-devel >= 1.4.0
23 BuildRequires:  libstdc++-devel
24 BuildRequires:  libtiff-devel
25 %{?with_pvm:BuildRequires:      pvm-devel >= 3.4.3-24}
26 %{?with_svga:BuildRequires:     svgalib-devel}
27 %{?with_x:BuildRequires:        xorg-lib-libX11-devel}
28 BuildRequires:  zlib-devel
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %if %{with pvm}
32 %define         _pvmarch        %(/usr/bin/pvmgetarch)
33 %define         _pvmroot        /usr/%{_lib}/pvm3
34 %endif
35
36 %description
37 The Persistence of Vision(tm) Ray-Tracer creates three-dimensional,
38 photo-realistic images using a rendering technique called ray-tracing.
39 It reads in a text file containing information describing the objects
40 and lighting in a scene and generates an image of that scene from the
41 view point of a camera also described in the text file. Ray-tracing is
42 not a fast process by any means, but it produces very high quality
43 images with realistic reflections, shading, perspective and other
44 effects.
45
46 %description -l pl.UTF-8
47 Persistence of Vision(tm) Ray-Tracer tworzy trójwymiarowe,
48 fotorealistyczne obrazy za pomocą techniki renderingu zwanej
49 ray-tracing. Program pobiera z pliku tekstowego informacje opisujące
50 obiekty oraz światło przedstawianego świata, a następnie generuje
51 rysunek z punktu widzenia kamery, która także jest definiowana w w/w
52 pliku tekstowym. Ray-tracing nie pozwala na szybkie tworzenie obrazów,
53 ale za to twórca otrzymuje wyskokiej jakości bitmapy z realistycznymi
54 efektami, tj. odbicia światła, cienie, perspektywa i inne.
55
56 %package X11
57 Summary:        X Window povray executable
58 Summary(pl.UTF-8):      povray pod X Window
59 Group:          Applications/Graphics
60 Requires:       %{name} = %{epoch}:%{version}-%{release}
61
62 %description X11
63 The Persistence of Vision(tm) Ray-Tracer X Window executable.
64
65 %description X11 -l pl.UTF-8
66 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla X
67 Window.
68
69 %package pvm
70 Summary:        PVM/Unix povray executable
71 Summary(pl.UTF-8):      Plik wykonywalny povray dla PVM/Unix
72 Group:          Applications/Graphics
73 Requires:       %{name} = %{epoch}:%{version}-%{release}
74
75 %description pvm
76 The Persistence of Vision(tm) Ray-Tracer PVM/Unix executable.
77
78 %description pvm -l pl.UTF-8
79 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla
80 PVM/Unix.
81
82 %package pvm-X11
83 Summary:        PVM/xwin povray executable
84 Summary(pl.UTF-8):      Plik wykonywalny povray dla PVM/xwin
85 Group:          Applications/Graphics
86 Requires:       %{name} = %{epoch}:%{version}-%{release}
87
88 %description pvm-X11
89 The Persistence of Vision(tm) Ray-Tracer PVM/xwin executable.
90
91 %description pvm-X11 -l pl.UTF-8
92 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla
93 PVM/xwin.
94
95 %prep
96 %setup -q -n %{name}-%{version}-%{beta}
97
98 %build
99 cd unix
100 ./prebuild.sh
101 cd ..
102
103 COMPILED_BY="PLD/Linux Team";export COMPILED_BY;
104 %if %{with x} && %{with pvm}
105 %configure \
106         --libdir=%{_datadir} \
107         --enable-pvm \
108         --with-pvm-arch=%{_pvmarch} \
109         --with-pvm-libs=%{_libdir}
110 %{__make}
111 install unix/povray x-pvmpov
112 %endif
113
114 %if %{with pvm}
115 %{__make} clean
116
117 %configure \
118         --libdir=%{_datadir} \
119         --enable-pvm \
120         --with-pvm-arch=%{_pvmarch} \
121         --with-pvm-libs=%{_libdir} \
122         --without-x
123 %{__make}
124 install unix/povray pvmpov
125 %endif
126
127 %if %{with x}
128 %configure \
129         --libdir=%{_datadir}
130 %{__make}
131 install unix/povray x-povray
132 %{__make} clean
133 %endif
134
135 %configure \
136         --libdir=%{_datadir} \
137         --without-x
138 %{__make}
139
140 %install
141 rm -rf $RPM_BUILD_ROOT
142 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_bindir},%{_datadir}}
143 %if %{with pvm}
144 install -d $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}
145 %endif
146
147 %{__make} install \
148         INSTALL="install -c -D" \
149         mkdir_p="mkdir -p" \
150         DESTDIR=$RPM_BUILD_ROOT
151
152 %if %{with x}
153 install x-povray $RPM_BUILD_ROOT%{_bindir}
154 %endif
155
156 %if %{with x} && %{with pvm}
157 install x-pvmpov $RPM_BUILD_ROOT%{_bindir}/x-pvmpov
158 ln -s %{_bindir}/x-pvmpov $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}/x-pvmpov
159 %endif
160
161 %if %{with pvm}
162 install pvmpov $RPM_BUILD_ROOT%{_bindir}/pvmpov
163 ln -s %{_bindir}/pvmpov $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}/pvmpov
164 %endif
165
166 ##install povray.ini $RPM_BUILD_ROOT%{_sysconfdir}
167 ##install povray.conf $RPM_BUILD_ROOT%{_sysconfdir}
168
169 %clean
170 rm -rf $RPM_BUILD_ROOT
171
172 %files
173 %defattr(644,root,root,755)
174 %doc AUTHORS ChangeLog NEWS README* changes.txt
175 %attr(755,root,root) %{_bindir}/povray
176 %{_datadir}/povray*
177 %{_docdir}/povray*
178 %{_mandir}/man?/*
179 %dir %{_sysconfdir}/povray
180 %dir %{_sysconfdir}/povray/3.7
181 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/3.7/povray.*
182 ## %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/povray.*
183
184 %if %{with x}
185 %files X11
186 %defattr(644,root,root,755)
187 %attr(755,root,root) %{_bindir}/x-povray
188 %endif
189
190 %if %{with pvm}
191 %files pvm
192 %defattr(644,root,root,755)
193 %attr(755,root,root) %{_pvmroot}/bin/%{_pvmarch}/pvmpov
194 %attr(755,root,root) %{_bindir}/pvmpov
195 %endif
196
197 %if %{with pvm} && %{with x}
198 %files pvm-X11
199 %defattr(644,root,root,755)
200 %attr(755,root,root) %{_pvmroot}/bin/%{_pvmarch}/x-pvmpov
201 %attr(755,root,root) %{_bindir}/x-pvmpov
202 %endif
This page took 0.077453 seconds and 3 git commands to generate.