]> git.pld-linux.org Git - packages/povray.git/blob - povray.spec
boost rebuild
[packages/povray.git] / povray.spec
1 #
2 # Conditional build:
3 %bcond_without  x       # - without X11 subpackage
4 %bcond_with     pvm     # - with PVM support
5 %bcond_with     svga    # - with svgalib support (doesn't work on many platforms)
6 #
7 %define subver  beta.2
8 %define rel     2
9 Summary:        Persistence of Vision Ray Tracer
10 Summary(pl.UTF-8):      Persistence of Vision Ray Tracer
11 Name:           povray
12 Version:        3.8.0
13 Release:        0.%{subver}.%{rel}
14 Epoch:          1
15 License:        AGPL v3+
16 Group:          Applications/Graphics
17 #Source0Download: https://github.com/POV-Ray/povray/releases
18 Source0:        https://github.com/POV-Ray/povray/archive/v%{version}-%{subver}/%{name}-%{version}-%{subver}.tar.gz
19 # Source0-md5:  f253c837495da02189723059236e9434
20 Patch1:         x32.patch
21 URL:            http://www.povray.org/
22 BuildRequires:  OpenEXR-devel >= 1.2
23 BuildRequires:  SDL-devel >= 1.2
24 BuildRequires:  autoconf >= 2.59
25 BuildRequires:  automake >= 1:1.9
26 BuildRequires:  boost-devel >= 1.38
27 BuildRequires:  libjpeg-devel >= 6b
28 BuildRequires:  libpng-devel >= 2:1.4.0
29 BuildRequires:  libstdc++-devel
30 BuildRequires:  libtiff-devel >= 3.6.1
31 BuildRequires:  perl-base
32 %{?with_pvm:BuildRequires:      pvm-devel >= 3.4.3-24}
33 %{?with_svga:BuildRequires:     svgalib-devel}
34 %{?with_x:BuildRequires:        xorg-lib-libX11-devel}
35 BuildRequires:  zlib-devel >= 1.2.1
36 Requires:       OpenEXR >= 1.2
37 Requires:       SDL >= 1.2
38 Requires:       libtiff >= 3.6.1
39 Requires:       zlib >= 1.2.1
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %if %{with pvm}
43 %define         _pvmarch        %(/usr/bin/pvmgetarch)
44 %define         _pvmroot        /usr/%{_lib}/pvm3
45 %endif
46
47 %define         specflags       -std=c++11
48
49 %description
50 The Persistence of Vision(tm) Ray-Tracer creates three-dimensional,
51 photo-realistic images using a rendering technique called ray-tracing.
52 It reads in a text file containing information describing the objects
53 and lighting in a scene and generates an image of that scene from the
54 view point of a camera also described in the text file. Ray-tracing is
55 not a fast process by any means, but it produces very high quality
56 images with realistic reflections, shading, perspective and other
57 effects.
58
59 %description -l pl.UTF-8
60 Persistence of Vision(tm) Ray-Tracer tworzy trójwymiarowe,
61 fotorealistyczne obrazy za pomocą techniki renderingu zwanej
62 ray-tracing. Program pobiera z pliku tekstowego informacje opisujące
63 obiekty oraz światło przedstawianego świata, a następnie generuje
64 rysunek z punktu widzenia kamery, która także jest definiowana w w/w
65 pliku tekstowym. Ray-tracing nie pozwala na szybkie tworzenie obrazów,
66 ale za to twórca otrzymuje wyskokiej jakości bitmapy z realistycznymi
67 efektami, tj. odbicia światła, cienie, perspektywa i inne.
68
69 %package X11
70 Summary:        X Window povray executable
71 Summary(pl.UTF-8):      povray pod X Window
72 Group:          Applications/Graphics
73 Requires:       %{name} = %{epoch}:%{version}-%{release}
74
75 %description X11
76 The Persistence of Vision(tm) Ray-Tracer X Window executable.
77
78 %description X11 -l pl.UTF-8
79 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla X
80 Window.
81
82 %package pvm
83 Summary:        PVM/Unix povray executable
84 Summary(pl.UTF-8):      Plik wykonywalny povray dla PVM/Unix
85 Group:          Applications/Graphics
86 Requires:       %{name} = %{epoch}:%{version}-%{release}
87
88 %description pvm
89 The Persistence of Vision(tm) Ray-Tracer PVM/Unix executable.
90
91 %description pvm -l pl.UTF-8
92 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla
93 PVM/Unix.
94
95 %package pvm-X11
96 Summary:        PVM/xwin povray executable
97 Summary(pl.UTF-8):      Plik wykonywalny povray dla PVM/xwin
98 Group:          Applications/Graphics
99 Requires:       %{name} = %{epoch}:%{version}-%{release}
100
101 %description pvm-X11
102 The Persistence of Vision(tm) Ray-Tracer PVM/xwin executable.
103
104 %description pvm-X11 -l pl.UTF-8
105 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla
106 PVM/xwin.
107
108 %prep
109 %setup -q -n %{name}-%{version}-%{subver}
110 %ifarch x32
111 %patch1 -p1
112 %endif
113
114 %build
115 cd unix
116 ./prebuild.sh
117 cd ..
118
119 COMPILED_BY="PLD/Linux Team";export COMPILED_BY;
120 # disable optimiz-arch, it means -march=native for gcc
121 %if %{with x} && %{with pvm}
122 %configure \
123         --libdir=%{_datadir} \
124         --disable-optimiz-arch \
125         --disable-strip \
126         --enable-pvm \
127         --with-pvm-arch=%{_pvmarch} \
128         --with-pvm-libs=%{_libdir}
129 %{__make}
130 install unix/povray x-pvmpov
131 %endif
132
133 %if %{with pvm}
134 %{__make} clean
135
136 %configure \
137         --libdir=%{_datadir} \
138         --disable-optimiz-arch \
139         --disable-strip \
140         --enable-pvm \
141         --with-pvm-arch=%{_pvmarch} \
142         --with-pvm-libs=%{_libdir} \
143         --without-x
144 %{__make}
145 install unix/povray pvmpov
146 %endif
147
148 %if %{with x}
149 %configure \
150         --libdir=%{_datadir} \
151         --disable-optimiz-arch \
152         --disable-strip
153 %{__make}
154 install unix/povray x-povray
155 %{__make} clean
156 %endif
157
158 %configure \
159         --libdir=%{_datadir} \
160         --disable-optimiz-arch \
161         --disable-strip \
162         --without-x
163 %{__make}
164
165 %install
166 rm -rf $RPM_BUILD_ROOT
167 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_bindir},%{_datadir}}
168 %if %{with pvm}
169 install -d $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}
170 %endif
171
172 %{__make} install \
173         INSTALL="install -c -D" \
174         mkdir_p="mkdir -p" \
175         DESTDIR=$RPM_BUILD_ROOT
176
177 %if %{with x}
178 install x-povray $RPM_BUILD_ROOT%{_bindir}
179 %endif
180
181 %if %{with x} && %{with pvm}
182 install x-pvmpov $RPM_BUILD_ROOT%{_bindir}/x-pvmpov
183 ln -s %{_bindir}/x-pvmpov $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}/x-pvmpov
184 %endif
185
186 %if %{with pvm}
187 install pvmpov $RPM_BUILD_ROOT%{_bindir}/pvmpov
188 ln -s %{_bindir}/pvmpov $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}/pvmpov
189 %endif
190
191 %clean
192 rm -rf $RPM_BUILD_ROOT
193
194 %files
195 %defattr(644,root,root,755)
196 %doc AUTHORS ChangeLog NEWS README* changes.txt
197 %attr(755,root,root) %{_bindir}/povray
198 %{_datadir}/povray*
199 %{_docdir}/povray*
200 %{_mandir}/man1/povray.1*
201 %dir %{_sysconfdir}/povray
202 %dir %{_sysconfdir}/povray/3.8
203 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/3.8/povray.conf
204 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/3.8/povray.ini
205
206 %if %{with x}
207 %files X11
208 %defattr(644,root,root,755)
209 %attr(755,root,root) %{_bindir}/x-povray
210 %endif
211
212 %if %{with pvm}
213 %files pvm
214 %defattr(644,root,root,755)
215 %attr(755,root,root) %{_pvmroot}/bin/%{_pvmarch}/pvmpov
216 %attr(755,root,root) %{_bindir}/pvmpov
217 %endif
218
219 %if %{with pvm} && %{with x}
220 %files pvm-X11
221 %defattr(644,root,root,755)
222 %attr(755,root,root) %{_pvmroot}/bin/%{_pvmarch}/x-pvmpov
223 %attr(755,root,root) %{_bindir}/x-pvmpov
224 %endif
This page took 0.03858 seconds and 3 git commands to generate.