]> git.pld-linux.org Git - packages/povray.git/blob - povray.spec
- up to 3.8.0-beta.2
[packages/povray.git] / povray.spec
1 #
2 # Conditional build:
3 %bcond_without  x       # - without X11 subpackage
4 %bcond_with     pvm     # - with PVM support
5 %bcond_with     svga    # - with svgalib support (doesn't work on many platforms)
6 #
7 %define subver  beta.2
8 %define rel     1
9 Summary:        Persistence of Vision Ray Tracer
10 Summary(pl.UTF-8):      Persistence of Vision Ray Tracer
11 Name:           povray
12 Version:        3.8.0
13 Release:        0.%{subver}.%{rel}
14 Epoch:          1
15 License:        AGPL v3+
16 Group:          Applications/Graphics
17 #Source0Download: https://github.com/POV-Ray/povray/releases
18 Source0:        https://github.com/POV-Ray/povray/archive/v%{version}-%{subver}/%{name}-%{version}-%{subver}.tar.gz
19 # Source0-md5:  f253c837495da02189723059236e9434
20 Patch1:         x32.patch
21 URL:            http://www.povray.org/
22 BuildRequires:  OpenEXR-devel >= 1.2
23 BuildRequires:  SDL-devel >= 1.2
24 BuildRequires:  autoconf >= 2.59
25 BuildRequires:  automake >= 1:1.9
26 BuildRequires:  boost-devel >= 1.38
27 BuildRequires:  libjpeg-devel >= 6b
28 BuildRequires:  libpng-devel >= 2:1.4.0
29 BuildRequires:  libstdc++-devel
30 BuildRequires:  libtiff-devel >= 3.6.1
31 BuildRequires:  perl-base
32 %{?with_pvm:BuildRequires:      pvm-devel >= 3.4.3-24}
33 %{?with_svga:BuildRequires:     svgalib-devel}
34 %{?with_x:BuildRequires:        xorg-lib-libX11-devel}
35 BuildRequires:  zlib-devel >= 1.2.1
36 Requires:       OpenEXR >= 1.2
37 Requires:       SDL >= 1.2
38 Requires:       libtiff >= 3.6.1
39 Requires:       zlib >= 1.2.1
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %if %{with pvm}
43 %define         _pvmarch        %(/usr/bin/pvmgetarch)
44 %define         _pvmroot        /usr/%{_lib}/pvm3
45 %endif
46
47 %description
48 The Persistence of Vision(tm) Ray-Tracer creates three-dimensional,
49 photo-realistic images using a rendering technique called ray-tracing.
50 It reads in a text file containing information describing the objects
51 and lighting in a scene and generates an image of that scene from the
52 view point of a camera also described in the text file. Ray-tracing is
53 not a fast process by any means, but it produces very high quality
54 images with realistic reflections, shading, perspective and other
55 effects.
56
57 %description -l pl.UTF-8
58 Persistence of Vision(tm) Ray-Tracer tworzy trójwymiarowe,
59 fotorealistyczne obrazy za pomocą techniki renderingu zwanej
60 ray-tracing. Program pobiera z pliku tekstowego informacje opisujące
61 obiekty oraz światło przedstawianego świata, a następnie generuje
62 rysunek z punktu widzenia kamery, która także jest definiowana w w/w
63 pliku tekstowym. Ray-tracing nie pozwala na szybkie tworzenie obrazów,
64 ale za to twórca otrzymuje wyskokiej jakości bitmapy z realistycznymi
65 efektami, tj. odbicia światła, cienie, perspektywa i inne.
66
67 %package X11
68 Summary:        X Window povray executable
69 Summary(pl.UTF-8):      povray pod X Window
70 Group:          Applications/Graphics
71 Requires:       %{name} = %{epoch}:%{version}-%{release}
72
73 %description X11
74 The Persistence of Vision(tm) Ray-Tracer X Window executable.
75
76 %description X11 -l pl.UTF-8
77 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla X
78 Window.
79
80 %package pvm
81 Summary:        PVM/Unix povray executable
82 Summary(pl.UTF-8):      Plik wykonywalny povray dla PVM/Unix
83 Group:          Applications/Graphics
84 Requires:       %{name} = %{epoch}:%{version}-%{release}
85
86 %description pvm
87 The Persistence of Vision(tm) Ray-Tracer PVM/Unix executable.
88
89 %description pvm -l pl.UTF-8
90 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla
91 PVM/Unix.
92
93 %package pvm-X11
94 Summary:        PVM/xwin povray executable
95 Summary(pl.UTF-8):      Plik wykonywalny povray dla PVM/xwin
96 Group:          Applications/Graphics
97 Requires:       %{name} = %{epoch}:%{version}-%{release}
98
99 %description pvm-X11
100 The Persistence of Vision(tm) Ray-Tracer PVM/xwin executable.
101
102 %description pvm-X11 -l pl.UTF-8
103 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla
104 PVM/xwin.
105
106 %prep
107 %setup -q -n %{name}-%{version}-%{subver}
108 %ifarch x32
109 %patch1 -p1
110 %endif
111
112 %build
113 cd unix
114 ./prebuild.sh
115 cd ..
116
117 COMPILED_BY="PLD/Linux Team";export COMPILED_BY;
118 # disable optimiz-arch, it means -march=native for gcc
119 %if %{with x} && %{with pvm}
120 %configure \
121         --libdir=%{_datadir} \
122         --disable-optimiz-arch \
123         --enable-pvm \
124         --with-pvm-arch=%{_pvmarch} \
125         --with-pvm-libs=%{_libdir}
126 %{__make}
127 install unix/povray x-pvmpov
128 %endif
129
130 %if %{with pvm}
131 %{__make} clean
132
133 %configure \
134         --libdir=%{_datadir} \
135         --disable-optimiz-arch \
136         --enable-pvm \
137         --with-pvm-arch=%{_pvmarch} \
138         --with-pvm-libs=%{_libdir} \
139         --without-x
140 %{__make}
141 install unix/povray pvmpov
142 %endif
143
144 %if %{with x}
145 %configure \
146         --libdir=%{_datadir} \
147         --disable-optimiz-arch
148 %{__make}
149 install unix/povray x-povray
150 %{__make} clean
151 %endif
152
153 %configure \
154         --libdir=%{_datadir} \
155         --disable-optimiz-arch \
156         --without-x
157 %{__make}
158
159 %install
160 rm -rf $RPM_BUILD_ROOT
161 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_bindir},%{_datadir}}
162 %if %{with pvm}
163 install -d $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}
164 %endif
165
166 %{__make} install \
167         INSTALL="install -c -D" \
168         mkdir_p="mkdir -p" \
169         DESTDIR=$RPM_BUILD_ROOT
170
171 %if %{with x}
172 install x-povray $RPM_BUILD_ROOT%{_bindir}
173 %endif
174
175 %if %{with x} && %{with pvm}
176 install x-pvmpov $RPM_BUILD_ROOT%{_bindir}/x-pvmpov
177 ln -s %{_bindir}/x-pvmpov $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}/x-pvmpov
178 %endif
179
180 %if %{with pvm}
181 install pvmpov $RPM_BUILD_ROOT%{_bindir}/pvmpov
182 ln -s %{_bindir}/pvmpov $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}/pvmpov
183 %endif
184
185 %clean
186 rm -rf $RPM_BUILD_ROOT
187
188 %files
189 %defattr(644,root,root,755)
190 %doc AUTHORS ChangeLog NEWS README* changes.txt
191 %attr(755,root,root) %{_bindir}/povray
192 %{_datadir}/povray*
193 %{_docdir}/povray*
194 %{_mandir}/man1/povray.1*
195 %dir %{_sysconfdir}/povray
196 %dir %{_sysconfdir}/povray/3.7
197 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/3.7/povray.conf
198 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/3.7/povray.ini
199
200 %if %{with x}
201 %files X11
202 %defattr(644,root,root,755)
203 %attr(755,root,root) %{_bindir}/x-povray
204 %endif
205
206 %if %{with pvm}
207 %files pvm
208 %defattr(644,root,root,755)
209 %attr(755,root,root) %{_pvmroot}/bin/%{_pvmarch}/pvmpov
210 %attr(755,root,root) %{_bindir}/pvmpov
211 %endif
212
213 %if %{with pvm} && %{with x}
214 %files pvm-X11
215 %defattr(644,root,root,755)
216 %attr(755,root,root) %{_pvmroot}/bin/%{_pvmarch}/x-pvmpov
217 %attr(755,root,root) %{_bindir}/x-pvmpov
218 %endif
This page took 0.151238 seconds and 3 git commands to generate.