]> git.pld-linux.org Git - packages/povray.git/blob - povray.spec
- fix building on x32
[packages/povray.git] / povray.spec
1 #
2 # Conditional build:
3 %bcond_without  x       # - without X11 subpackage
4 %bcond_with     pvm     # - with PVM support
5 %bcond_with     svga    # - with svgalib support (doesn't work on many platforms)
6 #
7 %define rel     2
8 %define beta    beta.5
9 Summary:        Persistence of Vision Ray Tracer
10 Summary(pl.UTF-8):      Persistence of Vision Ray Tracer
11 Name:           povray
12 Version:        3.7.1
13 Release:        0.%{beta}.%{rel}
14 Epoch:          1
15 License:        AGPLv3+
16 Group:          Applications/Graphics
17 Source0:        https://github.com/POV-Ray/povray/archive/v%{version}-%{beta}/%{name}-%{version}-%{beta}.tar.gz
18 # Source0-md5:  eeff460742acdaa84ebbc7e7e5135981
19 Patch0:         x32.patch
20 URL:            http://www.povray.org/
21 BuildRequires:  autoconf
22 BuildRequires:  automake
23 BuildRequires:  boost-devel
24 BuildRequires:  libjpeg-devel
25 BuildRequires:  libpng-devel >= 1.4.0
26 BuildRequires:  libstdc++-devel
27 BuildRequires:  libtiff-devel
28 %{?with_pvm:BuildRequires:      pvm-devel >= 3.4.3-24}
29 %{?with_svga:BuildRequires:     svgalib-devel}
30 %{?with_x:BuildRequires:        xorg-lib-libX11-devel}
31 BuildRequires:  zlib-devel
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %if %{with pvm}
35 %define         _pvmarch        %(/usr/bin/pvmgetarch)
36 %define         _pvmroot        /usr/%{_lib}/pvm3
37 %endif
38
39 %description
40 The Persistence of Vision(tm) Ray-Tracer creates three-dimensional,
41 photo-realistic images using a rendering technique called ray-tracing.
42 It reads in a text file containing information describing the objects
43 and lighting in a scene and generates an image of that scene from the
44 view point of a camera also described in the text file. Ray-tracing is
45 not a fast process by any means, but it produces very high quality
46 images with realistic reflections, shading, perspective and other
47 effects.
48
49 %description -l pl.UTF-8
50 Persistence of Vision(tm) Ray-Tracer tworzy trójwymiarowe,
51 fotorealistyczne obrazy za pomocą techniki renderingu zwanej
52 ray-tracing. Program pobiera z pliku tekstowego informacje opisujące
53 obiekty oraz światło przedstawianego świata, a następnie generuje
54 rysunek z punktu widzenia kamery, która także jest definiowana w w/w
55 pliku tekstowym. Ray-tracing nie pozwala na szybkie tworzenie obrazów,
56 ale za to twórca otrzymuje wyskokiej jakości bitmapy z realistycznymi
57 efektami, tj. odbicia światła, cienie, perspektywa i inne.
58
59 %package X11
60 Summary:        X Window povray executable
61 Summary(pl.UTF-8):      povray pod X Window
62 Group:          Applications/Graphics
63 Requires:       %{name} = %{epoch}:%{version}-%{release}
64
65 %description X11
66 The Persistence of Vision(tm) Ray-Tracer X Window executable.
67
68 %description X11 -l pl.UTF-8
69 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla X
70 Window.
71
72 %package pvm
73 Summary:        PVM/Unix povray executable
74 Summary(pl.UTF-8):      Plik wykonywalny povray dla PVM/Unix
75 Group:          Applications/Graphics
76 Requires:       %{name} = %{epoch}:%{version}-%{release}
77
78 %description pvm
79 The Persistence of Vision(tm) Ray-Tracer PVM/Unix executable.
80
81 %description pvm -l pl.UTF-8
82 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla
83 PVM/Unix.
84
85 %package pvm-X11
86 Summary:        PVM/xwin povray executable
87 Summary(pl.UTF-8):      Plik wykonywalny povray dla PVM/xwin
88 Group:          Applications/Graphics
89 Requires:       %{name} = %{epoch}:%{version}-%{release}
90
91 %description pvm-X11
92 The Persistence of Vision(tm) Ray-Tracer PVM/xwin executable.
93
94 %description pvm-X11 -l pl.UTF-8
95 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla
96 PVM/xwin.
97
98 %prep
99 %setup -q -n %{name}-%{version}-%{beta}
100 %ifarch x32
101 %patch0 -p1
102 %endif
103
104 %build
105 cd unix
106 ./prebuild.sh
107 cd ..
108
109 COMPILED_BY="PLD/Linux Team";export COMPILED_BY;
110 %if %{with x} && %{with pvm}
111 %configure \
112         --libdir=%{_datadir} \
113         --enable-pvm \
114         --with-pvm-arch=%{_pvmarch} \
115         --with-pvm-libs=%{_libdir}
116 %{__make}
117 install unix/povray x-pvmpov
118 %endif
119
120 %if %{with pvm}
121 %{__make} clean
122
123 %configure \
124         --libdir=%{_datadir} \
125         --enable-pvm \
126         --with-pvm-arch=%{_pvmarch} \
127         --with-pvm-libs=%{_libdir} \
128         --without-x
129 %{__make}
130 install unix/povray pvmpov
131 %endif
132
133 %if %{with x}
134 %configure \
135         --libdir=%{_datadir}
136 %{__make}
137 install unix/povray x-povray
138 %{__make} clean
139 %endif
140
141 %configure \
142         --libdir=%{_datadir} \
143         --without-x
144 %{__make}
145
146 %install
147 rm -rf $RPM_BUILD_ROOT
148 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_bindir},%{_datadir}}
149 %if %{with pvm}
150 install -d $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}
151 %endif
152
153 %{__make} install \
154         INSTALL="install -c -D" \
155         mkdir_p="mkdir -p" \
156         DESTDIR=$RPM_BUILD_ROOT
157
158 %if %{with x}
159 install x-povray $RPM_BUILD_ROOT%{_bindir}
160 %endif
161
162 %if %{with x} && %{with pvm}
163 install x-pvmpov $RPM_BUILD_ROOT%{_bindir}/x-pvmpov
164 ln -s %{_bindir}/x-pvmpov $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}/x-pvmpov
165 %endif
166
167 %if %{with pvm}
168 install pvmpov $RPM_BUILD_ROOT%{_bindir}/pvmpov
169 ln -s %{_bindir}/pvmpov $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}/pvmpov
170 %endif
171
172 ##install povray.ini $RPM_BUILD_ROOT%{_sysconfdir}
173 ##install povray.conf $RPM_BUILD_ROOT%{_sysconfdir}
174
175 %clean
176 rm -rf $RPM_BUILD_ROOT
177
178 %files
179 %defattr(644,root,root,755)
180 %doc AUTHORS ChangeLog NEWS README* changes.txt
181 %attr(755,root,root) %{_bindir}/povray
182 %{_datadir}/povray*
183 %{_docdir}/povray*
184 %{_mandir}/man?/*
185 %dir %{_sysconfdir}/povray
186 %dir %{_sysconfdir}/povray/3.7
187 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/3.7/povray.*
188 ## %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/povray.*
189
190 %if %{with x}
191 %files X11
192 %defattr(644,root,root,755)
193 %attr(755,root,root) %{_bindir}/x-povray
194 %endif
195
196 %if %{with pvm}
197 %files pvm
198 %defattr(644,root,root,755)
199 %attr(755,root,root) %{_pvmroot}/bin/%{_pvmarch}/pvmpov
200 %attr(755,root,root) %{_bindir}/pvmpov
201 %endif
202
203 %if %{with pvm} && %{with x}
204 %files pvm-X11
205 %defattr(644,root,root,755)
206 %attr(755,root,root) %{_pvmroot}/bin/%{_pvmarch}/x-pvmpov
207 %attr(755,root,root) %{_bindir}/x-pvmpov
208 %endif
This page took 0.513577 seconds and 3 git commands to generate.