]> git.pld-linux.org Git - packages/postfix.git/blob - postfix.spec
icu rebuild
[packages/postfix.git] / postfix.spec
1 #
2 # Conditional build:
3 %bcond_without  ldap    # LDAP map module
4 %bcond_without  mysql   # MySQL map module
5 %bcond_without  pgsql   # PostgreSQL map module
6 %bcond_without  sqlite  # SQLite map module
7 %bcond_without  sasl    # SMTP AUTH support
8 %bcond_without  ssl     # SSL/TLS support
9 %bcond_without  cdb     # cdb map support
10 %bcond_without  lmdb    # lmdb map support
11 %bcond_with     vda     # VDA patch
12 %bcond_with     hir     # Beeth's header_if_reject patch
13 %bcond_with     tcp     # unofficial tcp: lookup table
14 %if "%{pld_release}" == "ac"
15 %bcond_with     epoll   # epoll support for 2.6 kernels
16 # there didn't exist x86_64 2.4 kernel in PLD, so can safely enable epoll
17 %ifarch %{x8664}
18 %define         with_epoll      1
19 %endif
20 %else
21 %bcond_without  epoll   # epoll support (Linux >= 2.6)
22 %endif
23
24 %define         vda_ver v13-2.10.0
25 Summary:        Postfix Mail Transport Agent
26 Summary(cs.UTF-8):      Postfix - program pro přepravu pošty (MTA)
27 Summary(es.UTF-8):      Postfix - Un MTA (Mail Transport Agent) de alto desempeño
28 Summary(fr.UTF-8):      Agent de transport de courrier Postfix
29 Summary(pl.UTF-8):      Serwer SMTP Postfix
30 Summary(pt_BR.UTF-8):   Postfix - Um MTA (Mail Transport Agent) de alto desempenho
31 Summary(sk.UTF-8):      Agent prenosu pošty Postfix
32 Name:           postfix
33 Version:        3.6.2
34 Release:        2
35 Epoch:          2
36 License:        IBM Public License or Eclipse Public License v2.0
37 Group:          Networking/Daemons/SMTP
38 Source0:        ftp://ftp.porcupine.org/mirrors/postfix-release/official/%{name}-%{version}.tar.gz
39 # Source0-md5:  4718b498fa4285cf275f506c169f4746
40 Source1:        %{name}.aliases
41 Source2:        %{name}.cron
42 Source3:        %{name}.init
43 Source4:        %{name}.sysconfig
44 Source5:        %{name}.sasl
45 Source6:        %{name}.pamd
46 Source7:        %{name}-vda.patch
47 #Source7:       http://vda.sourceforge.net/VDA/%{name}-vda-%{vda_ver}.patch
48 # -ource7-md5:  01e1b031d79b85f3cb67d98ceddd775d
49 Source8:        %{name}-bounce.cf.pl
50 # http://postfix.state-of-mind.de/bounce-templates/bounce.de-DE.cf
51 Source9:        %{name}-bounce.cf.de
52 Source10:       %{name}.monitrc
53 Source11:       %{name}-vda-bigquota.patch
54 #Source11:      http://vda.sourceforge.net/VDA/%{name}-%{vda_ver}-vda-ng-bigquota.patch.gz
55 # -ource11-md5: d46103195b43ec5784ea2c166b238f71
56 Source12:       %{name}.service
57 Patch0:         %{name}-config.patch
58
59 Patch3:         %{name}-master.cf_cyrus.patch
60 # from http://akson.sgh.waw.pl/~chopin/unix/postfix-2.1.5-header_if_reject.diff
61 Patch4:         %{name}-header_if_reject.patch
62
63 Patch7:         %{name}-conf.patch
64 Patch8:         %{name}-dictname.patch
65
66 Patch11:        %{name}-scache_clnt.patch
67 Patch12:        format-security.patch
68 Patch13:        glibc-2.34.patch
69 URL:            http://www.postfix.org/
70 %{?with_sasl:BuildRequires:     cyrus-sasl-devel}
71 BuildRequires:  db-devel
72 # getifaddrs() with IPv6 support
73 BuildRequires:  glibc-devel >= 6:2.3.4
74 BuildRequires:  libicu-devel
75 BuildRequires:  libnsl-devel
76 %{?with_lmbd:BuildRequires:     lmdb-devel}
77 %{?with_mysql:BuildRequires:    mysql-devel}
78 %{?with_ldap:BuildRequires:     openldap-devel >= 2.0.12}
79 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.7l}
80 BuildRequires:  pcre-devel
81 BuildRequires:  perl-base
82 %{?with_pgsql:BuildRequires:    postgresql-devel}
83 BuildRequires:  rpm >= 4.4.9-56
84 BuildRequires:  rpmbuild(macros) >= 1.644
85 BuildRequires:  sed >= 4.0
86 %{?with_sqlite:BuildRequires:   sqlite3-devel}
87 %{?with_cdb:BuildRequires:      tinycdb-devel}
88 %{?with_mysql:BuildRequires:    zlib-devel}
89 Requires(post): /bin/hostname
90 Requires(post,postun):  /sbin/ldconfig
91 Requires(post,preun):   /sbin/chkconfig
92 Requires(postun):       /usr/sbin/groupdel
93 Requires(postun):       /usr/sbin/userdel
94 Requires(pre):  /bin/id
95 Requires(pre):  /usr/bin/getgid
96 Requires(pre):  /usr/sbin/groupadd
97 Requires(pre):  /usr/sbin/useradd
98 Requires:       /sbin/chkconfig
99 Requires:       diffutils
100 Requires:       findutils
101 Requires:       rc-scripts
102 Requires:       sed
103 %{?with_cdb:Requires:tinycdb}
104 Requires:       systemd-units >= 38
105 Suggests:       cyrus-sasl-saslauthd
106 Provides:       group(postfix)
107 Provides:       smtpdaemon
108 Provides:       user(postfix)
109 Obsoletes:      smtpdaemon
110 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
111
112 %description
113 Postfix is attempt to provide an alternative to the widely-used
114 Sendmail program. Postfix attempts to be fast, easy to administer, and
115 hopefully secure, while at the same time being sendmail compatible
116 enough to not upset your users. This version has IPv6 support.
117
118 %description -l es.UTF-8
119 Postfix es una alternativa para el mundialmente utilizado sendmail. Si
120 desea tener un servidor SMTP *rápido*, debe instalar este paquete.
121
122 %description -l fr.UTF-8
123 Postfix (voir http://www.postfix.org/) se veut une alternative à
124 sendmail, responsable de l'acheminement de 70% des courriers
125 électroniques sur Internet. IBM en a suppotré le développement, mais
126 ne contrôle pas son évolution. Le but est d'installer Postfix sur le
127 plus grand nombre de systèmes possible. Dans cette optique, il a été
128 écrit pour être totalement sous le contrôle de l'utilisateur.
129
130 %description -l it.UTF-8
131 Postfix (http://www.postfix.org/) e' un'alternativa al programma
132 sendmail utilizzato per la gestione del 70 per cento della posta
133 Internet.
134
135 Seppur IBM supporti lo sviluppo di Postfix, non controlla la sua
136 evoluzione.
137
138 Consultate la pagine web http://www.moongroup.com/how-to.phtml nella
139 quale troverete le indicazioni per una corretta installazione e
140 configurazione di questo programma.
141
142 %description -l pl.UTF-8
143 Postfix jest próbą dostarczenia alternatywnego MTA w stosunku do
144 szeroko używanego sendmaila. Postfix w zamierzeniu ma być szybki,
145 łatwy w administrowaniu, bezpieczny oraz ma być na tyle kompatybilny z
146 sendmailem by nie denerwować użytkowników. Ta wersja obsługuje IPv6.
147
148 %description -l pt_BR.UTF-8
149 O Postfix é uma alternativa para o mundialmente utilizado sendmail. Se
150 você deseja um servidor SMTP *rápido*, instale este pacote.
151
152 %description -l sk.UTF-8
153 Postfix (pozri http://www.postfix.org/) má za cieľ byť alternatívou k
154 široko rozšírenému programu sendmail, zodpovednému za 70% všetkej
155 elektronickej pošty doručenej na Internete.
156
157 Aj keď IBM podporovala vývoj Postfixu, zdržiava sa vplyvu na jeho
158 vývoj. Cieľom je inštalácia Postfixu na čo najväčšom počte systémov.
159 Do tohoto momentu je softvér poskytovaný bez ovplyvňovania, takže sa
160 môže vyvíjať podľa jeho používateľov.
161
162 Určite si prečítajte http://www.moongroup.com/how-to.phtml, kde sú
163 popísané kroky potrebné pred a po inštalácii Postfixu.
164
165 %package devel
166 Summary:        Postfix loadable modules development package
167 Summary(pl.UTF-8):      Pakiet dla programistów ładowanych modułów do postfiksa
168 Group:          Development/Libraries
169 Requires:       %{name} = %{epoch}:%{version}-%{release}
170
171 %description devel
172 Header files to build additional map types for Postfix.
173
174 %description devel -l pl.UTF-8
175 Pliki nagłówkowe do tworzenia dodatkowych typów map dla Postfiksa.
176
177 %package dict-ldap
178 Summary:        LDAP map support for Postfix
179 Summary(pl.UTF-8):      Obsługa map LDAP dla Postfiksa
180 Group:          Networking/Daemons/SMTP
181 Requires:       %{name} = %{epoch}:%{version}-%{release}
182 Requires:       openldap >= 2.3.6
183
184 %description dict-ldap
185 This package provides support for LDAP maps in Postfix.
186
187 %description dict-ldap -l pl.UTF-8
188 Ten pakiet dodaje obsługę map LDAP do Postfiksa.
189
190 %package dict-mysql
191 Summary:        MySQL map support for Postfix
192 Summary(pl.UTF-8):      Obsługa map MySQL dla Postfiksa
193 Group:          Networking/Daemons/SMTP
194 Requires:       %{name} = %{epoch}:%{version}-%{release}
195
196 %description dict-mysql
197 This package provides support for MySQL maps in Postfix.
198
199 %description dict-mysql -l pl.UTF-8
200 Ten pakiet dodaje obsługę map MySQL do Postfiksa.
201
202 %package dict-pcre
203 Summary:        PCRE map support for Postfix
204 Summary(pl.UTF-8):      Obsługa map PCRE dla Postfiksa
205 Group:          Networking/Daemons/SMTP
206 Requires:       %{name} = %{epoch}:%{version}-%{release}
207
208 %description dict-pcre
209 This package provides support for PCRE maps in Postfix.
210
211 %description dict-pcre -l pl.UTF-8
212 Ten pakiet dodaje obsługę map PCRE do Postfiksa.
213
214 %package dict-pgsql
215 Summary:        PostgreSQL map support for Postfix
216 Summary(pl.UTF-8):      Obsługa map PostgreSQL dla Postfiksa
217 Group:          Networking/Daemons/SMTP
218 Requires:       %{name} = %{epoch}:%{version}-%{release}
219
220 %description dict-pgsql
221 This package provides support for PostgreSQL maps in Postfix.
222
223 %description dict-pgsql -l pl.UTF-8
224 Ten pakiet dodaje obsługę map PostgreSQL do Postfiksa.
225
226 %package dict-sqlite
227 Summary:        SQLite map support for Postfix
228 Summary(pl.UTF-8):      Obsługa map SQLite dla Postfiksa
229 Group:          Networking/Daemons/SMTP
230 Requires:       %{name} = %{epoch}:%{version}-%{release}
231
232 %description dict-sqlite
233 This package provides support for SQLite maps in Postfix.
234
235 %description dict-sqlite -l pl.UTF-8
236 Ten pakiet dodaje obsługę map SQLite do Postfiksa.
237
238 %package dict-lmdb
239 Summary:        LMDB map support for Postfix
240 Summary(pl.UTF-8):      Obsługa map LMDB dla Postfiksa
241 Group:          Networking/Daemons/SMTP
242 Requires:       %{name} = %{epoch}:%{version}-%{release}
243
244 %description dict-lmdb
245 This package provides support for LMDB maps in Postfix.
246
247 %description dict-lmdb -l pl.UTF-8
248 Ten pakiet dodaje obsługę map LMDB do Postfiksa.
249
250 %package dict-cdb
251 Summary:        CDB map support for Postfix
252 Summary(pl.UTF-8):      Obsługa map CDB dla Postfiksa
253 Group:          Networking/Daemons/SMTP
254 Requires:       %{name} = %{epoch}:%{version}-%{release}
255
256 %description dict-cdb
257 This package provides support for CDB maps in Postfix.
258
259 %description dict-cdb -l pl.UTF-8
260 Ten pakiet dodaje obsługę map CDB do Postfiksa.
261
262 %package qshape
263 Summary:        qshape - Print Postfix queue domain and age distribution
264 Summary(pl.UTF-8):      qshape - wypisywanie rozkładu domen i wieku z kolejki Postfiksa
265 Group:          Networking/Daemons/SMTP
266 Requires:       %{name} = %{epoch}:%{version}-%{release}
267
268 %description qshape
269 The qshape program helps the administrator understand the Postfix
270 queue message distribution in time and by sender domain or recipient
271 domain. The program needs read access to the queue directories and
272 queue files, so it must run as the superuser or the mail_owner
273 specified in main.cf (typically postfix).
274
275 %description qshape -l pl.UTF-8
276 Program qshape pomaga administratorowi zrozumieć rozkład kolejki
277 wiadomości Postfiksa w czasie i w zależności od domeny nadawcy lub
278 adresata. Program wymaga prawa odczytu do katalogów kolejki i plików
279 kolejki, więc musi być uruchamiany przez superużytkownika lub
280 użytkownika mail_owner podanego w main.cf (zwykle nazywającego się
281 postfix).
282
283 %package -n monit-rc-%{name}
284 Summary:        monit support for Postfix
285 Summary(pl.UTF-8):      Wsparcie monita dla Postfiksa
286 Group:          Applications/System
287 Requires:       %{name} = %{epoch}:%{version}-%{release}
288 Requires:       monit
289
290 %description -n monit-rc-%{name}
291 monitrc file for monitoring Postfix.
292
293 %description -n monit-rc-%{name} -l pl.UTF-8
294 Plik monitrc do monitorowania serwera Postfix.
295
296 %prep
297 %setup -q
298 %if %{with vda}
299 cat %{SOURCE7} | %{__patch} -p1 -s
300 cat %{SOURCE11} | %{__patch} -p1 -s
301 %endif
302
303 find -type f | xargs %{__sed} -i -e 's|/etc/postfix|/etc/mail|g'
304
305 %patch0 -p1
306
307 %patch3 -p1
308 %{?with_hir:%patch4 -p0}
309
310 %{__sed} -i -e '/scache_clnt_create/s/server/var_scache_service/' src/global/scache_clnt.c
311 %patch7 -p1
312 %patch8 -p1
313
314 %patch11 -p1
315 %if %{with vda}
316 %patch12 -p1
317 %endif
318 %patch13 -p1
319
320 %if %{with tcp}
321 sed -i 's/ifdef SNAPSHOT/if 1/' src/util/dict_open.c
322 %endif
323
324 %{__sed} -i -e 's,/lib64\>,/%{_lib},' makedefs
325
326 %build
327 # export, as the same variables must be passed both to 'make makefiles' and 'make'
328 export CCARGS="%{!?with_epoll:-DNO_EPOLL} %{?with_ldap:-DHAS_LDAP} -DHAS_PCRE %{?with_sasl:-DUSE_SASL_AUTH -DUSE_CYRUS_SASL -I/usr/include/sasl} %{?with_mysql:-DHAS_MYSQL -I/usr/include/mysql} %{?with_pgsql:-DHAS_PGSQL} %{?with_ssl:-DUSE_TLS} -DMAX_DYNAMIC_MAPS %{?with_cdb:-DHAS_CDB} %{?with_sqlite:-DHAS_SQLITE} %{?with_lmdb:-DHAS_LMDB} -LHAS_SDBM"
329 export AUXLIBS="%{rpmldflags} -lsasl -lssl -lcrypto"
330 export AUXLIBS_CDB="%{?with_cdb:-lcdb}"
331 export AUXLIBS_LDAP="%{?with_ldap:-lldap -llber}"
332 export AUXLIBS_LMDB="%{?with_lmdb:-llmdb}"
333 export AUXLIBS_MYSQL="%{?with_mysql:-lmysqlclient}"
334 export AUXLIBS_PCRE="-lpcre"
335 export AUXLIBS_PGSQL="%{?with_pgsql:-lpq}"
336 export AUXLIBS_SQLITE="%{?with_sqlite:-lsqlite3}"
337
338 export CC="%{__cc}"
339 %{__make} makefiles \
340         shared=yes \
341         dynamicmaps=yes \
342         daemon_directory="%{_libdir}/postfix" \
343         shlib_directory="%{_libdir}/postfix" \
344         manpage_directory="%{_mandir}"
345
346 %{__make} -j1 \
347         DEBUG="" \
348         OPT="%{rpmcflags} %{rpmcppflags} -D_FILE_OFFSET_BITS=64"
349
350 %install
351 rm -rf $RPM_BUILD_ROOT
352 install -d $RPM_BUILD_ROOT/etc/{cron.daily,rc.d/init.d,sysconfig,pam.d,security,monit} \
353         $RPM_BUILD_ROOT%{_sysconfdir}/{mail,sasl} \
354         $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_libdir}/postfix,/usr/lib}\
355         $RPM_BUILD_ROOT{%{_includedir}/postfix,%{_mandir}} \
356         $RPM_BUILD_ROOT%{_var}/spool/postfix/{active,corrupt,deferred,maildrop,private,saved,bounce,defer,incoming,pid,public} \
357         $RPM_BUILD_ROOT%{_var}/lib/postfix \
358         $RPM_BUILD_ROOT%{systemdunitdir}
359
360 %{__make} non-interactive-package \
361        install_root=$RPM_BUILD_ROOT
362
363 #cp -a conf/* $RPM_BUILD_ROOT%{_sysconfdir}/mail
364 sed -e's,^daemon_directory = .*,daemon_directory = %{_libdir}/postfix,' \
365         conf/main.cf > $RPM_BUILD_ROOT%{_sysconfdir}/mail/main.cf
366
367 cp -a include/*.h $RPM_BUILD_ROOT%{_includedir}/postfix
368
369 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/mail/aliases
370 install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.daily/postfix
371 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/postfix
372 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/postfix
373 cp -a %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/sasl/smtpd.conf
374 cp -a %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/smtp
375 cp -a %{SOURCE8} $RPM_BUILD_ROOT%{_sysconfdir}/mail/bounce.cf.pl
376 cp -a %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/mail/bounce.cf.de
377 cp -a %{SOURCE10} $RPM_BUILD_ROOT/etc/monit/%{name}.monitrc
378 cp -a %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/%{name}.service
379 install -p auxiliary/rmail/rmail $RPM_BUILD_ROOT%{_bindir}/rmail
380 install -p auxiliary/qshape/qshape.pl $RPM_BUILD_ROOT%{_bindir}/qshape
381
382 ln -sf %{_sbindir}/sendmail $RPM_BUILD_ROOT%{_bindir}/mailq
383 ln -sf %{_sbindir}/sendmail $RPM_BUILD_ROOT%{_bindir}/newaliases
384 ln -sf %{_sbindir}/sendmail $RPM_BUILD_ROOT/usr/lib/sendmail
385
386 touch $RPM_BUILD_ROOT%{_sysconfdir}/mail/\
387         {aliases,access,canonical,relocated,transport,virtual}{,.db}
388
389 touch $RPM_BUILD_ROOT/etc/security/blacklist.smtp
390
391 > $RPM_BUILD_ROOT/var/spool/postfix/.nofinger
392
393 %{__rm} -r $RPM_BUILD_ROOT%{_sysconfdir}/mail/makedefs.out
394 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/mail/{,TLS_}LICENSE
395
396 %clean
397 rm -rf $RPM_BUILD_ROOT
398
399 %pre
400 %groupadd -g 62 postfix
401 %groupadd -g 63 maildrop
402 %useradd -u 62 -d /var/spool/postfix -s /bin/false -c "Postfix User" -g postfix postfix
403
404 %post
405 /sbin/ldconfig
406 if ! grep -q "^postmaster:" %{_sysconfdir}/mail/aliases; then
407         echo "Adding Entry for postmaster in %{_sysconfdir}/mail/aliases" >&2
408         echo "postmaster: root" >>%{_sysconfdir}/mail/aliases
409 fi
410 if [ "$1" = "1" ]; then
411         # only on installation, not upgrade; set sane defaults
412         # postfix expects gethostname() to return FQDN, which is obviously wrong
413         if ! grep -qE "^my(domain|hostname)" %{_sysconfdir}/mail/main.cf; then
414                 domain=$(/bin/hostname -d 2>/dev/null)
415                 [ -n "$domain" -a "$domain" != 'localdomain' ] && \
416                         postconf -e mydomain="$domain"
417         fi
418 else
419         %{_sbindir}/postfix upgrade-configuration
420 fi
421
422 %{_bindir}/newaliases
423 /sbin/chkconfig --add postfix
424 %service postfix restart "Postfix Daemon"
425 %systemd_post postfix.service
426
427 %preun
428 if [ "$1" = "0" ]; then
429         %service postfix stop
430         /sbin/chkconfig --del postfix
431 fi
432 %systemd_preun postfix.service
433
434 %postun
435 /sbin/ldconfig
436 if [ "$1" = "0" ]; then
437         %groupremove maildrop
438         %userremove postfix
439         %groupremove postfix
440 fi
441 %systemd_reload
442
443 %triggerpostun -- postfix < 2:2.9.4-4
444 %systemd_trigger postfix.service
445
446 %files
447 %defattr(644,root,root,755)
448 %doc html COMPATIBILITY HISTORY LICENSE RELEASE_NOTES* TLS_*
449 %doc README_FILES/*README
450 %doc examples/smtpd-policy
451 %dir %{_sysconfdir}/mail
452 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/access
453 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/aliases
454 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/bounce.cf.default
455 %lang(de) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/bounce.cf.de
456 %lang(pl) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/bounce.cf.pl
457 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/canonical
458 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/generic
459 #%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/regexp_table
460 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/relocated
461 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/transport
462 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/virtual
463 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/header_checks
464 #%ghost %{_sysconfdir}/mail/*.db
465 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/dynamicmaps.cf
466 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/main.cf
467 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/main.cf.default
468 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/main.cf.proto
469 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/master.cf
470 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/master.cf.proto
471 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/postfix-files
472 %attr(740,root,root) /etc/cron.daily/postfix
473 %attr(754,root,root) /etc/rc.d/init.d/postfix
474 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/postfix
475 %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/smtp
476 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.smtp
477 %{?with_sasl:%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sasl/smtpd.conf}
478 %attr(755,root,root) %{_bindir}/mailq
479 %attr(755,root,root) %{_bindir}/newaliases
480 %attr(755,root,root) %{_bindir}/rmail
481 %attr(755,root,root) %{_sbindir}/s*
482 %attr(755,root,root) %{_sbindir}/postfix
483 %attr(755,root,root) %{_sbindir}/postalias
484 %attr(755,root,root) %{_sbindir}/postkick
485 %attr(755,root,root) %{_sbindir}/postl*
486 %attr(755,root,root) %{_sbindir}/postc*
487 %attr(755,root,root) %{_sbindir}/postmap
488 %attr(755,root,root) %{_sbindir}/postmulti
489 %attr(2755,root,maildrop) %{_sbindir}/postqueue
490 %attr(755,root,root) %{_sbindir}/postsuper
491 %attr(2755,root,maildrop) %{_sbindir}/postdrop
492 %attr(755,root,root) /usr/lib/sendmail
493 %dir %{_libdir}/postfix
494 %attr(755,root,root) %{_libdir}/postfix/anvil
495 %attr(755,root,root) %{_libdir}/postfix/bounce
496 %attr(755,root,root) %{_libdir}/postfix/cleanup
497 %attr(755,root,root) %{_libdir}/postfix/discard
498 %attr(755,root,root) %{_libdir}/postfix/dnsblog
499 %attr(755,root,root) %{_libdir}/postfix/error
500 %attr(755,root,root) %{_libdir}/postfix/flush
501 %attr(755,root,root) %{_libdir}/postfix/libpostfix-dns.so
502 %attr(755,root,root) %{_libdir}/postfix/libpostfix-global.so
503 %attr(755,root,root) %{_libdir}/postfix/libpostfix-master.so
504 %attr(755,root,root) %{_libdir}/postfix/libpostfix-tls.so
505 %attr(755,root,root) %{_libdir}/postfix/libpostfix-util.so
506 %attr(755,root,root) %{_libdir}/postfix/lmtp
507 %attr(755,root,root) %{_libdir}/postfix/local
508 %attr(755,root,root) %{_libdir}/postfix/master
509 %attr(755,root,root) %{_libdir}/postfix/nqmgr
510 %attr(755,root,root) %{_libdir}/postfix/oqmgr
511 %attr(755,root,root) %{_libdir}/postfix/pickup
512 %attr(755,root,root) %{_libdir}/postfix/pipe
513 %attr(755,root,root) %{_libdir}/postfix/postfix-script
514 %attr(755,root,root) %{_libdir}/postfix/postfix-tls-script
515 %attr(755,root,root) %{_libdir}/postfix/postlogd
516 %attr(755,root,root) %{_libdir}/postfix/postfix-wrapper
517 %attr(755,root,root) %{_libdir}/postfix/post-install
518 %attr(755,root,root) %{_libdir}/postfix/postmulti-script
519 %attr(755,root,root) %{_libdir}/postfix/postscreen
520 %attr(755,root,root) %{_libdir}/postfix/proxymap
521 %attr(755,root,root) %{_libdir}/postfix/qmgr
522 %attr(755,root,root) %{_libdir}/postfix/qmqpd
523 %attr(755,root,root) %{_libdir}/postfix/scache
524 %attr(755,root,root) %{_libdir}/postfix/showq
525 %attr(755,root,root) %{_libdir}/postfix/smtp
526 %attr(755,root,root) %{_libdir}/postfix/smtpd
527 %attr(755,root,root) %{_libdir}/postfix/spawn
528 %attr(755,root,root) %{_libdir}/postfix/tlsmgr
529 %attr(755,root,root) %{_libdir}/postfix/tlsproxy
530 %attr(755,root,root) %{_libdir}/postfix/trivial-rewrite
531 %attr(755,root,root) %{_libdir}/postfix/verify
532 %attr(755,root,root) %{_libdir}/postfix/virtual
533 %attr(755,root,root) %dir %{_var}/spool/postfix
534 %attr(700,postfix,root) %dir %{_var}/spool/postfix/active
535 %attr(700,postfix,root) %dir %{_var}/spool/postfix/bounce
536 %attr(700,postfix,root) %dir %{_var}/spool/postfix/corrupt
537 %attr(700,postfix,root) %dir %{_var}/spool/postfix/defer
538 %attr(700,postfix,root) %dir %{_var}/spool/postfix/deferred
539 %attr(700,postfix,root) %dir %{_var}/spool/postfix/incoming
540 %attr(1730,postfix,maildrop) %dir %{_var}/spool/postfix/maildrop
541 %attr(755,root,root) %dir %{_var}/spool/postfix/pid
542 %attr(700,postfix,root) %dir %{_var}/spool/postfix/private
543 %attr(710,postfix,maildrop) %dir %{_var}/spool/postfix/public
544 %attr(700,postfix,root) %dir %{_var}/spool/postfix/saved
545 %attr(644,postfix,root) %{_var}/spool/postfix/.nofinger
546 %attr(700,postfix,root) %{_var}/lib/postfix
547 %{_mandir}/man1/mailq.1*
548 %{_mandir}/man1/newaliases.1*
549 %{_mandir}/man1/post*.1*
550 %{_mandir}/man1/sendmail.1*
551 %{_mandir}/man5/access.5*
552 %{_mandir}/man5/aliases.5*
553 %{_mandir}/man5/body_checks.5*
554 %{_mandir}/man5/bounce.5*
555 %{_mandir}/man5/canonical.5*
556 %{_mandir}/man5/cidr_table.5*
557 %{_mandir}/man5/generic.5*
558 %{_mandir}/man5/header_checks.5*
559 %{_mandir}/man5/master.5*
560 %{_mandir}/man5/memcache_table.5*
561 %{_mandir}/man5/nisplus_table.5*
562 %{_mandir}/man5/postconf.5*
563 %{_mandir}/man5/postfix-wrapper.5*
564 %{_mandir}/man5/regexp_table.5*
565 %{_mandir}/man5/relocated.5*
566 %{_mandir}/man5/socketmap_table.5*
567 %{_mandir}/man5/tcp_table.5*
568 %{_mandir}/man5/transport.5*
569 %{_mandir}/man5/virtual.5*
570 %{_mandir}/man8/*.8*
571 %{systemdunitdir}/%{name}.service
572
573 %files devel
574 %defattr(644,root,root,755)
575 %{_includedir}/postfix
576
577 %if %{with ldap}
578 %files dict-ldap
579 %defattr(644,root,root,755)
580 %attr(755,root,root) %{_libdir}/postfix/postfix-ldap.so
581 %{_mandir}/man5/ldap_table.5*
582 %endif
583
584 %if %{with mysql}
585 %files dict-mysql
586 %defattr(644,root,root,755)
587 %attr(755,root,root) %{_libdir}/postfix/postfix-mysql.so
588 %{_mandir}/man5/mysql_table.5*
589 %endif
590
591 %files dict-pcre
592 %defattr(644,root,root,755)
593 %attr(755,root,root) %{_libdir}/postfix/postfix-pcre.so
594 #%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/pcre_table
595 %{_mandir}/man5/pcre_table.5*
596
597 %if %{with pgsql}
598 %files dict-pgsql
599 %defattr(644,root,root,755)
600 %attr(755,root,root) %{_libdir}/postfix/postfix-pgsql.so
601 %{_mandir}/man5/pgsql_table.5*
602 %endif
603
604 %if %{with sqlite}
605 %files dict-sqlite
606 %defattr(644,root,root,755)
607 %attr(755,root,root) %{_libdir}/postfix/postfix-sqlite.so
608 %{_mandir}/man5/sqlite_table.5*
609 %endif
610
611 %if %{with lmdb}
612 %files dict-lmdb
613 %defattr(644,root,root,755)
614 %attr(755,root,root) %{_libdir}/postfix/postfix-lmdb.so
615 %{_mandir}/man5/lmdb_table.5*
616 %endif
617
618 %if %{with cdb}
619 %files dict-cdb
620 %attr(755,root,root) %{_libdir}/postfix/postfix-cdb.so
621 %endif
622
623 %files qshape
624 %defattr(644,root,root,755)
625 %attr(755,root,root) %{_bindir}/qshape
626
627 %files -n monit-rc-%{name}
628 %defattr(644,root,root,755)
629 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}.monitrc
This page took 0.130006 seconds and 4 git commands to generate.