]> git.pld-linux.org Git - packages/postfix.git/blob - postfix.spec
- up to 3.6.6
[packages/postfix.git] / postfix.spec
1 #
2 # Conditional build:
3 %bcond_without  ldap    # LDAP map module
4 %bcond_without  mysql   # MySQL map module
5 %bcond_without  pgsql   # PostgreSQL map module
6 %bcond_without  sqlite  # SQLite map module
7 %bcond_without  sasl    # SMTP AUTH support
8 %bcond_without  ssl     # SSL/TLS support
9 %bcond_without  cdb     # cdb map support
10 %bcond_without  lmdb    # lmdb map support
11 %bcond_with     vda     # VDA patch
12 %bcond_with     hir     # Beeth's header_if_reject patch
13 %bcond_with     tcp     # unofficial tcp: lookup table
14 %if "%{pld_release}" == "ac"
15 %bcond_with     epoll   # epoll support for 2.6 kernels
16 # there didn't exist x86_64 2.4 kernel in PLD, so can safely enable epoll
17 %ifarch %{x8664}
18 %define         with_epoll      1
19 %endif
20 %else
21 %bcond_without  epoll   # epoll support (Linux >= 2.6)
22 %endif
23
24 %define         vda_ver v13-2.10.0
25 Summary:        Postfix Mail Transport Agent
26 Summary(cs.UTF-8):      Postfix - program pro přepravu pošty (MTA)
27 Summary(es.UTF-8):      Postfix - Un MTA (Mail Transport Agent) de alto desempeño
28 Summary(fr.UTF-8):      Agent de transport de courrier Postfix
29 Summary(pl.UTF-8):      Serwer SMTP Postfix
30 Summary(pt_BR.UTF-8):   Postfix - Um MTA (Mail Transport Agent) de alto desempenho
31 Summary(sk.UTF-8):      Agent prenosu pošty Postfix
32 Name:           postfix
33 Version:        3.6.6
34 Release:        1
35 Epoch:          2
36 License:        IBM Public License or Eclipse Public License v2.0
37 Group:          Networking/Daemons/SMTP
38 Source0:        ftp://ftp.porcupine.org/mirrors/postfix-release/official/%{name}-%{version}.tar.gz
39 # Source0-md5:  891ea3d4e2d7a9a82c0363ce9de2abda
40 Source1:        %{name}.aliases
41 Source2:        %{name}.cron
42 Source3:        %{name}.init
43 Source4:        %{name}.sysconfig
44 Source5:        %{name}.sasl
45 Source6:        %{name}.pamd
46 Source7:        %{name}-vda.patch
47 #Source7:       http://vda.sourceforge.net/VDA/%{name}-vda-%{vda_ver}.patch
48 # -ource7-md5:  01e1b031d79b85f3cb67d98ceddd775d
49 Source8:        %{name}-bounce.cf.pl
50 # http://postfix.state-of-mind.de/bounce-templates/bounce.de-DE.cf
51 Source9:        %{name}-bounce.cf.de
52 Source10:       %{name}.monitrc
53 Source11:       %{name}-vda-bigquota.patch
54 #Source11:      http://vda.sourceforge.net/VDA/%{name}-%{vda_ver}-vda-ng-bigquota.patch.gz
55 # -ource11-md5: d46103195b43ec5784ea2c166b238f71
56 Source12:       %{name}.service
57 Patch0:         %{name}-config.patch
58
59 Patch3:         %{name}-master.cf_cyrus.patch
60 # from http://akson.sgh.waw.pl/~chopin/unix/postfix-2.1.5-header_if_reject.diff
61 Patch4:         %{name}-header_if_reject.patch
62
63 Patch7:         %{name}-conf.patch
64 Patch8:         %{name}-dictname.patch
65
66 Patch11:        %{name}-scache_clnt.patch
67 Patch12:        format-security.patch
68 Patch13:        glibc-2.34.patch
69 URL:            http://www.postfix.org/
70 %{?with_sasl:BuildRequires:     cyrus-sasl-devel}
71 BuildRequires:  db-devel
72 # getifaddrs() with IPv6 support
73 BuildRequires:  glibc-devel >= 6:2.3.4
74 BuildRequires:  libicu-devel
75 BuildRequires:  libnsl-devel
76 BuildRequires:  m4
77 %{?with_lmdb:BuildRequires:     lmdb-devel}
78 %{?with_mysql:BuildRequires:    mysql-devel}
79 %{?with_ldap:BuildRequires:     openldap-devel >= 2.0.12}
80 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.7l}
81 BuildRequires:  pcre-devel
82 BuildRequires:  perl-base
83 %{?with_pgsql:BuildRequires:    postgresql-devel}
84 BuildRequires:  rpm >= 4.4.9-56
85 BuildRequires:  rpmbuild(macros) >= 1.644
86 BuildRequires:  sed >= 4.0
87 %{?with_sqlite:BuildRequires:   sqlite3-devel}
88 %{?with_cdb:BuildRequires:      tinycdb-devel}
89 %{?with_mysql:BuildRequires:    zlib-devel}
90 Requires(post): /bin/hostname
91 Requires(post,postun):  /sbin/ldconfig
92 Requires(post,preun):   /sbin/chkconfig
93 Requires(postun):       /usr/sbin/groupdel
94 Requires(postun):       /usr/sbin/userdel
95 Requires(pre):  /bin/id
96 Requires(pre):  /usr/bin/getgid
97 Requires(pre):  /usr/sbin/groupadd
98 Requires(pre):  /usr/sbin/useradd
99 Requires:       /sbin/chkconfig
100 Requires:       diffutils
101 Requires:       findutils
102 Requires:       rc-scripts
103 Requires:       sed
104 %{?with_cdb:Requires:tinycdb}
105 Requires:       systemd-units >= 38
106 Suggests:       cyrus-sasl-saslauthd
107 Provides:       group(postfix)
108 Provides:       smtpdaemon
109 Provides:       user(postfix)
110 Obsoletes:      smtpdaemon
111 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
112
113 %description
114 Postfix is attempt to provide an alternative to the widely-used
115 Sendmail program. Postfix attempts to be fast, easy to administer, and
116 hopefully secure, while at the same time being sendmail compatible
117 enough to not upset your users. This version has IPv6 support.
118
119 %description -l es.UTF-8
120 Postfix es una alternativa para el mundialmente utilizado sendmail. Si
121 desea tener un servidor SMTP *rápido*, debe instalar este paquete.
122
123 %description -l fr.UTF-8
124 Postfix (voir http://www.postfix.org/) se veut une alternative à
125 sendmail, responsable de l'acheminement de 70% des courriers
126 électroniques sur Internet. IBM en a suppotré le développement, mais
127 ne contrôle pas son évolution. Le but est d'installer Postfix sur le
128 plus grand nombre de systèmes possible. Dans cette optique, il a été
129 écrit pour être totalement sous le contrôle de l'utilisateur.
130
131 %description -l it.UTF-8
132 Postfix (http://www.postfix.org/) e' un'alternativa al programma
133 sendmail utilizzato per la gestione del 70 per cento della posta
134 Internet.
135
136 Seppur IBM supporti lo sviluppo di Postfix, non controlla la sua
137 evoluzione.
138
139 Consultate la pagine web http://www.moongroup.com/how-to.phtml nella
140 quale troverete le indicazioni per una corretta installazione e
141 configurazione di questo programma.
142
143 %description -l pl.UTF-8
144 Postfix jest próbą dostarczenia alternatywnego MTA w stosunku do
145 szeroko używanego sendmaila. Postfix w zamierzeniu ma być szybki,
146 łatwy w administrowaniu, bezpieczny oraz ma być na tyle kompatybilny z
147 sendmailem by nie denerwować użytkowników. Ta wersja obsługuje IPv6.
148
149 %description -l pt_BR.UTF-8
150 O Postfix é uma alternativa para o mundialmente utilizado sendmail. Se
151 você deseja um servidor SMTP *rápido*, instale este pacote.
152
153 %description -l sk.UTF-8
154 Postfix (pozri http://www.postfix.org/) má za cieľ byť alternatívou k
155 široko rozšírenému programu sendmail, zodpovednému za 70% všetkej
156 elektronickej pošty doručenej na Internete.
157
158 Aj keď IBM podporovala vývoj Postfixu, zdržiava sa vplyvu na jeho
159 vývoj. Cieľom je inštalácia Postfixu na čo najväčšom počte systémov.
160 Do tohoto momentu je softvér poskytovaný bez ovplyvňovania, takže sa
161 môže vyvíjať podľa jeho používateľov.
162
163 Určite si prečítajte http://www.moongroup.com/how-to.phtml, kde sú
164 popísané kroky potrebné pred a po inštalácii Postfixu.
165
166 %package devel
167 Summary:        Postfix loadable modules development package
168 Summary(pl.UTF-8):      Pakiet dla programistów ładowanych modułów do postfiksa
169 Group:          Development/Libraries
170 Requires:       %{name} = %{epoch}:%{version}-%{release}
171
172 %description devel
173 Header files to build additional map types for Postfix.
174
175 %description devel -l pl.UTF-8
176 Pliki nagłówkowe do tworzenia dodatkowych typów map dla Postfiksa.
177
178 %package dict-ldap
179 Summary:        LDAP map support for Postfix
180 Summary(pl.UTF-8):      Obsługa map LDAP dla Postfiksa
181 Group:          Networking/Daemons/SMTP
182 Requires:       %{name} = %{epoch}:%{version}-%{release}
183 Requires:       openldap >= 2.3.6
184
185 %description dict-ldap
186 This package provides support for LDAP maps in Postfix.
187
188 %description dict-ldap -l pl.UTF-8
189 Ten pakiet dodaje obsługę map LDAP do Postfiksa.
190
191 %package dict-mysql
192 Summary:        MySQL map support for Postfix
193 Summary(pl.UTF-8):      Obsługa map MySQL dla Postfiksa
194 Group:          Networking/Daemons/SMTP
195 Requires:       %{name} = %{epoch}:%{version}-%{release}
196
197 %description dict-mysql
198 This package provides support for MySQL maps in Postfix.
199
200 %description dict-mysql -l pl.UTF-8
201 Ten pakiet dodaje obsługę map MySQL do Postfiksa.
202
203 %package dict-pcre
204 Summary:        PCRE map support for Postfix
205 Summary(pl.UTF-8):      Obsługa map PCRE dla Postfiksa
206 Group:          Networking/Daemons/SMTP
207 Requires:       %{name} = %{epoch}:%{version}-%{release}
208
209 %description dict-pcre
210 This package provides support for PCRE maps in Postfix.
211
212 %description dict-pcre -l pl.UTF-8
213 Ten pakiet dodaje obsługę map PCRE do Postfiksa.
214
215 %package dict-pgsql
216 Summary:        PostgreSQL map support for Postfix
217 Summary(pl.UTF-8):      Obsługa map PostgreSQL dla Postfiksa
218 Group:          Networking/Daemons/SMTP
219 Requires:       %{name} = %{epoch}:%{version}-%{release}
220
221 %description dict-pgsql
222 This package provides support for PostgreSQL maps in Postfix.
223
224 %description dict-pgsql -l pl.UTF-8
225 Ten pakiet dodaje obsługę map PostgreSQL do Postfiksa.
226
227 %package dict-sqlite
228 Summary:        SQLite map support for Postfix
229 Summary(pl.UTF-8):      Obsługa map SQLite dla Postfiksa
230 Group:          Networking/Daemons/SMTP
231 Requires:       %{name} = %{epoch}:%{version}-%{release}
232
233 %description dict-sqlite
234 This package provides support for SQLite maps in Postfix.
235
236 %description dict-sqlite -l pl.UTF-8
237 Ten pakiet dodaje obsługę map SQLite do Postfiksa.
238
239 %package dict-lmdb
240 Summary:        LMDB map support for Postfix
241 Summary(pl.UTF-8):      Obsługa map LMDB dla Postfiksa
242 Group:          Networking/Daemons/SMTP
243 Requires:       %{name} = %{epoch}:%{version}-%{release}
244
245 %description dict-lmdb
246 This package provides support for LMDB maps in Postfix.
247
248 %description dict-lmdb -l pl.UTF-8
249 Ten pakiet dodaje obsługę map LMDB do Postfiksa.
250
251 %package dict-cdb
252 Summary:        CDB map support for Postfix
253 Summary(pl.UTF-8):      Obsługa map CDB dla Postfiksa
254 Group:          Networking/Daemons/SMTP
255 Requires:       %{name} = %{epoch}:%{version}-%{release}
256
257 %description dict-cdb
258 This package provides support for CDB maps in Postfix.
259
260 %description dict-cdb -l pl.UTF-8
261 Ten pakiet dodaje obsługę map CDB do Postfiksa.
262
263 %package qshape
264 Summary:        qshape - Print Postfix queue domain and age distribution
265 Summary(pl.UTF-8):      qshape - wypisywanie rozkładu domen i wieku z kolejki Postfiksa
266 Group:          Networking/Daemons/SMTP
267 Requires:       %{name} = %{epoch}:%{version}-%{release}
268
269 %description qshape
270 The qshape program helps the administrator understand the Postfix
271 queue message distribution in time and by sender domain or recipient
272 domain. The program needs read access to the queue directories and
273 queue files, so it must run as the superuser or the mail_owner
274 specified in main.cf (typically postfix).
275
276 %description qshape -l pl.UTF-8
277 Program qshape pomaga administratorowi zrozumieć rozkład kolejki
278 wiadomości Postfiksa w czasie i w zależności od domeny nadawcy lub
279 adresata. Program wymaga prawa odczytu do katalogów kolejki i plików
280 kolejki, więc musi być uruchamiany przez superużytkownika lub
281 użytkownika mail_owner podanego w main.cf (zwykle nazywającego się
282 postfix).
283
284 %package -n monit-rc-%{name}
285 Summary:        monit support for Postfix
286 Summary(pl.UTF-8):      Wsparcie monita dla Postfiksa
287 Group:          Applications/System
288 Requires:       %{name} = %{epoch}:%{version}-%{release}
289 Requires:       monit
290
291 %description -n monit-rc-%{name}
292 monitrc file for monitoring Postfix.
293
294 %description -n monit-rc-%{name} -l pl.UTF-8
295 Plik monitrc do monitorowania serwera Postfix.
296
297 %prep
298 %setup -q
299 %if %{with vda}
300 cat %{SOURCE7} | %{__patch} -p1 -s
301 cat %{SOURCE11} | %{__patch} -p1 -s
302 %endif
303
304 find -type f | xargs %{__sed} -i -e 's|/etc/postfix|/etc/mail|g'
305
306 %patch0 -p1
307
308 %patch3 -p1
309 %{?with_hir:%patch4 -p0}
310
311 %{__sed} -i -e '/scache_clnt_create/s/server/var_scache_service/' src/global/scache_clnt.c
312 %patch7 -p1
313 %patch8 -p1
314
315 %patch11 -p1
316 %if %{with vda}
317 %patch12 -p1
318 %endif
319 %patch13 -p1
320
321 %if %{with tcp}
322 sed -i 's/ifdef SNAPSHOT/if 1/' src/util/dict_open.c
323 %endif
324
325 %{__sed} -i -e 's,/lib64\>,/%{_lib},' makedefs
326
327 %build
328 # export, as the same variables must be passed both to 'make makefiles' and 'make'
329 export CCARGS="%{!?with_epoll:-DNO_EPOLL} %{?with_ldap:-DHAS_LDAP} -DHAS_PCRE %{?with_sasl:-DUSE_SASL_AUTH -DUSE_CYRUS_SASL -I/usr/include/sasl} %{?with_mysql:-DHAS_MYSQL -I/usr/include/mysql} %{?with_pgsql:-DHAS_PGSQL} %{?with_ssl:-DUSE_TLS} -DMAX_DYNAMIC_MAPS %{?with_cdb:-DHAS_CDB} %{?with_sqlite:-DHAS_SQLITE} %{?with_lmdb:-DHAS_LMDB} -LHAS_SDBM"
330 export AUXLIBS="%{rpmldflags} -lsasl -lssl -lcrypto"
331 export AUXLIBS_CDB="%{?with_cdb:-lcdb}"
332 export AUXLIBS_LDAP="%{?with_ldap:-lldap -llber}"
333 export AUXLIBS_LMDB="%{?with_lmdb:-llmdb}"
334 export AUXLIBS_MYSQL="%{?with_mysql:-lmysqlclient}"
335 export AUXLIBS_PCRE="-lpcre"
336 export AUXLIBS_PGSQL="%{?with_pgsql:-lpq}"
337 export AUXLIBS_SQLITE="%{?with_sqlite:-lsqlite3}"
338
339 export CC="%{__cc}"
340 %{__make} makefiles \
341         shared=yes \
342         dynamicmaps=yes \
343         daemon_directory="%{_libdir}/postfix" \
344         shlib_directory="%{_libdir}/postfix" \
345         manpage_directory="%{_mandir}"
346
347 %{__make} -j1 \
348         DEBUG="" \
349         OPT="%{rpmcflags} %{rpmcppflags} -D_FILE_OFFSET_BITS=64"
350
351 %install
352 rm -rf $RPM_BUILD_ROOT
353 install -d $RPM_BUILD_ROOT/etc/{cron.daily,rc.d/init.d,sysconfig,pam.d,security,monit} \
354         $RPM_BUILD_ROOT%{_sysconfdir}/{mail,sasl} \
355         $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_libdir}/postfix,/usr/lib}\
356         $RPM_BUILD_ROOT{%{_includedir}/postfix,%{_mandir}} \
357         $RPM_BUILD_ROOT%{_var}/spool/postfix/{active,corrupt,deferred,maildrop,private,saved,bounce,defer,incoming,pid,public} \
358         $RPM_BUILD_ROOT%{_var}/lib/postfix \
359         $RPM_BUILD_ROOT%{systemdunitdir}
360
361 %{__make} non-interactive-package \
362        install_root=$RPM_BUILD_ROOT
363
364 #cp -a conf/* $RPM_BUILD_ROOT%{_sysconfdir}/mail
365 sed -e's,^daemon_directory = .*,daemon_directory = %{_libdir}/postfix,' \
366         conf/main.cf > $RPM_BUILD_ROOT%{_sysconfdir}/mail/main.cf
367
368 cp -a include/*.h $RPM_BUILD_ROOT%{_includedir}/postfix
369
370 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/mail/aliases
371 install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.daily/postfix
372 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/postfix
373 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/postfix
374 cp -a %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/sasl/smtpd.conf
375 cp -a %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/smtp
376 cp -a %{SOURCE8} $RPM_BUILD_ROOT%{_sysconfdir}/mail/bounce.cf.pl
377 cp -a %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/mail/bounce.cf.de
378 cp -a %{SOURCE10} $RPM_BUILD_ROOT/etc/monit/%{name}.monitrc
379 cp -a %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/%{name}.service
380 install -p auxiliary/rmail/rmail $RPM_BUILD_ROOT%{_bindir}/rmail
381 install -p auxiliary/qshape/qshape.pl $RPM_BUILD_ROOT%{_bindir}/qshape
382
383 ln -sf %{_sbindir}/sendmail $RPM_BUILD_ROOT%{_bindir}/mailq
384 ln -sf %{_sbindir}/sendmail $RPM_BUILD_ROOT%{_bindir}/newaliases
385 ln -sf %{_sbindir}/sendmail $RPM_BUILD_ROOT/usr/lib/sendmail
386
387 touch $RPM_BUILD_ROOT%{_sysconfdir}/mail/\
388         {aliases,access,canonical,relocated,transport,virtual}{,.db}
389
390 touch $RPM_BUILD_ROOT/etc/security/blacklist.smtp
391
392 > $RPM_BUILD_ROOT/var/spool/postfix/.nofinger
393
394 %{__rm} -r $RPM_BUILD_ROOT%{_sysconfdir}/mail/makedefs.out
395 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/mail/{,TLS_}LICENSE
396
397 %clean
398 rm -rf $RPM_BUILD_ROOT
399
400 %pre
401 %groupadd -g 62 postfix
402 %groupadd -g 63 maildrop
403 %useradd -u 62 -d /var/spool/postfix -s /bin/false -c "Postfix User" -g postfix postfix
404
405 %post
406 /sbin/ldconfig
407 if ! grep -q "^postmaster:" %{_sysconfdir}/mail/aliases; then
408         echo "Adding Entry for postmaster in %{_sysconfdir}/mail/aliases" >&2
409         echo "postmaster: root" >>%{_sysconfdir}/mail/aliases
410 fi
411 if [ "$1" = "1" ]; then
412         # only on installation, not upgrade; set sane defaults
413         # postfix expects gethostname() to return FQDN, which is obviously wrong
414         if ! grep -qE "^my(domain|hostname)" %{_sysconfdir}/mail/main.cf; then
415                 domain=$(/bin/hostname -d 2>/dev/null)
416                 [ -n "$domain" -a "$domain" != 'localdomain' ] && \
417                         postconf -e mydomain="$domain"
418         fi
419 else
420         %{_sbindir}/postfix upgrade-configuration
421 fi
422
423 %{_bindir}/newaliases
424 /sbin/chkconfig --add postfix
425 %service postfix restart "Postfix Daemon"
426 %systemd_post postfix.service
427
428 %preun
429 if [ "$1" = "0" ]; then
430         %service postfix stop
431         /sbin/chkconfig --del postfix
432 fi
433 %systemd_preun postfix.service
434
435 %postun
436 /sbin/ldconfig
437 if [ "$1" = "0" ]; then
438         %groupremove maildrop
439         %userremove postfix
440         %groupremove postfix
441 fi
442 %systemd_reload
443
444 %triggerpostun -- postfix < 2:2.9.4-4
445 %systemd_trigger postfix.service
446
447 %files
448 %defattr(644,root,root,755)
449 %doc html COMPATIBILITY HISTORY LICENSE RELEASE_NOTES* TLS_*
450 %doc README_FILES/*README
451 %doc examples/smtpd-policy
452 %dir %{_sysconfdir}/mail
453 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/access
454 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/aliases
455 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/bounce.cf.default
456 %lang(de) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/bounce.cf.de
457 %lang(pl) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/bounce.cf.pl
458 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/canonical
459 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/generic
460 #%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/regexp_table
461 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/relocated
462 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/transport
463 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/virtual
464 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/header_checks
465 #%ghost %{_sysconfdir}/mail/*.db
466 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/dynamicmaps.cf
467 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/main.cf
468 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/main.cf.default
469 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/main.cf.proto
470 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/master.cf
471 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/master.cf.proto
472 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/postfix-files
473 %attr(740,root,root) /etc/cron.daily/postfix
474 %attr(754,root,root) /etc/rc.d/init.d/postfix
475 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/postfix
476 %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/smtp
477 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.smtp
478 %{?with_sasl:%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sasl/smtpd.conf}
479 %attr(755,root,root) %{_bindir}/mailq
480 %attr(755,root,root) %{_bindir}/newaliases
481 %attr(755,root,root) %{_bindir}/rmail
482 %attr(755,root,root) %{_sbindir}/s*
483 %attr(755,root,root) %{_sbindir}/postfix
484 %attr(755,root,root) %{_sbindir}/postalias
485 %attr(755,root,root) %{_sbindir}/postkick
486 %attr(755,root,root) %{_sbindir}/postl*
487 %attr(755,root,root) %{_sbindir}/postc*
488 %attr(755,root,root) %{_sbindir}/postmap
489 %attr(755,root,root) %{_sbindir}/postmulti
490 %attr(2755,root,maildrop) %{_sbindir}/postqueue
491 %attr(755,root,root) %{_sbindir}/postsuper
492 %attr(2755,root,maildrop) %{_sbindir}/postdrop
493 %attr(755,root,root) /usr/lib/sendmail
494 %dir %{_libdir}/postfix
495 %attr(755,root,root) %{_libdir}/postfix/anvil
496 %attr(755,root,root) %{_libdir}/postfix/bounce
497 %attr(755,root,root) %{_libdir}/postfix/cleanup
498 %attr(755,root,root) %{_libdir}/postfix/discard
499 %attr(755,root,root) %{_libdir}/postfix/dnsblog
500 %attr(755,root,root) %{_libdir}/postfix/error
501 %attr(755,root,root) %{_libdir}/postfix/flush
502 %attr(755,root,root) %{_libdir}/postfix/libpostfix-dns.so
503 %attr(755,root,root) %{_libdir}/postfix/libpostfix-global.so
504 %attr(755,root,root) %{_libdir}/postfix/libpostfix-master.so
505 %attr(755,root,root) %{_libdir}/postfix/libpostfix-tls.so
506 %attr(755,root,root) %{_libdir}/postfix/libpostfix-util.so
507 %attr(755,root,root) %{_libdir}/postfix/lmtp
508 %attr(755,root,root) %{_libdir}/postfix/local
509 %attr(755,root,root) %{_libdir}/postfix/master
510 %attr(755,root,root) %{_libdir}/postfix/nqmgr
511 %attr(755,root,root) %{_libdir}/postfix/oqmgr
512 %attr(755,root,root) %{_libdir}/postfix/pickup
513 %attr(755,root,root) %{_libdir}/postfix/pipe
514 %attr(755,root,root) %{_libdir}/postfix/postfix-script
515 %attr(755,root,root) %{_libdir}/postfix/postfix-tls-script
516 %attr(755,root,root) %{_libdir}/postfix/postlogd
517 %attr(755,root,root) %{_libdir}/postfix/postfix-wrapper
518 %attr(755,root,root) %{_libdir}/postfix/post-install
519 %attr(755,root,root) %{_libdir}/postfix/postmulti-script
520 %attr(755,root,root) %{_libdir}/postfix/postscreen
521 %attr(755,root,root) %{_libdir}/postfix/proxymap
522 %attr(755,root,root) %{_libdir}/postfix/qmgr
523 %attr(755,root,root) %{_libdir}/postfix/qmqpd
524 %attr(755,root,root) %{_libdir}/postfix/scache
525 %attr(755,root,root) %{_libdir}/postfix/showq
526 %attr(755,root,root) %{_libdir}/postfix/smtp
527 %attr(755,root,root) %{_libdir}/postfix/smtpd
528 %attr(755,root,root) %{_libdir}/postfix/spawn
529 %attr(755,root,root) %{_libdir}/postfix/tlsmgr
530 %attr(755,root,root) %{_libdir}/postfix/tlsproxy
531 %attr(755,root,root) %{_libdir}/postfix/trivial-rewrite
532 %attr(755,root,root) %{_libdir}/postfix/verify
533 %attr(755,root,root) %{_libdir}/postfix/virtual
534 %attr(755,root,root) %dir %{_var}/spool/postfix
535 %attr(700,postfix,root) %dir %{_var}/spool/postfix/active
536 %attr(700,postfix,root) %dir %{_var}/spool/postfix/bounce
537 %attr(700,postfix,root) %dir %{_var}/spool/postfix/corrupt
538 %attr(700,postfix,root) %dir %{_var}/spool/postfix/defer
539 %attr(700,postfix,root) %dir %{_var}/spool/postfix/deferred
540 %attr(700,postfix,root) %dir %{_var}/spool/postfix/incoming
541 %attr(1730,postfix,maildrop) %dir %{_var}/spool/postfix/maildrop
542 %attr(755,root,root) %dir %{_var}/spool/postfix/pid
543 %attr(700,postfix,root) %dir %{_var}/spool/postfix/private
544 %attr(710,postfix,maildrop) %dir %{_var}/spool/postfix/public
545 %attr(700,postfix,root) %dir %{_var}/spool/postfix/saved
546 %attr(644,postfix,root) %{_var}/spool/postfix/.nofinger
547 %attr(700,postfix,root) %{_var}/lib/postfix
548 %{_mandir}/man1/mailq.1*
549 %{_mandir}/man1/newaliases.1*
550 %{_mandir}/man1/post*.1*
551 %{_mandir}/man1/sendmail.1*
552 %{_mandir}/man5/access.5*
553 %{_mandir}/man5/aliases.5*
554 %{_mandir}/man5/body_checks.5*
555 %{_mandir}/man5/bounce.5*
556 %{_mandir}/man5/canonical.5*
557 %{_mandir}/man5/cidr_table.5*
558 %{_mandir}/man5/generic.5*
559 %{_mandir}/man5/header_checks.5*
560 %{_mandir}/man5/master.5*
561 %{_mandir}/man5/memcache_table.5*
562 %{_mandir}/man5/nisplus_table.5*
563 %{_mandir}/man5/postconf.5*
564 %{_mandir}/man5/postfix-wrapper.5*
565 %{_mandir}/man5/regexp_table.5*
566 %{_mandir}/man5/relocated.5*
567 %{_mandir}/man5/socketmap_table.5*
568 %{_mandir}/man5/tcp_table.5*
569 %{_mandir}/man5/transport.5*
570 %{_mandir}/man5/virtual.5*
571 %{_mandir}/man8/*.8*
572 %{systemdunitdir}/%{name}.service
573
574 %files devel
575 %defattr(644,root,root,755)
576 %{_includedir}/postfix
577
578 %if %{with ldap}
579 %files dict-ldap
580 %defattr(644,root,root,755)
581 %attr(755,root,root) %{_libdir}/postfix/postfix-ldap.so
582 %{_mandir}/man5/ldap_table.5*
583 %endif
584
585 %if %{with mysql}
586 %files dict-mysql
587 %defattr(644,root,root,755)
588 %attr(755,root,root) %{_libdir}/postfix/postfix-mysql.so
589 %{_mandir}/man5/mysql_table.5*
590 %endif
591
592 %files dict-pcre
593 %defattr(644,root,root,755)
594 %attr(755,root,root) %{_libdir}/postfix/postfix-pcre.so
595 #%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/pcre_table
596 %{_mandir}/man5/pcre_table.5*
597
598 %if %{with pgsql}
599 %files dict-pgsql
600 %defattr(644,root,root,755)
601 %attr(755,root,root) %{_libdir}/postfix/postfix-pgsql.so
602 %{_mandir}/man5/pgsql_table.5*
603 %endif
604
605 %if %{with sqlite}
606 %files dict-sqlite
607 %defattr(644,root,root,755)
608 %attr(755,root,root) %{_libdir}/postfix/postfix-sqlite.so
609 %{_mandir}/man5/sqlite_table.5*
610 %endif
611
612 %if %{with lmdb}
613 %files dict-lmdb
614 %defattr(644,root,root,755)
615 %attr(755,root,root) %{_libdir}/postfix/postfix-lmdb.so
616 %{_mandir}/man5/lmdb_table.5*
617 %endif
618
619 %if %{with cdb}
620 %files dict-cdb
621 %attr(755,root,root) %{_libdir}/postfix/postfix-cdb.so
622 %endif
623
624 %files qshape
625 %defattr(644,root,root,755)
626 %attr(755,root,root) %{_bindir}/qshape
627
628 %files -n monit-rc-%{name}
629 %defattr(644,root,root,755)
630 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}.monitrc
This page took 0.113586 seconds and 3 git commands to generate.