]> git.pld-linux.org Git - packages/postfix.git/blob - postfix.spec
- dropped -j1, not needed
[packages/postfix.git] / postfix.spec
1 #
2 # Conditional build:
3 %bcond_without  ldap    # without LDAP map module
4 %bcond_without  mysql   # without MySQL map module
5 %bcond_without  pgsql   # without PostgreSQL map module
6 %bcond_without  sqlite  # without SQLite map module
7 %bcond_without  sasl    # without SMTP AUTH support
8 %bcond_without  ssl     # without SSL/TLS support
9 %bcond_without  cdb     # without cdb map support
10 %if "%{pld_release}" == "th"
11 %bcond_without  vda     # without VDA patch
12 %else
13 %bcond_with     vda     # with VDA patch
14 %endif
15 %bcond_with     hir     # with Beeth's header_if_reject patch
16 %bcond_with     tcp     # with unofficial tcp: lookup table
17 %if "%{pld_release}" == "ac"
18 %bcond_with             epoll   # enable epoll for 2.6 kernels
19 # there didn't exist x86_64 2.4 kernel in PLD, so can safely enable epoll
20 %ifarch %{x8664}
21 %define         with_epoll      1
22 %endif
23 %else
24 %bcond_without  epoll   # disable epoll for 2.4 kernels
25 %endif
26
27 %define         vda_ver v10-2.8.1
28 Summary:        Postfix Mail Transport Agent
29 Summary(cs.UTF-8):      Postfix - program pro přepravu pošty (MTA)
30 Summary(es.UTF-8):      Postfix - Un MTA (Mail Transport Agent) de alto desempeño
31 Summary(fr.UTF-8):      Agent de transport de courrier Postfix
32 Summary(pl.UTF-8):      Serwer SMTP Postfix
33 Summary(pt_BR.UTF-8):   Postfix - Um MTA (Mail Transport Agent) de alto desempenho
34 Summary(sk.UTF-8):      Agent prenosu pošty Postfix
35 Name:           postfix
36 Version:        2.8.3
37 Release:        1
38 Epoch:          2
39 License:        distributable
40 Group:          Networking/Daemons/SMTP
41 Source0:        ftp://ftp.porcupine.org/mirrors/postfix-release/official/%{name}-%{version}.tar.gz
42 # Source0-md5:  b3922ededd3fd6051f759e58a4ada3ae
43 Source1:        %{name}.aliases
44 Source2:        %{name}.cron
45 Source3:        %{name}.init
46 Source4:        %{name}.sysconfig
47 Source5:        %{name}.sasl
48 Source6:        %{name}.pamd
49 Source7:        http://vda.sourceforge.net/VDA/%{name}-vda-%{vda_ver}.patch
50 # Source7-md5:  5d5156e51cc07057bf347bbb34934d3e
51 Source8:        %{name}-bounce.cf.pl
52 # http://postfix.state-of-mind.de/bounce-templates/bounce.de-DE.cf
53 Source9:        %{name}-bounce.cf.de
54 Source10:       %{name}.monitrc
55 Source11:       %{name}-vda-bigquota.patch
56 #Source11:      http://vda.sourceforge.net/VDA/%{name}-%{vda_ver}-vda-ng-bigquota.patch.gz
57 # -ource11-md5: d46103195b43ec5784ea2c166b238f71
58 Patch0:         %{name}-config.patch
59 Patch1:         %{name}-conf_msg.patch
60 Patch2:         %{name}-dynamicmaps.patch
61 Patch3:         %{name}-master.cf_cyrus.patch
62 # from http://akson.sgh.waw.pl/~chopin/unix/postfix-2.1.5-header_if_reject.diff
63 Patch4:         %{name}-header_if_reject.patch
64 Patch5:         %{name}-ident.patch
65 Patch6:         %{name}-lib64.patch
66 Patch7:         %{name}-conf.patch
67 Patch8:         %{name}-dictname.patch
68 Patch9:         %{name}-make-jN.patch
69 Patch10:        %{name}-link.patch
70 Patch11:        %{name}-scache_clnt.patch
71 URL:            http://www.postfix.org/
72 %{?with_sasl:BuildRequires:     cyrus-sasl-devel}
73 BuildRequires:  db-devel
74 # getifaddrs() with IPv6 support
75 BuildRequires:  glibc-devel >= 6:2.3.4
76 %{?with_mysql:BuildRequires:    mysql-devel}
77 %{?with_ldap:BuildRequires:     openldap-devel >= 2.0.12}
78 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.7l}
79 BuildRequires:  pcre-devel
80 BuildRequires:  perl-base
81 %{?with_pgsql:BuildRequires:    postgresql-devel}
82 BuildRequires:  rpm >= 4.4.9-56
83 BuildRequires:  rpmbuild(macros) >= 1.268
84 BuildRequires:  sed >= 4.0
85 %{?with_sqlite:BuildRequires:   sqlite3-devel}
86 %{?with_cdb:BuildRequires:      tinycdb-devel}
87 %{?with_mysql:BuildRequires:    zlib-devel}
88 Requires(post): /bin/hostname
89 Requires(post,postun):  /sbin/ldconfig
90 Requires(post,preun):   /sbin/chkconfig
91 Requires(postun):       /usr/sbin/groupdel
92 Requires(postun):       /usr/sbin/userdel
93 Requires(pre):  /bin/id
94 Requires(pre):  /usr/bin/getgid
95 Requires(pre):  /usr/sbin/groupadd
96 Requires(pre):  /usr/sbin/useradd
97 Requires:       /sbin/chkconfig
98 Requires:       diffutils
99 Requires:       findutils
100 Requires:       rc-scripts
101 Requires:       sed
102 %{?with_cdb:Requires:tinycdb}
103 Suggests:       cyrus-sasl-saslauthd
104 Provides:       group(postfix)
105 Provides:       smtpdaemon
106 Provides:       user(postfix)
107 Obsoletes:      smtpdaemon
108 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
109
110 %description
111 Postfix is attempt to provide an alternative to the widely-used
112 Sendmail program. Postfix attempts to be fast, easy to administer, and
113 hopefully secure, while at the same time being sendmail compatible
114 enough to not upset your users. This version has IPv6 support.
115
116 %description -l es.UTF-8
117 Postfix es una alternativa para el mundialmente utilizado sendmail. Si
118 desea tener un servidor SMTP *rápido*, debe instalar este paquete.
119
120 %description -l fr.UTF-8
121 Postfix (voir http://www.postfix.org/) se veut une alternative à
122 sendmail, responsable de l'acheminement de 70% des courriers
123 électroniques sur Internet. IBM en a suppotré le développement, mais
124 ne contrôle pas son évolution. Le but est d'installer Postfix sur le
125 plus grand nombre de systèmes possible. Dans cette optique, il a été
126 écrit pour être totalement sous le contrôle de l'utilisateur.
127
128 %description -l it.UTF-8
129 Postfix (http://www.postfix.org/) e' un'alternativa al programma
130 sendmail utilizzato per la gestione del 70 per cento della posta
131 Internet.
132
133 Seppur IBM supporti lo sviluppo di Postfix, non controlla la sua
134 evoluzione.
135
136 Consultate la pagine web http://www.moongroup.com/how-to.phtml nella
137 quale troverete le indicazioni per una corretta installazione e
138 configurazione di questo programma.
139
140 %description -l pl.UTF-8
141 Postfix jest próbą dostarczenia alternatywnego MTA w stosunku do
142 szeroko używanego sendmaila. Postfix w zamierzeniu ma być szybki,
143 łatwy w administrowaniu, bezpieczny oraz ma być na tyle kompatybilny z
144 sendmailem by nie denerwować użytkowników. Ta wersja obsługuje IPv6.
145
146 %description -l pt_BR.UTF-8
147 O Postfix é uma alternativa para o mundialmente utilizado sendmail. Se
148 você deseja um servidor SMTP *rápido*, instale este pacote.
149
150 %description -l sk.UTF-8
151 Postfix (pozri http://www.postfix.org/) má za cieľ byť alternatívou k
152 široko rozšírenému programu sendmail, zodpovednému za 70% všetkej
153 elektronickej pošty doručenej na Internete.
154
155 Aj keď IBM podporovala vývoj Postfixu, zdržiava sa vplyvu na jeho
156 vývoj. Cieľom je inštalácia Postfixu na čo najväčšom počte systémov.
157 Do tohoto momentu je softvér poskytovaný bez ovplyvňovania, takže sa
158 môže vyvíjať podľa jeho používateľov.
159
160 Určite si prečítajte http://www.moongroup.com/how-to.phtml, kde sú
161 popísané kroky potrebné pred a po inštalácii Postfixu.
162
163 %package devel
164 Summary:        Postfix loadable modules development package
165 Summary(pl.UTF-8):      Pakiet dla programistów ładowanych modułów do postfiksa
166 Group:          Development/Libraries
167 Requires:       %{name} = %{epoch}:%{version}-%{release}
168
169 %description devel
170 Header files to build additional map types for Postfix.
171
172 %description devel -l pl.UTF-8
173 Pliki nagłówkowe do tworzenia dodatkowych typów map dla Postfiksa.
174
175 %package dict-ldap
176 Summary:        LDAP map support for Postfix
177 Summary(pl.UTF-8):      Obsługa map LDAP dla Postfiksa
178 Group:          Networking/Daemons/SMTP
179 Requires:       %{name} = %{epoch}:%{version}-%{release}
180 Requires:       openldap >= 2.3.6
181
182 %description dict-ldap
183 This package provides support for LDAP maps in Postfix.
184
185 %description dict-ldap -l pl.UTF-8
186 Ten pakiet dodaje obsługę map LDAP do Postfiksa.
187
188 %package dict-mysql
189 Summary:        MySQL map support for Postfix
190 Summary(pl.UTF-8):      Obsługa map MySQL dla Postfiksa
191 Group:          Networking/Daemons/SMTP
192 Requires:       %{name} = %{epoch}:%{version}-%{release}
193
194 %description dict-mysql
195 This package provides support for MySQL maps in Postfix.
196
197 %description dict-mysql -l pl.UTF-8
198 Ten pakiet dodaje obsługę map MySQL do Postfiksa.
199
200 %package dict-pcre
201 Summary:        PCRE map support for Postfix
202 Summary(pl.UTF-8):      Obsługa map PCRE dla Postfiksa
203 Group:          Networking/Daemons/SMTP
204 Requires:       %{name} = %{epoch}:%{version}-%{release}
205
206 %description dict-pcre
207 This package provides support for PCRE maps in Postfix.
208
209 %description dict-pcre -l pl.UTF-8
210 Ten pakiet dodaje obsługę map PCRE do Postfiksa.
211
212 %package dict-pgsql
213 Summary:        PostgreSQL map support for Postfix
214 Summary(pl.UTF-8):      Obsługa map PostgreSQL dla Postfiksa
215 Group:          Networking/Daemons/SMTP
216 Requires:       %{name} = %{epoch}:%{version}-%{release}
217
218 %description dict-pgsql
219 This package provides support for PostgreSQL maps in Postfix.
220
221 %description dict-pgsql -l pl.UTF-8
222 Ten pakiet dodaje obsługę map PostgreSQL do Postfiksa.
223
224 %package dict-sqlite
225 Summary:        SQLite map support for Postfix
226 Summary(pl.UTF-8):      Obsługa map SQLite dla Postfiksa
227 Group:          Networking/Daemons/SMTP
228 Requires:       %{name} = %{epoch}:%{version}-%{release}
229
230 %description dict-sqlite
231 This package provides support for SQLite maps in Postfix.
232
233 %description dict-sqlite -l pl.UTF-8
234 Ten pakiet dodaje obsługę map SQLite do Postfiksa.
235
236 %package qshape
237 Summary:        qshape - Print Postfix queue domain and age distribution
238 Summary(pl.UTF-8):      qshape - wypisywanie rozkładu domen i wieku z kolejki Postfiksa
239 Group:          Networking/Daemons/SMTP
240 Requires:       %{name} = %{epoch}:%{version}-%{release}
241
242 %description qshape
243 The qshape program helps the administrator understand the Postfix
244 queue message distribution in time and by sender domain or recipient
245 domain. The program needs read access to the queue directories and
246 queue files, so it must run as the superuser or the mail_owner
247 specified in main.cf (typically postfix).
248
249 %description qshape -l pl.UTF-8
250 Program qshape pomaga administratorowi zrozumieć rozkład kolejki
251 wiadomości Postfiksa w czasie i w zależności od domeny nadawcy lub
252 adresata. Program wymaga prawa odczytu do katalogów kolejki i plików
253 kolejki, więc musi być uruchamiany przez superużytkownika lub
254 użytkownika mail_owner podanego w main.cf (zwykle nazywającego się
255 postfix).
256
257 %package -n monit-rc-%{name}
258 Summary:        monit support for Postfix
259 Summary(pl.UTF-8):      Wsparcie monita dla Postfiksa
260 Group:          Applications/System
261 Requires:       %{name} = %{epoch}:%{version}-%{release}
262 Requires:       monit
263
264 %description -n monit-rc-%{name}
265 monitrc file for monitoring Postfix.
266
267 %description -n monit-rc-%{name} -l pl.UTF-8
268 Plik monitrc do monitorowania serwera Postfix.
269
270 %prep
271 %setup -q
272 %if %{with vda}
273 cat %{SOURCE7} | %{__patch} -p1 -s
274 cat %{SOURCE11} | %{__patch} -p1 -s
275 %endif
276
277 find -type f | xargs sed -i -e 's|/etc/postfix|/etc/mail|g'
278
279 %patch0 -p1
280 %patch1 -p0
281 %patch2 -p1
282 %patch3 -p1
283 %{?with_hir:%patch4 -p0}
284 %patch5 -p1
285 sed -i '/scache_clnt_create/s/server/var_scache_service/' src/global/scache_clnt.c
286 %if "%{_lib}" == "lib64"
287 %patch6 -p1
288 %endif
289 %patch7 -p1
290 %patch8 -p1
291 %patch9 -p1
292 %patch10 -p1
293 %patch11 -p1
294
295 %if %{with tcp}
296 sed -i 's/ifdef SNAPSHOT/if 1/' src/util/dict_open.c
297 %endif
298
299 %build
300 %{__make} -f Makefile.init makefiles
301 %{__make} tidy
302 CC="%{__cc}"
303 export CC
304 %{__make} \
305         DEBUG="" \
306         OPT="%{rpmcflags} -D_FILE_OFFSET_BITS=64" \
307         %{!?with_ldap:LDAPSO=""} \
308         %{!?with_mysql:MYSQLSO=""} \
309         %{!?with_pgsql:PGSQLSO=""} \
310         CCARGS="%{!?with_epoll:-DNO_EPOLL} %{?with_ldap:-DHAS_LDAP} -DHAS_PCRE %{?with_sasl:-DUSE_SASL_AUTH -DUSE_CYRUS_SASL -I/usr/include/sasl} %{?with_mysql:-DHAS_MYSQL -I/usr/include/mysql} %{?with_pgsql:-DHAS_PGSQL} %{?with_ssl:-DUSE_TLS} -DMAX_DYNAMIC_MAPS %{?with_cdb:-DHAS_CDB}" \
311         AUXLIBS="-ldb -lresolv %{?with_sasl:-lsasl} %{?with_ssl:-lssl -lcrypto} %{?with_cdb:-lcdb} -lpcre"
312
313 %install
314 rm -rf $RPM_BUILD_ROOT
315 install -d $RPM_BUILD_ROOT/etc/{cron.daily,rc.d/init.d,sysconfig,pam.d,security,monit} \
316         $RPM_BUILD_ROOT%{_sysconfdir}/{mail,sasl} \
317         $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_libdir}/postfix,/usr/lib}\
318         $RPM_BUILD_ROOT{%{_includedir}/postfix,%{_mandir}} \
319         $RPM_BUILD_ROOT%{_var}/spool/postfix/{active,corrupt,deferred,maildrop,private,saved,bounce,defer,incoming,pid,public} \
320         $RPM_BUILD_ROOT%{_var}/lib/postfix
321 %{__rm} html/Makefile.in conf/{LICENSE,main.cf.default}
322
323 install -p bin/* $RPM_BUILD_ROOT%{_sbindir}
324 install -p libexec/* $RPM_BUILD_ROOT%{_libdir}/postfix
325 ln $RPM_BUILD_ROOT%{_libdir}/postfix/smtp $RPM_BUILD_ROOT%{_libdir}/postfix/lmtp
326 ln $RPM_BUILD_ROOT%{_libdir}/postfix/qmgr $RPM_BUILD_ROOT%{_libdir}/postfix/nqmgr
327 cp -a conf/* $RPM_BUILD_ROOT%{_sysconfdir}/mail
328 sed -e's,^daemon_directory = .*,daemon_directory = %{_libdir}/postfix,' \
329         conf/main.cf > $RPM_BUILD_ROOT%{_sysconfdir}/mail/main.cf
330
331 for f in dns global master util ; do
332         cp -a lib/lib${f}.a $RPM_BUILD_ROOT%{_libdir}/libpostfix-${f}.so.1
333         ln -sf lib${f}.so.1 $RPM_BUILD_ROOT%{_libdir}/libpostfix-${f}.so
334 done
335 install -p lib/dict*.so $RPM_BUILD_ROOT%{_libdir}/postfix
336 cp -a include/*.h $RPM_BUILD_ROOT%{_includedir}/postfix
337
338 cp -a man/man* $RPM_BUILD_ROOT%{_mandir}
339
340 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/mail/aliases
341 install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.daily/postfix
342 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/postfix
343 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/postfix
344 cp -a %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/sasl/smtpd.conf
345 cp -a %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/smtp
346 cp -a %{SOURCE8} $RPM_BUILD_ROOT%{_sysconfdir}/mail/bounce.cf.pl
347 cp -a %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/mail/bounce.cf.de
348 cp -a %{SOURCE10} $RPM_BUILD_ROOT/etc/monit/%{name}.monitrc
349 install -p auxiliary/rmail/rmail $RPM_BUILD_ROOT%{_bindir}/rmail
350 install -p auxiliary/qshape/qshape.pl $RPM_BUILD_ROOT%{_bindir}/qshape
351
352 ln -sf %{_sbindir}/sendmail $RPM_BUILD_ROOT%{_bindir}/mailq
353 ln -sf %{_sbindir}/sendmail $RPM_BUILD_ROOT%{_bindir}/newaliases
354 ln -sf %{_sbindir}/sendmail $RPM_BUILD_ROOT/usr/lib/sendmail
355
356 touch $RPM_BUILD_ROOT%{_sysconfdir}/mail/\
357         {aliases,access,canonical,relocated,transport,virtual}{,.db}
358
359 touch $RPM_BUILD_ROOT/etc/security/blacklist.smtp
360
361 > $RPM_BUILD_ROOT/var/spool/postfix/.nofinger
362
363 %{__rm} -r $RPM_BUILD_ROOT%{_sysconfdir}/mail/makedefs.out
364 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/mail/TLS_LICENSE
365
366 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/mail/{postfix-files,postfix-script,post-install}
367
368 %clean
369 rm -rf $RPM_BUILD_ROOT
370
371 %pre
372 %groupadd -g 62 postfix
373 %groupadd -g 63 maildrop
374 %useradd -u 62 -d /var/spool/postfix -s /bin/false -c "Postfix User" -g postfix postfix
375
376 %post
377 /sbin/ldconfig
378 if ! grep -q "^postmaster:" %{_sysconfdir}/mail/aliases; then
379         echo "Adding Entry for postmaster in %{_sysconfdir}/mail/aliases" >&2
380         echo "postmaster: root" >>%{_sysconfdir}/mail/aliases
381 fi
382 if [ "$1" = "1" ]; then
383         # only on installation, not upgrade; set sane defaults
384         # postfix expects gethostname() to return FQDN, which is obviously wrong
385         if ! grep -qE "^my(domain|hostname)" %{_sysconfdir}/mail/main.cf; then
386                 domain=$(/bin/hostname -d 2>/dev/null)
387                 [ "$domain" != 'localdomain' ] && \
388                         postconf -e mydomain="$domain"
389         fi
390 else
391         %{_sbindir}/postfix upgrade-configuration
392 fi
393
394 %{_bindir}/newaliases
395 /sbin/chkconfig --add postfix
396 %service postfix restart "Postfix Daemon"
397
398 %preun
399 if [ "$1" = "0" ]; then
400         %service postfix stop
401         /sbin/chkconfig --del postfix
402 fi
403
404 %postun
405 /sbin/ldconfig
406 if [ "$1" = "0" ]; then
407         %groupremove maildrop
408         %userremove postfix
409         %groupremove postfix
410 fi
411
412 %files
413 %defattr(644,root,root,755)
414 %doc html COMPATIBILITY HISTORY LICENSE RELEASE_NOTES* TLS_*
415 %doc README_FILES/*README
416 %doc examples/smtpd-policy
417 %dir %{_sysconfdir}/mail
418 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/access
419 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/aliases
420 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/bounce.cf.default
421 %lang(de) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/bounce.cf.de
422 %lang(pl) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/bounce.cf.pl
423 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/canonical
424 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/generic
425 #%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/regexp_table
426 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/relocated
427 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/transport
428 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/virtual
429 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/header_checks
430 #%ghost %{_sysconfdir}/mail/*.db
431 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/dynamicmaps.cf
432 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/main.cf
433 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/master.cf
434 %{_sysconfdir}/mail/postfix-wrapper
435 %{_sysconfdir}/mail/postmulti-script
436 %attr(740,root,root) /etc/cron.daily/postfix
437 %attr(754,root,root) /etc/rc.d/init.d/postfix
438 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/postfix
439 %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/smtp
440 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.smtp
441 %{?with_sasl:%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sasl/smtpd.conf}
442 %attr(755,root,root) %{_libdir}/libpostfix-*.so.*
443 %attr(755,root,root) %{_bindir}/mailq
444 %attr(755,root,root) %{_bindir}/newaliases
445 %attr(755,root,root) %{_bindir}/rmail
446 %attr(755,root,root) %{_sbindir}/s*
447 %attr(755,root,root) %{_sbindir}/postfix
448 %attr(755,root,root) %{_sbindir}/postalias
449 %attr(755,root,root) %{_sbindir}/postkick
450 %attr(755,root,root) %{_sbindir}/postl*
451 %attr(755,root,root) %{_sbindir}/postc*
452 %attr(755,root,root) %{_sbindir}/postmap
453 %attr(755,root,root) %{_sbindir}/postmulti
454 %attr(2755,root,maildrop) %{_sbindir}/postqueue
455 %attr(755,root,root) %{_sbindir}/postsuper
456 %attr(2755,root,maildrop) %{_sbindir}/postdrop
457 %attr(755,root,root) %{_sbindir}/qmqp-sink
458 %attr(755,root,root) %{_sbindir}/qmqp-source
459 %attr(755,root,root) /usr/lib/sendmail
460 %dir %{_libdir}/postfix
461 %attr(755,root,root) %{_libdir}/postfix/[!d]*
462 %attr(755,root,root) %{_libdir}/postfix/discard
463 %attr(755,root,root) %dir %{_var}/spool/postfix
464 %attr(700,postfix,root) %dir %{_var}/spool/postfix/active
465 %attr(700,postfix,root) %dir %{_var}/spool/postfix/bounce
466 %attr(700,postfix,root) %dir %{_var}/spool/postfix/corrupt
467 %attr(700,postfix,root) %dir %{_var}/spool/postfix/defer
468 %attr(700,postfix,root) %dir %{_var}/spool/postfix/deferred
469 %attr(700,postfix,root) %dir %{_var}/spool/postfix/incoming
470 %attr(1730,postfix,maildrop) %dir %{_var}/spool/postfix/maildrop
471 %attr(755,postfix,root) %dir %{_var}/spool/postfix/pid
472 %attr(700,postfix,root) %dir %{_var}/spool/postfix/private
473 %attr(710,postfix,maildrop) %dir %{_var}/spool/postfix/public
474 %attr(700,postfix,root) %dir %{_var}/spool/postfix/saved
475 %attr(644,postfix,root) %{_var}/spool/postfix/.nofinger
476 %attr(700,postfix,root) %{_var}/lib/postfix
477 %{_mandir}/man1/mailq.1*
478 %{_mandir}/man1/newaliases.1*
479 %{_mandir}/man1/post*.1*
480 %{_mandir}/man1/qmqp-*.1*
481 %{_mandir}/man1/sendmail.1*
482 %{_mandir}/man1/smtp-*.1*
483 %{_mandir}/man5/access.5*
484 %{_mandir}/man5/aliases.5*
485 %{_mandir}/man5/body_checks.5*
486 %{_mandir}/man5/bounce.5*
487 %{_mandir}/man5/canonical.5*
488 %{_mandir}/man5/cidr_table.5*
489 %{_mandir}/man5/generic.5*
490 %{_mandir}/man5/header_checks.5*
491 %{_mandir}/man5/master.5*
492 %{_mandir}/man5/nisplus_table.5*
493 %{_mandir}/man5/postconf.5*
494 %{_mandir}/man5/postfix-wrapper.5*
495 %{_mandir}/man5/regexp_table.5*
496 %{_mandir}/man5/relocated.5*
497 %{_mandir}/man5/tcp_table.5*
498 %{_mandir}/man5/transport.5*
499 %{_mandir}/man5/virtual.5*
500 %{_mandir}/man8/*.8*
501
502 %files devel
503 %defattr(644,root,root,755)
504 %attr(755,root,root) %{_libdir}/libpostfix-*.so
505 %{_includedir}/postfix
506
507 %if %{with ldap}
508 %files dict-ldap
509 %defattr(644,root,root,755)
510 %attr(755,root,root) %{_libdir}/postfix/dict_ldap.so
511 %{_mandir}/man5/ldap_table.5*
512 %endif
513
514 %if %{with mysql}
515 %files dict-mysql
516 %defattr(644,root,root,755)
517 %attr(755,root,root) %{_libdir}/postfix/dict_mysql.so
518 %{_mandir}/man5/mysql_table.5*
519 %endif
520
521 %files dict-pcre
522 %defattr(644,root,root,755)
523 %attr(755,root,root) %{_libdir}/postfix/dict_pcre.so
524 #%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/pcre_table
525 %{_mandir}/man5/pcre_table.5*
526
527 %if %{with pgsql}
528 %files dict-pgsql
529 %defattr(644,root,root,755)
530 %attr(755,root,root) %{_libdir}/postfix/dict_pgsql.so
531 %{_mandir}/man5/pgsql_table.5*
532 %endif
533
534 %if %{with sqlite}
535 %files dict-sqlite
536 %defattr(644,root,root,755)
537 %attr(755,root,root) %{_libdir}/postfix/dict_sqlite.so
538 %{_mandir}/man5/sqlite_table.5*
539 %endif
540
541 %files qshape
542 %defattr(644,root,root,755)
543 %attr(755,root,root) %{_bindir}/qshape
544 %{_mandir}/man1/qshape.1*
545
546 %files -n monit-rc-%{name}
547 %defattr(644,root,root,755)
548 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}.monitrc
This page took 0.083694 seconds and 3 git commands to generate.