]> git.pld-linux.org Git - packages/postfix.git/blob - postfix.spec
- updated to 2.9.6
[packages/postfix.git] / postfix.spec
1 #
2 # Conditional build:
3 %bcond_without  ldap    # without LDAP map module
4 %bcond_without  mysql   # without MySQL map module
5 %bcond_without  pgsql   # without PostgreSQL map module
6 %bcond_without  sqlite  # without SQLite map module
7 %bcond_without  sasl    # without SMTP AUTH support
8 %bcond_without  ssl     # without SSL/TLS support
9 %bcond_without  cdb     # without cdb map support
10 %if "%{pld_release}" == "th"
11 %bcond_without  vda     # without VDA patch
12 %else
13 %bcond_with     vda     # with VDA patch
14 %endif
15 %bcond_with     hir     # with Beeth's header_if_reject patch
16 %bcond_with     tcp     # with unofficial tcp: lookup table
17 %if "%{pld_release}" == "ac"
18 %bcond_with             epoll   # enable epoll for 2.6 kernels
19 # there didn't exist x86_64 2.4 kernel in PLD, so can safely enable epoll
20 %ifarch %{x8664}
21 %define         with_epoll      1
22 %endif
23 %else
24 %bcond_without  epoll   # disable epoll for 2.4 kernels
25 %endif
26
27 %define         vda_ver v11-2.9.1
28 Summary:        Postfix Mail Transport Agent
29 Summary(cs.UTF-8):      Postfix - program pro přepravu pošty (MTA)
30 Summary(es.UTF-8):      Postfix - Un MTA (Mail Transport Agent) de alto desempeño
31 Summary(fr.UTF-8):      Agent de transport de courrier Postfix
32 Summary(pl.UTF-8):      Serwer SMTP Postfix
33 Summary(pt_BR.UTF-8):   Postfix - Um MTA (Mail Transport Agent) de alto desempenho
34 Summary(sk.UTF-8):      Agent prenosu pošty Postfix
35 Name:           postfix
36 Version:        2.9.6
37 Release:        1
38 Epoch:          2
39 License:        distributable
40 Group:          Networking/Daemons/SMTP
41 Source0:        ftp://ftp.porcupine.org/mirrors/postfix-release/official/%{name}-%{version}.tar.gz
42 # Source0-md5:  62eba08ce4acfa6b421e8fa88f2422d1
43 Source1:        %{name}.aliases
44 Source2:        %{name}.cron
45 Source3:        %{name}.init
46 Source4:        %{name}.sysconfig
47 Source5:        %{name}.sasl
48 Source6:        %{name}.pamd
49 Source7:        http://vda.sourceforge.net/VDA/%{name}-vda-%{vda_ver}.patch
50 # Source7-md5:  a54a21428de5eeae91b4bb670976e37a
51 Source8:        %{name}-bounce.cf.pl
52 # http://postfix.state-of-mind.de/bounce-templates/bounce.de-DE.cf
53 Source9:        %{name}-bounce.cf.de
54 Source10:       %{name}.monitrc
55 Source11:       %{name}-vda-bigquota.patch
56 #Source11:      http://vda.sourceforge.net/VDA/%{name}-%{vda_ver}-vda-ng-bigquota.patch.gz
57 # -ource11-md5: d46103195b43ec5784ea2c166b238f71
58 Source12:       %{name}.service
59 Patch0:         %{name}-config.patch
60 Patch1:         %{name}-conf_msg.patch
61 Patch2:         %{name}-dynamicmaps.patch
62 Patch3:         %{name}-master.cf_cyrus.patch
63 # from http://akson.sgh.waw.pl/~chopin/unix/postfix-2.1.5-header_if_reject.diff
64 Patch4:         %{name}-header_if_reject.patch
65 Patch5:         %{name}-ident.patch
66 Patch6:         %{name}-lib64.patch
67 Patch7:         %{name}-conf.patch
68 Patch8:         %{name}-dictname.patch
69 Patch9:         %{name}-make-jN.patch
70 Patch10:        %{name}-link.patch
71 Patch11:        %{name}-scache_clnt.patch
72 Patch12:        format-security.patch
73 URL:            http://www.postfix.org/
74 %{?with_sasl:BuildRequires:     cyrus-sasl-devel}
75 BuildRequires:  db-devel
76 # getifaddrs() with IPv6 support
77 BuildRequires:  glibc-devel >= 6:2.3.4
78 %{?with_mysql:BuildRequires:    mysql-devel}
79 %{?with_ldap:BuildRequires:     openldap-devel >= 2.0.12}
80 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.7l}
81 BuildRequires:  pcre-devel
82 BuildRequires:  perl-base
83 %{?with_pgsql:BuildRequires:    postgresql-devel}
84 BuildRequires:  rpm >= 4.4.9-56
85 BuildRequires:  rpmbuild(macros) >= 1.644
86 BuildRequires:  sed >= 4.0
87 %{?with_sqlite:BuildRequires:   sqlite3-devel}
88 %{?with_cdb:BuildRequires:      tinycdb-devel}
89 %{?with_mysql:BuildRequires:    zlib-devel}
90 Requires(post): /bin/hostname
91 Requires(post,postun):  /sbin/ldconfig
92 Requires(post,preun):   /sbin/chkconfig
93 Requires(postun):       /usr/sbin/groupdel
94 Requires(postun):       /usr/sbin/userdel
95 Requires(pre):  /bin/id
96 Requires(pre):  /usr/bin/getgid
97 Requires(pre):  /usr/sbin/groupadd
98 Requires(pre):  /usr/sbin/useradd
99 Requires:       /sbin/chkconfig
100 Requires:       diffutils
101 Requires:       findutils
102 Requires:       rc-scripts
103 Requires:       sed
104 %{?with_cdb:Requires:tinycdb}
105 Requires:       systemd-units >= 38
106 Suggests:       cyrus-sasl-saslauthd
107 Provides:       group(postfix)
108 Provides:       smtpdaemon
109 Provides:       user(postfix)
110 Obsoletes:      smtpdaemon
111 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
112
113 %description
114 Postfix is attempt to provide an alternative to the widely-used
115 Sendmail program. Postfix attempts to be fast, easy to administer, and
116 hopefully secure, while at the same time being sendmail compatible
117 enough to not upset your users. This version has IPv6 support.
118
119 %description -l es.UTF-8
120 Postfix es una alternativa para el mundialmente utilizado sendmail. Si
121 desea tener un servidor SMTP *rápido*, debe instalar este paquete.
122
123 %description -l fr.UTF-8
124 Postfix (voir http://www.postfix.org/) se veut une alternative à
125 sendmail, responsable de l'acheminement de 70% des courriers
126 électroniques sur Internet. IBM en a suppotré le développement, mais
127 ne contrôle pas son évolution. Le but est d'installer Postfix sur le
128 plus grand nombre de systèmes possible. Dans cette optique, il a été
129 écrit pour être totalement sous le contrôle de l'utilisateur.
130
131 %description -l it.UTF-8
132 Postfix (http://www.postfix.org/) e' un'alternativa al programma
133 sendmail utilizzato per la gestione del 70 per cento della posta
134 Internet.
135
136 Seppur IBM supporti lo sviluppo di Postfix, non controlla la sua
137 evoluzione.
138
139 Consultate la pagine web http://www.moongroup.com/how-to.phtml nella
140 quale troverete le indicazioni per una corretta installazione e
141 configurazione di questo programma.
142
143 %description -l pl.UTF-8
144 Postfix jest próbą dostarczenia alternatywnego MTA w stosunku do
145 szeroko używanego sendmaila. Postfix w zamierzeniu ma być szybki,
146 łatwy w administrowaniu, bezpieczny oraz ma być na tyle kompatybilny z
147 sendmailem by nie denerwować użytkowników. Ta wersja obsługuje IPv6.
148
149 %description -l pt_BR.UTF-8
150 O Postfix é uma alternativa para o mundialmente utilizado sendmail. Se
151 você deseja um servidor SMTP *rápido*, instale este pacote.
152
153 %description -l sk.UTF-8
154 Postfix (pozri http://www.postfix.org/) má za cieľ byť alternatívou k
155 široko rozšírenému programu sendmail, zodpovednému za 70% všetkej
156 elektronickej pošty doručenej na Internete.
157
158 Aj keď IBM podporovala vývoj Postfixu, zdržiava sa vplyvu na jeho
159 vývoj. Cieľom je inštalácia Postfixu na čo najväčšom počte systémov.
160 Do tohoto momentu je softvér poskytovaný bez ovplyvňovania, takže sa
161 môže vyvíjať podľa jeho používateľov.
162
163 Určite si prečítajte http://www.moongroup.com/how-to.phtml, kde sú
164 popísané kroky potrebné pred a po inštalácii Postfixu.
165
166 %package devel
167 Summary:        Postfix loadable modules development package
168 Summary(pl.UTF-8):      Pakiet dla programistów ładowanych modułów do postfiksa
169 Group:          Development/Libraries
170 Requires:       %{name} = %{epoch}:%{version}-%{release}
171
172 %description devel
173 Header files to build additional map types for Postfix.
174
175 %description devel -l pl.UTF-8
176 Pliki nagłówkowe do tworzenia dodatkowych typów map dla Postfiksa.
177
178 %package dict-ldap
179 Summary:        LDAP map support for Postfix
180 Summary(pl.UTF-8):      Obsługa map LDAP dla Postfiksa
181 Group:          Networking/Daemons/SMTP
182 Requires:       %{name} = %{epoch}:%{version}-%{release}
183 Requires:       openldap >= 2.3.6
184
185 %description dict-ldap
186 This package provides support for LDAP maps in Postfix.
187
188 %description dict-ldap -l pl.UTF-8
189 Ten pakiet dodaje obsługę map LDAP do Postfiksa.
190
191 %package dict-mysql
192 Summary:        MySQL map support for Postfix
193 Summary(pl.UTF-8):      Obsługa map MySQL dla Postfiksa
194 Group:          Networking/Daemons/SMTP
195 Requires:       %{name} = %{epoch}:%{version}-%{release}
196
197 %description dict-mysql
198 This package provides support for MySQL maps in Postfix.
199
200 %description dict-mysql -l pl.UTF-8
201 Ten pakiet dodaje obsługę map MySQL do Postfiksa.
202
203 %package dict-pcre
204 Summary:        PCRE map support for Postfix
205 Summary(pl.UTF-8):      Obsługa map PCRE dla Postfiksa
206 Group:          Networking/Daemons/SMTP
207 Requires:       %{name} = %{epoch}:%{version}-%{release}
208
209 %description dict-pcre
210 This package provides support for PCRE maps in Postfix.
211
212 %description dict-pcre -l pl.UTF-8
213 Ten pakiet dodaje obsługę map PCRE do Postfiksa.
214
215 %package dict-pgsql
216 Summary:        PostgreSQL map support for Postfix
217 Summary(pl.UTF-8):      Obsługa map PostgreSQL dla Postfiksa
218 Group:          Networking/Daemons/SMTP
219 Requires:       %{name} = %{epoch}:%{version}-%{release}
220
221 %description dict-pgsql
222 This package provides support for PostgreSQL maps in Postfix.
223
224 %description dict-pgsql -l pl.UTF-8
225 Ten pakiet dodaje obsługę map PostgreSQL do Postfiksa.
226
227 %package dict-sqlite
228 Summary:        SQLite map support for Postfix
229 Summary(pl.UTF-8):      Obsługa map SQLite dla Postfiksa
230 Group:          Networking/Daemons/SMTP
231 Requires:       %{name} = %{epoch}:%{version}-%{release}
232
233 %description dict-sqlite
234 This package provides support for SQLite maps in Postfix.
235
236 %description dict-sqlite -l pl.UTF-8
237 Ten pakiet dodaje obsługę map SQLite do Postfiksa.
238
239 %package qshape
240 Summary:        qshape - Print Postfix queue domain and age distribution
241 Summary(pl.UTF-8):      qshape - wypisywanie rozkładu domen i wieku z kolejki Postfiksa
242 Group:          Networking/Daemons/SMTP
243 Requires:       %{name} = %{epoch}:%{version}-%{release}
244
245 %description qshape
246 The qshape program helps the administrator understand the Postfix
247 queue message distribution in time and by sender domain or recipient
248 domain. The program needs read access to the queue directories and
249 queue files, so it must run as the superuser or the mail_owner
250 specified in main.cf (typically postfix).
251
252 %description qshape -l pl.UTF-8
253 Program qshape pomaga administratorowi zrozumieć rozkład kolejki
254 wiadomości Postfiksa w czasie i w zależności od domeny nadawcy lub
255 adresata. Program wymaga prawa odczytu do katalogów kolejki i plików
256 kolejki, więc musi być uruchamiany przez superużytkownika lub
257 użytkownika mail_owner podanego w main.cf (zwykle nazywającego się
258 postfix).
259
260 %package -n monit-rc-%{name}
261 Summary:        monit support for Postfix
262 Summary(pl.UTF-8):      Wsparcie monita dla Postfiksa
263 Group:          Applications/System
264 Requires:       %{name} = %{epoch}:%{version}-%{release}
265 Requires:       monit
266
267 %description -n monit-rc-%{name}
268 monitrc file for monitoring Postfix.
269
270 %description -n monit-rc-%{name} -l pl.UTF-8
271 Plik monitrc do monitorowania serwera Postfix.
272
273 %prep
274 %setup -q
275 %if %{with vda}
276 cat %{SOURCE7} | %{__patch} -p1 -s
277 cat %{SOURCE11} | %{__patch} -p1 -s
278 %endif
279
280 find -type f | xargs sed -i -e 's|/etc/postfix|/etc/mail|g'
281
282 %patch0 -p1
283 %patch1 -p0
284 %patch2 -p1
285 %patch3 -p1
286 %{?with_hir:%patch4 -p0}
287 %patch5 -p1
288 sed -i '/scache_clnt_create/s/server/var_scache_service/' src/global/scache_clnt.c
289 %if "%{_lib}" == "lib64"
290 %patch6 -p1
291 %endif
292 %patch7 -p1
293 %patch8 -p1
294 %patch9 -p1
295 %patch10 -p1
296 %patch11 -p1
297 %if %{with vda}
298 %patch12 -p1
299 %endif
300
301 %if %{with tcp}
302 sed -i 's/ifdef SNAPSHOT/if 1/' src/util/dict_open.c
303 %endif
304
305 %build
306 %{__make} -f Makefile.init makefiles
307 %{__make} tidy
308 CC="%{__cc}"
309 export CC
310 %{__make} \
311         DEBUG="" \
312         OPT="%{rpmcflags} %{rpmcppflags} -D_FILE_OFFSET_BITS=64" \
313         %{!?with_ldap:LDAPSO=""} \
314         %{!?with_mysql:MYSQLSO=""} \
315         %{!?with_pgsql:PGSQLSO=""} \
316         CCARGS="%{!?with_epoll:-DNO_EPOLL} %{?with_ldap:-DHAS_LDAP} -DHAS_PCRE %{?with_sasl:-DUSE_SASL_AUTH -DUSE_CYRUS_SASL -I/usr/include/sasl} %{?with_mysql:-DHAS_MYSQL -I/usr/include/mysql} %{?with_pgsql:-DHAS_PGSQL} %{?with_ssl:-DUSE_TLS} -DMAX_DYNAMIC_MAPS %{?with_cdb:-DHAS_CDB}" \
317         AUXLIBS="-ldb -lresolv %{?with_sasl:-lsasl} %{?with_ssl:-lssl -lcrypto} %{?with_cdb:-lcdb} -lpcre"
318
319 %install
320 rm -rf $RPM_BUILD_ROOT
321 install -d $RPM_BUILD_ROOT/etc/{cron.daily,rc.d/init.d,sysconfig,pam.d,security,monit} \
322         $RPM_BUILD_ROOT%{_sysconfdir}/{mail,sasl} \
323         $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_libdir}/postfix,/usr/lib}\
324         $RPM_BUILD_ROOT{%{_includedir}/postfix,%{_mandir}} \
325         $RPM_BUILD_ROOT%{_var}/spool/postfix/{active,corrupt,deferred,maildrop,private,saved,bounce,defer,incoming,pid,public} \
326         $RPM_BUILD_ROOT%{_var}/lib/postfix \
327         $RPM_BUILD_ROOT%{systemdunitdir}
328
329 %{__rm} html/Makefile.in conf/{LICENSE,main.cf.default}
330
331 install -p bin/* $RPM_BUILD_ROOT%{_sbindir}
332 install -p libexec/* $RPM_BUILD_ROOT%{_libdir}/postfix
333 ln $RPM_BUILD_ROOT%{_libdir}/postfix/smtp $RPM_BUILD_ROOT%{_libdir}/postfix/lmtp
334 ln $RPM_BUILD_ROOT%{_libdir}/postfix/qmgr $RPM_BUILD_ROOT%{_libdir}/postfix/nqmgr
335 cp -a conf/* $RPM_BUILD_ROOT%{_sysconfdir}/mail
336 sed -e's,^daemon_directory = .*,daemon_directory = %{_libdir}/postfix,' \
337         conf/main.cf > $RPM_BUILD_ROOT%{_sysconfdir}/mail/main.cf
338
339 for f in dns global master util ; do
340         cp -a lib/lib${f}.a $RPM_BUILD_ROOT%{_libdir}/libpostfix-${f}.so.1
341         ln -sf lib${f}.so.1 $RPM_BUILD_ROOT%{_libdir}/libpostfix-${f}.so
342 done
343 install -p lib/dict*.so $RPM_BUILD_ROOT%{_libdir}/postfix
344 cp -a include/*.h $RPM_BUILD_ROOT%{_includedir}/postfix
345
346 cp -a man/man* $RPM_BUILD_ROOT%{_mandir}
347
348 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/mail/aliases
349 install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.daily/postfix
350 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/postfix
351 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/postfix
352 cp -a %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/sasl/smtpd.conf
353 cp -a %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/smtp
354 cp -a %{SOURCE8} $RPM_BUILD_ROOT%{_sysconfdir}/mail/bounce.cf.pl
355 cp -a %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/mail/bounce.cf.de
356 cp -a %{SOURCE10} $RPM_BUILD_ROOT/etc/monit/%{name}.monitrc
357 cp -a %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/%{name}.service
358 install -p auxiliary/rmail/rmail $RPM_BUILD_ROOT%{_bindir}/rmail
359 install -p auxiliary/qshape/qshape.pl $RPM_BUILD_ROOT%{_bindir}/qshape
360
361 ln -sf %{_sbindir}/sendmail $RPM_BUILD_ROOT%{_bindir}/mailq
362 ln -sf %{_sbindir}/sendmail $RPM_BUILD_ROOT%{_bindir}/newaliases
363 ln -sf %{_sbindir}/sendmail $RPM_BUILD_ROOT/usr/lib/sendmail
364
365 touch $RPM_BUILD_ROOT%{_sysconfdir}/mail/\
366         {aliases,access,canonical,relocated,transport,virtual}{,.db}
367
368 touch $RPM_BUILD_ROOT/etc/security/blacklist.smtp
369
370 > $RPM_BUILD_ROOT/var/spool/postfix/.nofinger
371
372 %{__rm} -r $RPM_BUILD_ROOT%{_sysconfdir}/mail/makedefs.out
373 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/mail/TLS_LICENSE
374
375 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/mail/{postfix-files,postfix-script,post-install}
376
377 %clean
378 rm -rf $RPM_BUILD_ROOT
379
380 %pre
381 %groupadd -g 62 postfix
382 %groupadd -g 63 maildrop
383 %useradd -u 62 -d /var/spool/postfix -s /bin/false -c "Postfix User" -g postfix postfix
384
385 %post
386 /sbin/ldconfig
387 if ! grep -q "^postmaster:" %{_sysconfdir}/mail/aliases; then
388         echo "Adding Entry for postmaster in %{_sysconfdir}/mail/aliases" >&2
389         echo "postmaster: root" >>%{_sysconfdir}/mail/aliases
390 fi
391 if [ "$1" = "1" ]; then
392         # only on installation, not upgrade; set sane defaults
393         # postfix expects gethostname() to return FQDN, which is obviously wrong
394         if ! grep -qE "^my(domain|hostname)" %{_sysconfdir}/mail/main.cf; then
395                 domain=$(/bin/hostname -d 2>/dev/null)
396                 [ -n "$domain" -a "$domain" != 'localdomain' ] && \
397                         postconf -e mydomain="$domain"
398         fi
399 else
400         %{_sbindir}/postfix upgrade-configuration
401 fi
402
403 %{_bindir}/newaliases
404 /sbin/chkconfig --add postfix
405 %service postfix restart "Postfix Daemon"
406 %systemd_post
407
408 %preun
409 if [ "$1" = "0" ]; then
410         %service postfix stop
411         /sbin/chkconfig --del postfix
412 fi
413 %systemd_preun
414
415 %postun
416 /sbin/ldconfig
417 if [ "$1" = "0" ]; then
418         %groupremove maildrop
419         %userremove postfix
420         %groupremove postfix
421 fi
422 %systemd_postun
423
424 %files
425 %defattr(644,root,root,755)
426 %doc html COMPATIBILITY HISTORY LICENSE RELEASE_NOTES* TLS_*
427 %doc README_FILES/*README
428 %doc examples/smtpd-policy
429 %dir %{_sysconfdir}/mail
430 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/access
431 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/aliases
432 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/bounce.cf.default
433 %lang(de) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/bounce.cf.de
434 %lang(pl) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/bounce.cf.pl
435 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/canonical
436 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/generic
437 #%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/regexp_table
438 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/relocated
439 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/transport
440 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/virtual
441 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/header_checks
442 #%ghost %{_sysconfdir}/mail/*.db
443 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/dynamicmaps.cf
444 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/main.cf
445 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/master.cf
446 %{_sysconfdir}/mail/postfix-wrapper
447 %{_sysconfdir}/mail/postmulti-script
448 %attr(740,root,root) /etc/cron.daily/postfix
449 %attr(754,root,root) /etc/rc.d/init.d/postfix
450 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/postfix
451 %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/smtp
452 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.smtp
453 %{?with_sasl:%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sasl/smtpd.conf}
454 %attr(755,root,root) %{_libdir}/libpostfix-*.so.*
455 %attr(755,root,root) %{_bindir}/mailq
456 %attr(755,root,root) %{_bindir}/newaliases
457 %attr(755,root,root) %{_bindir}/rmail
458 %attr(755,root,root) %{_sbindir}/s*
459 %attr(755,root,root) %{_sbindir}/postfix
460 %attr(755,root,root) %{_sbindir}/postalias
461 %attr(755,root,root) %{_sbindir}/postkick
462 %attr(755,root,root) %{_sbindir}/postl*
463 %attr(755,root,root) %{_sbindir}/postc*
464 %attr(755,root,root) %{_sbindir}/postmap
465 %attr(755,root,root) %{_sbindir}/postmulti
466 %attr(2755,root,maildrop) %{_sbindir}/postqueue
467 %attr(755,root,root) %{_sbindir}/postsuper
468 %attr(2755,root,maildrop) %{_sbindir}/postdrop
469 %attr(755,root,root) %{_sbindir}/qmqp-sink
470 %attr(755,root,root) %{_sbindir}/qmqp-source
471 %attr(755,root,root) /usr/lib/sendmail
472 %dir %{_libdir}/postfix
473 %attr(755,root,root) %{_libdir}/postfix/[!d]*
474 %attr(755,root,root) %{_libdir}/postfix/discard
475 %attr(755,root,root) %{_libdir}/postfix/dnsblog
476 %attr(755,root,root) %dir %{_var}/spool/postfix
477 %attr(700,postfix,root) %dir %{_var}/spool/postfix/active
478 %attr(700,postfix,root) %dir %{_var}/spool/postfix/bounce
479 %attr(700,postfix,root) %dir %{_var}/spool/postfix/corrupt
480 %attr(700,postfix,root) %dir %{_var}/spool/postfix/defer
481 %attr(700,postfix,root) %dir %{_var}/spool/postfix/deferred
482 %attr(700,postfix,root) %dir %{_var}/spool/postfix/incoming
483 %attr(1730,postfix,maildrop) %dir %{_var}/spool/postfix/maildrop
484 %attr(755,postfix,root) %dir %{_var}/spool/postfix/pid
485 %attr(700,postfix,root) %dir %{_var}/spool/postfix/private
486 %attr(710,postfix,maildrop) %dir %{_var}/spool/postfix/public
487 %attr(700,postfix,root) %dir %{_var}/spool/postfix/saved
488 %attr(644,postfix,root) %{_var}/spool/postfix/.nofinger
489 %attr(700,postfix,root) %{_var}/lib/postfix
490 %{_mandir}/man1/mailq.1*
491 %{_mandir}/man1/newaliases.1*
492 %{_mandir}/man1/post*.1*
493 %{_mandir}/man1/qmqp-*.1*
494 %{_mandir}/man1/sendmail.1*
495 %{_mandir}/man1/smtp-*.1*
496 %{_mandir}/man5/access.5*
497 %{_mandir}/man5/aliases.5*
498 %{_mandir}/man5/body_checks.5*
499 %{_mandir}/man5/bounce.5*
500 %{_mandir}/man5/canonical.5*
501 %{_mandir}/man5/cidr_table.5*
502 %{_mandir}/man5/generic.5*
503 %{_mandir}/man5/header_checks.5*
504 %{_mandir}/man5/master.5*
505 %{_mandir}/man5/memcache_table.5*
506 %{_mandir}/man5/nisplus_table.5*
507 %{_mandir}/man5/postconf.5*
508 %{_mandir}/man5/postfix-wrapper.5*
509 %{_mandir}/man5/regexp_table.5*
510 %{_mandir}/man5/relocated.5*
511 %{_mandir}/man5/tcp_table.5*
512 %{_mandir}/man5/transport.5*
513 %{_mandir}/man5/virtual.5*
514 %{_mandir}/man8/*.8*
515 %{systemdunitdir}/%{name}.service
516
517 %files devel
518 %defattr(644,root,root,755)
519 %attr(755,root,root) %{_libdir}/libpostfix-*.so
520 %{_includedir}/postfix
521
522 %if %{with ldap}
523 %files dict-ldap
524 %defattr(644,root,root,755)
525 %attr(755,root,root) %{_libdir}/postfix/dict_ldap.so
526 %{_mandir}/man5/ldap_table.5*
527 %endif
528
529 %if %{with mysql}
530 %files dict-mysql
531 %defattr(644,root,root,755)
532 %attr(755,root,root) %{_libdir}/postfix/dict_mysql.so
533 %{_mandir}/man5/mysql_table.5*
534 %endif
535
536 %files dict-pcre
537 %defattr(644,root,root,755)
538 %attr(755,root,root) %{_libdir}/postfix/dict_pcre.so
539 #%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/pcre_table
540 %{_mandir}/man5/pcre_table.5*
541
542 %if %{with pgsql}
543 %files dict-pgsql
544 %defattr(644,root,root,755)
545 %attr(755,root,root) %{_libdir}/postfix/dict_pgsql.so
546 %{_mandir}/man5/pgsql_table.5*
547 %endif
548
549 %if %{with sqlite}
550 %files dict-sqlite
551 %defattr(644,root,root,755)
552 %attr(755,root,root) %{_libdir}/postfix/dict_sqlite.so
553 %{_mandir}/man5/sqlite_table.5*
554 %endif
555
556 %files qshape
557 %defattr(644,root,root,755)
558 %attr(755,root,root) %{_bindir}/qshape
559 %{_mandir}/man1/qshape.1*
560
561 %files -n monit-rc-%{name}
562 %defattr(644,root,root,755)
563 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}.monitrc
This page took 0.097185 seconds and 3 git commands to generate.