]> git.pld-linux.org Git - packages/postfix.git/blob - postfix.spec
2b1e1221e03dd224cea432acaa708ed4a980caa1
[packages/postfix.git] / postfix.spec
1 #
2 # Conditional build:
3 %bcond_without  ldap    # without LDAP map module
4 %bcond_without  mysql   # without MySQL map module
5 %bcond_without  pgsql   # without PostgreSQL map module
6 %bcond_without  sasl    # without SMTP AUTH support
7 %bcond_without  ssl     # without SSL/TLS support
8 %bcond_without  cdb     # without cdb map support
9 %if "%{pld_release}" == "th"
10 %bcond_without  vda     # without VDA patch
11 %else
12 %bcond_with     vda     # with VDA patch
13 %endif
14 %bcond_with     hir     # with Beeth's header_if_reject patch
15 %bcond_with     tcp     # with unofficial tcp: lookup table
16 %if "%{pld_release}" == "ac"
17 %bcond_with             epoll   # enable epoll for 2.6 kernels
18 # there didn't exist x86_64 2.4 kernel in PLD, so can safely enable epoll
19 %ifarch %{x8664}
20 %define         with_epoll      1
21 %endif
22 %else
23 %bcond_without  epoll   # disable epoll for 2.4 kernels
24 %endif
25
26 %define         vda_ver 2.7.0
27 Summary:        Postfix Mail Transport Agent
28 Summary(cs.UTF-8):      Postfix - program pro přepravu pošty (MTA)
29 Summary(es.UTF-8):      Postfix - Un MTA (Mail Transport Agent) de alto desempeño
30 Summary(fr.UTF-8):      Agent de transport de courrier Postfix
31 Summary(pl.UTF-8):      Serwer SMTP Postfix
32 Summary(pt_BR.UTF-8):   Postfix - Um MTA (Mail Transport Agent) de alto desempenho
33 Summary(sk.UTF-8):      Agent prenosu pošty Postfix
34 Name:           postfix
35 Version:        2.7.0
36 Release:        1
37 Epoch:          2
38 License:        distributable
39 Group:          Networking/Daemons/SMTP
40 Source0:        ftp://ftp.porcupine.org/mirrors/postfix-release/official/%{name}-%{version}.tar.gz
41 # Source0-md5:  df648f59421604e895cce56325f00bae
42 Source1:        %{name}.aliases
43 Source2:        %{name}.cron
44 Source3:        %{name}.init
45 Source4:        %{name}.sysconfig
46 Source5:        %{name}.sasl
47 Source6:        %{name}.pamd
48 Source7:        http://vda.sourceforge.net/VDA/%{name}-vda-%{vda_ver}.patch
49 # Source7-md5:  f73d119fc9e00f31f23599176554e763
50 Source8:        %{name}-bounce.cf.pl
51 # http://postfix.state-of-mind.de/bounce-templates/bounce.de-DE.cf
52 Source9:        %{name}-bounce.cf.de
53 Source10:       %{name}.monitrc
54 Source11:       postfix-vda-bigquota.patch
55 #Source11:      http://vda.sourceforge.net/VDA/%{name}-%{vda_ver}-vda-ng-bigquota.patch.gz
56 # -ource11-md5: d46103195b43ec5784ea2c166b238f71
57 Patch0:         %{name}-config.patch
58 Patch1:         %{name}-conf_msg.patch
59 Patch2:         %{name}-dynamicmaps.patch
60 Patch3:         %{name}-master.cf_cyrus.patch
61 # from http://akson.sgh.waw.pl/~chopin/unix/postfix-2.1.5-header_if_reject.diff
62 Patch4:         %{name}-header_if_reject.patch
63 Patch5:         %{name}-log-proxy-rejects.patch
64 Patch6:         %{name}-ident.patch
65 Patch7:         %{name}-lib64.patch
66 Patch8:         %{name}-conf.patch
67 Patch9:         %{name}-dictname.patch
68 Patch10:        %{name}-make-jN.patch
69 URL:            http://www.postfix.org/
70 %{?with_sasl:BuildRequires:     cyrus-sasl-devel}
71 BuildRequires:  db-devel
72 # getifaddrs() with IPv6 support
73 BuildRequires:  glibc-devel >= 6:2.3.4
74 %{?with_mysql:BuildRequires:    mysql-devel}
75 %{?with_ldap:BuildRequires:     openldap-devel >= 2.0.12}
76 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.7l}
77 BuildRequires:  pcre-devel
78 BuildRequires:  perl-base
79 %{?with_pgsql:BuildRequires:    postgresql-devel}
80 BuildRequires:  rpm >= 4.4.9-56
81 BuildRequires:  rpmbuild(macros) >= 1.268
82 BuildRequires:  sed >= 4.0
83 %{?with_cdb:BuildRequires:      tinycdb-devel}
84 %{?with_mysql:BuildRequires:    zlib-devel}
85 Requires(post): /bin/hostname
86 Requires(post,postun):  /sbin/ldconfig
87 Requires(post,preun):   /sbin/chkconfig
88 Requires(postun):       /usr/sbin/groupdel
89 Requires(postun):       /usr/sbin/userdel
90 Requires(pre):  /bin/id
91 Requires(pre):  /usr/bin/getgid
92 Requires(pre):  /usr/sbin/groupadd
93 Requires(pre):  /usr/sbin/useradd
94 Requires:       /sbin/chkconfig
95 Requires:       diffutils
96 Requires:       findutils
97 Requires:       rc-scripts
98 Requires:       sed
99 %{?with_cdb:Requires:tinycdb}
100 Suggests:       cyrus-sasl-saslauthd
101 Provides:       group(postfix)
102 Provides:       smtpdaemon
103 Provides:       user(postfix)
104 Obsoletes:      smtpdaemon
105 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
106
107 %description
108 Postfix is attempt to provide an alternative to the widely-used
109 Sendmail program. Postfix attempts to be fast, easy to administer, and
110 hopefully secure, while at the same time being sendmail compatible
111 enough to not upset your users. This version has IPv6 support.
112
113 %description -l es.UTF-8
114 Postfix es una alternativa para el mundialmente utilizado sendmail. Si
115 desea tener un servidor SMTP *rápido*, debe instalar este paquete.
116
117 %description -l fr.UTF-8
118 Postfix (voir http://www.postfix.org/) se veut une alternative à
119 sendmail, responsable de l'acheminement de 70% des courriers
120 électroniques sur Internet. IBM en a suppotré le développement, mais
121 ne contrôle pas son évolution. Le but est d'installer Postfix sur le
122 plus grand nombre de systèmes possible. Dans cette optique, il a été
123 écrit pour être totalement sous le contrôle de l'utilisateur.
124
125 %description -l it.UTF-8
126 Postfix (http://www.postfix.org/) e' un'alternativa al programma
127 sendmail utilizzato per la gestione del 70 per cento della posta
128 Internet.
129
130 Seppur IBM supporti lo sviluppo di Postfix, non controlla la sua
131 evoluzione.
132
133 Consultate la pagine web http://www.moongroup.com/how-to.phtml nella
134 quale troverete le indicazioni per una corretta installazione e
135 configurazione di questo programma.
136
137 %description -l pl.UTF-8
138 Postfix jest próbą dostarczenia alternatywnego MTA w stosunku do
139 szeroko używanego sendmaila. Postfix w zamierzeniu ma być szybki,
140 łatwy w administrowaniu, bezpieczny oraz ma być na tyle kompatybilny z
141 sendmailem by nie denerwować użytkowników. Ta wersja obsługuje IPv6.
142
143 %description -l pt_BR.UTF-8
144 O Postfix é uma alternativa para o mundialmente utilizado sendmail. Se
145 você deseja um servidor SMTP *rápido*, instale este pacote.
146
147 %description -l sk.UTF-8
148 Postfix (pozri http://www.postfix.org/) má za cieľ byť alternatívou k
149 široko rozšírenému programu sendmail, zodpovednému za 70% všetkej
150 elektronickej pošty doručenej na Internete.
151
152 Aj keď IBM podporovala vývoj Postfixu, zdržiava sa vplyvu na jeho
153 vývoj. Cieľom je inštalácia Postfixu na čo najväčšom počte systémov.
154 Do tohoto momentu je softvér poskytovaný bez ovplyvňovania, takže sa
155 môže vyvíjať podľa jeho používateľov.
156
157 Určite si prečítajte http://www.moongroup.com/how-to.phtml, kde sú
158 popísané kroky potrebné pred a po inštalácii Postfixu.
159
160 %package devel
161 Summary:        Postfix loadable modules development package
162 Summary(pl.UTF-8):      Pakiet dla programistów ładowanych modułów do postfiksa
163 Group:          Development/Libraries
164 Requires:       %{name} = %{epoch}:%{version}-%{release}
165
166 %description devel
167 Header files to build additional map types for Postfix.
168
169 %description devel -l pl.UTF-8
170 Pliki nagłówkowe do tworzenia dodatkowych typów map dla Postfiksa.
171
172 %package dict-ldap
173 Summary:        LDAP map support for Postfix
174 Summary(pl.UTF-8):      Obsługa map LDAP dla Postfiksa
175 Group:          Networking/Daemons/SMTP
176 Requires:       %{name} = %{epoch}:%{version}-%{release}
177 Requires:       openldap >= 2.3.6
178
179 %description dict-ldap
180 This package provides support for LDAP maps in Postfix.
181
182 %description dict-ldap -l pl.UTF-8
183 Ten pakiet dodaje obsługę map LDAP do Postfiksa.
184
185 %package dict-mysql
186 Summary:        MySQL map support for Postfix
187 Summary(pl.UTF-8):      Obsługa map MySQL dla Postfiksa
188 Group:          Networking/Daemons/SMTP
189 Requires:       %{name} = %{epoch}:%{version}-%{release}
190
191 %description dict-mysql
192 This package provides support for MySQL maps in Postfix.
193
194 %description dict-mysql -l pl.UTF-8
195 Ten pakiet dodaje obsługę map MySQL do Postfiksa.
196
197 %package dict-pcre
198 Summary:        PCRE map support for Postfix
199 Summary(pl.UTF-8):      Obsługa map PCRE dla Postfiksa
200 Group:          Networking/Daemons/SMTP
201 Requires:       %{name} = %{epoch}:%{version}-%{release}
202
203 %description dict-pcre
204 This package provides support for PCRE maps in Postfix.
205
206 %description dict-pcre -l pl.UTF-8
207 Ten pakiet dodaje obsługę map PCRE do Postfiksa.
208
209 %package dict-pgsql
210 Summary:        PostgreSQL map support for Postfix
211 Summary(pl.UTF-8):      Obsługa map PostgreSQL dla Postfiksa
212 Group:          Networking/Daemons/SMTP
213 Requires:       %{name} = %{epoch}:%{version}-%{release}
214
215 %description dict-pgsql
216 This package provides support for PostgreSQL maps in Postfix.
217
218 %description dict-pgsql -l pl.UTF-8
219 Ten pakiet dodaje obsługę map PostgreSQL do Postfiksa.
220
221 %package qshape
222 Summary:        qshape - Print Postfix queue domain and age distribution
223 Summary(pl.UTF-8):      qshape - wypisywanie rozkładu domen i wieku z kolejki Postfiksa
224 Group:          Networking/Daemons/SMTP
225 Requires:       %{name} = %{epoch}:%{version}-%{release}
226
227 %description qshape
228 The qshape program helps the administrator understand the Postfix
229 queue message distribution in time and by sender domain or recipient
230 domain. The program needs read access to the queue directories and
231 queue files, so it must run as the superuser or the mail_owner
232 specified in main.cf (typically postfix).
233
234 %description qshape -l pl.UTF-8
235 Program qshape pomaga administratorowi zrozumieć rozkład kolejki
236 wiadomości Postfiksa w czasie i w zależności od domeny nadawcy lub
237 adresata. Program wymaga prawa odczytu do katalogów kolejki i plików
238 kolejki, więc musi być uruchamiany przez superużytkownika lub
239 użytkownika mail_owner podanego w main.cf (zwykle nazywającego się
240 postfix).
241
242 %package -n monit-rc-%{name}
243 Summary:        monit support for Postfix
244 Summary(pl.UTF-8):      Wsparcie monita dla Postfiksa
245 Group:          Applications/System
246 Requires:       %{name} = %{epoch}:%{version}-%{release}
247 Requires:       monit
248
249 %description -n monit-rc-%{name}
250 monitrc file for monitoring Postfix.
251
252 %description -n monit-rc-%{name} -l pl.UTF-8
253 Plik monitrc do monitorowania serwera Postfix.
254
255 %prep
256 %setup -q
257 %if %{with vda}
258 cat %{SOURCE7} | %{__patch} -p1 -s
259 cat %{SOURCE11} | %{__patch} -p1 -s
260 %endif
261
262 find -type f | xargs sed -i -e 's|/etc/postfix|/etc/mail|g'
263
264 %patch0 -p1
265 %patch1 -p0
266 %patch2 -p1
267 %patch3 -p1
268 %{?with_hir:%patch4 -p0}
269 %patch5 -p1
270 %patch6 -p1
271 sed -i '/scache_clnt_create/s/server/var_scache_service/' src/global/scache_clnt.c
272 %if "%{_lib}" == "lib64"
273 %patch7 -p1
274 %endif
275 %patch8 -p1
276 %patch9 -p1
277 %patch10 -p1
278
279 %if %{with tcp}
280 sed -i 's/ifdef SNAPSHOT/if 1/' src/util/dict_open.c
281 %endif
282
283 %build
284 %{__make} -f Makefile.init makefiles
285 %{__make} tidy
286 CC="%{__cc}"
287 export CC
288 %{__make} \
289         DEBUG="" \
290         OPT="%{rpmcflags} -D_FILE_OFFSET_BITS=64" \
291         %{!?with_ldap:LDAPSO=""} \
292         %{!?with_mysql:MYSQLSO=""} \
293         %{!?with_pgsql:PGSQLSO=""} \
294         CCARGS="%{!?with_epoll:-DNO_EPOLL} %{?with_ldap:-DHAS_LDAP} -DHAS_PCRE %{?with_sasl:-DUSE_SASL_AUTH -DUSE_CYRUS_SASL -I/usr/include/sasl} %{?with_mysql:-DHAS_MYSQL -I/usr/include/mysql} %{?with_pgsql:-DHAS_PGSQL} %{?with_ssl:-DUSE_TLS} -DMAX_DYNAMIC_MAPS %{?with_cdb:-DHAS_CDB}" \
295         AUXLIBS="-ldb -lresolv %{?with_sasl:-lsasl} %{?with_ssl:-lssl -lcrypto} %{?with_cdb:-lcdb} -lpcre"
296
297 %install
298 rm -rf $RPM_BUILD_ROOT
299 install -d $RPM_BUILD_ROOT/etc/{cron.daily,rc.d/init.d,sysconfig,pam.d,security,monit} \
300         $RPM_BUILD_ROOT%{_sysconfdir}/{mail,sasl} \
301         $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_libdir}/postfix,/usr/lib}\
302         $RPM_BUILD_ROOT{%{_includedir}/postfix,%{_mandir}} \
303         $RPM_BUILD_ROOT%{_var}/spool/postfix/{active,corrupt,deferred,maildrop,private,saved,bounce,defer,incoming,pid,public} \
304         $RPM_BUILD_ROOT%{_var}/lib/postfix
305 rm -f html/Makefile.in conf/{LICENSE,main.cf.default}
306
307 install bin/* $RPM_BUILD_ROOT%{_sbindir}
308 install libexec/* $RPM_BUILD_ROOT%{_libdir}/postfix
309 ln $RPM_BUILD_ROOT%{_libdir}/postfix/smtp $RPM_BUILD_ROOT%{_libdir}/postfix/lmtp
310 ln $RPM_BUILD_ROOT%{_libdir}/postfix/qmgr $RPM_BUILD_ROOT%{_libdir}/postfix/nqmgr
311 install conf/* $RPM_BUILD_ROOT%{_sysconfdir}/mail
312 sed -e's,^daemon_directory = .*,daemon_directory = %{_libdir}/postfix,' \
313         conf/main.cf > $RPM_BUILD_ROOT%{_sysconfdir}/mail/main.cf
314
315 for f in dns global master util ; do
316         install lib/lib${f}.a $RPM_BUILD_ROOT%{_libdir}/libpostfix-${f}.so.1
317         ln -sf lib${f}.so.1 $RPM_BUILD_ROOT%{_libdir}/libpostfix-${f}.so
318 done
319 install lib/dict*.so $RPM_BUILD_ROOT%{_libdir}/postfix
320 install include/*.h $RPM_BUILD_ROOT%{_includedir}/postfix
321
322 cp -a man/man* $RPM_BUILD_ROOT%{_mandir}
323
324 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/mail/aliases
325 install %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.daily/postfix
326 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/postfix
327 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/postfix
328 install %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/sasl/smtpd.conf
329 install %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/smtp
330 install %{SOURCE8} $RPM_BUILD_ROOT%{_sysconfdir}/mail/bounce.cf.pl
331 install %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/mail/bounce.cf.de
332 install %{SOURCE10} $RPM_BUILD_ROOT/etc/monit/%{name}.monitrc
333 install auxiliary/rmail/rmail $RPM_BUILD_ROOT%{_bindir}/rmail
334 install auxiliary/qshape/qshape.pl $RPM_BUILD_ROOT%{_bindir}/qshape
335
336 ln -sf %{_sbindir}/sendmail $RPM_BUILD_ROOT%{_bindir}/mailq
337 ln -sf %{_sbindir}/sendmail $RPM_BUILD_ROOT%{_bindir}/newaliases
338 ln -sf %{_sbindir}/sendmail $RPM_BUILD_ROOT/usr/lib/sendmail
339
340 touch $RPM_BUILD_ROOT%{_sysconfdir}/mail/\
341         {aliases,access,canonical,relocated,transport,virtual}{,.db}
342
343 touch $RPM_BUILD_ROOT/etc/security/blacklist.smtp
344
345 > $RPM_BUILD_ROOT/var/spool/postfix/.nofinger
346
347 rm -rf $RPM_BUILD_ROOT%{_sysconfdir}/mail/makedefs.out
348 rm -f $RPM_BUILD_ROOT%{_sysconfdir}/mail/TLS_LICENSE
349
350 rm $RPM_BUILD_ROOT%{_sysconfdir}/mail/{postfix-files,postfix-script,post-install}
351
352 %clean
353 rm -rf $RPM_BUILD_ROOT
354
355 %pre
356 %groupadd -g 62 postfix
357 %groupadd -g 63 maildrop
358 %useradd -u 62 -d /var/spool/postfix -s /bin/false -c "Postfix User" -g postfix postfix
359
360 %post
361 /sbin/ldconfig
362 if ! grep -q "^postmaster:" %{_sysconfdir}/mail/aliases; then
363         echo "Adding Entry for postmaster in %{_sysconfdir}/mail/aliases" >&2
364         echo "postmaster: root" >>%{_sysconfdir}/mail/aliases
365 fi
366 if [ "$1" = "1" ]; then
367         # only on installation, not upgrade; set sane defaults
368         # postfix expects gethostname() to return FQDN, which is obviously wrong
369         if ! grep -qE "^my(domain|hostname)" %{_sysconfdir}/mail/main.cf; then
370                 [ `/bin/hostname -d` != 'localdomain' ] && \
371                         postconf -e mydomain=`/bin/hostname -d`
372         fi
373 else
374         %{_sbindir}/postfix upgrade-configuration
375 fi
376
377 %{_bindir}/newaliases
378 /sbin/chkconfig --add postfix
379 %service postfix restart "Postfix Daemon"
380
381 %preun
382 if [ "$1" = "0" ]; then
383         %service postfix stop
384         /sbin/chkconfig --del postfix
385 fi
386
387 %postun
388 /sbin/ldconfig
389 if [ "$1" = "0" ]; then
390         %groupremove maildrop
391         %userremove postfix
392         %groupremove postfix
393 fi
394
395 %files
396 %defattr(644,root,root,755)
397 %doc html COMPATIBILITY HISTORY LICENSE RELEASE_NOTES* TLS_*
398 %doc README_FILES/*README
399 %doc examples/smtpd-policy
400 %dir %{_sysconfdir}/mail
401 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/access
402 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/aliases
403 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/bounce.cf.default
404 %lang(de) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/bounce.cf.de
405 %lang(pl) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/bounce.cf.pl
406 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/canonical
407 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/generic
408 #%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/regexp_table
409 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/relocated
410 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/transport
411 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/virtual
412 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/header_checks
413 #%ghost %{_sysconfdir}/mail/*.db
414 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/dynamicmaps.cf
415 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/main.cf
416 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/master.cf
417 %{_sysconfdir}/mail/postfix-wrapper
418 %{_sysconfdir}/mail/postmulti-script
419 %attr(740,root,root) /etc/cron.daily/postfix
420 %attr(754,root,root) /etc/rc.d/init.d/postfix
421 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/postfix
422 %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/smtp
423 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.smtp
424 %{?with_sasl:%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sasl/smtpd.conf}
425 %attr(755,root,root) %{_libdir}/libpostfix-*.so.*
426 %attr(755,root,root) %{_bindir}/mailq
427 %attr(755,root,root) %{_bindir}/newaliases
428 %attr(755,root,root) %{_bindir}/rmail
429 %attr(755,root,root) %{_sbindir}/s*
430 %attr(755,root,root) %{_sbindir}/postfix
431 %attr(755,root,root) %{_sbindir}/postalias
432 %attr(755,root,root) %{_sbindir}/postkick
433 %attr(755,root,root) %{_sbindir}/postl*
434 %attr(755,root,root) %{_sbindir}/postc*
435 %attr(755,root,root) %{_sbindir}/postmap
436 %attr(755,root,root) %{_sbindir}/postmulti
437 %attr(2755,root,maildrop) %{_sbindir}/postqueue
438 %attr(755,root,root) %{_sbindir}/postsuper
439 %attr(2755,root,maildrop) %{_sbindir}/postdrop
440 %attr(755,root,root) %{_sbindir}/qmqp-sink
441 %attr(755,root,root) %{_sbindir}/qmqp-source
442 %attr(755,root,root) /usr/lib/sendmail
443 %dir %{_libdir}/postfix
444 %attr(755,root,root) %{_libdir}/postfix/[!d]*
445 %attr(755,root,root) %{_libdir}/postfix/discard
446 %attr(755,root,root) %dir %{_var}/spool/postfix
447 %attr(700,postfix,root) %dir %{_var}/spool/postfix/active
448 %attr(700,postfix,root) %dir %{_var}/spool/postfix/bounce
449 %attr(700,postfix,root) %dir %{_var}/spool/postfix/corrupt
450 %attr(700,postfix,root) %dir %{_var}/spool/postfix/defer
451 %attr(700,postfix,root) %dir %{_var}/spool/postfix/deferred
452 %attr(700,postfix,root) %dir %{_var}/spool/postfix/incoming
453 %attr(1730,postfix,maildrop) %dir %{_var}/spool/postfix/maildrop
454 %attr(755,postfix,root) %dir %{_var}/spool/postfix/pid
455 %attr(700,postfix,root) %dir %{_var}/spool/postfix/private
456 %attr(710,postfix,maildrop) %dir %{_var}/spool/postfix/public
457 %attr(700,postfix,root) %dir %{_var}/spool/postfix/saved
458 %attr(644,postfix,root) %{_var}/spool/postfix/.nofinger
459 %attr(700,postfix,root) %{_var}/lib/postfix
460 %{_mandir}/man1/mailq.1*
461 %{_mandir}/man1/newaliases.1*
462 %{_mandir}/man1/post*.1*
463 %{_mandir}/man1/qmqp-*.1*
464 %{_mandir}/man1/sendmail.1*
465 %{_mandir}/man1/smtp-*.1*
466 %{_mandir}/man5/access.5*
467 %{_mandir}/man5/aliases.5*
468 %{_mandir}/man5/body_checks.5*
469 %{_mandir}/man5/bounce.5*
470 %{_mandir}/man5/canonical.5*
471 %{_mandir}/man5/cidr_table.5*
472 %{_mandir}/man5/generic.5*
473 %{_mandir}/man5/header_checks.5*
474 %{_mandir}/man5/master.5*
475 %{_mandir}/man5/nisplus_table.5*
476 %{_mandir}/man5/postconf.5*
477 %{_mandir}/man5/postfix-wrapper.5*
478 %{_mandir}/man5/regexp_table.5*
479 %{_mandir}/man5/relocated.5*
480 %{_mandir}/man5/tcp_table.5*
481 %{_mandir}/man5/transport.5*
482 %{_mandir}/man5/virtual.5*
483 %{_mandir}/man8/*.8*
484
485 %files devel
486 %defattr(644,root,root,755)
487 %attr(755,root,root) %{_libdir}/libpostfix-*.so
488 %{_includedir}/postfix
489
490 %if %{with ldap}
491 %files dict-ldap
492 %defattr(644,root,root,755)
493 %attr(755,root,root) %{_libdir}/postfix/dict_ldap.so
494 %{_mandir}/man5/ldap_table.5*
495 %endif
496
497 %if %{with mysql}
498 %files dict-mysql
499 %defattr(644,root,root,755)
500 %attr(755,root,root) %{_libdir}/postfix/dict_mysql.so
501 %{_mandir}/man5/mysql_table.5*
502 %endif
503
504 %files dict-pcre
505 %defattr(644,root,root,755)
506 %attr(755,root,root) %{_libdir}/postfix/dict_pcre.so
507 #%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/pcre_table
508 %{_mandir}/man5/pcre_table.5*
509
510 %if %{with pgsql}
511 %files dict-pgsql
512 %defattr(644,root,root,755)
513 %attr(755,root,root) %{_libdir}/postfix/dict_pgsql.so
514 %{_mandir}/man5/pgsql_table.5*
515 %endif
516
517 %files qshape
518 %defattr(644,root,root,755)
519 %attr(755,root,root) %{_bindir}/qshape
520 %{_mandir}/man1/qshape.1*
521
522 %files -n monit-rc-%{name}
523 %defattr(644,root,root,755)
524 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}.monitrc
This page took 0.109814 seconds and 2 git commands to generate.