]> git.pld-linux.org Git - packages/popt.git/blob - popt.spec
- "s-/usr/lib/-%{_libdir}-"
[packages/popt.git] / popt.spec
1 Summary:        C library for parsing command line parameters
2 Summary(de):    C-Library zum Parsen von Befehlszeilenparametern 
3 Summary(fr):    Bibliothèque C pour analyser les paramètres de la ligne de commande
4 Summary(pl):    Biblioteka C do przetwarzania parametrów przekazywanych do programów w linii poleceñ
5 Summary(tr):    Komut satýrý parametrelerini ayrýþtýrýmak için C arþivi
6 Name:           popt
7 Version:        1.3
8 Release:        2
9 Copyright:      LGPL
10 Group:          Libraries
11 Group(pl):      Biblioteki
12 Source:         ftp://ftp.redhat.com/pub/redhat/code/popt/%{name}-%{version}.tar.gz
13 Buildroot:      /tmp/%{name}-%{version}-root
14
15 %description
16 Popt is a C library for pasing command line parameters. It was heavily
17 influenced by the getopt() and getopt_long() functions, but it allows
18 more powerfull argument expansion. It can parse arbitrary argv[] style
19 arrays and automatically set variables based on command line arguments.
20 It also allows command line arguments to be aliased via configuration
21 files and includes utility functions for parsing arbitrary strings into
22 argv[] arrays using shell-like rules. 
23
24 %description -l de
25 Popt ist eine C-Library zum Parsen von Befehlszeilenparametern, stark
26 beeinflußt von den getopt() und getopt_long()-Funktionen, aber mit sehr 
27 viel besserer Argumenterweiterung. Es können beliebige argv[]-Argument-
28 Arrays geparst und Variablen auf der Basis von Befehlszeilenargumenten
29 automatisch gesetzt werden. Ferner können Befehlszeilenargumente über
30 Konfigurationsdateien ge-aliast werden, und die Library enthält Utility-
31 funktionen zum Parsen beliebiger Strings in argv[]-Arrays anhand von 
32 Shell-ähnlichen Regeln. 
33
34 %description -l fr
35 Popt est une bibliothèque C pour analyser les paramêtres de la ligne de
36 commande. Elle a été beaucoup influencée par les fonctions getopt() et
37 getopt_long() mais permet une expansion plus puissante des arguments. Elle
38 peut analyser des tableaux arbitraires du style argv[] et configure les
39 variables automatiquement selon les arguments de la ligne de commande.
40 Elle permet aussi à ces arguments d'être des alias via des fichiers de
41 configuration et inclut des fonctions utilitaires pour analyser des
42 chaînes arbitraires dans les tableaux argv[] en utilisant des règles
43 à la shell
44
45 %description -l pl
46 Popt jest bibliotek± C s³u¿±c± 
47 Popt is a C library for pasing command line parameters. It was heavily
48 influenced by the getopt() and getopt_long() functions, but it allows
49 more powerfull argument expansion. It can parse arbitrary argv[] style
50 arrays and automatically set variables based on command line arguments.
51 It also allows command line arguments to be aliased via configuration
52 files and includes utility functions for parsing arbitrary strings into
53 argv[] arrays using shell-like rules. 
54
55 %description -l tr
56 Popt, komut satýrý parametrelerini ayrýþtýran bir C arþividir. Geliþigüzel
57 argv[] tarzý dizileri ayrýþtýrabilir ve otomatik olarak komut satýrý
58 deðiþkenlerine dayalý deðiþkenleri atayabilir.
59
60 %package devel
61 Summary:        Header file and library for popt development
62 Summary(pl):    Pliki nag³ówkowe dla popt
63 Group:          Development/Libraries
64 Group(pl):      Programowanie/Biblioteki
65 Requires:       %{name} = %{version}
66
67 %description devel
68 Header file and library for popt development
69
70 %description devel -l pl
71 Pliki nag³ówkowe i dokumentacja dla popt
72
73 %package static
74 Summary:        Static library for popt development
75 Summary(pl):    Biblioteka statyczna do popt
76 Group:          Development/Libraries
77 Group(pl):      Programowanie/Biblioteki
78 Requires:       %{name}-devel = %{version}
79
80 %description static
81 Static library for popt development
82
83 %description static -l pl
84 Biblioteka statyczna do popt
85
86 %prep
87 %setup -q
88
89 %build
90 CFLAGS="$RPM_OPT_FLAGS" \
91 ./configure %{_target} \
92         --prefix=/usr \
93         --enable-shared
94
95 make
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99 install -d $RPM_BUILD_ROOT/lib
100
101 make DESTDIR=$RPM_BUILD_ROOT install
102
103 mv -f $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.* $RPM_BUILD_ROOT/lib
104 rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.so
105 ln -sf ../../lib/`( cd $RPM_BUILD_ROOT/lib; echo *)` \
106         $RPM_BUILD_ROOT%{_libdir}/libpopt.so
107         
108 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man3/*
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %files
114 %defattr(644,root,root,755)
115 %lang(ro) /usr/share/locale/ro/LC_MESSAGES/*
116 %attr(755,root,root) /lib/*
117
118 %files devel
119 %defattr(644,root,root,755)
120 %attr(755,root,root) %{_libdir}/libpopt.so
121 %{_mandir}/man3/popt.3.gz
122 /usr/include/popt.h
123
124 %files static
125 %defattr(644,root,root,755)
126 %{_libdir}/libpopt.a
127 %{_libdir}/libpopt.la
128
129 %changelog
130 * Wed Apr 21 1999 Piotr Czerwiñski <pius@pld.org.pl>
131   [1.3-1]
132 - updated to 1.3,
133 - changed Group to Libraries,
134 - added Group(pl),
135 - DESTDIR instead of PREFIX in make install,
136 - added man pages in %files,
137 - gzipping man pages,
138 - ./configure moved from %setup to %build,
139 - added --disable-shared to configure options,
140 - added "rm -rf $RPM_BUILD_ROOT" in %install,
141 - cosmetic changes,
142 - recompiled on rpm 3.
143
144 * Sat Aug 15 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
145   [1.1.1-3]
146 - added -q %setup parameter,
147 - changed Buildroot to /tmp/%%{name}-%%{version}-root,
148 - added using %%{name} and %%{version} in Source,
149 - added pl translation,
150 - global %defattr macro instead %attr macros in %files.
151
152 * Thu May 07 1998 Prospector System <bugs@redhat.com>
153 - translations modified for de, fr, tr
154
155 * Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
156 - added ./configure step to spec file
This page took 0.061131 seconds and 4 git commands to generate.