]> git.pld-linux.org Git - packages/poldek.git/commitdiff
- backported patch from git to fix data types usage auto/th/poldek-0_30-1_rc4_2
authorMarcin Banasiak <marcin.banasiak@gmail.com>
Sun, 19 Feb 2012 16:07:52 +0000 (16:07 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- release 2

Changed files:
    poldek-git.patch -> 1.1
    poldek.spec -> 1.436

poldek-git.patch [new file with mode: 0644]
poldek.spec

diff --git a/poldek-git.patch b/poldek-git.patch
new file mode 100644 (file)
index 0000000..69a34ea
--- /dev/null
@@ -0,0 +1,20 @@
+commit f18bedfa368995550e231f382718029bdc2300df
+Author: Marcin Banasiak <marcin.banasiak@gmail.com>
+Date:   Sun Feb 19 16:55:35 2012 +0100
+
+    Fix types in tndb_get_all
+
+diff --git a/read.c b/read.c
+index b57bb50..d560799 100644
+--- a/tndb/read.c
++++ b/tndb/read.c
+@@ -497,7 +497,8 @@ size_t tndb_get_all(struct tndb *db, const void *key, size_t klen,
+                   void **val)
+ {
+     off_t  voffs;
+-    size_t nread = 0, vlen;
++    size_t nread = 0;
++    unsigned int vlen;
+     
+     if (tndb_get_voff(db, key, klen, &voffs, &vlen)) {
+       *val = n_malloc(vlen + 1); /* extra byte for \0 */
index af5d517799855397bffd3da8676339cc3a25ed07..f9bde96825b9dde16523d8e6faac2081c22f1d89 100644 (file)
@@ -17,7 +17,7 @@
 %define        ver_rpm 4.5-49
 
 %define                snap    rc4
-%define                rel     1
+%define                rel     2
 Summary:       RPM packages management helper tool
 Summary(hu.UTF-8):     RPM csomagkezelést segítő eszköz
 Summary(pl.UTF-8):     Pomocnicze narzędzie do zarządzania pakietami RPM
@@ -44,6 +44,7 @@ Patch0:               %{name}-vserver-packages.patch
 Patch1:                %{name}-config.patch
 Patch2:                %{name}-size-type.patch
 Patch3:                %{name}-Os-fail-workaround.patch
+Patch4:                %{name}-git.patch
 URL:           http://poldek.pld-linux.org/
 BuildRequires: autoconf
 BuildRequires: automake
@@ -204,6 +205,7 @@ Moduły języka Python dla poldka.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
 
 rm -f m4/libtool.m4 m4/lt*.m4
 
This page took 0.244692 seconds and 4 git commands to generate.