]> git.pld-linux.org Git - packages/poldek.git/commitdiff
remove --noorder option during package removal
authorKacper Kornet <draenog@pld-linux.org>
Sat, 22 Mar 2014 19:20:48 +0000 (20:20 +0100)
committerKacper Kornet <draenog@pld-linux.org>
Sat, 22 Mar 2014 19:25:39 +0000 (20:25 +0100)
Poldek assumption that rpm -e --noorder removes packages starting from
the last one is wrong for rpm 5.4. This causes error for packages with
Requires(preun). At the same time rpm 5.4 is able to sort them correctly
by itself.

poldek-noorder.patch [new file with mode: 0644]
poldek.spec

diff --git a/poldek-noorder.patch b/poldek-noorder.patch
new file mode 100644 (file)
index 0000000..b2187d4
--- /dev/null
@@ -0,0 +1,14 @@
+diff --git a/pm/rpm/rpminstall.c b/pm/rpm/rpminstall.c
+index c128216..1a3fed8 100644
+--- a/pm/rpm/rpminstall.c
++++ b/pm/rpm/rpminstall.c
+@@ -534,7 +534,9 @@ int pm_rpm_packages_uninstall(struct pkgdb *db, const tn_array *pkgs,
+         argv[nargs++] = (char*)ts->rootdir;
+     }
+     
++#ifndef HAVE_RPM_VERSION_GE_5
+     argv[nargs++] = "--noorder";
++#endif
+     
+     if (ts->rpmopts) 
+         for (i=0; i<n_array_size(ts->rpmopts); i++)
index 8817c09c04b57049537cd8514b359ec5048fc3bb..d676fd050b654e7521182459a877c96942c6e86b 100644 (file)
@@ -22,7 +22,7 @@
 %endif
 %define                ver_rpm         5.4.10
 
-%define                rel     7
+%define                rel     8
 Summary:       RPM packages management helper tool
 Summary(hu.UTF-8):     RPM csomagkezelést segítő eszköz
 Summary(pl.UTF-8):     Pomocnicze narzędzie do zarządzania pakietami RPM
@@ -51,6 +51,7 @@ Patch1:               %{name}-Os-fail-workaround.patch
 Patch2:                %{name}-config.patch
 Patch3:                at-char-completion.patch
 Patch4:                %{name}-ignore-too-long-paths.patch
+Patch5:                %{name}-noorder.patch
 URL:           http://poldek.pld-linux.org/
 BuildRequires: %{db_pkg}-devel >= %{ver_db}-%{ver_db_rel}
 BuildRequires: autoconf
@@ -220,6 +221,7 @@ Moduły języka Python dla poldka.
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
+%patch5 -p1
 
 %{__rm} m4/libtool.m4 m4/lt*.m4
 
This page took 0.094412 seconds and 4 git commands to generate.