]> git.pld-linux.org Git - packages/poldek.git/commitdiff
- n_free() is superfluous and duplicates free() work - don't use it
authortwittner <twittner@pld-linux.org>
Sat, 13 Nov 2004 18:42:50 +0000 (18:42 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    poldek-n_free.patch -> 1.1
    poldek.spec -> 1.186

poldek-n_free.patch [new file with mode: 0644]
poldek.spec

diff --git a/poldek-n_free.patch b/poldek-n_free.patch
new file mode 100644 (file)
index 0000000..3b8e995
--- /dev/null
@@ -0,0 +1,80 @@
+diff -Nurb b.poldek-0.18.7/capreq.c n.poldek-0.18.7/capreq.c
+--- b.poldek-0.18.7/capreq.c   2004-01-10 14:04:48.000000000 +0100
++++ n.poldek-0.18.7/capreq.c   2004-11-11 15:11:01.501825408 +0100
+@@ -39,7 +39,7 @@
+ #include "misc.h"
+ static void *(*capreq_alloc_fn)(size_t) = n_malloc;
+-static void (*capreq_free_fn)(void*) = n_free;
++static void (*capreq_free_fn)(void*) = free;
+ void set_capreq_allocfn(void *(*cr_allocfn)(size_t), void (*cr_freefn)(void*),
+                          void **prev_alloc, void **prev_free)
+diff -Nurb b.poldek-0.18.7/fileindex.c n.poldek-0.18.7/fileindex.c
+--- b.poldek-0.18.7/fileindex.c        2004-09-25 16:16:06.000000000 +0200
++++ n.poldek-0.18.7/fileindex.c        2004-11-11 15:11:28.151774000 +0100
+@@ -26,7 +26,7 @@
+ #include "fileindex.h"
+ #define obstack_chunk_alloc n_malloc
+-#define obstack_chunk_free  n_free
++#define obstack_chunk_free  free
+ struct file_ent {
+     struct flfile *flfile;
+diff -Nurb b.poldek-0.18.7/pkg.c n.poldek-0.18.7/pkg.c
+--- b.poldek-0.18.7/pkg.c      2004-09-25 16:15:36.000000000 +0200
++++ n.poldek-0.18.7/pkg.c      2004-11-11 15:12:03.494401104 +0100
+@@ -35,7 +35,7 @@
+ int poldek_conf_promote_epoch = 0;
+ static void *(*pkg_alloc_fn)(size_t) = n_malloc;
+-static void (*pkg_free_fn)(void*) = n_free;
++static void (*pkg_free_fn)(void*) = free;
+ #if 0                           /* disabled cause gives not reasonable profit */
+ void set_pkg_allocfn(void *(*pkg_allocfn)(size_t), void (*pkg_freefn)(void*))
+diff -Nurb b.poldek-0.18.7/pkgfl.c n.poldek-0.18.7/pkgfl.c
+--- b.poldek-0.18.7/pkgfl.c    2004-07-05 21:11:25.000000000 +0200
++++ n.poldek-0.18.7/pkgfl.c    2004-11-11 15:12:28.333624968 +0100
+@@ -34,7 +34,7 @@
+ #include "h2n.h"
+ #define obstack_chunk_alloc n_malloc
+-#define obstack_chunk_free  n_free
++#define obstack_chunk_free  free
+ struct flmark {
+     tn_array              *dirs;
+diff -Nurb b.poldek-0.18.7/pkgset.c n.poldek-0.18.7/pkgset.c
+--- b.poldek-0.18.7/pkgset.c   2004-07-02 19:42:40.000000000 +0200
++++ n.poldek-0.18.7/pkgset.c   2004-11-11 15:13:01.797537680 +0100
+@@ -49,7 +49,7 @@
+ int ask_pkg(const char *capname, struct pkg **pkgs, struct pkg *deflt);
+ #define obstack_chunk_alloc n_malloc
+-#define obstack_chunk_free  n_free
++#define obstack_chunk_free  free
+ struct obstack_s {
+     int ucnt;
+@@ -471,7 +471,7 @@
+     pkgset_order(ps);
+     mem_info(1, "MEM after order");
+-    set_capreq_allocfn(n_malloc, n_free, NULL, NULL);
++    set_capreq_allocfn(n_malloc, free, NULL, NULL);
+     return ps->nerrors == 0;
+ }
+diff -Nurb b.poldek-0.18.7/trurlib/xmalloc.c n.poldek-0.18.7/trurlib/xmalloc.c
+--- b.poldek-0.18.7/trurlib/xmalloc.c  2002-05-06 19:01:04.000000000 +0200
++++ n.poldek-0.18.7/trurlib/xmalloc.c  2004-11-11 15:13:50.949065512 +0100
+@@ -23,6 +23,6 @@
+ void xfree(void *ptr) 
+ {
+-    n_free(ptr);
++    free(ptr);
+ }
index af490de7cbf022522fe3fc6812d83a8a47b493bb..e09bb9c5522749461cc7df0dbeb65adbc9245b12 100644 (file)
@@ -22,6 +22,7 @@ Patch0:               %{name}-etc_dir.patch
 Patch1:                %{name}-retr_term.patch
 Patch2:                %{name}-simplestatic.patch
 Patch3:                %{name}-po.patch
+Patch4:                %{name}-n_free.patch
 Patch12:       %{name}-distver.patch
 URL:           http://team.pld.org.pl/~mis/poldek/
 BuildRequires: automake
@@ -93,6 +94,7 @@ modu
 %patch1 -p1
 %patch2 -p0
 %patch3 -p1
+%patch4 -p1
 %{?with_distver:%patch12 -p1}
 
 %build
This page took 0.062267 seconds and 4 git commands to generate.