]> git.pld-linux.org Git - packages/poldek.git/blob - poldek.spec
- add pld-archive.conf for th; rel 4
[packages/poldek.git] / poldek.spec
1 # TODO:
2 # - fails to build without poldek-devel - fix it !
3 #
4 # Conditional build:
5 %bcond_with     static  # don't use shared libraries
6 %bcond_without  imode   # don't build interactive mode
7 %bcond_without  python  # don't build python bindings
8
9 # required versions (forced to avoid SEGV with mixed db used by rpm and poldek)
10 %if "%{pld_release}" == "ti"
11 %define ver_db  4.5.20
12 %define ver_db_rel      8
13 %else
14 %define ver_db  4.7.25
15 %define ver_db_rel      1
16 %endif
17 %define ver_rpm 4.5-5
18
19 %define         snap    rc1
20 %define         rel             4
21 Summary:        RPM packages management helper tool
22 Summary(hu.UTF-8):      RPM csomagkezelést segítő eszköz
23 Summary(pl.UTF-8):      Pomocnicze narzędzie do zarządzania pakietami RPM
24 Name:           poldek
25 Version:        0.30
26 Release:        0.%{snap}.%{rel}
27 License:        GPL v2
28 Group:          Applications/System
29 #Source0:       http://poldek.pld-linux.org/download/snapshots/%{name}-%{version}-cvs%{snap}.tar.bz2
30 Source0:        http://carme.pld-linux.org/~megabajt/snaps/poldek/%{name}-%{version}%{snap}.tar.bz2
31 # Source0-md5:  ff3bde5f9451d2691d67112182b7a2df
32 Source1:        %{name}.conf
33 Source2:        %{name}-multilib.conf
34 Source3:        %{name}-ti.conf
35 Source4:        %{name}-multilib-ti.conf
36 Source5:        %{name}-aliases.conf
37 Source6:        %{name}.desktop
38 Source7:        %{name}.png
39 Source8:        %{name}-debuginfo.conf
40 Source9:        %{name}-aidath.conf
41 Source10:       %{name}-multilib-aidath.conf
42 Source11:       %{name}-archive.conf
43 Patch0:         %{name}-vserver-packages.patch
44 Patch1:         %{name}-config.patch
45 Patch2:         %{name}-size-type.patch
46 Patch3:         gcc-fvisibility.patch
47 Patch4:         ac-prog-libtool.patch
48 Patch5:         makefile-tabs.patch
49 URL:            http://poldek.pld-linux.org/
50 BuildRequires:  autoconf
51 BuildRequires:  automake
52 BuildRequires:  bzip2-devel
53 BuildRequires:  check-devel
54 BuildRequires:  db-devel >= %{ver_db}-%{ver_db_rel}
55 BuildRequires:  gettext-devel
56 BuildRequires:  libtool
57 BuildRequires:  libxml2-devel
58 BuildRequires:  openssl-devel >= 0.9.7d
59 BuildRequires:  pcre-devel
60 BuildRequires:  pkgconfig
61 BuildRequires:  popt-devel
62 %{?with_python:BuildRequires:   python-devel}
63 BuildRequires:  readline-devel >= 5.0
64 BuildRequires:  rpm-devel >= %{ver_rpm}
65 %{?with_python:BuildRequires:   rpm-pythonprov}
66 BuildRequires:  zlib-devel
67 %if %{with static}
68 BuildRequires:  bzip2-static
69 BuildRequires:  db-static >= %{ver_db}-%{ver_db_rel}
70 BuildRequires:  glibc-static
71 BuildRequires:  libselinux-static
72 BuildRequires:  libxml2-static
73 BuildRequires:  ncurses-static
74 BuildRequires:  openssl-static
75 BuildRequires:  pcre-static
76 BuildRequires:  popt-static
77 BuildRequires:  readline-static
78 BuildRequires:  rpm-static
79 BuildRequires:  zlib-static
80 %endif
81 Requires(triggerpostun):        awk
82 Requires(triggerpostun):        sed >= 4.0
83 Requires:       %{name}-libs = %{version}-%{release}
84 Requires:       db >= %{ver_db}-%{ver_db_rel}
85 Requires:       rpm >= %{ver_rpm}
86 Requires:       rpm-db-ver = %{ver_db}
87 Requires:       rpm-lib = %(rpm -q --qf '%{V}' rpm-lib)
88 # vf* scripts use sed
89 Requires:       sed
90 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
91
92 %description
93 poldek is an RPM package management tool which allows you to easily
94 perform package verification, installation (including system
95 installation from scratch), upgrading, and removal.
96
97 Program can be used in batch (like apt-get from Debian's APT) or
98 interactive mode. The interactive mode puts you into a readline
99 interface with command line autocompletion and history, similar to the
100 shell mode of Perl's CPAN.
101
102 %{?with_static:This version is statically linked.}
103
104 %{!?with_imode:This version hasn't got interactive mode.}
105 #'vim
106
107 %description -l hu.UTF-8
108 poldek egy RPM csomagkezelő eszköz, amely megkönnyíti a
109 csomagellenőrzést, telepítést (beleértve a rendszertelepítést a
110 nulláról), frissítést és eltávolítást.
111
112 A program használható parancssorból (mint a Debian apt-get programja)
113 vagy interaktív módban. Az interaktív mód egy readline környezetet
114 jelent, parancskiegészítéssel és előzményekkel, hasonlóan a Perl CPAN
115 shell módjához.
116
117 %{?with_static:Ez a verzió statikusan linkelt.}
118
119 %{!?with_imode:Ennek a verziónak nincs interaktív módja.}
120
121 %description -l pl.UTF-8
122 poldek jest narzędziem linii poleceń służącym do weryfikacji,
123 instalacji (włączając instalację systemu od zera), aktualizacji i
124 usuwania pakietów.
125
126 Program może być używany w trybie wsadowym (jak debianowy apt-get) lub
127 interaktywnym. Tryb interaktywny posiada interfejs readline z
128 dopełnianiem komend i historią, podobny do trybu shell perlowego
129 modułu CPAN.
130
131 %{?with_static:Ta wersja jest konsolidowana statycznie.}
132
133 %{!?with_imode:Ta wersja nie posiada trybu interaktywnego.}
134
135 %package libs
136 Summary:        poldek libraries
137 Summary(hu.UTF-8):      A poldek könyvtárai
138 Summary(pl.UTF-8):      Biblioteki poldka
139 Group:          Libraries
140
141 %description libs
142 poldek libraries.
143
144 %description libs -l hu.UTF-8
145 A poldek könyvtárai.
146
147 %description libs -l pl.UTF-8
148 Biblioteki poldka.
149
150 %package devel
151 Summary:        Header files for poldek libraries
152 Summary(hu.UTF-8):      A poldek könyvtár fejlesztői fájljai
153 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek poldka
154 Group:          Development/Libraries
155 Requires:       %{name}-libs = %{version}-%{release}
156 Requires:       rpm-devel >= %{ver_rpm}
157
158 %description devel
159 Header files for poldek libraries.
160
161 %description devel -l hu.UTF-8
162 A poldek könyvtár fejlesztői fájljai.
163
164 %description devel -l pl.UTF-8
165 Pliki nagłówkowe bibliotek poldka.
166
167 %package static
168 Summary:        poldek static libraries
169 Summary(hu.UTF-8):      poldek statikus könyvtárak
170 Summary(pl.UTF-8):      Biblioteki statyczne poldka
171 Group:          Development/Libraries
172 Requires:       %{name}-devel = %{version}-%{release}
173
174 %description static
175 poldek static libraries.
176
177 %description static -l hu.UTF-8
178 poldek statikus könyvtárak.
179
180 %description static -l pl.UTF-8
181 Biblioteki statyczne poldka.
182
183 %package -n python-poldek
184 Summary:        Python modules for poldek
185 Summary(hu.UTF-8):      Python modulok poldek-hez
186 Summary(pl.UTF-8):      Moduły języka Python dla poldka
187 Group:          Libraries/Python
188 Requires:       %{name}-libs = %{version}-%{release}
189 %pyrequires_eq  python-libs
190
191 %description -n python-poldek
192 Python modules for poldek.
193
194 %description -n python-poldek -l hu.UTF-8
195 Python modulok poldek-hez.
196
197 %description -n python-poldek -l pl.UTF-8
198 Moduły języka Python dla poldka.
199
200 %prep
201 %setup -q
202 %patch0 -p1
203 %patch1 -p1
204 %patch2 -p1
205 %patch3 -p1
206 %patch4 -p1
207 %patch5 -p1
208
209 rm -f m4/libtool.m4 m4/lt*.m4
210
211 # cleanup backups after patching
212 find . '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
213
214 %build
215 %{__libtoolize}
216 %{__aclocal} -I m4
217 %{__autoheader}
218 %{__autoconf}
219 %{__automake}
220 cp -f config.sub trurlib
221
222 CPPFLAGS="-std=gnu99"
223 %configure \
224         %{?with_static:--enable-static --disable-shared} \
225         %{!?with_imode:--disable-imode} \
226         --enable-nls \
227         %{?with_python:--with-python}
228 %{__make}
229 #       --enable-trace
230
231 %install
232 rm -rf $RPM_BUILD_ROOT
233 install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d
234
235 %{__make} install \
236         DESTDIR=$RPM_BUILD_ROOT
237
238 %if %{with python}
239 %{__make} -C python install \
240         DESTDIR=$RPM_BUILD_ROOT \
241         libdir=%{py_sitedir}
242 %endif
243
244 %{?with_static:rm -f $RPM_BUILD_ROOT%{_bindir}/rpmvercmp}
245
246 %ifarch i486 i686 ppc sparc alpha athlon
247         %define         _ftp_arch       %{_target_cpu}
248 %endif
249 %ifarch %{x8664}
250         %define         _ftp_arch       x86_64
251         %define         _ftp_alt_arch   i686
252 %endif
253 %ifarch i586
254         %if "%{pld_release}" == "ti"
255                 %define         _ftp_arch       i586
256         %else
257                 %define         _ftp_arch       i486
258         %endif
259 %endif
260 %ifarch pentium2 pentium3 pentium4
261         %define         _ftp_arch       i686
262 %endif
263 %ifarch sparcv9 sparc64
264         %define         _ftp_arch       sparc
265         %if "%{pld_release}" == "th"
266                 %define         _ftp_arch       %{_target_cpu}
267                 %ifarch sparc64
268                 %define         _ftp_alt_arch   sparcv9
269                 %endif
270         %endif
271 %endif
272
273 %if "%{pld_release}" == "ti"
274         %define pld_conf %{SOURCE3}
275         %ifarch %{x8664}
276                 %define pld_multilib_conf %{SOURCE4}
277         %endif
278 %endif
279
280 %if "%{pld_release}" == "th"
281         %define pld_conf %{SOURCE1}
282         %define pld_debuginfo_conf %{SOURCE8}
283         %define pld_archive_conf %{SOURCE11}
284
285         %ifarch %{x8664}
286                 %define pld_multilib_conf %{SOURCE2}
287         %endif
288
289         # aidath
290         %ifarch sparcv9 sparc64
291                 %define pld_conf %{SOURCE9}
292                 %undefine pld_archive_conf
293         %endif
294         %ifarch sparc64
295                 %define pld_multilib_conf %{SOURCE10}
296         %endif
297 %endif
298
299 sed -e 's|%%ARCH%%|%{_ftp_arch}|g' < %{pld_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
300
301 %if 0%{?pld_multilib_conf:1}
302         sed 's|%%ARCH%%|%{_ftp_alt_arch}|g' < %{pld_multilib_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-multilib.conf
303 %endif
304
305 %if 0%{?pld_debuginfo_conf:1}
306 sed -e 's|%%ARCH%%|%{_ftp_arch}|g' < %{pld_debuginfo_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-debuginfo.conf
307 %endif
308
309 %if 0%{?pld_archive_conf:1}
310 sed -e 's|%%ARCH%%|%{_ftp_arch}|g' < %{pld_archive_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-archive.conf
311 %endif
312
313 cp -a %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/cli.conf
314
315 %if %{with imode}
316 # add desktop file and icon
317 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
318 cp -a %{SOURCE6} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
319 cp -a %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
320 %endif
321
322 # sources we don't package
323 rm -f $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{rh,pld,fedora,centos}-source.conf
324 # include them in %doc
325 rm -rf configs
326 cp -a conf configs
327 rm -f configs/Makefile*
328
329 %if %{with python}
330 %py_postclean
331 rm -f $RPM_BUILD_ROOT%{py_sitedir}/_poldekmod.la
332 %endif
333
334 %find_lang %{name}
335
336 %clean
337 rm -rf $RPM_BUILD_ROOT
338
339 %post
340 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
341 if [ "$1" = "1" ]; then
342         # remove ignore = vserver-packages inside vserver on first install
343         {
344                 while read f ctx; do
345                         [ "$f" = "VxID:" -o "$f" = "s_context:" ] && break
346                 done </proc/self/status
347         } 2>/dev/null
348         if [ -z "$ctx" -o "$ctx" = "0" ]; then
349                 VSERVER=no
350         else
351                 VSERVER=yes
352         fi
353         if [ "$VSERVER" = "yes" ]; then
354                 %{__sed} -i -e '/^ignore/s/vserver-packages//' %{_sysconfdir}/%{name}/poldek.conf
355         fi
356 fi
357
358 %postun -p      /sbin/postshell
359 -/usr/sbin/fix-info-dir -c %{_infodir}
360
361 %post   libs -p /sbin/ldconfig
362 %postun libs -p /sbin/ldconfig
363
364 %triggerpostun -- poldek < 0.19.0-1.20050613.22.0
365 if [ -f /etc/poldek.conf.rpmsave ]; then
366         awk '/^source/ {
367         name = $3;
368         path = $4;
369         auto = "yes";
370         autoup = "yes";
371         type = "pdir";
372         pri = "";
373
374         if (sub(",noauto", "", name)) {
375                 auto = "no";
376         }
377
378         # process pri=\d+
379         if (match(name, /,pri=[0-9]+/)) {
380                 pri = substr(name, RSTART + 5, RLENGTH - 5);
381                 name = substr(name, 1, RSTART - 1) substr(name, RSTART + RLENGTH);
382         }
383
384         # skip ac sources. already in new config.
385         if (name !~ /^ac(-(ready|test|supported|updates-(general|security)))?$/) {
386                 print "";
387                 print "[source]";
388                 print "name = " name;
389                 print "type = " type;
390                 print "path = " path;
391                 print "auto = " auto;
392                 print "autoup = " autoup;
393                 if (pri) {
394                         print "pri = " pri;
395                 }
396         }
397
398         }' < /etc/poldek.conf.rpmsave >> /etc/poldek/source.conf
399         echo "Converted old custom sources from /etc/poldek.conf.rpmsave to new poldek format in /etc/poldek/source.conf"
400
401         # copy hold=
402         hold=$(grep ^hold /etc/poldek.conf.rpmsave)
403         if [ "$hold" ]; then
404                 sed -i -e "/^#hold =/s/^.*/$hold/" /etc/poldek/poldek.conf
405         fi
406 fi
407
408 %triggerpostun -- poldek < 0.30-0.20080225.00.1
409 if ! grep -q '^%%includedir repos.d' %{_sysconfdir}/%{name}/poldek.conf; then
410         %{__sed} -i -e '/^%%include source.conf/{
411                 a
412                 a# /etc/poldek/repos.d/*.conf
413                 a%%includedir repos.d
414         }' %{_sysconfdir}/%{name}/poldek.conf
415 fi
416
417 %{__sed} -i -e '/%%include %%{_distro}-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
418 %{__sed} -i -e '/%%include %%{_distro}-multilib-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
419
420 if [ -f %{_sysconfdir}/%{name}/pld-source.conf.rpmsave ]; then
421         cp -f %{_sysconfdir}/%{name}/repos.d/pld.conf{,.rpmnew}
422         cp -f %{_sysconfdir}/%{name}/pld-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld.conf
423 fi
424
425 %ifarch %{x8664}
426 if [ -f %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave ]; then
427         cp -f %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf{,.rpmnew}
428         cp -f %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf
429 fi
430 %endif
431
432 %files -f %{name}.lang
433 %defattr(644,root,root,755)
434 %doc ChangeLog README* NEWS TODO configs
435 %dir %{_sysconfdir}/%{name}
436 %dir %{_sysconfdir}/%{name}/repos.d
437 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
438 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/repos.d/*.conf
439 %attr(755,root,root) %{_bindir}/*
440 %dir %{_libdir}/%{name}
441 %attr(755,root,root) %{_libdir}/%{name}/*
442 %{_mandir}/man1/%{name}*
443 %lang(pl) %{_mandir}/pl/man1/%{name}*
444 %{_infodir}/poldek.info*
445 %if %{with imode}
446 %{_desktopdir}/%{name}.desktop
447 %{_pixmapsdir}/%{name}.png
448 %endif
449
450 %if %{without static}
451 %files libs
452 %defattr(644,root,root,755)
453 %attr(755,root,root) %{_libdir}/libpoclidek.so.*.*.*
454 %attr(755,root,root) %{_libdir}/libpoldek.so.*.*.*
455 %attr(755,root,root) %{_libdir}/libtndb.so.*.*.*
456 %attr(755,root,root) %{_libdir}/libtrurl.so.*.*.*
457 %attr(755,root,root) %{_libdir}/libvfile.so.*.*.*
458 %attr(755,root,root) %ghost %{_libdir}/libpoclidek.so.0
459 %attr(755,root,root) %ghost %{_libdir}/libpoldek.so.2
460 %attr(755,root,root) %ghost %{_libdir}/libtndb.so.0
461 %attr(755,root,root) %ghost %{_libdir}/libtrurl.so.0
462 %attr(755,root,root) %ghost %{_libdir}/libvfile.so.0
463 %endif
464
465 %files devel
466 %defattr(644,root,root,755)
467 %{!?with_static:%attr(755,root,root) %{_libdir}/lib*.so}
468 %{_libdir}/lib*.la
469 %{_includedir}/*
470
471 %files static
472 %defattr(644,root,root,755)
473 %{_libdir}/lib*.a
474
475 %if %{with python}
476 %files -n python-poldek
477 %defattr(644,root,root,755)
478 %attr(755,root,root) %{py_sitedir}/_poldekmod.so
479 %{py_sitescriptdir}/poldek.py[co]
480 %{py_sitescriptdir}/poldekmod.py[co]
481 %endif
This page took 0.05612 seconds and 4 git commands to generate.