]> git.pld-linux.org Git - packages/poldek.git/blob - poldek.spec
This commit was manufactured by cvs2git to create tag 'auto-ac-poldek-
[packages/poldek.git] / poldek.spec
1 #
2 # Conditional build:
3 %bcond_with     static  # don't use shared libraries
4 %bcond_without  imode   # don't build interactive mode
5 %bcond_with     curl    # link with curl
6 #
7 # required versions (forced to avoid SEGV with mixed db used by rpm and poldek)
8 %define ver_db  4.2.50-1
9 %define ver_rpm 4.3-0.20030610.29
10 %define snap    20040224
11 Summary:        RPM packages management helper tool
12 Summary(pl):    Pomocnicze narzêdzie do zarz±dzania pakietami RPM
13 Name:           poldek
14 Version:        0.18.4
15 Release:        0.%{snap}.1
16 License:        GPL v2
17 Group:          Applications/System
18 Source0:        http://team.pld.org.pl/~mis/poldek/download/snapshots/poldek-cvs%{snap}.tar.bz2
19 # Source0-md5:  9d70522ce9c515dab4a731d9eb70e04b
20 Source1:        %{name}.conf
21 Patch0:         %{name}-etc_dir.patch
22 Patch1:         %{name}-retr_term.patch
23 URL:            http://team.pld.org.pl/~mis/poldek/
24 BuildRequires:  automake
25 BuildRequires:  autoconf
26 BuildRequires:  bzip2-devel
27 %{?with_curl:BuildRequires:     curl-devel >= 7.8}
28 BuildRequires:  db-devel >= %{ver_db}
29 BuildRequires:  gettext-autopoint
30 BuildRequires:  openssl-devel >= 0.9.7c
31 BuildRequires:  pcre-devel
32 BuildRequires:  popt-devel
33 BuildRequires:  readline-devel
34 BuildRequires:  rpm-devel >= %{ver_rpm}
35 BuildRequires:  zlib-devel
36 BuildRequires:  perl-tools-pod
37 %if %{with static}
38 BuildRequires:  bzip2-static
39 %{?with_curl:BuildRequires:     curl-static}
40 BuildRequires:  db-static >= %{ver_db}
41 BuildRequires:  ncurses-static
42 BuildRequires:  openssl-static
43 BuildRequires:  pcre-static
44 BuildRequires:  popt-static
45 BuildRequires:  readline-static
46 BuildRequires:  rpm-static
47 BuildRequires:  zlib-static
48 BuildRequires:  glibc-static
49 %endif
50 Requires:       db >= %{ver_db}
51 Requires:       ed
52 Requires:       rpm >= %{ver_rpm}
53 Requires:       sed
54 Requires:       openssl >= 0.9.7c
55 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57 %description
58 poldek is an RPM package management tool which allows you to easily
59 perform package verification, installation (including system
60 installation from scratch), upgrading, and removal.
61
62 Program can be used in batch (like apt-get from Debian's APT) or
63 interactive mode. The interactive mode puts you into a readline
64 interface with command line autocompletion and history, similar to the
65 shell mode of Perl's CPAN.
66
67 %{?with_static:This version is statically linked.}
68
69 %{!?with_imode:This version hasn't got interactive mode.}
70
71 %description -l pl
72 poldek jest narzêdziem linii poleceñ s³u¿±cym do weryfikacji,
73 instalacji (w³±czaj±c instalacjê systemu od zera), aktualizacji i
74 usuwania pakietów.
75
76 Program mo¿e byæ u¿ywany w trybie wsadowym (jak debianowy apt-get) lub
77 interaktywnym. Tryb interaktywny posiada interfejs readline z
78 dope³nianiem komend i histori±, podobny do trybu shell perlowego
79 modu³u CPAN.
80
81 %{?with_static:Ta wersja jest konsolidowana statycznie.}
82
83 %{!?with_imode:Ta wersja nie posiada trybu interaktywnego.}
84
85 %prep
86 %setup -q -n %{name}-cvs%{snap}
87 %patch0 -p1
88 %patch1 -p1
89
90 %build
91 %{__autopoint}
92 %{__aclocal} -I m4
93 %{__autoconf}
94 %{__automake}
95 cp -f config.sub trurlib
96 %configure \
97         %{?with_static:--enable-static} \
98         %{!?with_imode:--disable-imode} \
99         %{?with_curl:--with-curl}
100 %{__make}
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104 install -d $RPM_BUILD_ROOT%{_sysconfdir}
105
106 %{__make} install \
107         DESTDIR=$RPM_BUILD_ROOT
108
109 %{?with_static:rm -f $RPM_BUILD_ROOT%{_bindir}/rpmvercmp}
110 sed "s|/i686/|/%{_target_cpu}/|g" < %{SOURCE1} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.conf
111
112 %find_lang %{name}
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %triggerpostun -- poldek <= 0.18.3-5
118 if grep -q '^promoteepoch.*yes' /etc/poldek.conf ; then
119         echo -e ',s:^promoteepoch:# promoteepoch:g\n,w' | ed -s /etc/poldek.conf
120 fi
121
122 %files -f %{name}.lang
123 %defattr(644,root,root,755)
124 %doc README* NEWS TODO *sample* conf/poldekrc*
125 %attr(644,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/%{name}.conf
126 %attr(755,root,root) %{_bindir}/*
127 %{_mandir}/man1/%{name}*
128 %lang(pl) %{_mandir}/pl/man1/%{name}*
This page took 0.047573 seconds and 3 git commands to generate.