]> git.pld-linux.org Git - packages/poldek.git/blob - poldek.spec
- rel 6; enable external downloaders by default and move fetcher registration errors...
[packages/poldek.git] / poldek.spec
1 # TODO
2 # - fix config having escaped html entities:
3 #   # package A requires capability foo >= 1.0 while package B provides "foo"
4
5 # Conditional build:
6 %bcond_with     static  # don't use shared libraries
7 %bcond_without  imode   # don't build interactive mode
8 %bcond_without  python  # don't build python bindings
9 %bcond_with     snap    # install configs for official Th snapshot
10 %bcond_with     db61    # DB 6.1 instead of 5.2
11 %bcond_with     rpm4    # use rpm4/db4.7 instead of rpm5
12
13 # current snapshot name
14 %define         SNAP    2016
15
16 # required versions (forced to avoid SEGV with mixed db used by rpm and poldek)
17 # NOTE: poldek links with "system db" (-ldb) anyway if it exists
18 %if %{with db61}
19 %define         db_pkg          db6.1
20 %define         ver_db          6.1
21 %define         ver_db_rel      1
22 %else
23 %define         db_pkg          db5.2
24 %define         ver_db          5.2
25 %define         ver_db_rel      3
26 %endif
27
28 %if %{with rpm4}
29 %define         db_pkg          db4.7
30 %define         ver_db          4.7.25
31 %define         ver_db_rel      1
32 %define         ver_rpm         4.5-49
33 %else
34 %define         ver_rpm         5.4.10
35 %endif
36
37 %define         rel     6
38 Summary:        RPM packages management helper tool
39 Summary(hu.UTF-8):      RPM csomagkezelést segítő eszköz
40 Summary(pl.UTF-8):      Pomocnicze narzędzie do zarządzania pakietami RPM
41 Name:           poldek
42 Version:        0.32.2
43 Release:        %{rel}%{?with_snap:.%{SNAP}}
44 License:        GPL v2
45 Group:          Applications/System
46 #Source0:       http://poldek.pld-linux.org/download/snapshots/%{name}-%{version}-cvs%{snap}.tar.bz2
47 Source0:        https://launchpad.net/poldek/0.32/%{version}/+download/%{name}-%{version}.tar.xz
48 # Source0-md5:  60b964723880569531f88f084cd3ae65
49 Source1:        %{name}.conf
50 Source2:        %{name}-multilib.conf
51 Source3:        %{name}-config.sh
52 Source5:        %{name}-aliases.conf
53 Source6:        %{name}.desktop
54 Source7:        %{name}.png
55 # Source7-md5:  ee487abede50874e9eceb6495d5ee150
56 Source8:        %{name}-debuginfo.conf
57 Source9:        %{name}-aidath.conf
58 Source10:       %{name}-multilib-aidath.conf
59 Source11:       %{name}-archive.conf
60 Source100:      %{name}-snap.conf
61 Source101:      %{name}-multilib-snap.conf
62 Source102:      %{name}-debuginfo-snap.conf
63 Patch0:         %{name}-size-type.patch
64 Patch1:         %{name}-config.patch
65 Patch2:         pm-hooks.patch
66 Patch3:         WTERMSIG.patch
67 Patch4:         %{name}-multiproto.patch
68 Patch5:         python-fix.patch
69 Patch6:         poldek-ext-down-enable.patch
70 URL:            http://poldek.pld-linux.org/
71 BuildRequires:  %{db_pkg}-devel >= %{ver_db}-%{ver_db_rel}
72 BuildRequires:  autoconf
73 BuildRequires:  automake >= 1:1.11
74 BuildRequires:  bzip2-devel
75 BuildRequires:  check-devel
76 BuildRequires:  docbook-dtd412-xml
77 BuildRequires:  gettext-tools
78 BuildRequires:  libgomp-devel
79 BuildRequires:  libtool
80 BuildRequires:  libxml2-devel
81 BuildRequires:  openssl-devel >= 0.9.7d
82 BuildRequires:  pcre-devel
83 BuildRequires:  pkgconfig
84 BuildRequires:  popt-devel
85 %{?with_python:BuildRequires:   python-devel}
86 BuildRequires:  readline-devel >= 5.0
87 BuildRequires:  rpm-devel >= %{ver_rpm}
88 %{?with_python:BuildRequires:   rpm-pythonprov}
89 BuildRequires:  tar >= 1:1.22
90 BuildRequires:  xmlto
91 BuildRequires:  xz
92 BuildRequires:  zlib-devel
93 %if %{with static}
94 BuildRequires:  %{db_pkg}-static >= %{ver_db}-%{ver_db_rel}
95 BuildRequires:  bzip2-static
96 BuildRequires:  glibc-static
97 BuildRequires:  libxml2-static
98 BuildRequires:  ncurses-static
99 BuildRequires:  openssl-static
100 BuildRequires:  pcre-static
101 BuildRequires:  popt-static
102 BuildRequires:  readline-static
103 BuildRequires:  rpm-static
104 BuildRequires:  zlib-static
105 %endif
106 Requires(triggerpostun):        awk
107 Requires(triggerpostun):        sed >= 4.0
108 Requires:       %{db_pkg} >= %{ver_db}-%{ver_db_rel}
109 Requires:       %{name}-libs = %{version}-%{release}
110 Requires:       /bin/run-parts
111 Requires:       rpm >= %{ver_rpm}
112 Requires:       rpm-db-ver = %{ver_db}
113 Requires:       rpm-lib >= %{ver_rpm}
114 Requires:       sed
115 Conflicts:      etckeeper < 1.18-2
116 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
117
118 %define         _libexecdir     %{_prefix}/lib/%{name}
119
120 %description
121 poldek is an RPM package management tool which allows you to easily
122 perform package verification, installation (including system
123 installation from scratch), upgrading, and removal.
124
125 Program can be used in batch (like apt-get from Debian's APT) or
126 interactive mode. The interactive mode puts you into a readline
127 interface with command line autocompletion and history, similar to the
128 shell mode of Perl's CPAN.
129
130 %{?with_static:This version is statically linked.}
131
132 %{!?with_imode:This version hasn't got interactive mode.}
133 #'vim
134
135 %description -l hu.UTF-8
136 poldek egy RPM csomagkezelő eszköz, amely megkönnyíti a
137 csomagellenőrzést, telepítést (beleértve a rendszertelepítést a
138 nulláról), frissítést és eltávolítást.
139
140 A program használható parancssorból (mint a Debian apt-get programja)
141 vagy interaktív módban. Az interaktív mód egy readline környezetet
142 jelent, parancskiegészítéssel és előzményekkel, hasonlóan a Perl CPAN
143 shell módjához.
144
145 %{?with_static:Ez a verzió statikusan linkelt.}
146
147 %{!?with_imode:Ennek a verziónak nincs interaktív módja.}
148
149 %description -l pl.UTF-8
150 poldek jest narzędziem linii poleceń służącym do weryfikacji,
151 instalacji (włączając instalację systemu od zera), aktualizacji i
152 usuwania pakietów.
153
154 Program może być używany w trybie wsadowym (jak debianowy apt-get) lub
155 interaktywnym. Tryb interaktywny posiada interfejs readline z
156 dopełnianiem komend i historią, podobny do trybu shell perlowego
157 modułu CPAN.
158
159 %{?with_static:Ta wersja jest konsolidowana statycznie.}
160
161 %{!?with_imode:Ta wersja nie posiada trybu interaktywnego.}
162
163 %package libs
164 Summary:        poldek libraries
165 Summary(hu.UTF-8):      A poldek könyvtárai
166 Summary(pl.UTF-8):      Biblioteki poldka
167 Group:          Libraries
168
169 %description libs
170 poldek libraries.
171
172 %description libs -l hu.UTF-8
173 A poldek könyvtárai.
174
175 %description libs -l pl.UTF-8
176 Biblioteki poldka.
177
178 %package devel
179 Summary:        Header files for poldek libraries
180 Summary(hu.UTF-8):      A poldek könyvtár fejlesztői fájljai
181 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek poldka
182 Group:          Development/Libraries
183 Requires:       %{name}-libs = %{version}-%{release}
184 Requires:       rpm-devel >= %{ver_rpm}
185
186 %description devel
187 Header files for poldek libraries.
188
189 %description devel -l hu.UTF-8
190 A poldek könyvtár fejlesztői fájljai.
191
192 %description devel -l pl.UTF-8
193 Pliki nagłówkowe bibliotek poldka.
194
195 %package static
196 Summary:        poldek static libraries
197 Summary(hu.UTF-8):      poldek statikus könyvtárak
198 Summary(pl.UTF-8):      Biblioteki statyczne poldka
199 Group:          Development/Libraries
200 Requires:       %{name}-devel = %{version}-%{release}
201
202 %description static
203 poldek static libraries.
204
205 %description static -l hu.UTF-8
206 poldek statikus könyvtárak.
207
208 %description static -l pl.UTF-8
209 Biblioteki statyczne poldka.
210
211 %package -n python-poldek
212 Summary:        Python modules for poldek
213 Summary(hu.UTF-8):      Python modulok poldek-hez
214 Summary(pl.UTF-8):      Moduły języka Python dla poldka
215 Group:          Libraries/Python
216 Requires:       %{name}-libs = %{version}-%{release}
217 Requires:       python-libs
218
219 %description -n python-poldek
220 Python modules for poldek.
221
222 %description -n python-poldek -l hu.UTF-8
223 Python modulok poldek-hez.
224
225 %description -n python-poldek -l pl.UTF-8
226 Moduły języka Python dla poldka.
227
228 %prep
229 %setup -q
230 %patch0 -p1
231 %patch1 -p1
232 %patch2 -p1
233 %patch3 -p1
234 %patch4 -p1
235 %patch5 -p1
236 %patch6 -p1
237
238 %{__rm} m4/libtool.m4 m4/lt*.m4
239
240 # cleanup backups after patching
241 find . '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
242 chmod u+x ./configure ./doc/conf-xml2.sh
243
244 %build
245 %{__gettextize}
246 %{__libtoolize}
247 %{__aclocal} -I m4
248 %{__autoheader}
249 %{__autoconf}
250 %{__automake}
251 cd tndb
252 %{__libtoolize}
253 %{__aclocal}
254 %{__autoheader}
255 %{__autoconf}
256 %{__automake}
257 cd ../trurlib
258 %{__libtoolize}
259 %{__aclocal}
260 %{__autoheader}
261 %{__autoconf}
262 %{__automake}
263 cd ..
264
265 CPPFLAGS="%{rpmcppflags} -std=gnu99 -fgnu89-inline"
266 %configure \
267         %{?with_static:--enable-static --disable-shared} \
268         %{!?with_imode:--disable-imode} \
269         --with-pkglibdir=%{_libexecdir} \
270         --enable-nls \
271         %{?with_python:--with-python}
272 %{__make} -j1
273 #       --enable-trace
274
275 %if %{with python}
276 %{__make} -C python
277 %endif
278
279 %install
280 rm -rf $RPM_BUILD_ROOT
281 install -d $RPM_BUILD_ROOT/var/cache/%{name}
282
283 %{__make} install -j1 \
284         DESTDIR=$RPM_BUILD_ROOT
285
286 install -p %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}/poldek-config
287
288 %if %{with python}
289 %{__make} -C python -j1 install \
290         DESTDIR=$RPM_BUILD_ROOT \
291         py_sitedir=%{py_sitedir}
292 %endif
293
294 %{?with_static:%{__rm} $RPM_BUILD_ROOT%{_bindir}/rpmvercmp}
295
296 %ifarch i486 i686 ppc sparc alpha athlon
297         %define         ftp_arch        %{_target_cpu}
298 %endif
299 %ifarch %{x8664}
300         %define         ftp_arch        x86_64
301         %define         ftp_alt_arch    i686
302         %define         ftp_alt2_arch   x32
303 %endif
304 %ifarch x32
305         %define         ftp_arch        x32
306         %define         ftp_alt_arch    x86_64
307         %define         ftp_alt2_arch   i686
308 %endif
309 %ifarch i586
310         %define         ftp_arch        i486
311 %endif
312 %ifarch pentium2 pentium3 pentium4
313         %define         ftp_arch        i686
314 %endif
315 %ifarch sparcv9 sparc64
316         %define         ftp_arch        sparc
317         %define         ftp_arch        %{_target_cpu}
318         %ifarch sparc64
319                 %define         ftp_alt_arch    sparcv9
320         %endif
321 %endif
322
323 %define pld_conf %{SOURCE1}
324 %define pld_debuginfo_conf %{SOURCE8}
325 %define pld_archive_conf %{SOURCE11}
326
327 %ifarch %{x8664} x32
328         %define pld_multilib_conf %{SOURCE2}
329         %define pld_multilib2_conf %{SOURCE2}
330 %endif
331
332 # aidath
333 %ifarch sparcv9 sparc64
334         %define pld_conf %{SOURCE9}
335         %undefine pld_archive_conf
336 %endif
337 %ifarch sparc64
338         %define pld_multilib_conf %{SOURCE10}
339 %endif
340
341 %{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' < %{pld_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
342
343 %if 0%{?pld_multilib_conf:1}
344         %{__sed} 's|%%ARCH%%|%{ftp_alt_arch}|g' < %{pld_multilib_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt_arch}.conf
345 %endif
346
347 %if 0%{?pld_multilib2_conf:1}
348         %{__sed} 's|%%ARCH%%|%{ftp_alt2_arch}|g' < %{pld_multilib_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt2_arch}.conf
349 %endif
350
351 %if 0%{?pld_debuginfo_conf:1}
352 %{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' < %{pld_debuginfo_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-debuginfo.conf
353 %endif
354
355 %if 0%{?pld_archive_conf:1}
356 %{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' < %{pld_archive_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-archive.conf
357 %endif
358
359 # Always install snapshot configs
360 %{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' \
361         -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE100} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
362 %{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' \
363         -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE102} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-debuginfo.conf
364 %ifarch %{x8664} x32
365         %{__sed} -e 's|%%ARCH%%|%{ftp_alt_arch}|g' \
366                 -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE101} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt_arch}.conf
367         %{__sed} -e 's|%%ARCH%%|%{ftp_alt2_arch}|g' \
368                 -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE101} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt2_arch}.conf
369 %endif
370
371 %if %{with snap}
372 %{__sed} -i -e 's|@@SNAP@@||g' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
373 %{__sed} -i '/@@SNAP@@.*/d' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
374 %else
375 %{__sed} -i -e 's|@@SNAP@@||g' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
376 %{__sed} -i '/@@SNAP@@.*/d' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
377 %endif
378
379 # create "all" meta repo
380 %if 0%{?ftp_alt_arch:1}%{?ftp_alt2_arch:1}
381 cat <<'EOF' >  $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-all.conf
382 # group source for referring th+th-multiarch sources together, i.e poldek -n th-all
383 [source]
384 type    = group
385 name    = th-all
386 sources = th %{?ftp_alt_arch:th-%{ftp_alt_arch}} %{?ftp_alt2_arch:th-%{ftp_alt2_arch}}
387 EOF
388 %endif
389
390 # th-2014 snap does not exist for x32 yet
391 %if "%{ftp_arch}" == "x32"
392 rm $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
393 %endif
394 %if "%{ftp_alt2_arch}" == "x32"
395 rm $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-x32.conf
396 %endif
397
398 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/cli.conf
399
400 %if %{with imode}
401 # add desktop file and icon
402 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
403 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
404 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
405 %endif
406
407 # sources we don't package
408 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{rh,fedora,centos}-source.conf
409 # include them in %doc
410 %{__rm} -rf configs
411 cp -a conf configs
412 %{__rm} -f configs/Makefile*
413
414 %if %{with python}
415 %py_postclean
416 %{__rm} $RPM_BUILD_ROOT%{_libdir}/_poldekmod.{la,so}
417 %endif
418
419 %find_lang %{name}
420
421 %clean
422 rm -rf $RPM_BUILD_ROOT
423
424 %post
425 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
426 if [ "$1" = "1" ]; then
427         # remove ignore = vserver-packages inside vserver on first install
428         {
429                 while read f ctx; do
430                         [ "$f" = "VxID:" -o "$f" = "s_context:" ] && break
431                 done </proc/self/status
432         } 2>/dev/null
433         if [ -z "$ctx" -o "$ctx" = "0" ]; then
434                 VSERVER=no
435         else
436                 VSERVER=yes
437         fi
438         if [ "$VSERVER" = "yes" ]; then
439                 %{__sed} -i -e '/^ignore/s/vserver-packages//' %{_sysconfdir}/%{name}/poldek.conf
440         fi
441 fi
442
443 %postun -p      /sbin/postshell
444 -/usr/sbin/fix-info-dir -c %{_infodir}
445
446 %post   libs -p /sbin/ldconfig
447 %postun libs -p /sbin/ldconfig
448
449 %triggerpostun -- poldek < 0.30-0.20080225.00.1
450 if ! grep -q '^%%includedir repos.d' %{_sysconfdir}/%{name}/poldek.conf; then
451         %{__sed} -i -e '/^%%include source.conf/{
452                 a
453                 a# /etc/poldek/repos.d/*.conf
454                 a%%includedir repos.d
455         }' %{_sysconfdir}/%{name}/poldek.conf
456 fi
457
458 %{__sed} -i -e '/%%include %%{_distro}-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
459 %{__sed} -i -e '/%%include %%{_distro}-multilib-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
460
461 if [ -f %{_sysconfdir}/%{name}/pld-source.conf.rpmsave ]; then
462         %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld.conf{,.rpmnew}
463         %{__mv} -v %{_sysconfdir}/%{name}/pld-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld.conf
464 fi
465
466 %ifarch %{x8664}
467 if [ -f %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave ]; then
468         %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf{,.rpmnew}
469         %{__mv} -v %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf
470 fi
471 %endif
472
473 %triggerpostun -- poldek < 0.30.1-3
474 if [ -f %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf.rpmsave ]; then
475         %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt_arch}.conf{,.rpmnew}
476         %{__mv} -v %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt_arch}.conf
477 fi
478 if [ -f %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-multilib.conf.rpmsave ]; then
479         %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt_arch}.conf{,.rpmnew}
480         %{__mv} -v %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-multilib.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt_arch}.conf
481 fi
482
483 %triggerpostun -- %{name} < 0.30.1-8
484 if [ $1 -le 1 ]; then
485         # revert change on  --downgrade
486         %{__sed} -i -re 's,^pm command = %{_libexecdir}/pm-command.sh,#&,' %{_sysconfdir}/%{name}/%{name}.conf
487 else
488         # setup pm command
489         %{__sed} -i -re 's,#?(pm command =).*,\1 %{_libexecdir}/pm-command.sh,' %{_sysconfdir}/%{name}/%{name}.conf
490 fi
491
492 %files -f %{name}.lang
493 %defattr(644,root,root,755)
494 %doc ChangeLog README* NEWS TODO configs
495 %dir %{_sysconfdir}/%{name}
496 %dir %{_sysconfdir}/%{name}/pre-install.d
497 %{_sysconfdir}/%{name}/pre-install.d/README
498 %dir %{_sysconfdir}/%{name}/post-install.d
499 %{_sysconfdir}/%{name}/post-install.d/README
500 %dir %{_sysconfdir}/%{name}/repos.d
501 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
502 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/repos.d/*.conf
503 %attr(755,root,root) %{_bindir}/ipoldek
504 %attr(755,root,root) %{_bindir}/poldek
505 %attr(755,root,root) %{_bindir}/poldek-config
506 %attr(755,root,root) %{_bindir}/rpmvercmp
507 %dir %{_libexecdir}
508 %attr(755,root,root) %{_libexecdir}/pm-command.sh
509 %attr(755,root,root) %{_libexecdir}/poldekuser-setup.sh
510 %attr(755,root,root) %{_libexecdir}/vfcompr
511 %attr(755,root,root) %{_libexecdir}/vfjuggle
512 %attr(755,root,root) %{_libexecdir}/vfsmb
513 %attr(755,root,root) %{_libexecdir}/zlib-in-rpm.sh
514 %{_mandir}/man1/%{name}*.1*
515 %lang(pl) %{_mandir}/pl/man1/%{name}*
516 %{_infodir}/poldek.info*
517 %if %{with imode}
518 %{_desktopdir}/%{name}.desktop
519 %{_pixmapsdir}/%{name}.png
520 %endif
521 %dir /var/cache/%{name}
522
523 %if %{without static}
524 %files libs
525 %defattr(644,root,root,755)
526 %attr(755,root,root) %{_libdir}/libpoclidek.so.*.*.*
527 %attr(755,root,root) %{_libdir}/libpoldek.so.*.*.*
528 %attr(755,root,root) %{_libdir}/libtndb.so.*.*.*
529 %attr(755,root,root) %{_libdir}/libtrurl.so.*.*.*
530 %attr(755,root,root) %{_libdir}/libvfile.so.*.*.*
531 %attr(755,root,root) %ghost %{_libdir}/libpoclidek.so.0
532 %attr(755,root,root) %ghost %{_libdir}/libpoldek.so.2
533 %attr(755,root,root) %ghost %{_libdir}/libtndb.so.0
534 %attr(755,root,root) %ghost %{_libdir}/libtrurl.so.0
535 %attr(755,root,root) %ghost %{_libdir}/libvfile.so.0
536 %endif
537
538 %files devel
539 %defattr(644,root,root,755)
540 %if %{without static}
541 %attr(755,root,root) %{_libdir}/libpoclidek.so
542 %attr(755,root,root) %{_libdir}/libpoldek.so
543 %attr(755,root,root) %{_libdir}/libtndb.so
544 %attr(755,root,root) %{_libdir}/libtrurl.so
545 %attr(755,root,root) %{_libdir}/libvfile.so
546 %endif
547 %{_libdir}/libpoclidek.la
548 %{_libdir}/libpoldek.la
549 %{_libdir}/libtndb.la
550 %{_libdir}/libtrurl.la
551 %{_libdir}/libvfile.la
552 %{_includedir}/poldek
553 %{_includedir}/tndb
554 %{_includedir}/trurl
555 %{_includedir}/vfile
556 %{_pkgconfigdir}/tndb.pc
557 %{_pkgconfigdir}/trurlib.pc
558
559 %files static
560 %defattr(644,root,root,755)
561 %{_libdir}/libtndb.a
562 %{_libdir}/libtrurl.a
563
564 %if %{with python}
565 %files -n python-poldek
566 %defattr(644,root,root,755)
567 %attr(755,root,root) %{py_sitedir}/_poldekmod.so
568 %{py_sitescriptdir}/poldek.py[co]
569 %{py_sitescriptdir}/poldekmod.py[co]
570 %endif
This page took 0.072572 seconds and 3 git commands to generate.