]> git.pld-linux.org Git - packages/poldek.git/blob - poldek.spec
88986a15af92c639132762ecca3098e41cb661d9
[packages/poldek.git] / poldek.spec
1 #
2 # Conditional build:
3 %bcond_with     static  # don't use shared libraries
4 %bcond_without  imode   # don't build interactive mode
5 %bcond_with     curl    # link with curl
6 #
7 # required versions (forced to avoid SEGV with mixed db used by rpm and poldek)
8 %define ver_db  4.2.50-1
9 %define ver_rpm 4.3-0.20030610.29
10 Summary:        RPM packages management helper tool
11 Summary(pl):    Pomocnicze narzêdzie do zarz±dzania pakietami RPM
12 Name:           poldek
13 Version:        0.18.3
14 Release:        1
15 License:        GPL v2
16 Group:          Applications/System
17 Source0:        http://team.pld.org.pl/~mis/poldek/download/%{name}-%{version}.tar.gz
18 # Source0-md5:  d257b86899719e4bd747e1afe4e6888f
19 Source1:        %{name}.conf
20 Patch1:         %{name}-etc_dir.patch
21 Patch2:         %{name}-retr_term.patch
22 Patch3:         %{name}-ldb4.patch
23 Patch4:         %{name}-be-nice-for-proxy.patch
24 URL:            http://team.pld.org.pl/~mis/poldek/
25 BuildRequires:  automake
26 BuildRequires:  autoconf
27 BuildRequires:  bzip2-devel
28 %{?with_curl:BuildRequires:     curl-devel >= 7.8}
29 BuildRequires:  db-devel >= %{ver_db}
30 BuildRequires:  gettext-autopoint
31 BuildRequires:  openssl-devel >= 0.9.7c
32 BuildRequires:  pcre-devel
33 BuildRequires:  popt-devel
34 BuildRequires:  readline-devel
35 BuildRequires:  rpm-devel >= %{ver_rpm}
36 BuildRequires:  zlib-devel
37 BuildRequires:  perl-tools-pod
38 %if %{with static}
39 BuildRequires:  bzip2-static
40 %{?with_curl:BuildRequires:     curl-static}
41 BuildRequires:  db-static >= %{ver_db}
42 BuildRequires:  ncurses-static
43 BuildRequires:  openssl-static
44 BuildRequires:  pcre-static
45 BuildRequires:  popt-static
46 BuildRequires:  readline-static
47 BuildRequires:  rpm-static
48 BuildRequires:  zlib-static
49 BuildRequires:  glibc-static
50 %endif
51 Requires:       db >= %{ver_db}
52 Requires:       rpm >= %{ver_rpm}
53 Requires:       sed
54 Requires:       openssl >= 0.9.7c
55 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57 %description
58 poldek is an RPM package management tool which allows you to easily
59 perform package verification, installation (including system
60 installation from scratch), upgrading, and removal.
61
62 Program can be used in batch (like apt-get from Debian's APT) or
63 interactive mode. The interactive mode puts you into a readline
64 interface with command line autocompletion and history, similar to the
65 shell mode of Perl's CPAN.
66
67 %{?with_static:This version is statically linked.}
68
69 %{!?with_imode:This version hasn't got interactive mode.}
70
71 %description -l pl
72 poldek jest narzêdziem linii poleceñ s³u¿±cym do weryfikacji,
73 instalacji (w³±czaj±c instalacjê systemu od zera), aktualizacji i
74 usuwania pakietów.
75
76 Program mo¿e byæ u¿ywany w trybie wsadowym (jak debianowy apt-get) lub
77 interaktywnym. Tryb interaktywny posiada interfejs readline z
78 dope³nianiem komend i histori±, podobny do trybu shell perlowego
79 modu³u CPAN.
80
81 %{?with_static:Ta wersja jest konsolidowana statycznie.}
82
83 %{!?with_imode:Ta wersja nie posiada trybu interaktywnego.}
84
85 %prep
86 %setup -q
87 %patch1 -p1
88 %patch2 -p1
89 %patch3 -p1
90 %patch4 -p1
91
92 %build
93 %{__autopoint}
94 %{__aclocal} -I m4
95 %{__autoconf}
96 %{__automake}
97 %configure \
98         %{?with_static:--enable-static} \
99         %{!?with_imode:--disable-imode} \
100         %{?with_curl:--with-curl}
101 %{__make}
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105 install -d $RPM_BUILD_ROOT%{_sysconfdir}
106
107 %{__make} install \
108         DESTDIR=$RPM_BUILD_ROOT
109
110 %{?with_static:rm -f $RPM_BUILD_ROOT%{_bindir}/rpmvercmp}
111 sed "s|/i686/|/%{_target_cpu}/|g" < %{SOURCE1} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.conf
112
113 %find_lang %{name}
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %files -f %{name}.lang
119 %defattr(644,root,root,755)
120 %doc README* NEWS TODO *sample* conf/poldekrc*
121 %attr(644,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/%{name}.conf
122 %attr(755,root,root) %{_bindir}/*
123 %{_mandir}/man1/%{name}*
124 %lang(pl) %{_mandir}/pl/man1/%{name}*
This page took 0.073847 seconds and 2 git commands to generate.