]> git.pld-linux.org Git - packages/poldek.git/blob - poldek.spec
- update
[packages/poldek.git] / poldek.spec
1 #
2 # Conditional build:
3 %bcond_with     static  # don't use shared libraries
4 %bcond_without  imode   # don't build interactive mode
5 %bcond_with     curl    # link with curl
6 #
7 # required versions (forced to avoid SEGV with mixed db used by rpm and poldek)
8 %define ver_db  4.3.27-1
9 %define ver_rpm 4.3-0.20040107.34
10 Summary:        RPM packages management helper tool
11 Summary(pl):    Pomocnicze narzêdzie do zarz±dzania pakietami RPM
12 Name:           poldek
13 Version:        0.18.9
14 Release:        1.1
15 License:        GPL v2
16 Group:          Applications/System
17 Source0:        http://team.pld.org.pl/~mis/poldek/download/%{name}-%{version}.tar.bz2
18 # Source0-md5:  c49eb9086a7ee77e50c527f9c95e41aa
19 Source1:        %{name}.conf
20 Patch0:         %{name}-etc_dir.patch
21 Patch1:         %{name}-retr_term.patch
22 Patch2:         %{name}-simplestatic.patch
23 Patch3:         %{name}-prereq.patch
24 URL:            http://team.pld.org.pl/~mis/poldek/
25 BuildRequires:  automake
26 BuildRequires:  autoconf
27 BuildRequires:  bzip2-devel
28 %{?with_curl:BuildRequires:     curl-devel >= 7.8}
29 BuildRequires:  db-devel >= %{ver_db}
30 BuildRequires:  gettext-autopoint
31 BuildRequires:  openssl-devel >= 0.9.7d
32 BuildRequires:  pcre-devel
33 BuildRequires:  perl-tools-pod
34 BuildRequires:  popt-devel
35 BuildRequires:  readline-devel
36 BuildRequires:  rpm-devel >= %{ver_rpm}
37 BuildRequires:  zlib-devel
38 %if %{with static}
39 BuildRequires:  bzip2-static
40 %{?with_curl:BuildRequires:     curl-static}
41 BuildRequires:  db-static >= %{ver_db}
42 BuildRequires:  glibc-static
43 BuildRequires:  libselinux-static
44 BuildRequires:  ncurses-static
45 BuildRequires:  openssl-static
46 BuildRequires:  pcre-static
47 BuildRequires:  popt-static
48 BuildRequires:  readline-static
49 BuildRequires:  rpm-static
50 BuildRequires:  zlib-static
51 %endif
52 Requires(triggerpostun):        sed >= 4.0
53 Requires:       db >= %{ver_db}
54 Requires:       rpm >= %{ver_rpm}
55 Requires:       sed
56 Requires:       openssl >= 0.9.7c
57 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
59 %description
60 poldek is an RPM package management tool which allows you to easily
61 perform package verification, installation (including system
62 installation from scratch), upgrading, and removal.
63
64 Program can be used in batch (like apt-get from Debian's APT) or
65 interactive mode. The interactive mode puts you into a readline
66 interface with command line autocompletion and history, similar to the
67 shell mode of Perl's CPAN.
68
69 %{?with_static:This version is statically linked.}
70
71 %{!?with_imode:This version hasn't got interactive mode.}
72
73 #' vim
74
75 %description -l pl
76 poldek jest narzêdziem linii poleceñ s³u¿±cym do weryfikacji,
77 instalacji (w³±czaj±c instalacjê systemu od zera), aktualizacji i
78 usuwania pakietów.
79
80 Program mo¿e byæ u¿ywany w trybie wsadowym (jak debianowy apt-get) lub
81 interaktywnym. Tryb interaktywny posiada interfejs readline z
82 dope³nianiem komend i histori±, podobny do trybu shell perlowego
83 modu³u CPAN.
84
85 %{?with_static:Ta wersja jest konsolidowana statycznie.}
86
87 %{!?with_imode:Ta wersja nie posiada trybu interaktywnego.}
88
89 %prep
90 %setup -q
91 %patch0 -p1
92 %patch1 -p1
93 %patch2 -p0
94 %patch3 -p1
95
96 %build
97 %{__autopoint}
98 %{__aclocal} -I m4
99 %{__autoconf}
100 %{__autoheader}
101 %{__automake}
102 cp -f config.sub trurlib
103 %configure \
104         %{?with_static:--enable-static} \
105         %{!?with_imode:--disable-imode} \
106         %{?with_curl:--with-curl}
107 %{__make}
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111 install -d $RPM_BUILD_ROOT%{_sysconfdir}
112
113 %{__make} install \
114         DESTDIR=$RPM_BUILD_ROOT
115
116 %{?with_static:rm -f $RPM_BUILD_ROOT%{_bindir}/rpmvercmp}
117
118 #
119 # CHANGE IT WHEN SWITCHING poldek.conf FROM AC TO TH !!!
120 #
121 %ifarch i386 i586 i686 ppc sparc alpha amd64 athlon
122 %define         _ftp_arch       %{_target_cpu}
123 %else
124 %ifarch i486
125 %define         _ftp_arch       i386
126 %else
127 %ifarch pentium2 pentium3 pentium4
128 %define         _ftp_arch       i686
129 %else
130 %ifarch sparcv9 sparc64
131 %define         _ftp_arch       sparc
132 %endif
133 %endif
134 %endif
135 %endif
136
137 sed "s|%%ARCH%%|%{_ftp_arch}|g" < %{SOURCE1} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.conf
138
139 %find_lang %{name}
140
141 # no poldek-{devel,static}
142 rm -rf $RPM_BUILD_ROOT%{_includedir}
143 rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.a
144 rm -rf $RPM_BUILD_ROOT%{_libdir}/libtrurl.so.0.4.0
145 rm -rf $RPM_BUILD_ROOT%{_libdir}/libtrurl.la
146
147 %clean
148 rm -rf $RPM_BUILD_ROOT
149
150 %triggerpostun -- poldek <= 0.18.3-5
151 sed -i -e '/^promoteepoch:.*yes/s/^/#/' %{_sysconfdir}/poldek.conf
152
153 # otherwise don't touch
154 %ifarch i386 i586 i686 ppc sparc alpha amd64 athlon
155 %triggerpostun -- poldek <= 0.18.7-1
156 sed -i -e 's://ftp.pld-linux.org://ftp.%{_target_cpu}.ac.pld-linux.org:g' /etc/poldek.conf
157 %endif
158
159 %files -f %{name}.lang
160 %defattr(644,root,root,755)
161 %doc README* NEWS TODO *sample* conf/poldekrc*
162 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.conf
163 %attr(755,root,root) %{_bindir}/*
164 %{_mandir}/man1/%{name}*
165 %lang(pl) %{_mandir}/pl/man1/%{name}*
This page took 0.070621 seconds and 3 git commands to generate.