]> git.pld-linux.org Git - packages/poldek.git/blob - poldek.spec
7efded6bff6a6f9e0f2e25208ff28b7f4bdc61af
[packages/poldek.git] / poldek.spec
1 #
2 # Conditional build:
3 %bcond_with     static  # don't use shared libraries
4 %bcond_without  imode   # don't build interactive mode
5 %bcond_with     curl    # link with curl
6 #
7 # required versions (forced to avoid SEGV with mixed db used by rpm and poldek)
8 %define ver_db  4.3.27-1
9 %define ver_rpm 4.3-0.20040107.34
10 Summary:        RPM packages management helper tool
11 Summary(pl):    Pomocnicze narzêdzie do zarz±dzania pakietami RPM
12 Name:           poldek
13 Version:        0.18.8
14 Release:        11
15 License:        GPL v2
16 Group:          Applications/System
17 Source0:        http://team.pld.org.pl/~mis/poldek/download/%{name}-%{version}.tar.bz2
18 # Source0-md5:  f7e2978c7f8b35b0b07d0278dd299881
19 Source1:        %{name}.conf
20 Patch0:         %{name}-etc_dir.patch
21 Patch1:         %{name}-retr_term.patch
22 Patch2:         %{name}-simplestatic.patch
23 Patch3:         %{name}-gcc4.patch
24 Patch4:         %{name}-cookie.patch
25 Patch5:         %{name}-rpmcmd.patch
26 Patch6:         %{name}-fmtime.patch
27 URL:            http://team.pld.org.pl/~mis/poldek/
28 BuildRequires:  automake
29 BuildRequires:  autoconf
30 BuildRequires:  bzip2-devel
31 %{?with_curl:BuildRequires:     curl-devel >= 7.8}
32 BuildRequires:  db-devel >= %{ver_db}
33 BuildRequires:  gettext-autopoint
34 BuildRequires:  openssl-devel >= 0.9.7d
35 BuildRequires:  pcre-devel
36 BuildRequires:  popt-devel
37 BuildRequires:  readline-devel
38 BuildRequires:  rpm-devel >= %{ver_rpm}
39 BuildRequires:  zlib-devel
40 BuildRequires:  perl-tools-pod
41 %if %{with static}
42 BuildRequires:  bzip2-static
43 %{?with_curl:BuildRequires:     curl-static}
44 BuildRequires:  db-static >= %{ver_db}
45 BuildRequires:  glibc-static
46 BuildRequires:  libselinux-static
47 BuildRequires:  ncurses-static
48 BuildRequires:  openssl-static
49 BuildRequires:  pcre-static
50 BuildRequires:  popt-static
51 BuildRequires:  readline-static
52 BuildRequires:  rpm-static
53 BuildRequires:  zlib-static
54 %endif
55 Requires:       db >= %{ver_db}
56 Requires:       ed
57 Requires:       rpm >= %{ver_rpm}
58 Requires:       sed
59 Requires:       openssl >= 0.9.7c
60 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
61
62 %description
63 poldek is an RPM package management tool which allows you to easily
64 perform package verification, installation (including system
65 installation from scratch), upgrading, and removal.
66
67 Program can be used in batch (like apt-get from Debian's APT) or
68 interactive mode. The interactive mode puts you into a readline
69 interface with command line autocompletion and history, similar to the
70 shell mode of Perl's CPAN.
71
72 %{?with_static:This version is statically linked.}
73
74 %{!?with_imode:This version hasn't got interactive mode.}
75
76 %description -l pl
77 poldek jest narzêdziem linii poleceñ s³u¿±cym do weryfikacji,
78 instalacji (w³±czaj±c instalacjê systemu od zera), aktualizacji i
79 usuwania pakietów.
80
81 Program mo¿e byæ u¿ywany w trybie wsadowym (jak debianowy apt-get) lub
82 interaktywnym. Tryb interaktywny posiada interfejs readline z
83 dope³nianiem komend i histori±, podobny do trybu shell perlowego
84 modu³u CPAN.
85
86 %{?with_static:Ta wersja jest konsolidowana statycznie.}
87
88 %{!?with_imode:Ta wersja nie posiada trybu interaktywnego.}
89
90 %prep
91 %setup -q
92 %patch0 -p1
93 %patch1 -p1
94 %patch2 -p0
95 %patch3 -p1
96 %patch4 -p1
97 %patch5 -p1
98 %patch6 -p0
99
100 %build
101 %{__autopoint}
102 %{__aclocal} -I m4
103 %{__autoconf}
104 %{__autoheader}
105 %{__automake}
106 cp -f config.sub trurlib
107 %configure \
108         %{?with_static:--enable-static} \
109         %{!?with_imode:--disable-imode} \
110         %{?with_curl:--with-curl}
111 %{__make}
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115 install -d $RPM_BUILD_ROOT%{_sysconfdir}
116
117 %{__make} install \
118         DESTDIR=$RPM_BUILD_ROOT
119
120 %{?with_static:rm -f $RPM_BUILD_ROOT%{_bindir}/rpmvercmp}
121
122 #
123 # CHANGE IT WHEN SWITCHING poldek.conf FROM AC TO TH !!!
124 #
125 %ifarch i386 i586 i686 ppc sparc alpha amd64 athlon
126 %define         _ftp_arch       %{_target_cpu}
127 %else
128 %ifarch i486
129 %define         _ftp_arch       i386
130 %else
131 %ifarch pentium2 pentium3 pentium4
132 %define         _ftp_arch       i686
133 %else
134 %ifarch sparcv9 sparc64
135 %define         _ftp_arch       sparc
136 %endif
137 %endif
138 %endif
139 %endif
140
141 sed "s|%%ARCH%%|%{_ftp_arch}|g" < %{SOURCE1} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.conf
142
143 %find_lang %{name}
144
145 %clean
146 rm -rf $RPM_BUILD_ROOT
147
148 %triggerpostun -- poldek <= 0.18.3-5
149 if grep -q '^promoteepoch.*yes' %{_sysconfdir}/poldek.conf ; then
150         echo -e ',s:^promoteepoch:# promoteepoch:g\n,w' | ed -s %{_sysconfdir}/poldek.conf
151 fi
152
153 # otherwise don't touch
154 %ifarch i386 i586 i686 ppc sparc alpha amd64 athlon
155 %triggerpostun -- poldek <= 0.18.7-1
156 echo -e ',s://ftp.pld-linux.org://ftp.%{_target_cpu}.ac.pld-linux.org:g\n,w' |\
157         ed -s /etc/poldek.conf ||:
158 %endif
159
160 %files -f %{name}.lang
161 %defattr(644,root,root,755)
162 %doc README* NEWS TODO *sample* conf/poldekrc*
163 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.conf
164 %attr(755,root,root) %{_bindir}/*
165 %{_mandir}/man1/%{name}*
166 %lang(pl) %{_mandir}/pl/man1/%{name}*
This page took 0.059476 seconds and 2 git commands to generate.