]> git.pld-linux.org Git - packages/poldek.git/blob - poldek.spec
- release 6
[packages/poldek.git] / poldek.spec
1 # TODO:
2 # - fails to build without poldek-devel - fix it !
3 #
4 # Conditional build:
5 %bcond_with     static  # don't use shared libraries
6 %bcond_without  imode   # don't build interactive mode
7 %bcond_without  python  # don't build python bindings
8
9 # required versions (forced to avoid SEGV with mixed db used by rpm and poldek)
10 %if "%{pld_release}" == "ti"
11 %define ver_db  4.5.20
12 %define ver_db_rel      8
13 %else
14 %define ver_db  4.7.25
15 %define ver_db_rel      1
16 %endif
17 %define ver_rpm 4.5-49
18
19 %define         snap    rc5
20 %define         rel     6
21 Summary:        RPM packages management helper tool
22 Summary(hu.UTF-8):      RPM csomagkezelést segítő eszköz
23 Summary(pl.UTF-8):      Pomocnicze narzędzie do zarządzania pakietami RPM
24 Name:           poldek
25 Version:        0.30
26 Release:        1.%{snap}.%{rel}
27 License:        GPL v2
28 Group:          Applications/System
29 #Source0:       http://poldek.pld-linux.org/download/snapshots/%{name}-%{version}-cvs%{snap}.tar.bz2
30 Source0:        http://carme.pld-linux.org/~cactus/snaps/poldek/%{name}-%{version}%{snap}.tar.xz
31 # Source0-md5:  ab89926c28cfb6b7d72497fc37c16ac4
32 Source1:        %{name}.conf
33 Source2:        %{name}-multilib.conf
34 Source3:        %{name}-ti.conf
35 Source4:        %{name}-multilib-ti.conf
36 Source5:        %{name}-aliases.conf
37 Source6:        %{name}.desktop
38 Source7:        %{name}.png
39 Source8:        %{name}-debuginfo.conf
40 Source9:        %{name}-aidath.conf
41 Source10:       %{name}-multilib-aidath.conf
42 Source11:       %{name}-archive.conf
43 Patch0:         %{name}-vserver-packages.patch
44 Patch1:         %{name}-config.patch
45 Patch2:         %{name}-size-type.patch
46 Patch3:         %{name}-Os-fail-workaround.patch
47 Patch4:         %{name}-git.patch
48 URL:            http://poldek.pld-linux.org/
49 BuildRequires:  autoconf
50 BuildRequires:  automake
51 BuildRequires:  bzip2-devel
52 BuildRequires:  check-devel
53 BuildRequires:  db-devel >= %{ver_db}-%{ver_db_rel}
54 BuildRequires:  docbook-dtd412-xml
55 BuildRequires:  gettext-devel
56 BuildRequires:  libtool
57 BuildRequires:  libxml2-devel
58 BuildRequires:  neon-devel
59 BuildRequires:  openssl-devel >= 0.9.7d
60 BuildRequires:  pcre-devel
61 BuildRequires:  pkgconfig
62 BuildRequires:  popt-devel
63 %{?with_python:BuildRequires:   python-devel}
64 BuildRequires:  readline-devel >= 5.0
65 BuildRequires:  rpm-devel >= %{ver_rpm}
66 %{?with_python:BuildRequires:   rpm-pythonprov}
67 BuildRequires:  swig-python
68 BuildRequires:  xmlto
69 BuildRequires:  zlib-devel
70 %if %{with static}
71 BuildRequires:  bzip2-static
72 BuildRequires:  db-static >= %{ver_db}-%{ver_db_rel}
73 BuildRequires:  glibc-static
74 BuildRequires:  libselinux-static
75 BuildRequires:  libxml2-static
76 BuildRequires:  ncurses-static
77 BuildRequires:  openssl-static
78 BuildRequires:  pcre-static
79 BuildRequires:  popt-static
80 BuildRequires:  readline-static
81 BuildRequires:  rpm-static
82 BuildRequires:  zlib-static
83 %endif
84 Requires(triggerpostun):        awk
85 Requires(triggerpostun):        sed >= 4.0
86 Requires:       %{name}-libs = %{version}-%{release}
87 Requires:       db >= %{ver_db}-%{ver_db_rel}
88 Requires:       rpm >= %{ver_rpm}
89 Requires:       rpm-db-ver = %{ver_db}
90 Requires:       rpm-lib = %(rpm -q --qf '%{V}' rpm-lib)
91 # vf* scripts use sed
92 Requires:       sed
93 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
94
95 %description
96 poldek is an RPM package management tool which allows you to easily
97 perform package verification, installation (including system
98 installation from scratch), upgrading, and removal.
99
100 Program can be used in batch (like apt-get from Debian's APT) or
101 interactive mode. The interactive mode puts you into a readline
102 interface with command line autocompletion and history, similar to the
103 shell mode of Perl's CPAN.
104
105 %{?with_static:This version is statically linked.}
106
107 %{!?with_imode:This version hasn't got interactive mode.}
108 #'vim
109
110 %description -l hu.UTF-8
111 poldek egy RPM csomagkezelő eszköz, amely megkönnyíti a
112 csomagellenőrzést, telepítést (beleértve a rendszertelepítést a
113 nulláról), frissítést és eltávolítást.
114
115 A program használható parancssorból (mint a Debian apt-get programja)
116 vagy interaktív módban. Az interaktív mód egy readline környezetet
117 jelent, parancskiegészítéssel és előzményekkel, hasonlóan a Perl CPAN
118 shell módjához.
119
120 %{?with_static:Ez a verzió statikusan linkelt.}
121
122 %{!?with_imode:Ennek a verziónak nincs interaktív módja.}
123
124 %description -l pl.UTF-8
125 poldek jest narzędziem linii poleceń służącym do weryfikacji,
126 instalacji (włączając instalację systemu od zera), aktualizacji i
127 usuwania pakietów.
128
129 Program może być używany w trybie wsadowym (jak debianowy apt-get) lub
130 interaktywnym. Tryb interaktywny posiada interfejs readline z
131 dopełnianiem komend i historią, podobny do trybu shell perlowego
132 modułu CPAN.
133
134 %{?with_static:Ta wersja jest konsolidowana statycznie.}
135
136 %{!?with_imode:Ta wersja nie posiada trybu interaktywnego.}
137
138 %package libs
139 Summary:        poldek libraries
140 Summary(hu.UTF-8):      A poldek könyvtárai
141 Summary(pl.UTF-8):      Biblioteki poldka
142 Group:          Libraries
143
144 %description libs
145 poldek libraries.
146
147 %description libs -l hu.UTF-8
148 A poldek könyvtárai.
149
150 %description libs -l pl.UTF-8
151 Biblioteki poldka.
152
153 %package devel
154 Summary:        Header files for poldek libraries
155 Summary(hu.UTF-8):      A poldek könyvtár fejlesztői fájljai
156 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek poldka
157 Group:          Development/Libraries
158 Requires:       %{name}-libs = %{version}-%{release}
159 Requires:       rpm-devel >= %{ver_rpm}
160
161 %description devel
162 Header files for poldek libraries.
163
164 %description devel -l hu.UTF-8
165 A poldek könyvtár fejlesztői fájljai.
166
167 %description devel -l pl.UTF-8
168 Pliki nagłówkowe bibliotek poldka.
169
170 %package static
171 Summary:        poldek static libraries
172 Summary(hu.UTF-8):      poldek statikus könyvtárak
173 Summary(pl.UTF-8):      Biblioteki statyczne poldka
174 Group:          Development/Libraries
175 Requires:       %{name}-devel = %{version}-%{release}
176
177 %description static
178 poldek static libraries.
179
180 %description static -l hu.UTF-8
181 poldek statikus könyvtárak.
182
183 %description static -l pl.UTF-8
184 Biblioteki statyczne poldka.
185
186 %package -n python-poldek
187 Summary:        Python modules for poldek
188 Summary(hu.UTF-8):      Python modulok poldek-hez
189 Summary(pl.UTF-8):      Moduły języka Python dla poldka
190 Group:          Libraries/Python
191 Requires:       %{name}-libs = %{version}-%{release}
192 %pyrequires_eq  python-libs
193
194 %description -n python-poldek
195 Python modules for poldek.
196
197 %description -n python-poldek -l hu.UTF-8
198 Python modulok poldek-hez.
199
200 %description -n python-poldek -l pl.UTF-8
201 Moduły języka Python dla poldka.
202
203 %prep
204 %setup -q
205 %patch0 -p1
206 %patch1 -p1
207 %patch2 -p1
208 %patch3 -p1
209 %patch4 -p1
210
211 rm -f m4/libtool.m4 m4/lt*.m4
212
213 # cleanup backups after patching
214 find . '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
215 chmod u+x ./configure ./doc/conf-xml2.sh
216
217 %build
218 %{__libtoolize}
219 %{__aclocal} -I m4
220 %{__autoheader}
221 %{__autoconf}
222 %{__automake}
223 cd tndb
224 %{__libtoolize}
225 autoreconf -i
226 cd ../trurlib
227 %{__libtoolize}
228 autoreconf -i
229 cd ..
230
231 CPPFLAGS="-std=gnu99"
232 %configure \
233         %{?with_static:--enable-static --disable-shared} \
234         %{!?with_imode:--disable-imode} \
235         --enable-nls \
236         %{?with_python:--with-python}
237 %{__make}
238 #       --enable-trace
239
240 %install
241 rm -rf $RPM_BUILD_ROOT
242 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name}/repos.d,/var/cache/%{name}}
243
244 %{__make} install \
245         DESTDIR=$RPM_BUILD_ROOT
246
247 %if %{with python}
248 %{__make} -C python install \
249         DESTDIR=$RPM_BUILD_ROOT \
250         libdir=%{py_sitedir}
251 %endif
252
253 %{?with_static:rm -f $RPM_BUILD_ROOT%{_bindir}/rpmvercmp}
254
255 %ifarch i486 i686 ppc sparc alpha athlon
256         %define         _ftp_arch       %{_target_cpu}
257 %endif
258 %ifarch %{x8664}
259         %define         _ftp_arch       x86_64
260         %define         _ftp_alt_arch   i686
261 %endif
262 %ifarch i586
263         %if "%{pld_release}" == "ti"
264                 %define         _ftp_arch       i586
265         %else
266                 %define         _ftp_arch       i486
267         %endif
268 %endif
269 %ifarch pentium2 pentium3 pentium4
270         %define         _ftp_arch       i686
271 %endif
272 %ifarch sparcv9 sparc64
273         %define         _ftp_arch       sparc
274         %if "%{pld_release}" == "th"
275                 %define         _ftp_arch       %{_target_cpu}
276                 %ifarch sparc64
277                 %define         _ftp_alt_arch   sparcv9
278                 %endif
279         %endif
280 %endif
281
282 %if "%{pld_release}" == "ti"
283         %define pld_conf %{SOURCE3}
284         %ifarch %{x8664}
285                 %define pld_multilib_conf %{SOURCE4}
286         %endif
287 %endif
288
289 %if "%{pld_release}" == "th"
290         %define pld_conf %{SOURCE1}
291         %define pld_debuginfo_conf %{SOURCE8}
292         %define pld_archive_conf %{SOURCE11}
293
294         %ifarch %{x8664}
295                 %define pld_multilib_conf %{SOURCE2}
296         %endif
297
298         # aidath
299         %ifarch sparcv9 sparc64
300                 %define pld_conf %{SOURCE9}
301                 %undefine pld_archive_conf
302         %endif
303         %ifarch sparc64
304                 %define pld_multilib_conf %{SOURCE10}
305         %endif
306 %endif
307
308 sed -e 's|%%ARCH%%|%{_ftp_arch}|g' < %{pld_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
309
310 %if 0%{?pld_multilib_conf:1}
311         sed 's|%%ARCH%%|%{_ftp_alt_arch}|g' < %{pld_multilib_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-multilib.conf
312 %endif
313
314 %if 0%{?pld_debuginfo_conf:1}
315 sed -e 's|%%ARCH%%|%{_ftp_arch}|g' < %{pld_debuginfo_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-debuginfo.conf
316 %endif
317
318 %if 0%{?pld_archive_conf:1}
319 sed -e 's|%%ARCH%%|%{_ftp_arch}|g' < %{pld_archive_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-archive.conf
320 %endif
321
322 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/cli.conf
323
324 %if %{with imode}
325 # add desktop file and icon
326 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
327 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
328 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
329 %endif
330
331 # sources we don't package
332 rm -f $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{rh,pld,fedora,centos}-source.conf
333 # include them in %doc
334 rm -rf configs
335 cp -a conf configs
336 rm -f configs/Makefile*
337
338 %if %{with python}
339 %py_postclean
340 rm -f $RPM_BUILD_ROOT%{py_sitedir}/_poldekmod.la
341 %endif
342
343 %find_lang %{name}
344
345 %clean
346 rm -rf $RPM_BUILD_ROOT
347
348 %post
349 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
350 if [ "$1" = "1" ]; then
351         # remove ignore = vserver-packages inside vserver on first install
352         {
353                 while read f ctx; do
354                         [ "$f" = "VxID:" -o "$f" = "s_context:" ] && break
355                 done </proc/self/status
356         } 2>/dev/null
357         if [ -z "$ctx" -o "$ctx" = "0" ]; then
358                 VSERVER=no
359         else
360                 VSERVER=yes
361         fi
362         if [ "$VSERVER" = "yes" ]; then
363                 %{__sed} -i -e '/^ignore/s/vserver-packages//' %{_sysconfdir}/%{name}/poldek.conf
364         fi
365 fi
366
367 %postun -p      /sbin/postshell
368 -/usr/sbin/fix-info-dir -c %{_infodir}
369
370 %post   libs -p /sbin/ldconfig
371 %postun libs -p /sbin/ldconfig
372
373 %triggerpostun -- poldek < 0.19.0-1.20050613.22.0
374 if [ -f /etc/poldek.conf.rpmsave ]; then
375         awk '/^source/ {
376         name = $3;
377         path = $4;
378         auto = "yes";
379         autoup = "yes";
380         type = "pdir";
381         pri = "";
382
383         if (sub(",noauto", "", name)) {
384                 auto = "no";
385         }
386
387         # process pri=\d+
388         if (match(name, /,pri=[0-9]+/)) {
389                 pri = substr(name, RSTART + 5, RLENGTH - 5);
390                 name = substr(name, 1, RSTART - 1) substr(name, RSTART + RLENGTH);
391         }
392
393         # skip ac sources. already in new config.
394         if (name !~ /^ac(-(ready|test|supported|updates-(general|security)))?$/) {
395                 print "";
396                 print "[source]";
397                 print "name = " name;
398                 print "type = " type;
399                 print "path = " path;
400                 print "auto = " auto;
401                 print "autoup = " autoup;
402                 if (pri) {
403                         print "pri = " pri;
404                 }
405         }
406
407         }' < /etc/poldek.conf.rpmsave >> /etc/poldek/source.conf
408         echo "Converted old custom sources from /etc/poldek.conf.rpmsave to new poldek format in /etc/poldek/source.conf"
409
410         # copy hold=
411         hold=$(grep ^hold /etc/poldek.conf.rpmsave)
412         if [ "$hold" ]; then
413                 sed -i -e "/^#hold =/s/^.*/$hold/" /etc/poldek/poldek.conf
414         fi
415 fi
416
417 %triggerpostun -- poldek < 0.30-0.20080225.00.1
418 if ! grep -q '^%%includedir repos.d' %{_sysconfdir}/%{name}/poldek.conf; then
419         %{__sed} -i -e '/^%%include source.conf/{
420                 a
421                 a# /etc/poldek/repos.d/*.conf
422                 a%%includedir repos.d
423         }' %{_sysconfdir}/%{name}/poldek.conf
424 fi
425
426 %{__sed} -i -e '/%%include %%{_distro}-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
427 %{__sed} -i -e '/%%include %%{_distro}-multilib-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
428
429 if [ -f %{_sysconfdir}/%{name}/pld-source.conf.rpmsave ]; then
430         cp -f %{_sysconfdir}/%{name}/repos.d/pld.conf{,.rpmnew}
431         cp -f %{_sysconfdir}/%{name}/pld-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld.conf
432 fi
433
434 %ifarch %{x8664}
435 if [ -f %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave ]; then
436         cp -f %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf{,.rpmnew}
437         cp -f %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf
438 fi
439 %endif
440
441 %files -f %{name}.lang
442 %defattr(644,root,root,755)
443 %doc ChangeLog README* NEWS TODO configs
444 %dir %{_sysconfdir}/%{name}
445 %dir %{_sysconfdir}/%{name}/repos.d
446 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
447 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/repos.d/*.conf
448 %attr(755,root,root) %{_bindir}/*
449 %dir %{_libdir}/%{name}
450 %attr(755,root,root) %{_libdir}/%{name}/*
451 %{_mandir}/man1/%{name}*
452 %lang(pl) %{_mandir}/pl/man1/%{name}*
453 %{_infodir}/poldek.info*
454 %if %{with imode}
455 %{_desktopdir}/%{name}.desktop
456 %{_pixmapsdir}/%{name}.png
457 %endif
458 %dir /var/cache/%{name}
459
460 %if %{without static}
461 %files libs
462 %defattr(644,root,root,755)
463 %attr(755,root,root) %{_libdir}/libpoclidek.so.*.*.*
464 %attr(755,root,root) %{_libdir}/libpoldek.so.*.*.*
465 %attr(755,root,root) %{_libdir}/libtndb.so.*.*.*
466 %attr(755,root,root) %{_libdir}/libtrurl.so.*.*.*
467 %attr(755,root,root) %{_libdir}/libvfile.so.*.*.*
468 %attr(755,root,root) %ghost %{_libdir}/libpoclidek.so.0
469 %attr(755,root,root) %ghost %{_libdir}/libpoldek.so.2
470 %attr(755,root,root) %ghost %{_libdir}/libtndb.so.0
471 %attr(755,root,root) %ghost %{_libdir}/libtrurl.so.0
472 %attr(755,root,root) %ghost %{_libdir}/libvfile.so.0
473 %endif
474
475 %files devel
476 %defattr(644,root,root,755)
477 %{!?with_static:%attr(755,root,root) %{_libdir}/lib*.so}
478 %{_libdir}/lib*.la
479 %{_includedir}/*
480
481 %files static
482 %defattr(644,root,root,755)
483 %{_libdir}/lib*.a
484
485 %if %{with python}
486 %files -n python-poldek
487 %defattr(644,root,root,755)
488 %attr(755,root,root) %{py_sitedir}/_poldekmod.so
489 %{py_sitescriptdir}/poldek.py[co]
490 %{py_sitescriptdir}/poldekmod.py[co]
491 %endif
This page took 0.091521 seconds and 3 git commands to generate.