]> git.pld-linux.org Git - packages/poldek.git/blob - poldek.spec
- release 5: changes in default poldek.conf file:
[packages/poldek.git] / poldek.spec
1 #
2 # conditional build:
3 #  --with static        - don't use shared libraries
4 #  --without imode      - don't build interactive mode
5 #  --without curl       - don't link curl
6 #
7 Summary:        RPM packages management helper tool
8 Summary(pl):    Pomocnicze narzêdzie do zarz±dzania pakietami RPM
9 Name:           poldek
10 Version:        0.18
11 Release:        5
12 License:        GPL v2
13 Group:          Applications/System
14 Source0:        http://team.pld.org.pl/~mis/poldek/download/%{name}-%{version}.tar.bz2
15 Source1:        %{name}.conf
16 Patch0:         %{name}-vfprogress.patch
17 Patch1:         %{name}-hold-fix.patch
18 Patch2:         %{name}-sigsev.patch
19 URL:            http://team.pld.org.pl/~mis/poldek/
20 Requires:       rpm >= 4.0.2-62
21 Requires:       sed
22 BuildRequires:  bzip2-devel
23 %{?_with_curl:BuildRequires:    curl-devel >= 7.8}
24 BuildRequires:  openssl-devel
25 BuildRequires:  pcre-devel
26 BuildRequires:  popt-devel
27 BuildRequires:  readline-devel
28 BuildRequires:  rpm-devel >= 4.0.2-62
29 BuildRequires:  zlib-devel
30 BuildRequires:  /usr/bin/pod2man
31 %{?_with_static:BuildRequires:  bzip2-static}
32 %{?_with_curl:%{?_with_static:BuildRequires:    curl-static}}
33 %{?_with_static:BuildRequires:  openssl-static}
34 %{?_with_static:BuildRequires:  pcre-static}
35 %{?_with_static:BuildRequires:  popt-static}
36 %{?_with_static:BuildRequires:  rpm-static}
37 %{?_with_static:BuildRequires:  zlib-static}
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 poldek is an RPM package management tool which allows you to easily
42 perform package verification, installation (including system
43 installation from scratch), upgrading, and removal.
44
45 Program can be used in batch (like apt-get from Debian's APT) or
46 interactive mode. The interactive mode puts you into a readline
47 interface with command line autocompletion and history, similar to the
48 shell mode of Perl's CPAN.
49
50 %{?_with_static:This version is statically linked.}
51
52 %{?_without_imode:This version hasn't got interactive mode.}
53
54 %description -l pl
55 poldek jest narzêdziem linii poleceñ s³u¿±cym do weryfikacji,
56 instalacji (w³±czaj±c instalacjê systemu od zera), aktualizacji
57 i usuwania pakietów.
58
59 Program mo¿e byæ u¿ywany w trybie wsadowym (jak debianowy apt-get)
60 lub interaktywnym. Tryb interaktywny posiada interfejs readline
61 z dope³nianiem komend i histori±, podobny do trybu shell perlowego
62 modu³u CPAN.
63
64 %{?_with_static:Ta wersja jest konsolidowana statycznie.}
65
66 %{?_without_imode:Ta wersja nie posiada trybu interaktywnego.}
67
68 %prep
69 %setup -q
70 %patch0 -p0
71 %patch1 -p0 
72 %patch2 -p0
73
74 %build
75 if ! grep -q AM_GNU_GETTEXT_VERSION configure.in ; then
76         cp configure.in configure.in.orig
77         sed -e 's/AM_GNU_GETTEXT\(.*\)/AM_GNU_GETTEXT\1\
78 AM_GNU_GETTEXT_VERSION(0.10.40)/' \
79                 -e 's=po/Makefile.in=po/Makefile.in intl/Makefile=' \
80                 configure.in.orig >configure.in
81         autopoint --force
82 fi
83 %{__aclocal} -I m4
84 %{__autoconf}
85 %{__automake}
86 %configure \
87         %{?_with_static:--enable-static} \
88         %{?_without_imode:--disable-imode} \
89         %{?_with_curl:--with-curl}
90 %{__make}
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94 install -d $RPM_BUILD_ROOT%{_sysconfdir}
95
96 # no strip cause program's beta stage and core may be useful
97 %{__make} install DESTDIR=$RPM_BUILD_ROOT
98 %{?_with_static:rm -f $RPM_BUILD_ROOT/%{_bindir}/rpmvercmp}
99 sed "s|/i686/|/%{_target_cpu}/|g" < %{SOURCE1} > $RPM_BUILD_ROOT/etc/%{name}.conf
100
101 %find_lang %{name}
102
103 %clean
104 rm -rf $RPM_BUILD_ROOT
105
106 %files -f %{name}.lang
107 %defattr(644,root,root,755)
108 %doc README* NEWS TODO *sample* conf/poldekrc*
109 %attr(644,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/%{name}.conf
110 %attr(755,root,root) %{_bindir}/*
111 %{_mandir}/man1/%{name}*
112 %lang(pl) %{_mandir}/pl/man1/%{name}*
This page took 0.033094 seconds and 3 git commands to generate.