]> git.pld-linux.org Git - packages/pokerth.git/commitdiff
- added protobuf patch (fixes regeneration with recent protoc, required by protobuf... auto/th/pokerth-1.1.1-4
authorJakub Bogusz <qboosh@pld-linux.org>
Tue, 12 Dec 2017 20:16:03 +0000 (21:16 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Tue, 12 Dec 2017 20:16:03 +0000 (21:16 +0100)
- release 4

pokerth-protobuf.patch [new file with mode: 0644]
pokerth.spec

diff --git a/pokerth-protobuf.patch b/pokerth-protobuf.patch
new file mode 100644 (file)
index 0000000..cb0ba08
--- /dev/null
@@ -0,0 +1,24 @@
+"reserved" is protoc keyword now.
+
+--- PokerTH-1.1.1-src/pokerth.proto.orig       2014-01-10 22:18:20.743643130 +0100
++++ PokerTH-1.1.1-src/pokerth.proto    2017-12-12 20:56:47.300267594 +0100
+@@ -701,7 +701,7 @@
+ message ErrorMessage {
+       enum ErrorReason {
+-              reserved = 0;
++              reserved_ = 0;
+               initVersionNotSupported = 1;
+               initServerFull = 2;
+               initAuthFailure = 3;
+--- PokerTH-1.1.1-src/src/net/common/netpacket.cpp.orig        2014-01-10 22:18:20.917643110 +0100
++++ PokerTH-1.1.1-src/src/net/common/netpacket.cpp     2017-12-12 21:02:41.138399391 +0100
+@@ -249,7 +249,7 @@
+               retVal = ErrorMessage::sessionTimeout;
+               break;
+       default :
+-              retVal = ErrorMessage::reserved;
++              retVal = ErrorMessage::reserved_;
+               break;
+       }
+       return retVal;
index 503329775737c836a32a9f59fe5a3af7aca61aff..bf0302cbe67fe3e3df00c9bd4d3d8ca4f3a1c76c 100644 (file)
@@ -2,7 +2,7 @@ Summary:        The Open Source Texas-Holdem Poker Engine
 Summary(pl.UTF-8):     Silnik gry Texas-Holdem poker
 Name:          pokerth
 Version:       1.1.1
-Release:       3
+Release:       4
 License:       GPL v2+
 Group:         X11/Applications/Games
 Source0:       http://downloads.sourceforge.net/pokerth/PokerTH-%{version}-src.tar.bz2
@@ -14,6 +14,7 @@ Patch3:               cxx11-build.patch
 Patch4:                cxx11-fixes.patch
 Patch5:                system-qtsingleapp.patch
 Patch6:                moc.patch
+Patch7:                %{name}-protobuf.patch
 URL:           http://www.pokerth.net/
 BuildRequires: QtCore-devel >= 4.3.1
 BuildRequires: QtGui-devel >= 4.3.1
@@ -55,6 +56,7 @@ Silnik gry dostÄ™pny jest na platformy Linux, Windows oraz MacOS X.
 %patch4 -p1
 %patch5 -p1
 %patch6 -p1
+%patch7 -p1
 
 %{__rm} -r src/third_party/qtsingleapplication
 
This page took 0.124973 seconds and 4 git commands to generate.