]> git.pld-linux.org Git - packages/pokerth.git/blob - pokerth.spec
d390b66202442a48b7df0bb40e161d10c6687c18
[packages/pokerth.git] / pokerth.spec
1 Summary:        The Open Source Texas-Holdem Poker Engine
2 Summary(pl.UTF-8):      Silnik gry Texas-Holdem poker
3 Name:           pokerth
4 Version:        1.1
5 Release:        6
6 License:        GPL v2+
7 Group:          X11/Applications/Games
8 Source0:        http://downloads.sourceforge.net/pokerth/PokerTH-%{version}-src.tar.bz2
9 # Source0-md5:  7f577fdb04c697ac7227c1a0d4311ffc
10 Patch0:         qt.patch
11 Patch1:         x32.patch
12 URL:            http://www.pokerth.net/
13 BuildRequires:  QtCore-devel >= 4.3.1
14 BuildRequires:  QtGui-devel >= 4.3.1
15 BuildRequires:  QtNetwork-devel
16 BuildRequires:  QtSql-devel
17 BuildRequires:  SDL_mixer-devel
18 BuildRequires:  boost-devel >= 1.37.0-3
19 BuildRequires:  curl-devel >= 7.16
20 BuildRequires:  gnutls-devel
21 BuildRequires:  gsasl-devel
22 BuildRequires:  libircclient-devel
23 BuildRequires:  protobuf-devel
24 BuildRequires:  qt4-build >= 4.3.1
25 BuildRequires:  qt4-qmake >= 4.3.1
26 BuildRequires:  sed >= 4.0
27 BuildRequires:  tinyxml-devel
28 BuildRequires:  zlib-devel >= 1.2.3
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 PokerTH is a poker game written in C++/Qt4. You can play the popular
33 "Texas Hold'em" poker variant against up to six computer-opponents or
34 play network games with people all over the world. This poker engine
35 is available for Linux, Windows, and MacOS X.
36
37 %description -l pl.UTF-8
38 PokerTH to komputerowa gra w pokera napisana w C++/Qt4. Umożliwia ona
39 grę w popularny wariant "Texas Hold'em" przeciwko maksymalnie sześciu
40 komputerowym przeciwnikom lub sieciową grę z innymi zawodnikami.
41 Silnik gry dostępny jest na platformy Linux, Windows oraz MacOS X.
42
43 %prep
44 %setup -q -n PokerTH-%{version}-src
45 %patch0 -p1
46 %patch1 -p1
47
48 %build
49 qmake-qt4 pokerth.pro \
50         QMAKE_CXX="%{__cxx}" \
51         QMAKE_CXXFLAGS_RELEASE="%{rpmcxxflags}"
52         QMAKE_LFLAGS_RELEASE="%{rpmldflags}"
53 %{__make}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57 install -d $RPM_BUILD_ROOT%{_bindir}
58 %{__make} install \
59         INSTALL_ROOT=$RPM_BUILD_ROOT
60
61 install pokerth bin/pokerth_server $RPM_BUILD_ROOT%{_bindir}
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc COPYING ChangeLog TODO
69 %attr(755,root,root) %{_bindir}/pokerth*
70 %{_desktopdir}/%{name}.desktop
71 %{_pixmapsdir}/%{name}.png
72 %{_datadir}/%{name}
This page took 0.048145 seconds and 2 git commands to generate.