]> git.pld-linux.org Git - packages/pokerth.git/blob - pokerth.spec
- release 2 (rebuild with protobuf 3.9)
[packages/pokerth.git] / pokerth.spec
1 Summary:        The Open Source Texas-Holdem Poker Engine
2 Summary(pl.UTF-8):      Silnik gry Texas-Holdem poker
3 Name:           pokerth
4 Version:        1.1.2
5 Release:        2
6 License:        AGPL v3+
7 Group:          X11/Applications/Games
8 Source0:        http://downloads.sourceforge.net/pokerth/pokerth-%{version}.tar.gz
9 # Source0-md5:  8fd7d7fc7ece17315e58aa3240dd4586
10 Patch0:         x32.patch
11 Patch1:         system-qtsingleapp.patch
12 Patch2:         moc.patch
13 Patch3:         %{name}-protobuf.patch
14 Patch4:         %{name}-boost.patch
15 # from https://github.com/zaphoyd/websocketpp/pull/814/commits/c769c9238ad62178f506038178714a1c35aa2769.patch
16 Patch5:         %{name}-websocketpp-boost.patch
17 URL:            http://www.pokerth.net/
18 BuildRequires:  QtCore-devel >= 4.4.3
19 BuildRequires:  QtGui-devel >= 4.4.3
20 BuildRequires:  QtNetwork-devel >= 4.4.3
21 BuildRequires:  QtSingleApplication-devel
22 BuildRequires:  QtSql-devel >= 4.4.3
23 BuildRequires:  SDL-devel
24 BuildRequires:  SDL_mixer-devel
25 BuildRequires:  boost-devel >= 1.49
26 BuildRequires:  curl-devel >= 7.16
27 BuildRequires:  gnutls-devel
28 BuildRequires:  gsasl-devel >= 1.4
29 BuildRequires:  libircclient-devel >= 1.3
30 BuildRequires:  libstdc++-devel >= 6:4.7
31 BuildRequires:  protobuf-devel >= 2.3.0
32 BuildRequires:  qt4-build >= 4.3.1
33 BuildRequires:  qt4-qmake >= 4.3.1
34 BuildRequires:  sed >= 4.0
35 BuildRequires:  sqlite3-devel >= 3
36 BuildRequires:  tinyxml-devel
37 BuildRequires:  zlib-devel >= 1.2.3
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 PokerTH is a poker game written in C++/Qt4. You can play the popular
42 "Texas Hold'em" poker variant against up to six computer-opponents or
43 play network games with people all over the world. This poker engine
44 is available for Linux, Windows, and MacOS X.
45
46 %description -l pl.UTF-8
47 PokerTH to komputerowa gra w pokera napisana w C++/Qt4. Umożliwia ona
48 grę w popularny wariant "Texas Hold'em" przeciwko maksymalnie sześciu
49 komputerowym przeciwnikom lub sieciową grę z innymi zawodnikami.
50 Silnik gry dostępny jest na platformy Linux, Windows oraz MacOS X.
51
52 %prep
53 %setup -q -n pokerth-%{version}-rc
54 %patch0 -p1
55 %patch1 -p1
56 %patch2 -p1
57 %patch3 -p1
58 %patch4 -p1
59 cd src/third_party/websocketpp
60 %patch5 -p1
61 cd ../../..
62
63 %{__rm} -r src/third_party/qtsingleapplication
64
65 %build
66 install -d build-client build-server
67 cd build-server
68 qmake-qt4 ../pokerth.pro \
69         QMAKE_CXX="%{__cxx}" \
70         QMAKE_CXXFLAGS_RELEASE="%{rpmcxxflags}" \
71         QMAKE_LFLAGS_RELEASE="%{rpmldflags}"
72 %{__make}
73
74 cd ../build-client
75 qmake-qt4 ../pokerth.pro \
76         CONFIG+=client \
77         QMAKE_CXX="%{__cxx}" \
78         QMAKE_CXXFLAGS_RELEASE="%{rpmcxxflags}" \
79         QMAKE_LFLAGS_RELEASE="%{rpmldflags}"
80 %{__make}
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1}
85
86 %{__make} -C build-client install \
87         INSTALL_ROOT=$RPM_BUILD_ROOT
88
89 install build-client/pokerth build-server/bin/pokerth_server $RPM_BUILD_ROOT%{_bindir}
90 cp -p docs/pokerth.1 $RPM_BUILD_ROOT%{_mandir}/man1
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %files
96 %defattr(644,root,root,755)
97 %doc COPYING ChangeLog TODO
98 %attr(755,root,root) %{_bindir}/pokerth
99 %attr(755,root,root) %{_bindir}/pokerth_server
100 %{_desktopdir}/pokerth.desktop
101 %{_pixmapsdir}/pokerth.png
102 %{_datadir}/pokerth
103 %{_mandir}/man1/pokerth.1*
This page took 0.076277 seconds and 3 git commands to generate.