]> git.pld-linux.org Git - packages/pokerth.git/blob - pokerth.spec
- release 6 (by relup.sh)
[packages/pokerth.git] / pokerth.spec
1 Summary:        The Open Source Texas-Holdem Poker Engine
2 Summary(pl.UTF-8):      Silnik gry Texas-Holdem poker
3 Name:           pokerth
4 Version:        1.1.1
5 Release:        6
6 License:        GPL v2+
7 Group:          X11/Applications/Games
8 Source0:        http://downloads.sourceforge.net/pokerth/PokerTH-%{version}-src.tar.bz2
9 # Source0-md5:  a7f76f95782099f966e5f2b6809f502a
10 Patch0:         x32.patch
11 Patch1:         boost-1.60.patch
12 Patch2:         ownerless.patch
13 Patch3:         cxx11-build.patch
14 Patch4:         cxx11-fixes.patch
15 Patch5:         system-qtsingleapp.patch
16 Patch6:         moc.patch
17 Patch7:         %{name}-protobuf.patch
18 URL:            http://www.pokerth.net/
19 BuildRequires:  QtCore-devel >= 4.3.1
20 BuildRequires:  QtGui-devel >= 4.3.1
21 BuildRequires:  QtNetwork-devel
22 BuildRequires:  QtSingleApplication-devel
23 BuildRequires:  QtSql-devel
24 BuildRequires:  SDL_mixer-devel
25 BuildRequires:  boost-devel >= 1.37.0-3
26 BuildRequires:  curl-devel >= 7.16
27 BuildRequires:  gnutls-devel
28 BuildRequires:  gsasl-devel
29 BuildRequires:  libircclient-devel
30 BuildRequires:  protobuf-devel
31 BuildRequires:  qt4-build >= 4.3.1
32 BuildRequires:  qt4-qmake >= 4.3.1
33 BuildRequires:  sed >= 4.0
34 BuildRequires:  tinyxml-devel
35 BuildRequires:  zlib-devel >= 1.2.3
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 PokerTH is a poker game written in C++/Qt4. You can play the popular
40 "Texas Hold'em" poker variant against up to six computer-opponents or
41 play network games with people all over the world. This poker engine
42 is available for Linux, Windows, and MacOS X.
43
44 %description -l pl.UTF-8
45 PokerTH to komputerowa gra w pokera napisana w C++/Qt4. Umożliwia ona
46 grę w popularny wariant "Texas Hold'em" przeciwko maksymalnie sześciu
47 komputerowym przeciwnikom lub sieciową grę z innymi zawodnikami.
48 Silnik gry dostępny jest na platformy Linux, Windows oraz MacOS X.
49
50 %prep
51 %setup -q -n PokerTH-%{version}-src
52 %patch0 -p1
53 %patch1 -p1
54 %patch2 -p1
55 %patch3 -p1
56 %patch4 -p1
57 %patch5 -p1
58 %patch6 -p1
59 %patch7 -p1
60
61 %{__rm} -r src/third_party/qtsingleapplication
62
63 %build
64 qmake-qt4 pokerth.pro \
65         QMAKE_CXX="%{__cxx}" \
66         QMAKE_CXXFLAGS_RELEASE="%{rpmcxxflags}"
67         QMAKE_LFLAGS_RELEASE="%{rpmldflags}"
68 %{__make}
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72 install -d $RPM_BUILD_ROOT%{_bindir}
73 %{__make} install \
74         INSTALL_ROOT=$RPM_BUILD_ROOT
75
76 install pokerth bin/pokerth_server $RPM_BUILD_ROOT%{_bindir}
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %files
82 %defattr(644,root,root,755)
83 %doc COPYING ChangeLog TODO
84 %attr(755,root,root) %{_bindir}/pokerth*
85 %{_desktopdir}/%{name}.desktop
86 %{_pixmapsdir}/%{name}.png
87 %{_datadir}/%{name}
This page took 0.072027 seconds and 3 git commands to generate.